mv runuser to /bin

This commit is contained in:
Daniel J Walsh 2004-10-04 18:44:25 +00:00
parent 1600261614
commit 0c03014b5b
2 changed files with 43 additions and 22 deletions

View File

@ -1,5 +1,5 @@
--- /dev/null 2004-09-30 04:21:43.103661032 -0400 --- /dev/null 2004-09-30 04:21:43.103661032 -0400
+++ coreutils-5.2.1/man/runuser.1 2004-10-04 13:27:51.614675086 -0400 +++ coreutils-5.2.1/man/runuser.1 2004-10-04 13:27:51.000000000 -0400
@@ -0,0 +1,59 @@ @@ -0,0 +1,59 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.33. +.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.33.
+.TH RUNUSER "1" "September 2004" "runuser (coreutils) 5.2.1" "User Commands" +.TH RUNUSER "1" "September 2004" "runuser (coreutils) 5.2.1" "User Commands"
@ -60,8 +60,8 @@
+.B info coreutils su +.B info coreutils su
+.PP +.PP
+should give you access to the complete manual. +should give you access to the complete manual.
--- coreutils-5.2.1/man/Makefile.am.runuser 2004-10-04 13:26:23.658654506 -0400 --- coreutils-5.2.1/man/Makefile.am.runuser 2004-10-04 13:26:23.000000000 -0400
+++ coreutils-5.2.1/man/Makefile.am 2004-10-04 13:26:23.698649968 -0400 +++ coreutils-5.2.1/man/Makefile.am 2004-10-04 13:26:23.000000000 -0400
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
rm.1 rmdir.1 seq.1 sha1sum.1 shred.1 sleep.1 sort.1 split.1 stat.1 stty.1 \ rm.1 rmdir.1 seq.1 sha1sum.1 shred.1 sleep.1 sort.1 split.1 stat.1 stty.1 \
su.1 sum.1 sync.1 tac.1 tail.1 tee.1 test.1 touch.1 tr.1 true.1 tsort.1 \ su.1 sum.1 sync.1 tac.1 tail.1 tee.1 test.1 touch.1 tr.1 true.1 tsort.1 \
@ -80,14 +80,14 @@
SUFFIXES = .x .1 SUFFIXES = .x .1
--- /dev/null 2004-09-30 04:21:43.103661032 -0400 --- /dev/null 2004-09-30 04:21:43.103661032 -0400
+++ coreutils-5.2.1/man/runuser.x 2004-10-04 13:26:23.700649741 -0400 +++ coreutils-5.2.1/man/runuser.x 2004-10-04 13:26:23.000000000 -0400
@@ -0,0 +1,4 @@ @@ -0,0 +1,4 @@
+[NAME] +[NAME]
+runuser \- run a shell with substitute user and group IDs +runuser \- run a shell with substitute user and group IDs
+[DESCRIPTION] +[DESCRIPTION]
+.\" Add any additional description here +.\" Add any additional description here
--- coreutils-5.2.1/README.runuser 2004-10-04 13:26:23.679652124 -0400 --- coreutils-5.2.1/README.runuser 2004-10-04 13:26:23.000000000 -0400
+++ coreutils-5.2.1/README 2004-10-04 13:26:23.701649628 -0400 +++ coreutils-5.2.1/README 2004-10-04 13:26:23.000000000 -0400
@@ -11,7 +11,7 @@ @@ -11,7 +11,7 @@
df dir dircolors dirname du echo env expand expr factor false fmt fold df dir dircolors dirname du echo env expand expr factor false fmt fold
ginstall groups head hostid hostname id join kill link ln logname ls ginstall groups head hostid hostname id join kill link ln logname ls
@ -97,8 +97,8 @@
split stat stty su sum sync tac tail tee test touch tr true tsort tty split stat stty su sum sync tac tail tee test touch tr true tsort tty
uname unexpand uniq unlink uptime users vdir wc who whoami yes uname unexpand uniq unlink uptime users vdir wc who whoami yes
--- coreutils-5.2.1/tests/help-version.runuser 2004-10-04 13:26:23.581663242 -0400 --- coreutils-5.2.1/tests/help-version.runuser 2004-10-04 13:26:23.000000000 -0400
+++ coreutils-5.2.1/tests/help-version 2004-10-04 13:26:23.702649514 -0400 +++ coreutils-5.2.1/tests/help-version 2004-10-04 13:26:23.000000000 -0400
@@ -132,6 +132,7 @@ @@ -132,6 +132,7 @@
seq_args=10 seq_args=10
sleep_args=0 sleep_args=0
@ -107,8 +107,8 @@
test_args=foo test_args=foo
# This is necessary in the unusual event that there is # This is necessary in the unusual event that there is
--- coreutils-5.2.1/src/su.c.runuser 2004-10-04 13:26:23.230703061 -0400 --- coreutils-5.2.1/src/su.c.runuser 2004-10-04 13:26:23.000000000 -0400
+++ coreutils-5.2.1/src/su.c 2004-10-04 13:26:23.704649288 -0400 +++ coreutils-5.2.1/src/su.c 2004-10-04 13:26:23.000000000 -0400
@@ -171,6 +171,10 @@ @@ -171,6 +171,10 @@
#ifndef USE_PAM #ifndef USE_PAM
char *crypt (); char *crypt ();
@ -129,17 +129,16 @@
{ {
#ifdef SYSLOG_FAILURE #ifdef SYSLOG_FAILURE
log_su (pw, 0); log_su (pw, 0);
--- coreutils-5.2.1/src/Makefile.am.runuser 2004-10-04 13:26:23.598661313 -0400 --- coreutils-5.2.1/src/Makefile.am.runuser 2004-10-04 13:26:23.000000000 -0400
+++ coreutils-5.2.1/src/Makefile.am 2004-10-04 13:26:23.705649174 -0400 +++ coreutils-5.2.1/src/Makefile.am 2004-10-04 14:26:31.123772661 -0400
@@ -9,7 +9,7 @@ @@ -1,6 +1,6 @@
cat cksum comm csplit cut expand fmt fold head join md5sum \ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
nl od paste pr ptx sha1sum sort split sum tac tail tr tsort unexpand uniq wc \
basename date dirname echo env expr factor false \
- hostname id kill logname pathchk printenv printf pwd runcon seq sleep tee \
+ hostname id kill logname pathchk printenv printf pwd runcon runuser seq sleep tee \
test true tty whoami yes \
$(OPTIONAL_BIN_PROGS) $(DF_PROG)
-EXTRA_PROGRAMS = chroot df hostid nice pinky stty su uname uptime users who
+EXTRA_PROGRAMS = chroot df hostid nice pinky stty su runuser uname uptime users who
bin_SCRIPTS = groups
bin_PROGRAMS = [ chgrp chown chmod chcon cp dd dircolors du \
@@ -74,6 +74,7 @@ @@ -74,6 +74,7 @@
uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS) uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS)
@ -148,8 +147,26 @@
$(PROGRAMS): ../lib/libfetish.a $(PROGRAMS): ../lib/libfetish.a
@@ -91,7 +92,7 @@
chmod +x $@-t
mv $@-t $@
-all-local: su$(EXEEXT)
+all-local: su$(EXEEXT) runuser
installed_su = $(DESTDIR)$(bindir)/`echo su|sed '$(transform)'`
@@ -107,7 +108,7 @@
chmod $(setuid_root_mode) $(installed_su)
install-root: su$(EXEEXT)
- @$(INSTALL_SU)
+ @$(INSTALL_SU)
install-exec-local: su$(EXEEXT)
@TMPFILE=$(DESTDIR)$(bindir)/.su-$$$$; \
--- /dev/null 2004-09-30 04:21:43.103661032 -0400 --- /dev/null 2004-09-30 04:21:43.103661032 -0400
+++ coreutils-5.2.1/src/runuser.c 2004-10-04 13:26:23.707648947 -0400 +++ coreutils-5.2.1/src/runuser.c 2004-10-04 13:26:23.000000000 -0400
@@ -0,0 +1,33 @@ @@ -0,0 +1,33 @@
+#define CHECKPASSWD 0 +#define CHECKPASSWD 0
+#define pam_start my_pam_start +#define pam_start my_pam_start

View File

@ -4,7 +4,7 @@
Summary: The GNU core utilities: a set of tools commonly used in shell scripts Summary: The GNU core utilities: a set of tools commonly used in shell scripts
Name: coreutils Name: coreutils
Version: 5.2.1 Version: 5.2.1
Release: 28 Release: 29
License: GPL License: GPL
Group: System Environment/Base Group: System Environment/Base
Url: ftp://alpha.gnu.org/gnu/coreutils/ Url: ftp://alpha.gnu.org/gnu/coreutils/
@ -185,6 +185,7 @@ install -c -m755 %SOURCE106 $RPM_BUILD_ROOT/etc/profile.d
# su # su
install -m 4755 src/su $RPM_BUILD_ROOT/bin install -m 4755 src/su $RPM_BUILD_ROOT/bin
install -m 755 src/runuser $RPM_BUILD_ROOT/bin
# These come from util-linux and/or procps. # These come from util-linux and/or procps.
for i in hostname uptime kill ; do for i in hostname uptime kill ; do
@ -245,6 +246,9 @@ fi
%_sbindir/chroot %_sbindir/chroot
%changelog %changelog
* Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-29
- Mv runuser to /bin
* Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28 * Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
- Fix runuser man page. - Fix runuser man page.