fix DIR_COLORS.256color file

This commit is contained in:
Ondrej Vasik 2009-12-16 12:17:58 +00:00
parent 422af9d036
commit 0ab9d455d1
3 changed files with 112 additions and 138 deletions

View File

@ -1,32 +1,3 @@
diff -urNp coreutils-7.2-orig/gnulib-tests/gnulib.mk coreutils-7.2/gnulib-tests/gnulib.mk
--- coreutils-7.2-orig/gnulib-tests/gnulib.mk 2009-03-31 14:28:30.000000000 +0200
+++ coreutils-7.2/gnulib-tests/gnulib.mk 2009-04-01 12:37:00.000000000 +0200
@@ -606,9 +606,9 @@ EXTRA_DIST += test-mbsstr1.c test-mbsstr
## begin gnulib module memchr-tests
-TESTS += test-memchr
-check_PROGRAMS += test-memchr
-EXTRA_DIST += test-memchr.c zerosize-ptr.h
+#TESTS += test-memchr
+#check_PROGRAMS += test-memchr
+#EXTRA_DIST += test-memchr.c zerosize-ptr.h
## end gnulib module memchr-tests
@@ -910,9 +910,9 @@ EXTRA_DIST += test-strtod.c
## begin gnulib module strverscmp-tests
-TESTS += test-strverscmp
-check_PROGRAMS += test-strverscmp
-EXTRA_DIST += test-strverscmp.c
+#TESTS += test-strverscmp
+#check_PROGRAMS += test-strverscmp
+#EXTRA_DIST += test-strverscmp.c
## end gnulib module strverscmp-tests
diff -urNp coreutils-6.11-orig/tests/test-lib.sh coreutils-6.11/tests/test-lib.sh diff -urNp coreutils-6.11-orig/tests/test-lib.sh coreutils-6.11/tests/test-lib.sh
--- coreutils-6.11-orig/tests/test-lib.sh 2008-04-19 23:34:23.000000000 +0200 --- coreutils-6.11-orig/tests/test-lib.sh 2008-04-19 23:34:23.000000000 +0200
+++ coreutils-6.11/tests/test-lib.sh 2008-04-24 14:18:59.000000000 +0200 +++ coreutils-6.11/tests/test-lib.sh 2008-04-24 14:18:59.000000000 +0200

View File

@ -52,17 +52,17 @@ EIGHTBIT 1
#NORMAL 00 # global default, no color code at all #NORMAL 00 # global default, no color code at all
#FILE 00 # normal file, use no color at all #FILE 00 # normal file, use no color at all
RESET 0 # reset to "normal" color RESET 0 # reset to "normal" color
DIR 01;38;5;27 # directory DIR 38;5;27 # directory
LINK 01;38;5;51 # symbolic link (If you set this to 'target' instead of a LINK 38;5;51 # symbolic link (If you set this to 'target' instead of a
# numerical value, the color is as for the file pointed to.) # numerical value, the color is as for the file pointed to.)
MULTIHARDLINK 44;38;5;15 # regular file with more than one link MULTIHARDLINK 44;38;5;15 # regular file with more than one link
FIFO 40;38;5;11 # pipe FIFO 40;38;5;11 # pipe
SOCK 01;38;5;13 # socket SOCK 38;5;13 # socket
DOOR 01;38;5;5 # door DOOR 38;5;5 # door
BLK 01;48;5;232;38;5;11 # block device driver BLK 48;5;232;38;5;11 # block device driver
CHR 01;48;5;232;38;5;3 # character device driver CHR 48;5;232;38;5;3 # character device driver
ORPHAN 01;48;5;232;38;5;9 # symlink to nonexistent file, or non-stat'able file ORPHAN 48;5;232;38;5;9 # symlink to nonexistent file, or non-stat'able file
MISSING 01;05;48;5;232;38;5;15 # ... and the files they point to MISSING 05;48;5;232;38;5;15 # ... and the files they point to
SETUID 48;5;196;38;5;15 # file that is setuid (u+s) SETUID 48;5;196;38;5;15 # file that is setuid (u+s)
SETGID 48;5;11;38;5;16 # file that is setgid (g+s) SETGID 48;5;11;38;5;16 # file that is setgid (g+s)
CAPABILITY 48;5;196;38;5;226 # file with capability CAPABILITY 48;5;196;38;5;226 # file with capability
@ -71,117 +71,117 @@ OTHER_WRITABLE 48;5;10;38;5;21 # dir that is other-writable (o+w) and not sticky
STICKY 48;5;21;38;5;15 # dir with the sticky bit set (+t) and not other-writable STICKY 48;5;21;38;5;15 # dir with the sticky bit set (+t) and not other-writable
# This is for files with execute permission: # This is for files with execute permission:
EXEC 01;38;5;34 EXEC 38;5;34
# List any file extensions like '.gz' or '.tar' that you would like ls # List any file extensions like '.gz' or '.tar' that you would like ls
# to colorize below. Put the extension, a space, and the color init string. # to colorize below. Put the extension, a space, and the color init string.
# (and any comments you want to add after a '#') # (and any comments you want to add after a '#')
# executables (bright green) # executables (bright green)
#.cmd 01;38;5;34 #.cmd 38;5;34
#.exe 01;38;5;34 #.exe 38;5;34
#.com 01;38;5;34 #.com 38;5;34
#.btm 01;38;5;34 #.btm 38;5;34
#.bat 01;38;5;34 #.bat 38;5;34
#.sh 01;38;5;34 #.sh 38;5;34
#.csh 01;38;5;34 #.csh 38;5;34
# archives or compressed (bright red) # archives or compressed (bright red)
.tar 01;38;5;9 .tar 38;5;9
.tgz 01;38;5;9 .tgz 38;5;9
.arj 01;38;5;9 .arj 38;5;9
.taz 01;38;5;9 .taz 38;5;9
.lzh 01;38;5;9 .lzh 38;5;9
.lzma 01;38;5;9 .lzma 38;5;9
.tlz 01;38;5;9 .tlz 38;5;9
.txz 01;38;5;9 .txz 38;5;9
.zip 01;38;5;9 .zip 38;5;9
.z 01;38;5;9 .z 38;5;9
.Z 01;38;5;9 .Z 38;5;9
.dz 01;38;5;9 .dz 38;5;9
.gz 01;38;5;9 .gz 38;5;9
.lz 01;38;5;9 .lz 38;5;9
.xz 01;38;5;9 .xz 38;5;9
.bz2 01;38;5;9 .bz2 38;5;9
.tbz 01;38;5;9 .tbz 38;5;9
.tbz2 01;38;5;9 .tbz2 38;5;9
.bz 01;38;5;9 .bz 38;5;9
.tz 01;38;5;9 .tz 38;5;9
.deb 01;38;5;9 .deb 38;5;9
.rpm 01;38;5;9 .rpm 38;5;9
.jar 01;38;5;9 .jar 38;5;9
.rar 01;38;5;9 .rar 38;5;9
.ace 01;38;5;9 .ace 38;5;9
.zoo 01;38;5;9 .zoo 38;5;9
.cpio 01;38;5;9 .cpio 38;5;9
.7z 01;38;5;9 .7z 38;5;9
.rz 01;38;5;9 .rz 38;5;9
# image formats (magenta) # image formats (magenta)
.jpg 01;38;5;13 .jpg 38;5;13
.jpeg 01;38;5;13 .jpeg 38;5;13
.gif 01;38;5;13 .gif 38;5;13
.bmp 01;38;5;13 .bmp 38;5;13
.pbm 01;38;5;13 .pbm 38;5;13
.pgm 01;38;5;13 .pgm 38;5;13
.ppm 01;38;5;13 .ppm 38;5;13
.tga 01;38;5;13 .tga 38;5;13
.xbm 01;38;5;13 .xbm 38;5;13
.xpm 01;38;5;13 .xpm 38;5;13
.tif 01;38;5;13 .tif 38;5;13
.tiff 01;38;5;13 .tiff 38;5;13
.png 01;38;5;13 .png 38;5;13
.svg 01;38;5;13 .svg 38;5;13
.svgz 01;38;5;13 .svgz 38;5;13
.mng 01;38;5;13 .mng 38;5;13
.pcx 01;38;5;13 .pcx 38;5;13
.mov 01;38;5;13 .mov 38;5;13
.mpg 01;38;5;13 .mpg 38;5;13
.mpeg 01;38;5;13 .mpeg 38;5;13
.m2v 01;38;5;13 .m2v 38;5;13
.mkv 01;38;5;13 .mkv 38;5;13
.ogm 01;38;5;13 .ogm 38;5;13
.mp4 01;38;5;13 .mp4 38;5;13
.m4v 01;38;5;13 .m4v 38;5;13
.mp4v 01;38;5;13 .mp4v 38;5;13
.vob 01;38;5;13 .vob 38;5;13
.qt 01;38;5;13 .qt 38;5;13
.nuv 01;38;5;13 .nuv 38;5;13
.wmv 01;38;5;13 .wmv 38;5;13
.asf 01;38;5;13 .asf 38;5;13
.rm 01;38;5;13 .rm 38;5;13
.rmvb 01;38;5;13 .rmvb 38;5;13
.flc 01;38;5;13 .flc 38;5;13
.avi 01;38;5;13 .avi 38;5;13
.fli 01;38;5;13 .fli 38;5;13
.flv 01;38;5;13 .flv 38;5;13
.gl 01;38;5;13 .gl 38;5;13
.dl 01;38;5;13 .dl 38;5;13
.xcf 01;38;5;13 .xcf 38;5;13
.xwd 01;38;5;13 .xwd 38;5;13
.yuv 01;38;5;13 .yuv 38;5;13
.cgm 01;38;5;13 .cgm 38;5;13
.emf 01;38;5;13 .emf 38;5;13
# http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions # http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions
.axv 01;38;5;13 .axv 38;5;13
.anx 01;38;5;13 .anx 38;5;13
.ogv 01;38;5;13 .ogv 38;5;13
.ogx 01;38;5;13 .ogx 38;5;13
# audio formats (cyan) # audio formats (cyan)
.aac 01;38;5;45 .aac 38;5;45
.au 01;38;5;45 .au 38;5;45
.flac 01;38;5;45 .flac 38;5;45
.mid 01;38;5;45 .mid 38;5;45
.midi 01;38;5;45 .midi 38;5;45
.mka 01;38;5;45 .mka 38;5;45
.mp3 01;38;5;45 .mp3 38;5;45
.mpc 01;38;5;45 .mpc 38;5;45
.ogg 01;38;5;45 .ogg 38;5;45
.ra 01;38;5;45 .ra 38;5;45
.wav 01;38;5;45 .wav 38;5;45
# http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions # http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions
.axa 01;38;5;45 .axa 38;5;45
.oga 01;38;5;45 .oga 38;5;45
.spx 01;38;5;45 .spx 38;5;45
.xspf 01;38;5;45 .xspf 38;5;45

View File

@ -1,7 +1,7 @@
Summary: A set of basic GNU tools commonly used in shell scripts Summary: A set of basic GNU tools commonly used in shell scripts
Name: coreutils Name: coreutils
Version: 8.2 Version: 8.2
Release: 1%{?dist} Release: 2%{?dist}
License: GPLv3+ License: GPLv3+
Group: System Environment/Base Group: System Environment/Base
Url: http://www.gnu.org/software/coreutils/ Url: http://www.gnu.org/software/coreutils/
@ -326,6 +326,9 @@ fi
%{_libdir}/coreutils %{_libdir}/coreutils
%changelog %changelog
* Wed Dec 16 2009 Ondrej Vasik <ovasik@redhat.com> - 8.2-2
- fix DIR_COLORS.256color file
* Fri Dec 11 2009 Ondrej Vasik <ovasik@redhat.com> - 8.2-1 * Fri Dec 11 2009 Ondrej Vasik <ovasik@redhat.com> - 8.2-1
- new upstream release 8.2 - new upstream release 8.2
- removed applied patches, temporarily do not run dup_cloexec() - removed applied patches, temporarily do not run dup_cloexec()