Do not fail getaddrinfo gnulib test ifor temporary name resolution errors.

This commit is contained in:
Ondrej Vasik 2008-01-25 18:25:32 +00:00
parent 2bb0e0589a
commit 0629e270fb
1 changed files with 14 additions and 0 deletions

View File

@ -10,3 +10,17 @@ diff -urp coreutils-6.10-orig/src/Makefile.am coreutils-6.10/src/Makefile.am
else \
:; \
fi
diff -urp coreutils-6.10-orig/gnulib-tests/test-getaddrinfo.c coreutils-6.10/gnulib-tests/test-getaddrinfo.c
--- coreutils-6.10-orig/gnulib-tests/test-getaddrinfo.c 2007-11-17 07:59:42.000000000 +0100
+++ coreutils-6.10/gnulib-tests/test-getaddrinfo.c 2008-01-25 19:19:43.000000000 +0100
@@ -61,6 +61,10 @@ int simple (char *host, char *service)
if (res == EAI_SERVICE)
return 0;
+ /* Do not fail this test for temporary name resolution errors. */
+ if (res == EAI_AGAIN)
+ return 0;
+
return 1;
}