conky/conky-cmakefix.patch

43 lines
1.2 KiB
Diff

commit 700e872f781b982b762fc3d16fe4eba1f9e535bc
Author: Miroslav Lichvar <mlichvar@redhat.com>
Date: Tue Nov 3 17:05:18 2015 +0100
Include CheckIncludeFiles for check_include_files
This seems to be required with recent cmake versions.
diff --git a/cmake/ConkyPlatformChecks.cmake b/cmake/ConkyPlatformChecks.cmake
index 26d0bea..c6c6b52 100644
--- a/cmake/ConkyPlatformChecks.cmake
+++ b/cmake/ConkyPlatformChecks.cmake
@@ -22,7 +22,7 @@
include(FindPkgConfig)
include(CheckFunctionExists)
-include(CheckIncludeFile)
+include(CheckIncludeFiles)
include(CheckSymbolExists)
# Check for some headers
commit 8545ac711371e32ef28fb7bb4cb4db39289b3450
Author: Miroslav Lichvar <mlichvar@redhat.com>
Date: Tue Nov 3 16:57:25 2015 +0100
Use LIB_SUFFIX when installing libraries
This is needed on systems with /usr/lib64.
diff --git a/lua/CMakeLists.txt b/lua/CMakeLists.txt
index 45eb854..8f53f8a 100644
--- a/lua/CMakeLists.txt
+++ b/lua/CMakeLists.txt
@@ -76,6 +76,6 @@ endif(BUILD_LUA_CAIRO AND BUILD_LUA_IMLIB2)
install(TARGETS
${lua_libs}
- LIBRARY DESTINATION lib/conky
- ARCHIVE DESTINATION lib/conky
+ LIBRARY DESTINATION lib${LIB_SUFFIX}/conky
+ ARCHIVE DESTINATION lib${LIB_SUFFIX}/conky
)