update to 1.9.0
This commit is contained in:
parent
878e888af6
commit
f4853f6b8d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
conky-1.8.1.tar.bz2
|
||||
/conky-1.9.0.tar.bz2
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -Nur conky-1.8.1-orig/src/ccurl_thread.c conky-1.8.1/src/ccurl_thread.c
|
||||
--- conky-1.8.1-orig/src/ccurl_thread.c 2010-10-05 23:29:36.000000000 +0200
|
||||
+++ conky-1.8.1/src/ccurl_thread.c 2011-12-24 11:16:13.455464858 +0100
|
||||
@@ -33,7 +33,6 @@
|
||||
#endif /* DEBUG */
|
||||
|
||||
#include <curl/curl.h>
|
||||
-#include <curl/types.h>
|
||||
#include <curl/easy.h>
|
||||
|
||||
/*
|
18
conky-1.9.0-nobool.patch
Normal file
18
conky-1.9.0-nobool.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -up conky-1.9.0/src/conky.c.nobool conky-1.9.0/src/conky.c
|
||||
--- conky-1.9.0/src/conky.c.nobool 2012-05-03 23:22:21.000000000 +0200
|
||||
+++ conky-1.9.0/src/conky.c 2012-05-07 15:56:40.000000000 +0200
|
||||
@@ -882,12 +882,12 @@ void generate_text_internal(char *p, int
|
||||
OBJ(cpu) {
|
||||
if (cur->cpu_usage) {
|
||||
if (obj->data.i > info.cpu_count) {
|
||||
- static bool warned = false;
|
||||
+ static int warned = 0;
|
||||
if(!warned) {
|
||||
NORM_ERR("obj->data.i %i info.cpu_count %i",
|
||||
obj->data.i, info.cpu_count);
|
||||
NORM_ERR("attempting to use more CPUs than you have!");
|
||||
- warned = true;
|
||||
+ warned = 1;
|
||||
}
|
||||
} else {
|
||||
percent_print(p, p_max_size,
|
11
conky.spec
11
conky.spec
@ -14,8 +14,8 @@
|
||||
%bcond_without wlan
|
||||
|
||||
Name: conky
|
||||
Version: 1.8.1
|
||||
Release: 5%{?dist}
|
||||
Version: 1.9.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A system monitor for X
|
||||
|
||||
Group: User Interface/X
|
||||
@ -24,7 +24,7 @@ URL: http://conky.sf.net/
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch0: conky-1.8.1-libcurl.patch
|
||||
Patch1: conky-1.9.0-nobool.patch
|
||||
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXt-devel
|
||||
@ -48,7 +48,7 @@ It just keeps on given'er. Yeah.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .libcurl-no-types-header
|
||||
%patch1 -p1 -b .nobool
|
||||
|
||||
for i in AUTHORS; do
|
||||
iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
|
||||
@ -103,6 +103,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon May 07 2012 Miroslav Lichvar <mlichvar@redhat.com> - 1.9.0-1
|
||||
- update to 1.9.0
|
||||
|
||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user