update to 1.10.0-20150824git341495

This commit is contained in:
Miroslav Lichvar 2015-11-03 17:18:36 +01:00
parent 1c3d6c1942
commit d241b2f118
4 changed files with 86 additions and 47 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/conky-1.9.0-20141003git30d09e.tar.xz
/conky-341495.tar.gz

42
conky-cmakefix.patch Normal file
View File

@ -0,0 +1,42 @@
commit 700e872f781b982b762fc3d16fe4eba1f9e535bc
Author: Miroslav Lichvar <mlichvar@redhat.com>
Date: Tue Nov 3 17:05:18 2015 +0100
Include CheckIncludeFiles for check_include_files
This seems to be required with recent cmake versions.
diff --git a/cmake/ConkyPlatformChecks.cmake b/cmake/ConkyPlatformChecks.cmake
index 26d0bea..c6c6b52 100644
--- a/cmake/ConkyPlatformChecks.cmake
+++ b/cmake/ConkyPlatformChecks.cmake
@@ -22,7 +22,7 @@
include(FindPkgConfig)
include(CheckFunctionExists)
-include(CheckIncludeFile)
+include(CheckIncludeFiles)
include(CheckSymbolExists)
# Check for some headers
commit 8545ac711371e32ef28fb7bb4cb4db39289b3450
Author: Miroslav Lichvar <mlichvar@redhat.com>
Date: Tue Nov 3 16:57:25 2015 +0100
Use LIB_SUFFIX when installing libraries
This is needed on systems with /usr/lib64.
diff --git a/lua/CMakeLists.txt b/lua/CMakeLists.txt
index 45eb854..8f53f8a 100644
--- a/lua/CMakeLists.txt
+++ b/lua/CMakeLists.txt
@@ -76,6 +76,6 @@ endif(BUILD_LUA_CAIRO AND BUILD_LUA_IMLIB2)
install(TARGETS
${lua_libs}
- LIBRARY DESTINATION lib/conky
- ARCHIVE DESTINATION lib/conky
+ LIBRARY DESTINATION lib${LIB_SUFFIX}/conky
+ ARCHIVE DESTINATION lib${LIB_SUFFIX}/conky
)

View File

@ -1,12 +1,11 @@
%global gitdate 20141003
%global gitrev 30d09e
%global gitdate 20150824
%global gitcommit 3414955ad64580731fbd5d46a96f0b313c4b6a32
%global gitshort %(c=%{gitcommit}; echo ${c:0:6})
%bcond_without alsa
%bcond_with audacious
%bcond_without curl
%bcond_without ibm
%bcond_without imlib
%bcond_without lua
%bcond_without lua_cairo
%bcond_without lua_imlib
%bcond_with moc
@ -19,27 +18,24 @@
%bcond_without wlan
Name: conky
Version: 1.9.0
Release: 14.%{gitdate}git%{gitrev}%{?dist}
Version: 1.10.0
Release: 14.%{gitdate}git%{gitshort}%{?dist}
Summary: A system monitor for X
Group: User Interface/X
License: GPLv3+
URL: http://conky.sf.net/
# git clone git://github.com/brndnmtthws/conky.git; cd conky
# git archive --prefix=conky/ %{gitrev} | xz > %{name}-%{version}-%{gitdate}git%{gitrev}.tar.xz
Source0: %{name}-%{version}-%{gitdate}git%{gitrev}.tar.xz
#Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
URL: https://github.com/brndnmtthws/conky
Source0: https://github.com/brndnmtthws/%{name}/archive/%{gitshort}/%{name}-%{gitshort}.tar.gz
Patch1: conky-cmakefix.patch
BuildRequires: libXft-devel
BuildRequires: libXt-devel
BuildRequires: libXdamage-devel
BuildRequires: libXext-devel
%{?with_alsa:BuildRequires: alsa-lib-devel}
BuildRequires: lua-devel
%{?with_audacious:BuildRequires: audacious-devel < 3.5 dbus-glib-devel}
%{?with_curl:BuildRequires: curl-devel}
%{?with_imlib:BuildRequires: imlib2-devel}
%{?with_lua:BuildRequires: lua-devel}
# tolua++ switched to lua-5.2 in 1.0.93-14
%{?with_lua_cairo:BuildRequires: cairo-devel tolua++-devel > 1.0.93-14}
%{?with_lua_imlib:BuildRequires: imlib2-devel tolua++-devel > 1.0.93-14}
@ -50,59 +46,60 @@ BuildRequires: libXext-devel
%{?with_weather_xoap:BuildRequires: libxml2-devel}
%{?with_wlan:BuildRequires: wireless-tools-devel}
# needed to generate documentation in the git snapshot
BuildRequires: libtool docbook2X docbook-style-xsl man
BuildRequires: docbook2X docbook-style-xsl man
BuildRequires: cmake git
%description
A system monitor for X originally based on the torsmo code. but more kickass.
It just keeps on given'er. Yeah.
%prep
%setup -q -n %{name}
# build with lua-5.2
sed -i 's|lua == 5.1|lua >= 5.2|' configure.ac.in
%setup -q -n %{name}-%{gitcommit}
%patch1 -p1 -b .cmakefix
# remove -Werror from CFLAGS
sed -i 's|-Werror||' cmake/ConkyBuildOptions.cmake
# remove executable bits from files included in %{_docdir}
chmod a-x extras/convert.lua
for i in AUTHORS; do
iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
done
%build
# needed also to use recent config.guess and config.sub for aarch64
./autogen.sh
%configure \
%{!?with_alsa: --disable-alsa} \
%{?with_audacious: --enable-audacious=yes} \
%{?with_curl: --enable-curl} \
%{?with_ibm: --enable-ibm} \
%{?with_imlib: --enable-imlib2} \
%{!?with_lua: --disable-lua} \
%{?with_lua_cairo: --enable-lua-cairo} \
%{?with_lua_imlib: --enable-lua-imlib2} \
%{!?with_moc: --disable-moc} \
%{!?with_mpd: --disable-mpd} \
%{!?with_ncurses: --disable-ncurses} \
%{?with_nvidia: --enable-nvidia} \
%{?with_rss: --enable-rss} \
%{?with_weather: --enable-weather-metar} \
%{?with_weather_xoap: --enable-weather-xoap} \
%{?with_wlan: --enable-wlan} \
;
# don't use rpath
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
%cmake \
-DMAINTAINER_MODE=ON \
-DBUILD_BUILTIN_CONFIG=OFF \
-DBUILD_PORT_MONITORS=OFF \
%{?with_audacious: -DBUILD_AUDACIOUS=ON} \
%{?with_curl: -DBUILD_CURL=ON} \
%{!?with_ibm: -DBUILD_IBM=OFF} \
%{?with_imlib: -DBUILD_IMLIB2=ON} \
%{?with_lua_cairo: -DBUILD_LUA_CAIRO=ON} \
%{?with_lua_imlib: -DBUILD_LUA_IMLIB2=ON} \
%{!?with_moc: -DBUILD_MOC=OFF} \
%{!?with_mpd: -DBUILD_MPD=OFF} \
%{!?with_ncurses: -DBUILD_NCURSES=OFF} \
%{?with_nvidia: -DBUILD_NVIDIA=ON} \
%{?with_rss: -DBUILD_RSS=ON} \
%{?with_weather: -DBUILD_WEATHER_METAR=ON} \
%{?with_weather_xoap: -DBUILD_WEATHER_XOAP=ON} \
%{?with_wlan: -DBUILD_WLAN=ON} \
.
make %{?_smp_mflags}
%install
make install DESTDIR=$RPM_BUILD_ROOT
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conky/conky_no_x11.conf
rm -f $RPM_BUILD_ROOT%{_libdir}/conky/*.{la,a}
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/conky
install -m644 -p data/conky.conf $RPM_BUILD_ROOT%{_sysconfdir}/conky
rm -rf $RPM_BUILD_ROOT%{_docdir}/conky-*
%files
%doc AUTHORS ChangeLog COPYING TODO README NEWS extras/* doc/docs.html
%doc AUTHORS COPYING README.md extras/* doc/docs.html
%dir %{_sysconfdir}/conky
%config %{_sysconfdir}/conky/conky.conf
%{_bindir}/conky

View File

@ -1 +1 @@
79a6caba1759b55289a0f4fcd87dc5c6 conky-1.9.0-20141003git30d09e.tar.xz
a2e9973191e20d6071c2a8b1882cc3fb conky-341495.tar.gz