auto-import conky-1.4.5-2 on branch devel from conky-1.4.5-2.src.rpm

This commit is contained in:
Michael Rice 2006-12-14 15:33:59 +00:00
parent 13f77c7e02
commit 5d1f068980
6 changed files with 212 additions and 0 deletions

View File

@ -0,0 +1 @@
conky-1.4.5.tar.bz2

37
conky-news.diff Normal file
View File

@ -0,0 +1,37 @@
--- /home/errr/src/conky-1.4.5/NEWS 2006-11-21 14:08:08.000000000 -0600
+++ NEWS 2006-12-14 00:29:27.000000000 -0600
@@ -1,3 +1,34 @@
+Summary of changes for Conky release 1.4.5:
+-------------------------------------------
+Added config items:
+- max_specials
+- max_port_monitor_connections
+
+Removed config items:
+- min_port_monitors
+- min_port_monitor_connections
+
+Added variables:
+- entropy_avail
+- entropy_poolsize
+- entropy_bar
+
+Added length specifier to audacious_title.
+
+Split battery var into:
+- battery and battery_time
+
+Fixed broken texeci variable.
+Fixed build error with --disable-x11.
+Fixed build error with --disable-xdamage.
+Fixed acpi battery issues.
+Fixed mem var overflows when >= 4GB.
+Close pop3/imap sockets properly.
+Improved internal thread handling.
+Converted tcp_portmon internal hash to GLib
+for GPL compatibility.
+
+
Summary of changes for Conky release 1.4.4:
-------------------------------------------
* fix build error for freebsd.

34
conky-timed_c.diff Normal file
View File

@ -0,0 +1,34 @@
--- /home/errr/src/conky-1.4.5/src/timed_thread.c 2006-12-02 17:07:47.000000000 -0600
+++ src/timed_thread.c 2006-12-14 00:29:24.000000000 -0600
@@ -1,10 +1,26 @@
-/* $Id: timed_thread.c 803 2006-12-02 23:07:21Z pkovacs $ */
+/* $Id: timed_thread.c 817 2006-12-13 16:54:59Z pkovacs $ */
-/* timed_thread.c
- * Author: Philip Kovacs
+/*
+ * timed_thread.c: Abstraction layer for timed threads
*
- * Abstraction layer for timed threads
- * */
+ * Copyright (C) 2006 Philip Kovacs pkovacs@users.sourceforge.net
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
+ * USA.
+ *
+ */
#include <pthread.h>
#include <assert.h>

34
conky-timed_h.diff Normal file
View File

@ -0,0 +1,34 @@
--- /home/errr/src/conky-1.4.5/src/timed_thread.h 2006-11-21 14:08:07.000000000 -0600
+++ src/timed_thread.h 2006-12-14 00:29:24.000000000 -0600
@@ -1,10 +1,26 @@
-/* $Id: timed_thread.h 772 2006-11-15 01:20:49Z pkovacs $ */
+/* $Id: timed_thread.h 817 2006-12-13 16:54:59Z pkovacs $ */
-/* timed_thread.h
- * Author: Philip Kovacs
+/*
+ * timed_thread.h: Abstraction layer for timed threads
*
- * Abstraction layer for timed threads
- * */
+ * Copyright (C) 2006 Philip Kovacs pkovacs@users.sourceforge.net
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
+ * USA.
+ *
+ */
#ifndef _TIMED_THREAD_H_
#define _TIMED_THREAD_H_

105
conky.spec Normal file
View File

@ -0,0 +1,105 @@
Name: conky
Version: 1.4.5
Release: 2%{?dist}
Summary: A system monitor for X
Group: User Interface/X
License: GPL
URL: http://conky.sf.net/
Source0: http://easynews.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.bz2
Patch0: conky-news.diff
Patch1: conky-timed_c.diff
Patch2: conky-timed_h.diff
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libXft-devel
BuildRequires: libXt-devel
BuildRequires: libXdamage-devel
BuildRequires: libXext-devel
BuildRequires: audacious-devel
%description
A system monitor for X originally based on the torsmo code. but more kickass.
It just keeps on given'er. Yeah.
%prep
%setup -q
%patch0
%patch1
%patch2
%build
%configure --enable-audacious \
--enable-hddtemp \
--enable-own-window \
--enable-proc-uptime \
--enable-portmon \
--enable-double-buffer \
--enable-xft \
--enable-xdamage \
--enable-x11 \
--disable-bmpx \
--disable-xmms2 \
--disable-mpd \
--with-x
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING TODO README NEWS extras/* doc/docs.html doc/conkyrc.sample
%{_bindir}/*
%{_mandir}/man1/*
%changelog
* Thu Dec 14 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-2
- Ship NEWS
- Add patch for license of timed_thread and NEWS
* Tue Dec 12 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-1
- version bump
- change group
* Wed Dec 06 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-3
- rebuild for new audacious lib version
* Thu Nov 30 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-2
- Move nano and vim files into docs
- remove unneeded BR's
* Tue Nov 21 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-1
- Version bump
- Add vim and nano syntax files to package
* Thu Oct 05 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.3-1
- Version bump
- Remove Install file from docs
* Mon Oct 02 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-4
- moved to configure macro from ./configure
- clean up changelog and make more informative entrys
- Fixed sumary in spec file
- remove NEWS file since it was empty
- remove xmms support due to possible security issue
- remove bmp support due to possible security issue
- add missing BR for libXext-devel and remove unneeded libX11-devel
* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-3
- use the GPL as licence since the whole package is GPL
* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-2
- remove unneeded deps
* Tue Sep 26 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-1
- Initial RPM release

View File

@ -0,0 +1 @@
4625c052852f2919a5e7ce2eb7c31189 conky-1.4.5.tar.bz2