update to 1.10.1-20151201git1abd25

This commit is contained in:
Miroslav Lichvar 2015-12-04 09:32:15 +01:00
parent 1f19157278
commit 203654c04c
4 changed files with 7 additions and 52 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/conky-341495.tar.gz
/conky-1abd25.tar.gz

View File

@ -1,42 +0,0 @@
commit 700e872f781b982b762fc3d16fe4eba1f9e535bc
Author: Miroslav Lichvar <mlichvar@redhat.com>
Date: Tue Nov 3 17:05:18 2015 +0100
Include CheckIncludeFiles for check_include_files
This seems to be required with recent cmake versions.
diff --git a/cmake/ConkyPlatformChecks.cmake b/cmake/ConkyPlatformChecks.cmake
index 26d0bea..c6c6b52 100644
--- a/cmake/ConkyPlatformChecks.cmake
+++ b/cmake/ConkyPlatformChecks.cmake
@@ -22,7 +22,7 @@
include(FindPkgConfig)
include(CheckFunctionExists)
-include(CheckIncludeFile)
+include(CheckIncludeFiles)
include(CheckSymbolExists)
# Check for some headers
commit 8545ac711371e32ef28fb7bb4cb4db39289b3450
Author: Miroslav Lichvar <mlichvar@redhat.com>
Date: Tue Nov 3 16:57:25 2015 +0100
Use LIB_SUFFIX when installing libraries
This is needed on systems with /usr/lib64.
diff --git a/lua/CMakeLists.txt b/lua/CMakeLists.txt
index 45eb854..8f53f8a 100644
--- a/lua/CMakeLists.txt
+++ b/lua/CMakeLists.txt
@@ -76,6 +76,6 @@ endif(BUILD_LUA_CAIRO AND BUILD_LUA_IMLIB2)
install(TARGETS
${lua_libs}
- LIBRARY DESTINATION lib/conky
- ARCHIVE DESTINATION lib/conky
+ LIBRARY DESTINATION lib${LIB_SUFFIX}/conky
+ ARCHIVE DESTINATION lib${LIB_SUFFIX}/conky
)

View File

@ -1,5 +1,5 @@
%global gitdate 20150824
%global gitcommit 3414955ad64580731fbd5d46a96f0b313c4b6a32
%global gitdate 20151201
%global gitcommit 1abd253470f5a230b221c2993e54f6137e0ed2b3
%global gitshort %(c=%{gitcommit}; echo ${c:0:6})
%bcond_with audacious
@ -19,7 +19,7 @@
%bcond_without xdbe
Name: conky
Version: 1.10.0
Version: 1.10.1
Release: 1.%{gitdate}git%{gitshort}%{?dist}
Summary: A system monitor for X
@ -27,7 +27,6 @@ Group: User Interface/X
License: GPLv3+
URL: https://github.com/brndnmtthws/conky
Source0: https://github.com/brndnmtthws/%{name}/archive/%{gitshort}/%{name}-%{gitshort}.tar.gz
Patch1: conky-cmakefix.patch
BuildRequires: libXft-devel
BuildRequires: libXt-devel
@ -37,9 +36,8 @@ BuildRequires: lua-devel
%{?with_audacious:BuildRequires: audacious-devel < 3.5 dbus-glib-devel}
%{?with_curl:BuildRequires: curl-devel}
%{?with_imlib:BuildRequires: imlib2-devel}
# tolua++ switched to lua-5.2 in 1.0.93-14
%{?with_lua_cairo:BuildRequires: cairo-devel tolua++-devel > 1.0.93-14}
%{?with_lua_imlib:BuildRequires: imlib2-devel tolua++-devel > 1.0.93-14}
%{?with_lua_cairo:BuildRequires: cairo-devel tolua++-devel}
%{?with_lua_imlib:BuildRequires: imlib2-devel tolua++-devel}
%{?with_ncurses:BuildRequires: ncurses-devel}
%{?with_nvidia:BuildRequires: libXNVCtrl-devel}
%{?with_rss:BuildRequires: curl-devel libxml2-devel}
@ -56,7 +54,6 @@ It just keeps on given'er. Yeah.
%prep
%setup -q -n %{name}-%{gitcommit}
%patch1 -p1 -b .cmakefix
# remove -Werror from CFLAGS
sed -i 's|-Werror||' cmake/ConkyBuildOptions.cmake

View File

@ -1 +1 @@
a2e9973191e20d6071c2a8b1882cc3fb conky-341495.tar.gz
5715898d8756c5203d754006749f1201 conky-1abd25.tar.gz