Merge branch 'master' into f13

Conflicts:
	.gitignore
	conky-1.8.0-audclient.patch
	conky.spec
	sources
This commit is contained in:
Miroslav Lichvar 2010-10-06 15:46:14 +02:00
commit 1e59b9a048
5 changed files with 7 additions and 80 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
conky-1.8.0.tar.bz2
conky-1.8.1.tar.bz2

View File

@ -1,35 +0,0 @@
diff -up conky-1.8.0/configure.audclient conky-1.8.0/configure
--- conky-1.8.0/configure.audclient 2010-03-30 19:50:43.000000000 +0200
+++ conky-1.8.0/configure 2010-04-01 17:29:13.000000000 +0200
@@ -11233,12 +11233,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_Audacious_CFLAGS="$Audacious_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0\""; } >&5
- ($PKG_CONFIG --exists --print-errors "audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"audclient >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "audclient >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_Audacious_CFLAGS=`$PKG_CONFIG --cflags "audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0" 2>/dev/null`
+ pkg_cv_Audacious_CFLAGS=`$PKG_CONFIG --cflags "audclient >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -11251,12 +11251,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_Audacious_LIBS="$Audacious_LIBS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0\""; } >&5
- ($PKG_CONFIG --exists --print-errors "audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"audclient >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "audclient >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_Audacious_LIBS=`$PKG_CONFIG --libs "audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0" 2>/dev/null`
+ pkg_cv_Audacious_LIBS=`$PKG_CONFIG --libs "audclient >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0" 2>/dev/null`
else
pkg_failed=yes
fi

View File

@ -1,37 +0,0 @@
diff -up conky-1.8.0/src/conky.c.truefalse conky-1.8.0/src/conky.c
--- conky-1.8.0/src/conky.c.truefalse 2010-03-25 21:27:32.000000000 +0100
+++ conky-1.8.0/src/conky.c 2010-04-01 18:00:48.000000000 +0200
@@ -4518,13 +4518,13 @@ void setalignment(int* ltext_alignment,
int a = string_to_alignment(value);
if (a <= 0) {
- if(setbyconffile == true) {
+ if(setbyconffile == TRUE) {
CONF_ERR;
} else NORM_ERR("'%s' is not a alignment setting", value);
} else {
*ltext_alignment = a;
}
- } else if(setbyconffile == true) {
+ } else if(setbyconffile == TRUE) {
CONF_ERR;
}
}
@@ -4573,7 +4573,7 @@ char load_config_file(const char *f)
}
}
CONF("alignment") {
- setalignment(&text_alignment, window.type, value, f, line, true);
+ setalignment(&text_alignment, window.type, value, f, line, TRUE);
}
CONF("background") {
fork_to_background = string_to_bool(value);
@@ -5696,7 +5696,7 @@ void initialisation(int argc, char **arg
set_first_font(optarg);
break;
case 'a':
- setalignment(&text_alignment, window.type, optarg, NULL, 0, false);
+ setalignment(&text_alignment, window.type, optarg, NULL, 0, FALSE);
break;
#ifdef OWN_WINDOW

View File

@ -14,16 +14,14 @@
%bcond_without wlan
Name: conky
Version: 1.8.0
Release: 4%{?dist}
Version: 1.8.1
Release: 1%{?dist}
Summary: A system monitor for X
Group: User Interface/X
License: GPLv3+
URL: http://conky.sf.net/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
Patch0: conky-1.8.0-audclient.patch
Patch1: conky-1.8.0-truefalse.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libXft-devel
@ -48,8 +46,6 @@ It just keeps on given'er. Yeah.
%prep
%setup -q
%patch0 -p1 -b .audclient
%patch1 -p1 -b .truefalse
for i in AUTHORS; do
iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
@ -104,6 +100,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Oct 06 2010 Miroslav Lichvar <mlichvar@redhat.com> - 1.8.1-1
- update to 1.8.1
* Wed Apr 21 2010 Miroslav Lichvar <mlichvar@redhat.com> - 1.8.0-4
- remove rpath

View File

@ -1 +1 @@
494cbaf1108cfdb977fc80454d9b13e2 conky-1.8.0.tar.bz2
366dc6a5c2ebebfbe6f53da25061b5d6 conky-1.8.1.tar.bz2