compiz/compiz-0.7.8-kde42.patch

90 lines
3.6 KiB
Diff

diff -ur compiz-0.7.8/configure compiz-0.7.8-kde42/configure
--- compiz-0.7.8/configure 2008-09-17 13:34:28.000000000 +0200
+++ compiz-0.7.8-kde42/configure 2008-12-01 19:07:49.000000000 +0100
@@ -25429,7 +25429,7 @@
kde4libs=`kde4-config --install lib --expandvars 2>/dev/null`
kde4incs=`kde4-config --install include --expandvars 2>/dev/null`
- kde4_test_includes="kdecoration.h kcommondecoration.h kdecorationbridge.h plasma/panelsvg.h"
+ kde4_test_includes="kdecoration.h kcommondecoration.h kdecorationbridge.h plasma/framesvg.h"
{ echo "$as_me:$LINENO: checking for KWin headers" >&5
echo $ECHO_N "checking for KWin headers... $ECHO_C" >&6; }
diff -ur compiz-0.7.8/configure.ac compiz-0.7.8-kde42/configure.ac
--- compiz-0.7.8/configure.ac 2008-09-17 13:33:40.000000000 +0200
+++ compiz-0.7.8-kde42/configure.ac 2008-12-01 19:07:33.000000000 +0100
@@ -487,7 +487,7 @@
kde4libs=`kde4-config --install lib --expandvars 2>/dev/null`
kde4incs=`kde4-config --install include --expandvars 2>/dev/null`
- kde4_test_includes="kdecoration.h kcommondecoration.h kdecorationbridge.h plasma/panelsvg.h"
+ kde4_test_includes="kdecoration.h kcommondecoration.h kdecorationbridge.h plasma/framesvg.h"
dnl Check for KWin headers
AC_MSG_CHECKING([for KWin headers])
diff -ur compiz-0.7.8/kde/window-decorator-kde4/switcher.cpp compiz-0.7.8-kde42/kde/window-decorator-kde4/switcher.cpp
--- compiz-0.7.8/kde/window-decorator-kde4/switcher.cpp 2008-08-08 13:20:31.000000000 +0200
+++ compiz-0.7.8-kde42/kde/window-decorator-kde4/switcher.cpp 2008-12-01 19:13:18.000000000 +0100
@@ -30,7 +30,7 @@
#include <fixx11h.h>
-#include <KDE/Plasma/PanelSvg>
+#include <KDE/Plasma/FrameSvg>
#include <KDE/Plasma/Theme>
#include <kwindowsystem.h>
@@ -46,9 +46,9 @@
QColor color;
color = Plasma::Theme::defaultTheme ()->color (Plasma::Theme::TextColor);
- mBackground = new Plasma::PanelSvg();
+ mBackground = new Plasma::FrameSvg();
mBackground->setImagePath ("dialogs/background");
- mBackground->setEnabledBorders(Plasma::PanelSvg::AllBorders);
+ mBackground->setEnabledBorders(Plasma::FrameSvg::AllBorders);
mBorder.left = mBackground->marginSize(Plasma::LeftMargin);
mBorder.right = mBackground->marginSize(Plasma::RightMargin);
@@ -131,8 +131,8 @@
p.setCompositionMode (QPainter::CompositionMode_Source);
p.setRenderHint (QPainter::SmoothPixmapTransform);
- mBackground->resizePanel (QSizeF (contentWidth, contentHeight));
- mBackground->paintPanel (&p, QRect (0, 0, contentWidth,
+ mBackground->resizeFrame (QSizeF (contentWidth, contentHeight));
+ mBackground->paintFrame (&p, QRect (0, 0, contentWidth,
contentHeight));
mBackgroundPixmap = mPixmap.copy (mBorder.left, mBorder.top,
@@ -168,7 +168,7 @@
p.setCompositionMode (QPainter::CompositionMode_Source);
- mBackground->paintPanel (&p, QRect (mBorder.left, mBorder.top +
+ mBackground->paintFrame (&p, QRect (mBorder.left, mBorder.top +
mGeometry.height () + 5, mGeometry.width (),
fm.height ()));
diff -ur compiz-0.7.8/kde/window-decorator-kde4/switcher.h compiz-0.7.8-kde42/kde/window-decorator-kde4/switcher.h
--- compiz-0.7.8/kde/window-decorator-kde4/switcher.h 2008-08-08 13:20:31.000000000 +0200
+++ compiz-0.7.8-kde42/kde/window-decorator-kde4/switcher.h 2008-12-01 19:28:37.000000000 +0100
@@ -30,7 +30,7 @@
namespace Plasma
{
-class PanelSvg;
+class FrameSvg;
}
class QSpacerItem;
@@ -70,7 +70,7 @@
QRect mGeometry;
- Plasma::PanelSvg *mBackground;
+ Plasma::FrameSvg *mBackground;
QPixmap mPixmap;
QPixmap mBackgroundPixmap;