Backport gwd fix from upstream, should fix RH #484056
This commit is contained in:
parent
3538ba1b91
commit
fb3cf1e194
47
compiz-0.7.8-gwd-pixmap-fix.patch
Normal file
47
compiz-0.7.8-gwd-pixmap-fix.patch
Normal file
@ -0,0 +1,47 @@
|
||||
From 9fddbce130442354cdcc7d575c0c747e2c1c3a0f Mon Sep 17 00:00:00 2001
|
||||
From: Christopher Williams <crdlb@compiz-fusion.org>
|
||||
Date: Wed, 11 Feb 2009 08:23:11 +0000
|
||||
Subject: Fix compatibility with newer libmetacity-private versions.
|
||||
|
||||
GtkStyle is colormap specific, so we can't use a new colormap each time
|
||||
we create a pixmap.
|
||||
---
|
||||
diff --git a/gtk/window-decorator/gtk-window-decorator.c b/gtk/window-decorator/gtk-window-decorator.c
|
||||
index 5b14eb6..0ab118c 100644
|
||||
--- a/gtk/window-decorator/gtk-window-decorator.c
|
||||
+++ b/gtk/window-decorator/gtk-window-decorator.c
|
||||
@@ -637,32 +637,10 @@ static GdkPixmap *
|
||||
create_pixmap (int w,
|
||||
int h)
|
||||
{
|
||||
- GdkPixmap *pixmap;
|
||||
- GdkVisual *visual;
|
||||
- GdkColormap *colormap;
|
||||
-
|
||||
- visual = gdk_visual_get_best_with_depth (32);
|
||||
- if (!visual)
|
||||
- return NULL;
|
||||
-
|
||||
if (w == 0 || h ==0)
|
||||
abort ();
|
||||
|
||||
- pixmap = gdk_pixmap_new (NULL, w, h, 32);
|
||||
- if (!pixmap)
|
||||
- return NULL;
|
||||
-
|
||||
- colormap = gdk_colormap_new (visual, FALSE);
|
||||
- if (!colormap)
|
||||
- {
|
||||
- g_object_unref (G_OBJECT (pixmap));
|
||||
- return NULL;
|
||||
- }
|
||||
-
|
||||
- gdk_drawable_set_colormap (GDK_DRAWABLE (pixmap), colormap);
|
||||
- g_object_unref (G_OBJECT (colormap));
|
||||
-
|
||||
- return pixmap;
|
||||
+ return gdk_pixmap_new (GDK_DRAWABLE (style_window->window), w, h, 32);
|
||||
}
|
||||
|
||||
#define CORNER_TOPLEFT (1 << 0)
|
||||
|
10
compiz.spec
10
compiz.spec
@ -14,7 +14,7 @@ URL: http://www.go-compiz.org
|
||||
License: GPLv2+ and LGPLv2+ and MIT
|
||||
Group: User Interface/Desktops
|
||||
Version: 0.7.8
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
|
||||
Summary: OpenGL window and compositing manager
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -86,6 +86,9 @@ Patch126: compiz-0.7.8-kde42-crash.patch
|
||||
# 4cc1d813a9748c3740662233a2add3fe65a4c533
|
||||
Patch127: compiz-0.7.8-kde42-krunner.patch
|
||||
|
||||
# backport to fix RH #484056
|
||||
Patch128: compiz-0.7.8-gwd-pixmap-fix.patch
|
||||
|
||||
%description
|
||||
Compiz is one of the first OpenGL-accelerated compositing window
|
||||
managers for the X Window System. The integration allows it to perform
|
||||
@ -172,6 +175,8 @@ touch configure
|
||||
%patch125 -p1 -b .terminal
|
||||
%patch126 -p1 -b .kde-crash
|
||||
%patch127 -p1 -b .krunner
|
||||
%define _default_patch_fuzz 2
|
||||
%patch128 -p1 -b .gwd-pixmap
|
||||
|
||||
%build
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -388,6 +393,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Feb 28 2009 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.8-14
|
||||
- Backport gwd fix from upstream, should fix RH #484056
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.8-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user