0.6.2
This commit is contained in:
parent
9238c26fc0
commit
f90e30c583
@ -1,2 +1,2 @@
|
||||
compiz-0.6.0.tar.gz
|
||||
desktop-effects-0.7.7.tar.bz2
|
||||
compiz-0.6.2.tar.gz
|
||||
|
@ -1,26 +0,0 @@
|
||||
http://lists.freedesktop.org/archives/compiz/2007-October/002697.html
|
||||
|
||||
From: Danny Baumann <dannybaumann@web.de>
|
||||
Date: Tue, 2 Oct 2007 05:16:00 +0000 (+0200)
|
||||
Subject: We always need to restack windows on map. Newly created windows are placed on top ...
|
||||
X-Git-Tag: start
|
||||
X-Git-Url: http://gitweb.freedesktop.org/?p=xorg/app/compiz.git;a=commitdiff;h=b6c6acc70261d0942977441914c23e7a1c99215e
|
||||
|
||||
We always need to restack windows on map. Newly created windows are placed on top of the stack first, which is not desired for some windows that may be denied focus (such as desktop windows).
|
||||
This commit reverts commit 67648904b15c7781000a212a122b558a2d2afcf6.
|
||||
---
|
||||
|
||||
--- a/src/event.c
|
||||
+++ b/src/event.c
|
||||
@@ -1922,10 +1922,7 @@ handleEvent (CompDisplay *d,
|
||||
|
||||
allowFocus = allowWindowFocus (w);
|
||||
|
||||
- if (allowFocus)
|
||||
- updateWindowAttributes (w, CompStackingUpdateModeNormal);
|
||||
- else
|
||||
- updateWindowAttributes (w, CompStackingUpdateModeNone);
|
||||
+ updateWindowAttributes (w, CompStackingUpdateModeNormal);
|
||||
|
||||
if (!allowFocus &&
|
||||
(w->type & ~(CompWindowTypeSplashMask |
|
@ -1,75 +0,0 @@
|
||||
From: Danny Baumann <dannybaumann@web.de>
|
||||
Date: Tue, 2 Oct 2007 10:17:42 +0000 (+0200)
|
||||
Subject: Send synthetic configure notify events where needed according to ICCCM chapter 4 ...
|
||||
X-Git-Url: http://gitweb.opencompositing.org/?p=compiz;a=commitdiff_plain;h=d301a011471469fea70f3d3d519ed47ead1f8e22;hp=d5f647f57219b8413e3d964a214570a1ca12bac3
|
||||
|
||||
Send synthetic configure notify events where needed according to ICCCM chapter 4.1.5.
|
||||
Specifically, we have to send them when
|
||||
a) moving or restacking a window without resizing it
|
||||
b) not reacting to ConfigureRequest events.
|
||||
---
|
||||
|
||||
diff --git a/src/window.c b/src/window.c
|
||||
index 253976c..bbcdbeb 100644
|
||||
--- a/src/window.c
|
||||
+++ b/src/window.c
|
||||
@@ -2805,6 +2805,8 @@ syncWindowPosition (CompWindow *w)
|
||||
w->serverY = w->attrib.y;
|
||||
|
||||
XMoveWindow (w->screen->display->display, w->id, w->attrib.x, w->attrib.y);
|
||||
+ /* we moved without resizing, so we have to send a configure notify */
|
||||
+ sendConfigureNotify (w);
|
||||
|
||||
if (w->frame)
|
||||
XMoveWindow (w->screen->display->display, w->frame,
|
||||
@@ -3347,8 +3349,16 @@ configureXWindow (CompWindow *w,
|
||||
if (valueMask & CWBorderWidth)
|
||||
w->serverBorderWidth = xwc->border_width;
|
||||
|
||||
- XConfigureWindow (w->screen->display->display, w->id,
|
||||
- valueMask, xwc);
|
||||
+ if (valueMask)
|
||||
+ {
|
||||
+ XConfigureWindow (w->screen->display->display, w->id, valueMask, xwc);
|
||||
+ if (!(valueMask & (CWWidth | CWHeight)))
|
||||
+ {
|
||||
+ /* we have to send a configure notify event if we move or restack
|
||||
+ a window without resizing it according to ICCCM 4.1.5 */
|
||||
+ sendConfigureNotify (w);
|
||||
+ }
|
||||
+ }
|
||||
|
||||
if (w->frame && (valueMask & (CWSibling | CWStackMode)))
|
||||
XConfigureWindow (w->screen->display->display, w->frame,
|
||||
@@ -3795,6 +3805,18 @@ moveResizeWindow (CompWindow *w,
|
||||
}
|
||||
}
|
||||
|
||||
+ if (xwcm & CWX)
|
||||
+ {
|
||||
+ if (xwc->x == w->serverX)
|
||||
+ xwcm &= ~CWX;
|
||||
+ }
|
||||
+
|
||||
+ if (xwcm & CWY)
|
||||
+ {
|
||||
+ if (xwc->y == w->serverY)
|
||||
+ xwcm &= ~CWY;
|
||||
+ }
|
||||
+
|
||||
if (xwcm & CWBorderWidth)
|
||||
{
|
||||
if (xwc->border_width == w->serverBorderWidth)
|
||||
@@ -3820,6 +3842,12 @@ moveResizeWindow (CompWindow *w,
|
||||
sendSyncRequest (w);
|
||||
|
||||
configureXWindow (w, xwcm, xwc);
|
||||
+ if (!xwcm)
|
||||
+ {
|
||||
+ /* we have to send a configure notify on ConfigureRequest events if
|
||||
+ we decide not to do anything according to ICCCM 4.1.5 */
|
||||
+ sendConfigureNotify (w);
|
||||
+ }
|
||||
|
||||
if (placed)
|
||||
w->placed = TRUE;
|
13
compiz.spec
13
compiz.spec
@ -1,6 +1,6 @@
|
||||
%define dialogversion 0.7.7
|
||||
|
||||
%define core_plugins blur clone cube dbus decoration fade ini inotify minimize move place plane png regex resize rotate scale screenshot switcher video water wobbly zoom
|
||||
%define core_plugins blur clone cube dbus decoration fade ini inotify minimize move place plane png regex resize rotate scale screenshot switcher video water wobbly zoom fs
|
||||
|
||||
%define gnome_plugins annotate gconf glib svg
|
||||
|
||||
@ -12,8 +12,8 @@ Name: compiz
|
||||
URL: http://www.go-compiz.org
|
||||
License: X11/MIT/GPL
|
||||
Group: User Interface/Desktops
|
||||
Version: 0.6.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.6.2
|
||||
Release: 1%{?dist}
|
||||
|
||||
Summary: OpenGL window and compositing manager
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -46,8 +46,6 @@ BuildRequires: dbus-qt-devel
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Source1: desktop-effects-%{dialogversion}.tar.bz2
|
||||
|
||||
Patch0: compiz-synthetic-configure-notify-events.patch
|
||||
Patch1: compiz-always-restack-windows-on-map.patch
|
||||
# Patches that are not upstream
|
||||
Patch103: composite-cube-logo.patch
|
||||
Patch105: fedora-logo.patch
|
||||
@ -110,8 +108,6 @@ and other kde integration related stuff
|
||||
%setup -q -T -b1 -n desktop-effects-%{dialogversion}
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .synthetic-configure-notify-events
|
||||
%patch1 -p1 -b .always-restack-windows-on-map
|
||||
%patch103 -p1 -b .composite-cube-logo
|
||||
%if 0%{?fedora}
|
||||
%patch105 -p1 -b .fedora-logo
|
||||
@ -278,6 +274,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
|
||||
- 0.6.2
|
||||
|
||||
* Fri Oct 12 2007 Kristian Høgsberg <krh@redhat.com> - 0.6.0-2
|
||||
- Disable scale corner initiate and install a GNOME key config entry.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user