auto-import compiz-0.0.13-0.5.20060717git on branch devel from

compiz-0.0.13-0.5.20060717git.src.rpm
This commit is contained in:
Matthias Clasen 2006-07-18 17:15:08 +00:00
parent fa3ce39924
commit f86ce572a6
7 changed files with 303 additions and 0 deletions

View File

@ -0,0 +1 @@
compiz-99c96865db7b46b881fcd44f709008043ecfcb66.tar.bz2

56
aiglx-defaults.patch Normal file
View File

@ -0,0 +1,56 @@
Change the compiz indirect rendering and tfp binding settings to
From: Kristian Høgsberg <krh@redhat.com>
work with AIGLX.
---
src/main.c | 16 +++++++++++++---
1 files changed, 13 insertions(+), 3 deletions(-)
diff --git a/src/main.c b/src/main.c
index cf0a5d7..fd7afc3 100644
--- a/src/main.c
+++ b/src/main.c
@@ -72,8 +72,8 @@ CompWindow *lastFoundWindow = 0;
CompWindow *lastDamagedWindow = 0;
Bool replaceCurrentWm = FALSE;
-Bool indirectRendering = FALSE;
-Bool strictBinding = FALSE;
+Bool indirectRendering = TRUE;
+Bool strictBinding = TRUE;
static void
usage (void)
@@ -84,8 +84,10 @@ usage (void)
"[--refresh-rate RATE]\n "
"[--fast-filter] "
"[--indirect-rendering] "
+ "[--direct-rendering]\n "
"[--strict-binding] "
- "[--test-mode]\n "
+ "[--xgl-binding] "
+ "[--test-mode]\n "
"[--replace] "
"[--sm-disable] "
"[--sm-client-id ID] "
@@ -176,10 +178,18 @@ main (int argc, char **argv)
{
indirectRendering = TRUE;
}
+ else if (!strcmp (argv[i], "--direct-rendering"))
+ {
+ indirectRendering = FALSE;
+ }
else if (!strcmp (argv[i], "--strict-binding"))
{
strictBinding = TRUE;
}
+ else if (!strcmp (argv[i], "--xgl-binding"))
+ {
+ strictBinding = FALSE;
+ }
else if (!strcmp (argv[i], "--replace"))
{
replaceCurrentWm = TRUE;

110
compiz.spec Normal file
View File

@ -0,0 +1,110 @@
%define sha1 99c96865db7b46b881fcd44f709008043ecfcb66
Name: compiz
Url: http://www.freedesktop.org/Software/compiz
License: X11/MIT/GPL
Group: User Interface/Desktops
Version: 0.0.13
Release: 0.5.20060717git%{?dist}
Summary: OpenGL window and compositing manager
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: xorg-x11-server-Xorg >= 1.1.0-26
Requires: mesa-libGL >= 6.5-9
Requires: fedora-logos
BuildRequires: libX11-devel, libdrm-devel, libwnck-devel
BuildRequires: libXfixes-devel, libXrandr-devel, libXrender-devel
BuildRequires: libXcomposite-devel, libXdamage-devel, libXext-devel
BuildRequires: libXt-devel, libXmu-devel, libICE-devel, libSM-devel
BuildRequires: gnome-desktop-devel, control-center-devel, GConf2-devel
BuildRequires: gettext
Source0: %{name}-%{sha1}.tar.bz2
Patch100: gl-include-inferiors.patch
Patch101: aiglx-defaults.patch
Patch102: tfp-server-extension.patch
Patch103: composite-cube-logo.patch
Patch104: fbconfig-depth-fix.patch
Patch105: fedora-logo.patch
%description
Compiz is one of the first OpenGL-accelerated compositing window
managers for the X Window System. The integration allows it to perform
compositing effects in window management, such as a minimization
effect and a cube workspace. Compiz is an OpenGL compositing manager
that use Compiz use EXT_texture_from_pixmap OpenGL extension extension
for binding redirected top-level windows to texture objects.
%prep
%setup -q -n %{name}-%{sha1}
%patch100 -p1 -b .gl-include-inferiors
%patch101 -p1 -b .aiglx-defaults
%patch102 -p1 -b .tfp-server-extension
%patch103 -p1 -b .composite-cube-logo
%patch104 -p1 -b .fbconfig-depth-fix
%patch105 -p1 -b .fedora-logo
%build
%configure --disable-libsvg-cairo
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=0
make DESTDIR=$RPM_BUILD_ROOT install || exit 1
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
rm -rf $RPM_BUILD_ROOT%{_includedir}/compiz
rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
%post
export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
/usr/bin/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/compiz.schemas > /dev/null
%preun
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/compiz.schemas > /dev/null
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING* INSTALL README TODO
%{_bindir}/compiz
%{_bindir}/gnome-window-decorator
%{_libdir}/compiz/*.so
%{_libdir}/window-manager-settings/libcompiz.so
%{_sysconfdir}/gconf/schemas/compiz.schemas
%{_datadir}/compiz/*.png
%{_datadir}/gnome/wm-properties/compiz.desktop
%{_datadir}/locale/*/LC_MESSAGES/compiz.mo
%changelog
* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
- Do some changes forced upon us by package review
* Thu Jul 13 2006 Kristian Høgsberg <krh@redhat.com> - 0.0.13-5.1
- Use sane numbering scheme.
* Fri Jul 7 2006 Kristian Høgsberg <krh@redhat.com> - 0.0.13.fedora1-4
- Drop the fullscreen hardcode patch and require X server that has
GLX_MESA_copy_sub_buffer.
* Tue Jun 27 2006 Kristian Høgsberg <krh@redhat.com> - 0.0.13.fedora1-3
- Unbreak --replace.
* Thu Jun 15 2006 Kristian Høgsberg <krh@redhat.com> - 0.0.13.fedora1-2
- Add Requires, fix start-compiz.sh.
* Wed Jun 14 2006 Kristian Høgsberg <krh@redhat.com> - 0.0.13.fedora1-1
- Spec file for compiz, borrowing bits and pieces from Alphonse Van
Assches spec file (#192432).

43
composite-cube-logo.patch Normal file
View File

@ -0,0 +1,43 @@
Composite cube logo against background color.
From: Kristian Høgsberg <krh@redhat.com>
---
plugins/cube.c | 17 +++++++++++++++++
1 files changed, 17 insertions(+), 0 deletions(-)
diff --git a/plugins/cube.c b/plugins/cube.c
index b605e22..6439b9e 100644
--- a/plugins/cube.c
+++ b/plugins/cube.c
@@ -1204,11 +1204,28 @@ cubePaintTransformedScreen (CompScreen
if (cs->invert == 1 && s->size == 4 && cs->texture.name)
{
+ glTexEnvf (GL_TEXTURE_ENV, GL_TEXTURE_ENV_MODE, GL_COMBINE);
+
+ glTexEnvf (GL_TEXTURE_ENV, GL_COMBINE_RGB, GL_INTERPOLATE);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE0_RGB, GL_TEXTURE0);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE1_RGB, GL_PRIMARY_COLOR);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE2_RGB, GL_TEXTURE0);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND0_RGB, GL_SRC_COLOR);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND1_RGB, GL_SRC_COLOR);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND2_RGB, GL_SRC_ALPHA);
+
+ glTexEnvf (GL_TEXTURE_ENV, GL_COMBINE_ALPHA, GL_REPLACE);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE0_ALPHA, GL_PREVIOUS);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND0_ALPHA, GL_SRC_ALPHA);
+
enableTexture (s, &cs->texture, COMP_TEXTURE_FILTER_GOOD);
+
glTexCoordPointer (2, GL_FLOAT, 0, cs->tc);
glDrawArrays (GL_TRIANGLE_FAN, 0, cs->nvertices >> 1);
disableTexture (s, &cs->texture);
glDisableClientState (GL_TEXTURE_COORD_ARRAY);
+
+ glTexEnvi (GL_TEXTURE_ENV, GL_TEXTURE_ENV_MODE, GL_REPLACE);
}
else
{

56
fedora-logo.patch Normal file
View File

@ -0,0 +1,56 @@
Change cube logo defaults to use fedora logo and colors.
From: Kristian Høgsberg <krh@redhat.com>
---
plugins/compiz.schemas.in.in | 4 ++--
plugins/cube.c | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/plugins/compiz.schemas.in.in b/plugins/compiz.schemas.in.in
index 949cfe6..59c3e81 100644
--- a/plugins/compiz.schemas.in.in
+++ b/plugins/compiz.schemas.in.in
@@ -913,7 +913,7 @@
<applyto>/apps/compiz/plugins/cube/screen0/options/color</applyto>
<owner>compiz</owner>
<type>string</type>
- <default>#efebe7ff</default>
+ <default>#00194aff</default>
<locale name="C">
<short>Cube Color</short>
<long>
@@ -956,7 +956,7 @@
<owner>compiz</owner>
<type>list</type>
<list_type>string</list_type>
- <default>[novell.png]</default>
+ <default>[/usr/share/pixmaps/fedora-logo.png]</default>
<locale name="C">
<short>Image files</short>
<long>
diff --git a/plugins/cube.c b/plugins/cube.c
index 6439b9e..6563cca 100644
--- a/plugins/cube.c
+++ b/plugins/cube.c
@@ -44,14 +44,14 @@ #include <X11/Xproto.h>
#include <compiz.h>
-#define CUBE_COLOR_RED_DEFAULT 0xefef
-#define CUBE_COLOR_GREEN_DEFAULT 0xebeb
-#define CUBE_COLOR_BLUE_DEFAULT 0xe7e7
+#define CUBE_COLOR_RED_DEFAULT 0x0000
+#define CUBE_COLOR_GREEN_DEFAULT 0x1919
+#define CUBE_COLOR_BLUE_DEFAULT 0x4a4a
#define CUBE_IN_DEFAULT FALSE
static char *cubeImages[] = {
- "novell.png"
+ "/usr/share/pixmaps/fedora-logo.png"
};
#define N_CUBE_IMAGES (sizeof (cubeImages) / sizeof (cubeImages[0]))

View File

@ -0,0 +1 @@
4f652f76edac9e0cc7d6c0fe329de802 compiz-99c96865db7b46b881fcd44f709008043ecfcb66.tar.bz2

View File

@ -0,0 +1,36 @@
Make compiz look for GLX_EXT_texture_from_pixmap in the server extensions
From: Kristian Høgsberg <krh@redhat.com>
too.
---
src/screen.c | 8 ++++++--
1 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/screen.c b/src/screen.c
index f45663c..0a13d9b 100644
--- a/src/screen.c
+++ b/src/screen.c
@@ -897,7 +897,7 @@ addScreen (CompDisplay *display,
Window *children;
unsigned int nchildren;
int defaultDepth, nvisinfo, nElements, value, i;
- const char *glxExtensions, *glExtensions;
+ const char *glxExtensions, *glxServerExtensions, *glExtensions;
GLint stencilBits;
XSetWindowAttributes attrib;
GLfloat globalAmbient[] = { 0.1f, 0.1f, 0.1f, 0.1f };
@@ -1117,7 +1117,11 @@ addScreen (CompDisplay *display,
XFree (visinfo);
glxExtensions = glXQueryExtensionsString (s->display->display, screenNum);
- if (!strstr (glxExtensions, "GLX_EXT_texture_from_pixmap"))
+ glxServerExtensions = glXQueryServerString(s->display->display,
+ screenNum, GLX_EXTENSIONS );
+
+ if (!strstr (glxExtensions, "GLX_EXT_texture_from_pixmap") &&
+ !strstr (glxServerExtensions, "GLX_EXT_texture_from_pixmap"))
{
fprintf (stderr, "%s: GLX_EXT_texture_from_pixmap is missing\n",
programName);