- Update to 0.5.2.
- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz with LIBGL_ALWAYS_INDIRECT set.
This commit is contained in:
parent
eb563a182d
commit
e060f05729
@ -1,2 +1,2 @@
|
||||
compiz-0.5.0.tar.bz2
|
||||
compiz-0.5.2.tar.gz
|
||||
desktop-effects-0.7.2.tar.bz2
|
||||
|
42
compiz.spec
42
compiz.spec
@ -1,11 +1,11 @@
|
||||
%define dialogversion 0.7.1
|
||||
%define dialogversion 0.7.2
|
||||
%define plugins place,png,decoration,clone,fade,minimize,move,resize,switcher,scale
|
||||
|
||||
Name: compiz
|
||||
Url: http://www.go-compiz.org
|
||||
License: X11/MIT/GPL
|
||||
Group: User Interface/Desktops
|
||||
Version: 0.4.0
|
||||
Version: 0.5.2
|
||||
Release: 1%{?dist}
|
||||
|
||||
Summary: OpenGL window and compositing manager
|
||||
@ -18,7 +18,7 @@ Requires: xorg-x11-server-Xorg >= 1.1.0-26
|
||||
Requires: mesa-libGL >= 6.5-9
|
||||
Requires: libwnck >= 2.15.4
|
||||
Requires: system-logos
|
||||
Requires: gnome-session >= 2.16
|
||||
Requires: gnome-session >= 2.19.6-4
|
||||
Requires: metacity >= 2.18
|
||||
|
||||
Requires(pre): GConf2
|
||||
@ -47,7 +47,6 @@ Patch101: aiglx-defaults.patch
|
||||
Patch102: tfp-server-extension.patch
|
||||
Patch103: composite-cube-logo.patch
|
||||
Patch105: fedora-logo.patch
|
||||
Patch117: close-session.patch
|
||||
Patch118: compiz-0.3.6-wnck-modal-window.patch
|
||||
|
||||
%description
|
||||
@ -76,12 +75,9 @@ windows and compositing manager.
|
||||
%setup -q -T -b1 -n desktop-effects-%{dialogversion}
|
||||
%setup -q
|
||||
|
||||
%patch101 -p1 -b .aiglx-defaults
|
||||
%patch102 -p1 -b .tfp-server-extension
|
||||
%patch103 -p1 -b .composite-cube-logo
|
||||
# %patch103 -p1 -b .composite-cube-logo
|
||||
%patch105 -p1 -b .fedora-logo
|
||||
%patch117 -p1 -b .close-session
|
||||
%patch118 -p1 -b .wnck-modal-window
|
||||
# %patch118 -p1 -b .wnck-modal-window
|
||||
|
||||
%build
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -132,9 +128,9 @@ cat compiz.lang desktop-effects.lang > all.lang
|
||||
%post
|
||||
update-desktop-database -q %{_datadir}/applications
|
||||
export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
|
||||
|
||||
/usr/bin/gconftool-2 --makefile-install-rule \
|
||||
%{_sysconfdir}/gconf/schemas/compiz.schemas \
|
||||
%{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
|
||||
%{_sysconfdir}/gconf/schemas/*.schemas >& /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
|
||||
@ -144,16 +140,14 @@ fi
|
||||
if [ "$1" -gt 1 ]; then
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
gconftool-2 --makefile-uninstall-rule \
|
||||
%{_sysconfdir}/gconf/schemas/compiz.schemas \
|
||||
%{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
|
||||
%{_sysconfdir}/gconf/schemas/*.schemas >& /dev/null || :
|
||||
fi
|
||||
|
||||
%preun
|
||||
if [ "$1" -eq 0 ]; then
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
gconftool-2 --makefile-uninstall-rule \
|
||||
%{_sysconfdir}/gconf/schemas/compiz.schemas \
|
||||
%{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
|
||||
%{_sysconfdir}/gconf/schemas/*.schemas >& /dev/null || :
|
||||
fi
|
||||
|
||||
%postun
|
||||
@ -174,11 +168,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_libdir}/compiz
|
||||
%{_libdir}/compiz/*.so
|
||||
%{_libdir}/window-manager-settings/libcompiz.so
|
||||
%{_sysconfdir}/gconf/schemas/compiz.schemas
|
||||
%{_sysconfdir}/gconf/schemas/gwd.schemas
|
||||
%{_sysconfdir}/gconf/schemas/*.schemas
|
||||
%dir %{_datadir}/compiz
|
||||
%{_datadir}/compiz/*.png
|
||||
%{_datadir}/gnome/wm-properties/compiz.desktop
|
||||
%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
|
||||
%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
|
||||
%{_bindir}/desktop-effects
|
||||
%{_datadir}/compiz/desktop-effects.glade
|
||||
%{_datadir}/applications/redhat-desktop-effects.desktop
|
||||
@ -193,10 +188,23 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%defattr(-, root, root)
|
||||
%{_libdir}/pkgconfig/compiz.pc
|
||||
%{_libdir}/pkgconfig/libdecoration.pc
|
||||
%{_libdir}/pkgconfig/compiz-cube.pc
|
||||
%{_libdir}/pkgconfig/compiz-gconf.pc
|
||||
%{_libdir}/pkgconfig/compiz-scale.pc
|
||||
%{_datadir}/compiz/*.xml
|
||||
%{_datadir}/compiz/schemas.xslt
|
||||
%{_includedir}/compiz
|
||||
%{_libdir}/libdecoration.so
|
||||
|
||||
%changelog
|
||||
* Thu Aug 9 2007 Kristian Høgsberg <krh@redhat.com> - 0.5.2-1
|
||||
- Update to 0.5.2.
|
||||
- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
|
||||
with LIBGL_ALWAYS_INDIRECT set.
|
||||
|
||||
* Wed Jun 27 2007 Kristian Høgsberg <krh@redhat.com> - 0.5.0-1
|
||||
- Update to 0.5.0
|
||||
|
||||
* Tue Jun 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
|
||||
- Update to 0.4.0
|
||||
|
||||
|
@ -1,41 +1,24 @@
|
||||
--- compiz-0.3.6/plugins/cube.c.foo 2007-01-12 18:21:50.000000000 -0500
|
||||
+++ compiz-0.3.6/plugins/cube.c 2007-01-12 18:22:25.000000000 -0500
|
||||
@@ -46,14 +46,14 @@
|
||||
|
||||
#include <compiz.h>
|
||||
|
||||
-#define CUBE_COLOR_RED_DEFAULT 0xefef
|
||||
-#define CUBE_COLOR_GREEN_DEFAULT 0xebeb
|
||||
-#define CUBE_COLOR_BLUE_DEFAULT 0xe7e7
|
||||
+#define CUBE_COLOR_RED_DEFAULT 0x0000
|
||||
+#define CUBE_COLOR_GREEN_DEFAULT 0x1919
|
||||
+#define CUBE_COLOR_BLUE_DEFAULT 0x4a4a
|
||||
|
||||
#define CUBE_IN_DEFAULT FALSE
|
||||
|
||||
static char *cubeImages[] = {
|
||||
- "freedesktop"
|
||||
+ "fedora-logo"
|
||||
};
|
||||
#define N_CUBE_IMAGES (sizeof (cubeImages) / sizeof (cubeImages[0]))
|
||||
|
||||
--- compiz-0.3.6/plugins/compiz.schemas.in.foo 2006-12-28 22:27:00.000000000 -0500
|
||||
+++ compiz-0.3.6/plugins/compiz.schemas.in 2007-01-12 18:21:50.000000000 -0500
|
||||
@@ -15753,7 +15753,7 @@
|
||||
<applyto>/apps/compiz/plugins/cube/screen0/options/color</applyto>
|
||||
<owner>compiz</owner>
|
||||
<type>string</type>
|
||||
- <default>#efebe7ff</default>
|
||||
+ <default>#00194aff</default>
|
||||
<locale name="C">
|
||||
<short>Cube Color</short>
|
||||
<long>Color of top and bottom sides of the cube</long>
|
||||
@@ -15946,7 +15946,7 @@
|
||||
<owner>compiz</owner>
|
||||
<type>list</type>
|
||||
<list_type>string</list_type>
|
||||
- <default>[freedesktop]</default>
|
||||
+ <default>[/usr/share/pixmaps/fedora-logo]</default>
|
||||
<locale name="C">
|
||||
<short>Image files</short>
|
||||
<long>List of PNG and SVG files that should be rendered on top face of cube</long>
|
||||
--- compiz-0.5.2/metadata/cube.xml~ 2007-08-03 14:39:29.000000000 -0400
|
||||
+++ compiz-0.5.2/metadata/cube.xml 2007-08-08 18:48:30.000000000 -0400
|
||||
@@ -197,9 +197,9 @@
|
||||
<long xml:lang="zh_CN">立方体顶边和底边的颜色</long>
|
||||
<long xml:lang="zh_TW">立方體的頂面和底面顏色</long>
|
||||
<default>
|
||||
- <red>0xfefe</red>
|
||||
- <green>0xffff</green>
|
||||
- <blue>0xc7c7</blue>
|
||||
+ <red>0x1919</red>
|
||||
+ <green>0x4a4a</green>
|
||||
+ <blue>0xffff</blue>
|
||||
</default>
|
||||
</option>
|
||||
<option type="bool" name="in">
|
||||
@@ -319,7 +319,7 @@
|
||||
<long xml:lang="zh_TW">應該要描繪至立方體頂面的 PNG 和 SVG 檔案清單</long>
|
||||
<type>string</type>
|
||||
<default>
|
||||
- <value>freedesktop</value>
|
||||
+ <value>/usr/share/pixmaps/fedora-logo</value>
|
||||
</default>
|
||||
</option>
|
||||
<option type="bool" name="skydome">
|
||||
|
Loading…
x
Reference in New Issue
Block a user