update to 0.8.6

This commit is contained in:
drago01 2010-03-30 13:09:31 +00:00
parent 90c788bcbe
commit d2435e945a
10 changed files with 95 additions and 312 deletions

View File

@ -1,2 +1,3 @@
compiz-0.8.4.tar.bz2
kde-desktop-effects-0.0.6.tar.bz2
compiz-0.8.6.tar.bz2

View File

@ -1,12 +0,0 @@
diff -upNr compiz-0.8.2.orign/configure.ac compiz-0.8.2/configure.ac
--- compiz-0.8.2.orign/configure.ac 2009-03-01 13:10:46.000000000 +0100
+++ compiz-0.8.2/configure.ac 2009-08-22 17:25:51.905352173 +0200
@@ -331,7 +331,7 @@ if test "x$use_gtk" = "xyes"; then
if test "x$use_gnome" = "xyes"; then
PKG_CHECK_MODULES(GNOME_WINDOW_SETTINGS,
- gnome-window-settings-2.0 gnome-desktop-2.0,
+ gnome-window-settings-2.0 gnome-desktop-2.0 gconf-2.0,
[use_gnome=yes], [use_gnome=no])
fi

View File

@ -1,12 +0,0 @@
diff -upNr compiz-0.8.2.orign/metadata/gnomecompat.xml.in compiz-0.8.2/metadata/gnomecompat.xml.in
--- compiz-0.8.2.orign/metadata/gnomecompat.xml.in 2009-02-15 10:10:23.000000000 +0100
+++ compiz-0.8.2/metadata/gnomecompat.xml.in 2009-05-25 21:27:20.864114328 +0200
@@ -40,7 +40,7 @@
<option name="command_terminal" type="string">
<_short>Terminal command line</_short>
<_long>Terminal command line</_long>
- <default></default>
+ <default>gnome-terminal</default>
</option>
<option name="run_command_terminal_key" type="key">
<_short>Open a terminal</_short>

View File

@ -1,164 +0,0 @@
diff -upNr compiz-0.8.2.orign/include/compiz-core.h compiz-0.8.2/include/compiz-core.h
--- compiz-0.8.2.orign/include/compiz-core.h 2009-02-15 10:10:23.000000000 +0100
+++ compiz-0.8.2/include/compiz-core.h 2009-07-10 13:53:53.353467924 +0200
@@ -220,6 +220,9 @@ extern Bool noDetection;
extern Bool useDesktopHints;
extern Bool onlyCurrentScreen;
+extern char **initialPlugins;
+extern int nInitialPlugins;
+
extern int defaultRefreshRate;
extern char *defaultTextureFilter;
diff -upNr compiz-0.8.2.orign/src/display.c compiz-0.8.2/src/display.c
--- compiz-0.8.2.orign/src/display.c 2009-02-15 10:10:23.000000000 +0100
+++ compiz-0.8.2/src/display.c 2009-07-10 13:53:53.354468151 +0200
@@ -675,24 +675,59 @@ updatePlugins (CompDisplay *d)
{
CompOption *o;
CompPlugin *p, **pop = 0;
- int nPop, i, j;
+ int nPop, i, j, k, dupPluginCount;
+ CompOptionValue *pList;
+ int pList_count;
d->dirtyPluginList = FALSE;
o = &d->opt[COMP_DISPLAY_OPTION_ACTIVE_PLUGINS];
- /* The old plugin list always begins with the core plugin. To make sure
- we don't unnecessarily unload plugins if the new plugin list does not
- contain the core plugin, we have to use an offset */
- if (o->value.list.nValue > 0 && strcmp (o->value.list.value[0].s, "core"))
- i = 0;
- else
- i = 1;
+ /* Make sure the new plugin list always list core first, then the
+ initial plugins... */
+ dupPluginCount = 0;
+ for (i=0; i < o->value.list.nValue; ++i) {
+ if (strcmp(o->value.list.value[i].s, "core") == 0)
+ ++dupPluginCount;
+ else
+ for (j=0; j < nInitialPlugins; ++j)
+ if (strcmp(o->value.list.value[i].s, initialPlugins[j]) == 0) {
+ ++dupPluginCount;
+ break;
+ }
+ }
+
+ pList_count = 1+nInitialPlugins+o->value.list.nValue-dupPluginCount;
+
+ pList = malloc(sizeof(CompOptionValue) * pList_count);
+ if (!pList) {
+ (*core.setOptionForPlugin) (&d->base, "core", o->name, &d->plugin);
+ return;
+ }
+
+ pList[0].s = "core";
+ for (j=0; j < nInitialPlugins; ++j)
+ pList[j+1].s = initialPlugins[j];
+ ++j;
+
+ for (i=0; i < o->value.list.nValue; ++i) {
+ if (strcmp(o->value.list.value[i].s, "core") == 0)
+ goto L_nextPlugin;
+ else
+ for (k=0; k < nInitialPlugins; ++k)
+ if (strcmp(o->value.list.value[i].s, initialPlugins[k]) == 0)
+ goto L_nextPlugin;
+ pList[j++].s = o->value.list.value[i].s;
+ L_nextPlugin:
+ (void)0;
+ }
+
+ assert(j == pList_count);
/* j is initialized to 1 to make sure we never pop the core plugin */
- for (j = 1; j < d->plugin.list.nValue && i < o->value.list.nValue; i++, j++)
+ for (i = j = 1; j < d->plugin.list.nValue && i < pList_count; i++, j++)
{
- if (strcmp (d->plugin.list.value[j].s, o->value.list.value[i].s))
+ if (strcmp (d->plugin.list.value[j].s, pList[i].s))
break;
}
@@ -704,6 +739,7 @@ updatePlugins (CompDisplay *d)
if (!pop)
{
(*core.setOptionForPlugin) (&d->base, "core", o->name, &d->plugin);
+ free(pList);
return;
}
}
@@ -715,13 +751,13 @@ updatePlugins (CompDisplay *d)
free (d->plugin.list.value[d->plugin.list.nValue].s);
}
- for (; i < o->value.list.nValue; i++)
+ for (; i < pList_count; i++)
{
p = 0;
for (j = 0; j < nPop; j++)
{
if (pop[j] && strcmp (pop[j]->vTable->name,
- o->value.list.value[i].s) == 0)
+ pList[i].s) == 0)
{
if (pushPlugin (pop[j]))
{
@@ -734,7 +770,7 @@ updatePlugins (CompDisplay *d)
if (p == 0)
{
- p = loadPlugin (o->value.list.value[i].s);
+ p = loadPlugin (pList[i].s);
if (p)
{
if (!pushPlugin (p))
@@ -775,7 +811,9 @@ updatePlugins (CompDisplay *d)
if (nPop)
free (pop);
+ free(pList);
(*core.setOptionForPlugin) (&d->base, "core", o->name, &d->plugin);
+
}
static void
diff -upNr compiz-0.8.2.orign/src/main.c compiz-0.8.2/src/main.c
--- compiz-0.8.2.orign/src/main.c 2009-02-16 14:57:22.000000000 +0100
+++ compiz-0.8.2/src/main.c 2009-07-10 13:53:53.354468151 +0200
@@ -40,6 +40,9 @@ char *programName;
char **programArgv;
int programArgc;
+char **initialPlugins = NULL;
+int nInitialPlugins = 0;
+
char *backgroundImage = NULL;
REGION emptyRegion;
@@ -413,6 +416,11 @@ main (int argc, char **argv)
ptr += sprintf (ptr, "</default>");
}
+
+ initialPlugins = malloc (nPlugin * sizeof (char *));
+ memcpy (initialPlugins, plugin, nPlugin * sizeof (char *));
+ nInitialPlugins = nPlugin;
+
}
xmlInitParser ();
@@ -462,6 +470,9 @@ main (int argc, char **argv)
xmlCleanupParser ();
+ if (initialPlugins != NULL)
+ free (initialPlugins);
+
if (restartSignal)
{
execvp (programName, programArgv);

View File

@ -1,24 +0,0 @@
diff -upNr compiz-0.8.4.orign/configure.ac compiz-0.8.4/configure.ac
--- compiz-0.8.4.orign/configure.ac 2009-10-14 01:51:02.000000000 +0200
+++ compiz-0.8.4/configure.ac 2010-02-13 21:24:59.644078004 +0100
@@ -517,7 +517,7 @@ if test "x$use_kde4" = "xyes"; then
[use_kde4=yes], [use_kde4=no])
KDE4_CFLAGS="-I$kde4incs"
- KDE4_LIBS="-L$kde4libs -lkdecore -lkdecorations -lplasma"
+ KDE4_LIBS="-L$kde4libs -lkdecore -lkdecorations -lplasma -lX11 -lXext -ldl -lkdeui"
QT4_MOC=`pkg-config QtGui --variable=moc_location`
QDBUSXML2CPP=`pkg-config QtGui --variable=exec_prefix`"/bin/qdbusxml2cpp"
diff -upNr compiz-0.8.4.orign/src/Makefile.am compiz-0.8.4/src/Makefile.am
--- compiz-0.8.4.orign/src/Makefile.am 2009-09-30 14:46:45.000000000 +0200
+++ compiz-0.8.4/src/Makefile.am 2010-02-13 21:23:26.691078634 +0100
@@ -9,7 +9,7 @@ INCLUDES = \
bin_PROGRAMS = compiz
-compiz_LDADD = @COMPIZ_LIBS@ @GL_LIBS@ -lm
+compiz_LDADD = @COMPIZ_LIBS@ @GL_LIBS@ -lm -lX11 -lXext -ldl
compiz_LDFLAGS = -export-dynamic -pthread
compiz_SOURCES = \
main.c \

View File

@ -0,0 +1,35 @@
diff -upNr compiz-0.8.6.orign/include/compiz-core.h compiz-0.8.6/include/compiz-core.h
--- compiz-0.8.6.orign/include/compiz-core.h 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/include/compiz-core.h 2010-03-30 14:48:59.055172395 +0200
@@ -27,6 +27,7 @@
#define _COMPIZ_CORE_H
#include <compiz-plugin.h>
+#include <dlfcn.h>
#define CORE_ABIVERSION 20091102
diff -upNr compiz-0.8.6.orign/plugins/gconf.c compiz-0.8.6/plugins/gconf.c
--- compiz-0.8.6.orign/plugins/gconf.c 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/plugins/gconf.c 2010-03-30 14:48:59.056187055 +0200
@@ -802,6 +802,8 @@ gconfFiniObject (CompPlugin *p,
static Bool
gconfInit (CompPlugin *p)
{
+ dlopen ("libgconf-2.so.4", RTLD_LAZY);
+
if (!compInitPluginMetadataFromInfo (&gconfMetadata, p->vTable->name,
0, 0, 0, 0))
return FALSE;
diff -upNr compiz-0.8.6.orign/plugins/glib.c compiz-0.8.6/plugins/glib.c
--- compiz-0.8.6.orign/plugins/glib.c 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/plugins/glib.c 2010-03-30 14:48:59.056187055 +0200
@@ -197,6 +197,8 @@ glibInitDisplay (CompPlugin *p,
{
GLibDisplay *gd;
+ dlopen ("libglib-2.0.so.0", RTLD_LAZY);
+
if (!checkPluginABI ("core", CORE_ABIVERSION))
return FALSE;

View File

@ -1,6 +1,6 @@
diff -upNr compiz-0.8.2.orign/metadata/Makefile.am compiz-0.8.2/metadata/Makefile.am
--- compiz-0.8.2.orign/metadata/Makefile.am 2009-02-15 10:11:43.000000000 +0100
+++ compiz-0.8.2/metadata/Makefile.am 2009-07-11 10:36:15.265893844 +0200
diff -upNr compiz-0.8.6.orign/metadata/Makefile.am compiz-0.8.6/metadata/Makefile.am
--- compiz-0.8.6.orign/metadata/Makefile.am 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/metadata/Makefile.am 2010-03-30 14:53:23.499283857 +0200
@@ -31,6 +31,7 @@ xml_in_files = \
video.xml.in \
water.xml.in \
@ -9,40 +9,9 @@ diff -upNr compiz-0.8.2.orign/metadata/Makefile.am compiz-0.8.2/metadata/Makefil
zoom.xml.in
xml_files = $(xml_in_files:.xml.in=.xml)
xml_DATA = $(xml_files)
diff -upNr compiz-0.8.2.orign/plugins/Makefile.am compiz-0.8.2/plugins/Makefile.am
--- compiz-0.8.2.orign/plugins/Makefile.am 2009-02-15 10:10:23.000000000 +0100
+++ compiz-0.8.2/plugins/Makefile.am 2009-07-11 10:19:29.303832241 +0200
@@ -74,6 +74,9 @@ libcommands_la_SOURCES = commands.c
libgnomecompat_la_LDFLAGS = -module -avoid-version -no-undefined
libgnomecompat_la_SOURCES = gnomecompat.c
+libwall_la_LDFLAGS = -module -avoid-version -no-undefined `pkg-config --libs cairo`
+libwall_la_SOURCES = wall.c wall_options.c
+
if USE_LIBRSVG
libsvg_la_DEPENDENCIES = $(top_builddir)/libdecoration/libdecoration.la
libsvg_la_LDFLAGS = -module -avoid-version -no-undefined
@@ -149,7 +152,8 @@ INCLUDES = \
-DIMAGEDIR=\"$(imagedir)\" \
-I$(top_srcdir)/include \
-I$(top_builddir)/include \
- -DMETADATADIR=\"$(metadatadir)\"
+ -DMETADATADIR=\"$(metadatadir)\" \
+ `pkg-config --cflags cairo`
moduledir = $(plugindir)
@@ -181,6 +185,7 @@ module_LTLIBRARIES = \
libobs.la \
libcommands.la \
libgnomecompat.la \
+ libwall.la \
$(libsvg_module) \
$(libannotate_module) \
$(libinotify_module) \
diff -upNr compiz-0.8.4.orig/metadata/wall.xml.in compiz-0.8.4/metadata/wall.xml.in
--- compiz-0.8.4.orig/metadata/wall.xml.in 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.4/metadata/wall.xml.in 2009-10-14 02:01:42.000000000 +0100
diff -upNr compiz-0.8.6.orign/metadata/wall.xml.in compiz-0.8.6/metadata/wall.xml.in
--- compiz-0.8.6.orign/metadata/wall.xml.in 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.6/metadata/wall.xml.in 2010-03-30 14:53:23.499283857 +0200
@@ -0,0 +1,357 @@
+<?xml version="1.0"?>
+<compiz>
@ -401,10 +370,41 @@ diff -upNr compiz-0.8.4.orig/metadata/wall.xml.in compiz-0.8.4/metadata/wall.xml
+ </screen>
+ </plugin>
+</compiz>
diff -upNr compiz-0.8.4.orig/plugins/wall.c compiz-0.8.4/plugins/wall.c
--- compiz-0.8.4.orig/plugins/wall.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.4/plugins/wall.c 2009-10-14 02:01:42.000000000 +0100
@@ -0,0 +1,2263 @@
diff -upNr compiz-0.8.6.orign/plugins/Makefile.am compiz-0.8.6/plugins/Makefile.am
--- compiz-0.8.6.orign/plugins/Makefile.am 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/plugins/Makefile.am 2010-03-30 14:53:23.499283857 +0200
@@ -74,6 +74,9 @@ libcommands_la_SOURCES = commands.c
libgnomecompat_la_LDFLAGS = -module -avoid-version -no-undefined
libgnomecompat_la_SOURCES = gnomecompat.c
+libwall_la_LDFLAGS = -module -avoid-version -no-undefined `pkg-config --libs cairo`
+libwall_la_SOURCES = wall.c wall_options.c
+
if USE_LIBRSVG
libsvg_la_DEPENDENCIES = $(top_builddir)/libdecoration/libdecoration.la
libsvg_la_LDFLAGS = -module -avoid-version -no-undefined
@@ -149,7 +152,8 @@ INCLUDES = \
-DIMAGEDIR=\"$(imagedir)\" \
-I$(top_srcdir)/include \
-I$(top_builddir)/include \
- -DMETADATADIR=\"$(metadatadir)\"
+ -DMETADATADIR=\"$(metadatadir)\" \
+ `pkg-config --cflags cairo`
moduledir = $(plugindir)
@@ -181,6 +185,7 @@ module_LTLIBRARIES = \
libobs.la \
libcommands.la \
libgnomecompat.la \
+ libwall.la \
$(libsvg_module) \
$(libannotate_module) \
$(libinotify_module) \
diff -upNr compiz-0.8.6.orign/plugins/wall.c compiz-0.8.6/plugins/wall.c
--- compiz-0.8.6.orign/plugins/wall.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.6/plugins/wall.c 2010-03-30 14:54:31.256187250 +0200
@@ -0,0 +1,2264 @@
+/**
+ *
+ * Compiz wall plugin
@ -2639,6 +2639,7 @@ diff -upNr compiz-0.8.4.orig/plugins/wall.c compiz-0.8.4/plugins/wall.c
+static Bool
+wallInit (CompPlugin *p)
+{
+ dlopen ("libcairo.so.2", RTLD_LAZY);
+ WallCorePrivateIndex = allocateCorePrivateIndex ();
+ if (WallCorePrivateIndex < 0)
+ return FALSE;
@ -2668,9 +2669,9 @@ diff -upNr compiz-0.8.4.orig/plugins/wall.c compiz-0.8.4/plugins/wall.c
+{
+ return &wallVTable;
+}
diff -upNr compiz-0.8.4.orig/plugins/wall_options.c compiz-0.8.4/plugins/wall_options.c
--- compiz-0.8.4.orig/plugins/wall_options.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.4/plugins/wall_options.c 2010-01-16 15:52:04.000000000 +0000
diff -upNr compiz-0.8.6.orign/plugins/wall_options.c compiz-0.8.6/plugins/wall_options.c
--- compiz-0.8.6.orign/plugins/wall_options.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.6/plugins/wall_options.c 2010-03-30 14:53:23.509344956 +0200
@@ -0,0 +1,1949 @@
+/*
+ * This file is autogenerated with bcop:
@ -4621,9 +4622,9 @@ diff -upNr compiz-0.8.4.orig/plugins/wall_options.c compiz-0.8.4/plugins/wall_op
+ return &wallOptionsVTable;
+}
+
diff -upNr compiz-0.8.4.orig/plugins/wall_options.h compiz-0.8.4/plugins/wall_options.h
--- compiz-0.8.4.orig/plugins/wall_options.h 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.4/plugins/wall_options.h 2010-01-16 15:52:04.000000000 +0000
diff -upNr compiz-0.8.6.orign/plugins/wall_options.h compiz-0.8.6/plugins/wall_options.h
--- compiz-0.8.6.orign/plugins/wall_options.h 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.6/plugins/wall_options.h 2010-03-30 14:53:23.510343112 +0200
@@ -0,0 +1,375 @@
+/*
+ * This file is autogenerated with bcop:

View File

@ -12,8 +12,8 @@ Name: compiz
URL: http://www.go-compiz.org
License: GPLv2+ and LGPLv2+ and MIT
Group: User Interface/Desktops
Version: 0.8.4
Release: 6%{?dist}
Version: 0.8.6
Release: 1%{?dist}
Summary: OpenGL window and compositing manager
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -54,12 +54,9 @@ Obsoletes: beryl-core
Patch103: composite-cube-logo.patch
Patch105: fedora-logo.patch
Patch106: redhat-logo.patch
Patch107: compiz-0.8.4-wall.patch
Patch107: compiz-0.8.6-wall.patch
#Patch110: scale-key.patch
Patch127: unknown-key.patch
Patch128: kde44-api.patch
Patch129: compiz-0.8.4-linkfix.patch
Patch111: compiz-0.8.6-unloadpluginfix.patch
%description
Compiz is one of the first OpenGL-accelerated compositing window
@ -125,11 +122,7 @@ and other kde integration related stuff.
%endif
%patch107 -p1 -b .wall
#%patch110 -p1 -b .scale-key
%patch127 -p1 -b .unknown-key
# http://bugs.opencompositing.org/show_bug.cgi?id=1249
%patch128 -p1 -b .kde44-api
%patch129 -p1 -b .linkfix
%patch111 -p1 -b .unloadfix
%build
rm -rf $RPM_BUILD_ROOT
@ -308,6 +301,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Mar 30 2010 Adel Gadllah <adel.gadllah@gmail.com> - 0.8.6-1
- Update to 0.8.6
- Drop upstreamed patches
- Forward port crashfix from F-12
* Sun Feb 21 2010 Adel Gadllah <adel.gadllah@gmail.com> - 0.8.4-6
- Use ccp if present (RH #532229)

View File

@ -1,2 +1,2 @@
03fa78ce0c464f3a413b2a3b74f09559 compiz-0.8.4.tar.bz2
e40e51ba5837a11bea58231b6ae49611 kde-desktop-effects-0.0.6.tar.bz2
1e284eade99ff310551d5919b6ba57c1 compiz-0.8.6.tar.bz2

View File

@ -1,40 +0,0 @@
diff -up compiz-0.8.2/gtk/gnome/50-compiz-desktop-key.xml.in.unknown-key compiz-0.8.2/gtk/gnome/50-compiz-desktop-key.xml.in
--- compiz-0.8.2/gtk/gnome/50-compiz-desktop-key.xml.in.unknown-key 2009-10-26 19:31:49.714797414 -0400
+++ compiz-0.8.2/gtk/gnome/50-compiz-desktop-key.xml.in 2009-10-26 19:32:47.250797450 -0400
@@ -1,16 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<KeyListEntries _name="Desktop" wm_name="compiz" package="compiz">
- <KeyListEntry name="/apps/compiz/gnomecompat/allscreens/options/run_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/gnomecompat/allscreens/options/run_key"/>
- <KeyListEntry name="/apps/compiz/gnomecompat/allscreens/options/main_menu_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/gnomecompat/allscreens/options/main_menu_key"/>
- <KeyListEntry name="/apps/compiz/gnomecompat/allscreens/options/run_command_screenshot_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/gnomecompat/allscreens/options/run_command_screenshot_key"/>
- <KeyListEntry name="/apps/compiz/gnomecompat/allscreens/options/run_command_window_screenshot_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/gnomecompat/allscreens/options/run_command_window_screenshot_key"/>
<KeyListEntry name="/apps/compiz/general/allscreens/options/show_desktop_key"/>
- <KeyListEntry name="/apps/compiz/gnomecompat/allscreens/options/run_command_terminal_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/gnomecompat/allscreens/options/run_command_terminal_key"/>
</KeyListEntries>
diff -up compiz-0.8.2/gtk/gnome/50-compiz-key.xml.in.unknown-key compiz-0.8.2/gtk/gnome/50-compiz-key.xml.in
--- compiz-0.8.2/gtk/gnome/50-compiz-key.xml.in.unknown-key 2009-10-26 19:33:00.669802869 -0400
+++ compiz-0.8.2/gtk/gnome/50-compiz-key.xml.in 2009-10-26 19:47:07.630802031 -0400
@@ -15,9 +15,9 @@
<KeyListEntry name="/apps/compiz/general/allscreens/options/minimize_window_key"/>
- <KeyListEntry name="/apps/compiz/general/allscreens/options/opacity_decrease_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/obs/allscreens/options/opacity_decrease_key"/>
- <KeyListEntry name="/apps/compiz/general/allscreens/options/opacity_increase_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/obs/allscreens/options/opacity_increase_key"/>
<KeyListEntry name="/apps/compiz/general/allscreens/options/show_desktop_key"/>