Retire compiz due to lack of a maintainer.

This commit is contained in:
Bill Nottingham 2012-02-06 14:34:19 -05:00
parent 22b81f2428
commit 9dcac2c352
26 changed files with 1 additions and 7174 deletions

View File

@ -1,45 +0,0 @@
From 984bca5801d6179b9f8081c4b6c466063975d940 Mon Sep 17 00:00:00 2001
From: Owen W. Taylor <otaylor@fishsoup.net>
Date: Tue, 22 Jun 2010 23:29:17 +0000
Subject: Don't stack focus-denied windows in a disallowed position
When a window is focus-stealing-prevented, we should only stack
it below the active window if that is possible. If it's not
(the window has the "Above" state, for example), then we should
stack it at the normal location.
http://bugs.opencompositing.org/show_bug.cgi?id=1304
---
diff --git a/src/window.c b/src/window.c
index 60b47b9..0cfeee9 100644
--- a/src/window.c
+++ b/src/window.c
@@ -4447,14 +4447,19 @@ updateWindowAttributes (CompWindow *w,
if (p->id == w->screen->display->activeWindow)
break;
- /* window is above active window so we should lower it */
- if (p)
+ /* window is above active window so we should lower it, assuming
+ * that is allowed (if, for example, our window has the "above" state,
+ * then lowering beneath the active window may not be allowed.)
+ */
+ if (p && validSiblingBelow (p, w))
+ {
p = findValidStackSiblingBelow (sibling, p);
- /* if we found a valid sibling under the active window, it's
- our new sibling we want to stack above */
- if (p)
- sibling = p;
+ /* if we found a valid sibling under the active window, it's
+ our new sibling we want to stack above */
+ if (p)
+ sibling = p;
+ }
}
mask |= addWindowStackChanges (w, &xwc, sibling);
--
cgit v0.8.3.1-30-gff3a

View File

@ -1,42 +0,0 @@
From 1bed3dbcea6473f84745ec7a1f936c4f5d3b3a01 Mon Sep 17 00:00:00 2001
From: Danny Baumann <dannybaumann@web.de>
Date: Sat, 03 Apr 2010 12:14:19 +0000
Subject: Correctly handle weird icon sizes.
iw * ih may overflow the value range of unsigned long if iw and ih are
large enough, so check the single values as well.
---
diff --git a/src/window.c b/src/window.c
index 24300fe..bd5aae8 100644
--- a/src/window.c
+++ b/src/window.c
@@ -5361,18 +5361,22 @@ getWindowIcon (CompWindow *w,
if (result == Success && data)
{
- CARD32 *p;
- CARD32 alpha, red, green, blue;
- int iw, ih, j;
+ CARD32 *p;
+ CARD32 alpha, red, green, blue;
+ unsigned long iw, ih;
for (i = 0; i + 2 < n; i += iw * ih + 2)
{
unsigned long *idata = (unsigned long *) data;
+ unsigned long j;
iw = idata[i];
ih = idata[i + 1];
- if (iw * ih + 2 > n - i)
+ /* iw * ih may be larger than the value range of unsigned
+ long, so better do some checking for extremely weird
+ icon sizes first */
+ if (iw > 2048 || ih > 2048 || iw * ih + 2 > n - i)
break;
if (iw && ih)
--
cgit v0.8.3.1-30-gff3a

View File

@ -1,44 +0,0 @@
From a86c461684f122fd286884c4ff28f6ea673fe669 Mon Sep 17 00:00:00 2001
From: Danny Baumann <dannybaumann@web.de>
Date: Tue, 15 Jun 2010 05:47:05 +0000
Subject: Only reflect the decoration size in MapRequest gravity adjustment, not
the whole window size.
---
diff --git a/src/event.c b/src/event.c
index 8600b5b..febb22d 100644
--- a/src/event.c
+++ b/src/event.c
@@ -2042,11 +2042,11 @@ handleEvent (CompDisplay *d,
XWindowChanges xwc;
unsigned int xwcm, source;
- /* adjust for gravity */
+ /* adjust for gravity, but only for frame size */
xwc.x = w->serverX;
xwc.y = w->serverY;
- xwc.width = w->serverWidth;
- xwc.height = w->serverHeight;
+ xwc.width = 0;
+ xwc.height = 0;
xwcm = adjustConfigureRequestForGravity (w, &xwc,
CWX | CWY,
diff --git a/src/window.c b/src/window.c
index 9974df2..60b47b9 100644
--- a/src/window.c
+++ b/src/window.c
@@ -2568,8 +2568,8 @@ unmapWindow (CompWindow *w)
/* revert gravity adjustment made at MapRequest time */
xwc.x = w->serverX;
xwc.y = w->serverY;
- xwc.width = w->serverWidth;
- xwc.height = w->serverHeight;
+ xwc.width = 0;
+ xwc.height = 0;
xwcm = adjustConfigureRequestForGravity (w, &xwc,
CWX | CWY,
--
cgit v0.8.3.1-30-gff3a

View File

@ -1,25 +0,0 @@
From 0f95c41a0aa175ddf7947ba18b01f746c95594a9 Mon Sep 17 00:00:00 2001
From: Paul Donohue <compiz@paulsd.com>
Date: Sun, 17 Oct 2010 16:24:14 +0000
Subject: Fix pixmap size calculation, server drawn borders are also included in
the pixmap.
---
diff --git a/src/window.c b/src/window.c
index a925288..6674643 100644
--- a/src/window.c
+++ b/src/window.c
@@ -1446,8 +1446,8 @@ bindWindow (CompWindow *w)
}
w->pixmap = XCompositeNameWindowPixmap (dpy, w->id);
- w->width = attr.width;
- w->height = attr.height;
+ w->width = attr.width + attr.border_width * 2;
+ w->height = attr.height + attr.border_width * 2;
XUngrabServer (dpy);
}
--
cgit v0.8.3.1-30-gff3a

View File

@ -1,35 +0,0 @@
diff -upNr compiz-0.8.6.orign/include/compiz-core.h compiz-0.8.6/include/compiz-core.h
--- compiz-0.8.6.orign/include/compiz-core.h 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/include/compiz-core.h 2010-03-30 14:48:59.055172395 +0200
@@ -27,6 +27,7 @@
#define _COMPIZ_CORE_H
#include <compiz-plugin.h>
+#include <dlfcn.h>
#define CORE_ABIVERSION 20091102
diff -upNr compiz-0.8.6.orign/plugins/gconf.c compiz-0.8.6/plugins/gconf.c
--- compiz-0.8.6.orign/plugins/gconf.c 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/plugins/gconf.c 2010-03-30 14:48:59.056187055 +0200
@@ -802,6 +802,8 @@ gconfFiniObject (CompPlugin *p,
static Bool
gconfInit (CompPlugin *p)
{
+ dlopen ("libgconf-2.so.4", RTLD_LAZY);
+
if (!compInitPluginMetadataFromInfo (&gconfMetadata, p->vTable->name,
0, 0, 0, 0))
return FALSE;
diff -upNr compiz-0.8.6.orign/plugins/glib.c compiz-0.8.6/plugins/glib.c
--- compiz-0.8.6.orign/plugins/glib.c 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/plugins/glib.c 2010-03-30 14:48:59.056187055 +0200
@@ -197,6 +197,8 @@ glibInitDisplay (CompPlugin *p,
{
GLibDisplay *gd;
+ dlopen ("libglib-2.0.so.0", RTLD_LAZY);
+
if (!checkPluginABI ("core", CORE_ABIVERSION))
return FALSE;

File diff suppressed because it is too large Load Diff

View File

@ -1,60 +0,0 @@
--- compiz-with-glib-mainloop/plugins/cube/cube.xml.in 2011-01-15 13:20:16.396170197 +0000
+++ compiz-with-glib-mainloop/plugins/cube/cube.xml.in.new 2011-01-15 14:14:24.005435105 +0000
@@ -86,18 +86,18 @@
<_short>Top</_short>
<_long>Color of top face of the cube</_long>
<default>
- <red>0xffff</red>
- <green>0xffff</green>
- <blue>0xffff</blue>
+ <red>0x0000</red>
+ <green>0x1919</green>
+ <blue>0x4a4a</blue>
</default>
</option>
<option name="bottom_color" type="color">
<_short>Bottom</_short>
<_long>Color of bottom face of the cube</_long>
<default>
- <red>0xffff</red>
- <green>0xffff</green>
- <blue>0xffff</blue>
+ <red>0x0000</red>
+ <green>0x1919</green>
+ <blue>0x4a4a</blue>
</default>
</option>
</subgroup>
@@ -112,6 +112,7 @@
<_short>Skydome Image</_short>
<_long>Image to use as texture for the skydome</_long>
<hints>file;image;</hints>
+ <value>/usr/share/pixmaps/fedora-logo</value>
</option>
<option name="skydome_animated" type="bool">
<_short>Animate Skydome</_short>
@@ -122,18 +123,18 @@
<_short>Skydome Gradient Start Color</_short>
<_long>Color to use for the top color-stop of the skydome-fallback gradient</_long>
<default>
- <red>0x0d0d</red>
- <green>0xb1b1</green>
- <blue>0xfdfd</blue>
+ <red>0x0000</red>
+ <green>0x1919</green>
+ <blue>0x4a4a</blue>
</default>
</option>
<option name="skydome_gradient_end_color" type="color">
<_short>Skydome Gradient End Color</_short>
<_long>Color to use for the bottom color-stop of the skydome-fallback gradient</_long>
<default>
- <red>0xfefe</red>
- <green>0xffff</green>
- <blue>0xc7c7</blue>
+ <red>0x0000</red>
+ <green>0x1919</green>
+ <blue>0x4a4a</blue>
</default>
</option>
</subgroup>

View File

@ -1,60 +0,0 @@
--- compiz-with-glib-mainloop/plugins/cube/cube.xml.in 2011-01-15 13:20:16.396170197 +0000
+++ compiz-with-glib-mainloop/plugins/cube/cube.xml.in.new 2011-01-15 14:14:24.005435105 +0000
@@ -86,18 +86,18 @@
<_short>Top</_short>
<_long>Color of top face of the cube</_long>
<default>
- <red>0xffff</red>
- <green>0xffff</green>
- <blue>0xffff</blue>
+ <red>0x8888</red>
+ <green>0x0000</green>
+ <blue>0x0000</blue>
</default>
</option>
<option name="bottom_color" type="color">
<_short>Bottom</_short>
<_long>Color of bottom face of the cube</_long>
<default>
- <red>0xffff</red>
- <green>0xffff</green>
- <blue>0xffff</blue>
+ <red>0x8888</red>
+ <green>0x0000</green>
+ <blue>0x0000</blue>
</default>
</option>
</subgroup>
@@ -112,6 +112,7 @@
<_short>Skydome Image</_short>
<_long>Image to use as texture for the skydome</_long>
<hints>file;image;</hints>
+ <value>/usr/share/pixmaps/redhat/shadowman-transparent</value>
</option>
<option name="skydome_animated" type="bool">
<_short>Animate Skydome</_short>
@@ -122,18 +123,18 @@
<_short>Skydome Gradient Start Color</_short>
<_long>Color to use for the top color-stop of the skydome-fallback gradient</_long>
<default>
- <red>0x0d0d</red>
- <green>0xb1b1</green>
- <blue>0xfdfd</blue>
+ <red>0x8888</red>
+ <green>0x0000</green>
+ <blue>0x0000</blue>
</default>
</option>
<option name="skydome_gradient_end_color" type="color">
<_short>Skydome Gradient End Color</_short>
<_long>Color to use for the bottom color-stop of the skydome-fallback gradient</_long>
<default>
- <red>0xfefe</red>
- <green>0xffff</green>
- <blue>0xc7c7</blue>
+ <red>0x8888</red>
+ <green>0x0000</green>
+ <blue>0x0000</blue>
</default>
</option>
</subgroup>

View File

@ -1,59 +0,0 @@
--- compiz-with-glib-mainloop/gtk/gnome/CMakeLists.txt 2011-01-15 13:20:16.375170002 +0000
+++ compiz-with-glib-mainloop/gtk/gnome/CMakeLists.txt.new 2011-01-16 00:57:18.129161249 +0000
@@ -1,3 +1,26 @@
+if (USE_GNOME_KEYBINDINGS)
+ compiz_translate_xml (
+ ${CMAKE_CURRENT_SOURCE_DIR}/50-compiz-desktop-key.xml.in
+ ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-desktop-key.xml
+ )
+ compiz_translate_xml (
+ ${CMAKE_CURRENT_SOURCE_DIR}/50-compiz-key.xml.in
+ ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-key.xml
+ )
+ set (key_xml
+ ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-desktop-key.xml
+ ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-key.xml
+ )
+ compiz_opt_install_file (
+ ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-desktop-key.xml
+ ${keybindingsdir}/50-compiz-desktop-key.xml
+ )
+ compiz_opt_install_file (
+ ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-key.xml
+ ${keybindingsdir}/50-compiz-key.xml
+ )
+endif (USE_GNOME_KEYBINDINGS)
+
if (USE_GNOME)
include_directories (
@@ -36,29 +59,6 @@
)
- if (USE_GNOME_KEYBINDINGS)
- compiz_translate_xml (
- ${CMAKE_CURRENT_SOURCE_DIR}/50-compiz-desktop-key.xml.in
- ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-desktop-key.xml
- )
- compiz_translate_xml (
- ${CMAKE_CURRENT_SOURCE_DIR}/50-compiz-key.xml.in
- ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-key.xml
- )
- set (key_xml
- ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-desktop-key.xml
- ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-key.xml
- )
- compiz_opt_install_file (
- ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-desktop-key.xml
- ${keybindingsdir}/50-compiz-desktop-key.xml
- )
- compiz_opt_install_file (
- ${CMAKE_CURRENT_BINARY_DIR}/50-compiz-key.xml
- ${keybindingsdir}/50-compiz-key.xml
- )
- endif (USE_GNOME_KEYBINDINGS)
-
add_library (gnome-compiz MODULE
compiz-window-manager.c
compiz-window-manager.h

View File

@ -1,8 +0,0 @@
[Desktop Entry]
Encoding=UTF-8
Name=Classic GNOME with Compiz
Comment=This session logs you into the classic GNOME desktop (panel, not shell) with Compiz
Exec=/usr/bin/gnome-session --session=compiz-gnome
# no icon yet, only the top three are currently used
Icon=
Type=XSession

View File

@ -1,6 +0,0 @@
[GNOME Session]
Name=Classic GNOME with Compiz
RequiredComponents=gnome-panel;gnome-settings-daemon;
RequiredProviders=windowmanager;notifications;
DefaultProvider-windowmanager=compiz-gtk
DefaultProvider-notifications=notification-daemon

View File

@ -1,27 +0,0 @@
#!/bin/bash
function runCompiz() {
gtk-window-decorator &
exec compiz ccp $@
}
ISSW=`glxinfo | grep "Software Rasterizer" -c`
# Try with direct rendering
HAVETFP=`glxinfo | grep texture_from_pixmap -c`
if ( [ $ISSW == 0 ] && [ $HAVETFP -gt 2 ] ); then
runCompiz $@
fi
# Try again with indirect rendering
export LIBGL_ALWAYS_INDIRECT=1
HAVETFP=`glxinfo | grep texture_from_pixmap -c`
if ( [ $ISSW == 0 ] && [ $HAVETFP -gt 2 ] ); then
runCompiz $@
fi
# Fall back to metacity
exec metacity $@

View File

@ -1,7 +0,0 @@
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Compiz
TryExec=compiz-gtk
Exec=compiz-gtk
NoDisplay=true

File diff suppressed because it is too large Load Diff

View File

@ -1,31 +0,0 @@
diff -up compiz-0ec3ec/plugins/cube.c~ compiz-0ec3ec/plugins/cube.c
--- compiz-0ec3ec/plugins/cube.c~ 2007-07-23 16:20:42.000000000 -0400
+++ compiz-0ec3ec/plugins/cube.c 2007-08-15 17:45:18.000000000 -0400
@@ -1272,11 +1272,27 @@ cubePaintTop (CompScreen *s,
if (cs->invert == 1 && size == 4 && cs->texture.name)
{
+ glTexEnvf (GL_TEXTURE_ENV, GL_TEXTURE_ENV_MODE, GL_COMBINE);
+
+ glTexEnvf (GL_TEXTURE_ENV, GL_COMBINE_RGB, GL_INTERPOLATE);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE0_RGB, GL_TEXTURE0);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE1_RGB, GL_PRIMARY_COLOR);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE2_RGB, GL_TEXTURE0);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND0_RGB, GL_SRC_COLOR);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND1_RGB, GL_SRC_COLOR);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND2_RGB, GL_SRC_ALPHA);
+
+ glTexEnvf (GL_TEXTURE_ENV, GL_COMBINE_ALPHA, GL_REPLACE);
+ glTexEnvf (GL_TEXTURE_ENV, GL_SOURCE0_ALPHA, GL_PREVIOUS);
+ glTexEnvf (GL_TEXTURE_ENV, GL_OPERAND0_ALPHA, GL_SRC_ALPHA);
+
enableTexture (s, &cs->texture, COMP_TEXTURE_FILTER_GOOD);
glTexCoordPointer (2, GL_FLOAT, 0, cs->tc);
glDrawArrays (GL_TRIANGLE_FAN, 0, cs->nVertices >> 1);
disableTexture (s, &cs->texture);
glDisableClientState (GL_TEXTURE_COORD_ARRAY);
+
+ glTexEnvi (GL_TEXTURE_ENV, GL_TEXTURE_ENV_MODE, GL_REPLACE);
}
else
{

1
dead.package Normal file
View File

@ -0,0 +1 @@
This package was retired on 2012-02-06 due to lack of a maintainer.

View File

@ -1,25 +0,0 @@
diff -upNr compiz-0.8.2.orign/metadata/cube.xml.in compiz-0.8.2/metadata/cube.xml.in
--- compiz-0.8.2.orign/metadata/cube.xml.in 2009-02-15 10:10:23.000000000 +0100
+++ compiz-0.8.2/metadata/cube.xml.in 2009-05-25 22:54:03.060114649 +0200
@@ -92,9 +92,9 @@
<_short>Cube Color</_short>
<_long>Color of top and bottom sides of the cube</_long>
<default>
- <red>0xfefe</red>
- <green>0xffff</green>
- <blue>0xc7c7</blue>
+ <red>0x0000</red>
+ <green>0x1919</green>
+ <blue>0x4a4a</blue>
</default>
</option>
<subgroup>
@@ -110,7 +110,7 @@
<type>string</type>
<hints>file;image;</hints>
<default>
- <value>freedesktop</value>
+ <value>/usr/share/pixmaps/fedora-logo</value>
</default>
</option>
<option name="adjust_image" type="bool">

View File

@ -1,97 +0,0 @@
From: Danny Baumann <dannybaumann@web.de>
Date: Sun, 10 Oct 2010 12:22:09 +0000 (+0200)
Subject: Don't rely on deprecated gdk symbol gdk_display.
X-Git-Url: http://gitweb.compiz.org/?p=compiz%2Fcore;a=commitdiff_plain;h=5ea5e2130c56d405fcccd63932918fc49ca1f1b9
Don't rely on deprecated gdk symbol gdk_display.
---
diff --git a/gtk/window-decorator/gtk-window-decorator.c b/gtk/window-decorator/gtk-window-decorator.c
index adb20d5..4fac3d3 100644
--- a/gtk/window-decorator/gtk-window-decorator.c
+++ b/gtk/window-decorator/gtk-window-decorator.c
@@ -2635,6 +2635,7 @@ get_window_prop (Window xwindow,
Atom atom,
Window *val)
{
+ Display *dpy = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
Atom type;
int format;
gulong nitems;
@@ -2647,7 +2648,7 @@ get_window_prop (Window xwindow,
gdk_error_trap_push ();
type = None;
- result = XGetWindowProperty (gdk_display,
+ result = XGetWindowProperty (dpy,
xwindow,
atom,
0, G_MAXLONG,
@@ -4940,7 +4941,7 @@ force_quit_dialog_realize (GtkWidget *dialog,
WnckWindow *win = data;
gdk_error_trap_push ();
- XSetTransientForHint (gdk_display,
+ XSetTransientForHint (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()),
GDK_WINDOW_XID (dialog->window),
wnck_window_get_xid (win));
gdk_display_sync (gdk_display_get_default ());
@@ -4950,17 +4951,18 @@ force_quit_dialog_realize (GtkWidget *dialog,
static char *
get_client_machine (Window xwindow)
{
- Atom atom, type;
- gulong nitems, bytes_after;
- guchar *str = NULL;
- int format, result;
- char *retval;
+ Display *xdisplay = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
+ Atom atom, type;
+ gulong nitems, bytes_after;
+ guchar *str = NULL;
+ int format, result;
+ char *retval;
- atom = XInternAtom (gdk_display, "WM_CLIENT_MACHINE", FALSE);
+ atom = XInternAtom (xdisplay, "WM_CLIENT_MACHINE", FALSE);
gdk_error_trap_push ();
- result = XGetWindowProperty (gdk_display,
+ result = XGetWindowProperty (xdisplay,
xwindow, atom,
0, G_MAXLONG,
FALSE, XA_STRING, &type, &format, &nitems,
@@ -4987,6 +4989,8 @@ get_client_machine (Window xwindow)
static void
kill_window (WnckWindow *win)
{
+ GdkDisplay *gdk_display = gdk_display_get_default ();
+ Display *xdisplay = GDK_DISPLAY_XDISPLAY (gdk_display);
WnckApplication *app;
app = wnck_window_get_application (win);
@@ -5012,8 +5016,8 @@ kill_window (WnckWindow *win)
}
gdk_error_trap_push ();
- XKillClient (gdk_display, wnck_window_get_xid (win));
- gdk_display_sync (gdk_display_get_default ());
+ XKillClient (xdisplay, wnck_window_get_xid (win));
+ gdk_display_sync (gdk_display);
gdk_error_trap_pop ();
}
@@ -5597,9 +5601,9 @@ static int
update_shadow (void)
{
decor_shadow_options_t opt;
- Display *xdisplay = gdk_display;
- GdkDisplay *display = gdk_display_get_default ();
- GdkScreen *screen = gdk_display_get_default_screen (display);
+ GdkDisplay *display = gdk_display_get_default ();
+ Display *xdisplay = GDK_DISPLAY_XDISPLAY (display);
+ GdkScreen *screen = gdk_display_get_default_screen (display);
opt.shadow_radius = shadow_radius;
opt.shadow_opacity = shadow_opacity;

View File

@ -1,184 +0,0 @@
From: Danny Baumann <dannybaumann@web.de>
Date: Mon, 6 Sep 2010 09:25:02 +0000 (+0200)
Subject: Replace old gdk_draw_drawable method calls with cairo equivalents.
X-Git-Url: http://gitweb.compiz.org/?p=compiz%2Fcore;a=commitdiff_plain;h=777e5ecdb197105f770e7bcedd83eb54c53457f3
Replace old gdk_draw_drawable method calls with cairo equivalents.
---
diff --git a/gtk/window-decorator/gtk-window-decorator.c b/gtk/window-decorator/gtk-window-decorator.c
index 18b907e..adb20d5 100644
--- a/gtk/window-decorator/gtk-window-decorator.c
+++ b/gtk/window-decorator/gtk-window-decorator.c
@@ -380,7 +380,7 @@ typedef struct _decor {
guint button_states[BUTTON_NUM];
GdkPixmap *pixmap;
GdkPixmap *buffer_pixmap;
- GdkGC *gc;
+ cairo_t *cr;
decor_layout_t border_layout;
decor_context_t *context;
decor_shadow_t *shadow;
@@ -918,6 +918,17 @@ button_state_paint (cairo_t *cr,
}
static void
+copy_to_front_buffer (decor_t *d)
+{
+ if (!d->buffer_pixmap)
+ return;
+
+ cairo_set_operator (d->cr, CAIRO_OPERATOR_SOURCE);
+ gdk_cairo_set_source_pixmap (d->cr, d->buffer_pixmap, 0, 0);
+ cairo_paint (d->cr);
+}
+
+static void
draw_window_decoration (decor_t *d)
{
cairo_t *cr;
@@ -1298,16 +1309,7 @@ draw_window_decoration (decor_t *d)
cairo_destroy (cr);
- if (d->buffer_pixmap)
- gdk_draw_drawable (d->pixmap,
- d->gc,
- d->buffer_pixmap,
- 0,
- 0,
- 0,
- 0,
- d->width,
- d->height);
+ copy_to_front_buffer (d);
if (d->prop_xid)
{
@@ -2103,16 +2105,7 @@ meta_draw_window_decoration (decor_t *d)
XRenderFreePicture (xdisplay, src);
}
- if (d->buffer_pixmap)
- gdk_draw_drawable (d->pixmap,
- d->gc,
- d->buffer_pixmap,
- 0,
- 0,
- 0,
- 0,
- d->width,
- d->height);
+ copy_to_front_buffer (d);
if (d->prop_xid)
{
@@ -2361,18 +2354,9 @@ draw_switcher_background (decor_t *d)
alpha);
cairo_stroke (cr);
-
cairo_destroy (cr);
- gdk_draw_drawable (d->pixmap,
- d->gc,
- d->buffer_pixmap,
- 0,
- 0,
- 0,
- 0,
- d->width,
- d->height);
+ copy_to_front_buffer (d);
pixel = ((((a * style->bg[GTK_STATE_NORMAL].blue ) >> 24) & 0x0000ff) |
(((a * style->bg[GTK_STATE_NORMAL].green) >> 16) & 0x00ff00) |
@@ -2439,15 +2423,7 @@ draw_switcher_foreground (decor_t *d)
cairo_destroy (cr);
- gdk_draw_drawable (d->pixmap,
- d->gc,
- d->buffer_pixmap,
- 0,
- 0,
- 0,
- 0,
- d->width,
- d->height);
+ copy_to_front_buffer (d);
}
static void
@@ -3512,15 +3488,15 @@ update_window_decoration_size (WnckWindow *win)
if (d->buffer_pixmap)
g_object_unref (G_OBJECT (d->buffer_pixmap));
- if (d->gc)
- g_object_unref (G_OBJECT (d->gc));
-
if (d->picture)
XRenderFreePicture (xdisplay, d->picture);
+ if (d->cr)
+ cairo_destroy (d->cr);
+
d->pixmap = pixmap;
d->buffer_pixmap = buffer_pixmap;
- d->gc = gdk_gc_new (pixmap);
+ d->cr = gdk_cairo_create (pixmap);
d->picture = picture;
@@ -3642,6 +3618,7 @@ update_switcher_window (WnckWindow *win,
{
g_object_ref (G_OBJECT (switcher_pixmap));
d->pixmap = switcher_pixmap;
+ d->cr = gdk_cairo_create (switcher_pixmap);
}
if (!d->buffer_pixmap && switcher_buffer_pixmap)
@@ -3729,9 +3706,6 @@ update_switcher_window (WnckWindow *win,
if (width == d->width && height == d->height)
{
- if (!d->gc)
- d->gc = gdk_gc_new (d->pixmap);
-
if (!d->picture)
d->picture =
XRenderCreatePicture (xdisplay,
@@ -3765,8 +3739,8 @@ update_switcher_window (WnckWindow *win,
if (d->buffer_pixmap)
g_object_unref (G_OBJECT (d->buffer_pixmap));
- if (d->gc)
- g_object_unref (G_OBJECT (d->gc));
+ if (d->cr)
+ cairo_destroy (d->cr);
if (d->picture)
XRenderFreePicture (xdisplay, d->picture);
@@ -3782,7 +3756,7 @@ update_switcher_window (WnckWindow *win,
d->pixmap = pixmap;
d->buffer_pixmap = buffer_pixmap;
- d->gc = gdk_gc_new (pixmap);
+ d->cr = gdk_cairo_create (pixmap);
d->picture = XRenderCreatePicture (xdisplay, GDK_PIXMAP_XID (buffer_pixmap),
xformat, 0, NULL);
@@ -3817,10 +3791,10 @@ remove_frame_window (WnckWindow *win)
d->buffer_pixmap = NULL;
}
- if (d->gc)
+ if (d->cr)
{
- g_object_unref (G_OBJECT (d->gc));
- d->gc = NULL;
+ cairo_destroy (d->cr);
+ d->cr = NULL;
}
if (d->picture)

View File

@ -1,204 +0,0 @@
diff --git a/kde/window-decorator-kde4/window.cpp b/kde/window-decorator-kde4/window.cpp
index a7cd2d4..d7ab93d 100644
--- a/kde/window-decorator-kde4/window.cpp
+++ b/kde/window-decorator-kde4/window.cpp
@@ -486,31 +486,39 @@ KWD::Window::showWindowMenu (const QRect &pos)
showWindowMenu (pos.bottomLeft ());
}
-void
-KWD::Window::processMousePressEvent (QMouseEvent *qme)
+KWD::Options::MouseCommand
+KWD::Window::buttonToCommand (Qt::MouseButtons button)
{
Options::MouseCommand com = Options::MouseNothing;
- bool active = isActive ();
+ bool active = isActive ();
if (!mSupportTakeFocus)
- active = TRUE;
+ active = true;
- switch (qme->button ()) {
+ switch (button) {
case Qt::LeftButton:
com = active ? Decorator::options ()->commandActiveTitlebar1 () :
- Decorator::options()->commandInactiveTitlebar1 ();
+ Decorator::options()->commandInactiveTitlebar1 ();
break;
case Qt::MidButton:
com = active ? Decorator::options ()->commandActiveTitlebar2 () :
- Decorator::options()->commandInactiveTitlebar2 ();
+ Decorator::options()->commandInactiveTitlebar2 ();
break;
case Qt::RightButton:
com = active ? Decorator::options ()->commandActiveTitlebar3 () :
- Decorator::options()->commandInactiveTitlebar3 ();
+ Decorator::options()->commandInactiveTitlebar3 ();
default:
break;
}
+ return com;
+}
+
+void
+KWD::Window::processMousePressEvent (QMouseEvent *qme)
+{
+ Options::MouseCommand com = buttonToCommand (qme->button ());
+
if (qme->button () == Qt::LeftButton)
{
// actions where it's not possible to get the matching release event
@@ -752,6 +760,92 @@ KWD::Window::compositingActive (void) const
return true;
}
+QRect
+KWD::Window::transparentRect () const
+{
+ return QRect ();
+}
+
+bool
+KWD::Window::isClientGroupActive ()
+{
+ return true;
+}
+
+QList<ClientGroupItem>
+KWD::Window::clientGroupItems () const
+{
+ QList<ClientGroupItem> items;
+
+ QIcon icon (mIcon);
+ icon.addPixmap (mMiniIcon);
+
+ items.append (ClientGroupItem (mName, icon));
+
+ return items;
+}
+
+long
+KWD::Window::itemId (int index)
+{
+ return (long) mClientId;
+}
+
+int
+KWD::Window::visibleClientGroupItem ()
+{
+ return 0;
+}
+
+void
+KWD::Window::setVisibleClientGroupItem (int index)
+{
+}
+
+void
+KWD::Window::moveItemInClientGroup (int index, int before)
+{
+}
+
+void
+KWD::Window::moveItemToClientGroup (long itemId, int before)
+{
+}
+
+void
+KWD::Window::removeFromClientGroup (int index, const QRect& newGeom)
+{
+}
+
+void
+KWD::Window::closeClientGroupItem (int index)
+{
+ closeWindow ();
+}
+
+void
+KWD::Window::closeAllInClientGroup ()
+{
+ closeWindow ();
+}
+
+void
+KWD::Window::displayClientMenu (int index, const QPoint& pos)
+{
+ showWindowMenu (pos);
+}
+
+KDecorationDefines::WindowOperation
+KWD::Window::buttonToWindowOperation(Qt::MouseButtons button)
+{
+ Options::MouseCommand com = buttonToCommand (button);
+
+ if (com == Options::MouseOperationsMenu)
+ return KDecorationDefines::OperationsOp;
+
+ return KDecorationDefines::NoOp;
+}
+
void
KWD::Window::createDecoration (void)
{
@@ -1466,7 +1560,7 @@ KWD::Window::moveWindow (QMouseEvent *qme)
NET::Direction direction;
direction = positionToDirection (mDecor->mousePosition (qme->pos ()));
-
+
QPoint p (mGeometry.x () - mExtents.left, mGeometry.y () - mExtents.top);
p += qme->pos ();
@@ -1476,7 +1570,7 @@ KWD::Window::moveWindow (QMouseEvent *qme)
Decorator::rootInfo ()->restackRequest (mClientId, NET::FromApplication,
None, Above,
QX11Info::appTime());
-
+
Decorator::rootInfo ()->moveResizeRequest (mClientId,
p.x (),
p.y (),
diff --git a/kde/window-decorator-kde4/window.h b/kde/window-decorator-kde4/window.h
index 40a5076..e230a83 100644
--- a/kde/window-decorator-kde4/window.h
+++ b/kde/window-decorator-kde4/window.h
@@ -111,7 +111,23 @@ class Window: public QObject, public KDecorationBridgeUnstable {
/* unstable API */
virtual bool compositingActive () const;
-
+ virtual QRect transparentRect () const;
+
+ virtual bool isClientGroupActive ();
+ virtual QList<ClientGroupItem> clientGroupItems () const;
+ virtual long itemId (int index);
+ virtual int visibleClientGroupItem ();
+ virtual void setVisibleClientGroupItem (int index);
+ virtual void moveItemInClientGroup (int index, int before);
+ virtual void moveItemToClientGroup (long itemId, int before);
+ virtual void removeFromClientGroup (int index, const QRect& newGeom);
+ virtual void closeClientGroupItem (int index);
+ virtual void closeAllInClientGroup ();
+ virtual void displayClientMenu (int index, const QPoint& pos);
+
+ virtual WindowOperation
+ buttonToWindowOperation(Qt::MouseButtons button);
+
virtual bool eventFilter (QObject* o, QEvent* e);
void handleActiveChange (void);
@@ -191,8 +207,10 @@ class Window: public QObject, public KDecorationBridgeUnstable {
int rightOffset);
void updateProperty (void);
void getWindowProtocols (void);
+
+ Options::MouseCommand buttonToCommand (Qt::MouseButtons button);
void performMouseCommand (KWD::Options::MouseCommand command,
- QMouseEvent *qme);
+ QMouseEvent *qme);
NET::Direction positionToDirection (int pos);
Cursor positionToCursor (QPoint pos);

View File

@ -1,41 +0,0 @@
commit fe5ef3cb092a35aef03303d5895e6db3afca240a
Author: Kristian Høgsberg <krh@redhat.com>
Date: Tue Aug 21 10:56:19 2007 -0400
Set SM restart style to SmRestartIfRunning on exit.
diff --git a/src/session.c b/src/session.c
index 9c6cc07..a354c3b 100644
--- a/src/session.c
+++ b/src/session.c
@@ -89,11 +89,10 @@ setCloneRestartCommands (SmcConn connection)
}
static void
-setRestartStyle (SmcConn connection)
+setRestartStyle (SmcConn connection, char hint)
{
SmProp prop, *pProp;
SmPropValue propVal;
- char hint = SmRestartImmediately;
prop.name = SmRestartStyleHint;
prop.type = SmCARD8;
@@ -139,7 +138,7 @@ saveYourselfGotProps (SmcConn connection,
}
out:
- setRestartStyle (connection);
+ setRestartStyle (connection, SmRestartImmediately);
setCloneRestartCommands (connection);
SmcSaveYourselfDone (connection, 1);
@@ -227,6 +226,8 @@ closeSession (void)
{
if (connected)
{
+ setRestartStyle (smcConnection, SmRestartIfRunning);
+
if (SmcCloseConnection (smcConnection, 0, NULL) != SmcConnectionInUse)
connected = FALSE;
if (smClientId) {

View File

@ -1,74 +0,0 @@
diff -upNr compiz-0.8.6.orign/gtk/gnome/Makefile.am compiz-0.8.6/gtk/gnome/Makefile.am
--- compiz-0.8.6.orign/gtk/gnome/Makefile.am 2010-03-28 14:15:35.000000000 +0200
+++ compiz-0.8.6/gtk/gnome/Makefile.am 2010-07-15 20:51:40.241254711 +0200
@@ -1,21 +1,9 @@
moduledir = $(DESTDIR)$(windowsettingslibdir)/window-manager-settings
-if USE_GNOME
-libcompiz_la_LDFLAGS = -export-dynamic -avoid-version -rpath $(moduledir)
-libcompiz_la_LIBADD = @GNOME_WINDOW_SETTINGS_LIBS@
-libcompiz_la_SOURCES = \
- compiz-window-manager.c \
- compiz-window-manager.h
-libcompiz_module = libcompiz.la
-
desktopfilesdir = $(DESTDIR)$(datadir)/applications
desktopfiles_in_files = compiz.desktop.in
desktopfiles_files = $(desktopfiles_in_files:.desktop.in=.desktop)
-wmpropertiesdir = $(DESTDIR)$(windowsettingsdatadir)/gnome/wm-properties
-wmproperties_in_files = compiz-wm.desktop.in
-wmproperties_files = $(wmproperties_in_files:.desktop.in=.desktop)
-
@INTLTOOL_DESKTOP_RULE@
if USE_GNOME_KEYBINDINGS
@@ -28,24 +16,12 @@ xml_files = $(xml_in_files:.xml.in=.x
endif
-install-exec-local:
- if mkdir -p $(moduledir) && test -w $(moduledir); then ( \
- $(LIBTOOL) --mode=install $(INSTALL) $(libcompiz_module) \
- $(moduledir) \
- ); \
- fi
-
install-data-local:
if mkdir -p $(desktopfilesdir) && test -w $(desktopfilesdir); then ( \
$(INSTALL) -m 644 $(desktopfiles_files) \
$(desktopfilesdir) \
); \
fi
- if mkdir -p $(wmpropertiesdir) && test -w $(wmpropertiesdir); then ( \
- $(INSTALL) -m 644 $(wmproperties_files) \
- $(wmpropertiesdir) \
- ); \
- fi
if USE_GNOME_KEYBINDINGS
if mkdir -p $(xmldir) && test -w $(xmldir); then ( \
@@ -74,23 +50,18 @@ if USE_GNOME_KEYBINDINGS
); \
fi
endif
-endif
INCLUDES = @GNOME_WINDOW_SETTINGS_CFLAGS@ \
-DMETACITY_THEME_DIR=\""$(windowsettingsdatadir)/themes"\" \
-DLOCALEDIR="\"@datadir@/locale"\"
-noinst_LTLIBRARIES = \
- $(libcompiz_module)
noinst_DATA = \
$(desktopfiles_files) \
- $(wmproperties_files) \
$(xml_files)
EXTRA_DIST = \
$(desktopfiles_in_files) \
- $(wmproperties_in_files) \
$(xml_in_files)
DISTCLEANFILES = \

View File

@ -1,25 +0,0 @@
diff -up compiz-0ec3ec/metadata/cube.xml.in.fedora-logo compiz-0ec3ec/metadata/cube.xml.in
--- compiz-0ec3ec/metadata/cube.xml.in.fedora-logo 2007-08-13 17:49:03.000000000 -0400
+++ compiz-0ec3ec/metadata/cube.xml.in 2007-08-15 18:07:54.000000000 -0400
@@ -42,9 +42,9 @@
<_short>Cube Color</_short>
<_long>Color of top and bottom sides of the cube</_long>
<default>
- <red>0xfefe</red>
- <green>0xffff</green>
- <blue>0xc7c7</blue>
+ <red>0x8888</red>
+ <green>0x0000</green>
+ <blue>0x0000</blue>
</default>
</option>
<option name="in" type="bool">
@@ -62,7 +62,7 @@
<_long>List of PNG and SVG files that should be rendered on top face of cube</_long>
<type>string</type>
<default>
- <value>freedesktop</value>
+ <value>/usr/share/pixmaps/redhat/shadowman-transparent</value>
</default>
</option>
<option name="skydome" type="bool">

View File

@ -1,17 +0,0 @@
commit 0ddeef41dd42e22ed75c68ac67154b8de00f9595
Author: Kristian Høgsberg <krh@redhat.com>
Date: Tue Aug 14 18:28:05 2007 -0400
Add run_command to keyboard shortcut list.
diff --git a/gtk/gnome/50-compiz-desktop-key.xml.in b/gtk/gnome/50-compiz-desktop-key.xml.in
index da1f8cf..1559d03 100644
--- a/gtk/gnome/50-compiz-desktop-key.xml.in
+++ b/gtk/gnome/50-compiz-desktop-key.xml.in
@@ -11,4 +11,6 @@
<KeyListEntry name="/apps/compiz/general/allscreens/options/show_desktop_key"/>
+ <KeyListEntry name="/apps/compiz/general/allscreens/options/run_command_terminal_key"/>
+
</KeyListEntries>

View File

@ -1,21 +0,0 @@
diff -up compiz-6b86f3/metadata/scale.xml.in.scale-key compiz-6b86f3/metadata/scale.xml.in
--- compiz-6b86f3/metadata/scale.xml.in.scale-key 2007-08-22 18:57:43.000000000 -0400
+++ compiz-6b86f3/metadata/scale.xml.in 2007-10-12 10:59:02.000000000 -0400
@@ -12,7 +12,6 @@
<allowed key="true" button="true" edge="true" edgednd="true"/>
<default>
<key>&lt;Shift&gt;&lt;Alt&gt;Up</key>
- <edges top_right="true"/>
</default>
</option>
<option name="initiate_all" type="action">
diff -up compiz-6b86f3/gtk/gnome/50-compiz-desktop-key.xml.in.scale-key compiz-6b86f3/gtk/gnome/50-compiz-desktop-key.xml.in
--- compiz-6b86f3/gtk/gnome/50-compiz-desktop-key.xml.in.scale-key 2007-10-12 11:18:03.000000000 -0400
+++ compiz-6b86f3/gtk/gnome/50-compiz-desktop-key.xml.in 2007-10-12 11:16:56.000000000 -0400
@@ -13,4 +13,6 @@
<KeyListEntry name="/apps/compiz/general/allscreens/options/run_command_terminal_key"/>
+ <KeyListEntry name="/apps/compiz/plugins/scale/allscreens/options/initiate_key"/>
+
</KeyListEntries>

View File

@ -1 +0,0 @@
7d165d69fe47aee5919cff706e8ba135 core-e676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.tar.gz