fix build

This commit is contained in:
drago01 2009-07-11 08:25:55 +00:00
parent d9c0697d02
commit 09004523ec
1 changed files with 36 additions and 32 deletions

View File

@ -359,36 +359,40 @@ diff -upNr compiz-0.8.2.orign/metadata/wall.xml.in compiz-0.8.2/metadata/wall.xm
+ </screen>
+ </plugin>
+</compiz>
diff -upNr compiz-0.8.2.orign/src/Makefile.am compiz-0.8.2/src/Makefile.am
--- compiz-0.8.2.orign/src/Makefile.am 2009-02-15 10:10:23.000000000 +0100
+++ compiz-0.8.2/src/Makefile.am 2009-07-10 23:09:39.215435000 +0200
@@ -5,12 +5,13 @@ INCLUDES = \
-I$(top_builddir)/include \
-DPLUGINDIR=\"$(plugindir)\" \
-DIMAGEDIR=\"$(imagedir)\" \
diff -upNr compiz-0.8.2.orign/plugins/Makefile.am compiz-0.8.2/plugins/Makefile.am
--- compiz-0.8.2.orign/plugins/Makefile.am 2009-02-15 10:10:23.000000000 +0100
+++ compiz-0.8.2/plugins/Makefile.am 2009-07-11 10:19:29.303832241 +0200
@@ -74,6 +74,9 @@ libcommands_la_SOURCES = commands.c
libgnomecompat_la_LDFLAGS = -module -avoid-version -no-undefined
libgnomecompat_la_SOURCES = gnomecompat.c
+libwall_la_LDFLAGS = -module -avoid-version -no-undefined `pkg-config --libs cairo`
+libwall_la_SOURCES = wall.c wall_options.c
+
if USE_LIBRSVG
libsvg_la_DEPENDENCIES = $(top_builddir)/libdecoration/libdecoration.la
libsvg_la_LDFLAGS = -module -avoid-version -no-undefined
@@ -149,7 +152,8 @@ INCLUDES = \
-DIMAGEDIR=\"$(imagedir)\" \
-I$(top_srcdir)/include \
-I$(top_builddir)/include \
- -DMETADATADIR=\"$(metadatadir)\"
+ -DMETADATADIR=\"$(metadatadir)\" \
+ -DMETADATADIR=\"$(metadatadir)\" \
+ `pkg-config --cflags cairo`
bin_PROGRAMS = compiz
moduledir = $(plugindir)
compiz_LDADD = @COMPIZ_LIBS@ @GL_LIBS@ -lm
-compiz_LDFLAGS = -export-dynamic
+compiz_LDFLAGS = -export-dynamic `pkg-config --libs cairo`
compiz_SOURCES = \
main.c \
privates.c \
@@ -29,4 +30,6 @@ compiz_SOURCES = \
matrix.c \
cursor.c \
match.c \
- metadata.c
+ metadata.c \
+ wall_options.c \
+ wall.c
diff -upNr compiz-0.8.2.orign/src/wall.c compiz-0.8.2/src/wall.c
--- compiz-0.8.2.orign/src/wall.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.2/src/wall.c 2009-03-05 04:36:21.000000000 +0100
@@ -181,6 +185,7 @@ module_LTLIBRARIES = \
libobs.la \
libcommands.la \
libgnomecompat.la \
+ libwall.la \
$(libsvg_module) \
$(libannotate_module) \
$(libinotify_module) \
diff -upNr compiz-0.8.2.orign/plugins/wall.c compiz-0.8.2/plugins/wall.c
--- compiz-0.8.2.orign/plugins/wall.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.2/plugins/wall.c 2009-03-05 04:36:21.000000000 +0100
@@ -0,0 +1,2215 @@
+/**
+ *
@ -2605,9 +2609,9 @@ diff -upNr compiz-0.8.2.orign/src/wall.c compiz-0.8.2/src/wall.c
+{
+ return &wallVTable;
+}
diff -upNr compiz-0.8.2.orign/src/wall_options.c compiz-0.8.2/src/wall_options.c
--- compiz-0.8.2.orign/src/wall_options.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.2/src/wall_options.c 2009-07-10 23:02:20.185497000 +0200
diff -upNr compiz-0.8.2.orign/plugins/wall_options.c compiz-0.8.2/plugins/wall_options.c
--- compiz-0.8.2.orign/plugins/wall_options.c 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.2/plugins/wall_options.c 2009-07-10 23:02:20.185497000 +0200
@@ -0,0 +1,1936 @@
+/*
+ * This file is autogenerated with bcop:
@ -4545,9 +4549,9 @@ diff -upNr compiz-0.8.2.orign/src/wall_options.c compiz-0.8.2/src/wall_options.c
+ return &wallOptionsVTable;
+}
+
diff -upNr compiz-0.8.2.orign/src/wall_options.h compiz-0.8.2/src/wall_options.h
--- compiz-0.8.2.orign/src/wall_options.h 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.2/src/wall_options.h 2009-07-10 23:02:18.076511000 +0200
diff -upNr compiz-0.8.2.orign/plugins/wall_options.h compiz-0.8.2/plugins/wall_options.h
--- compiz-0.8.2.orign/plugins/wall_options.h 1970-01-01 01:00:00.000000000 +0100
+++ compiz-0.8.2/plugins/wall_options.h 2009-07-10 23:02:18.076511000 +0200
@@ -0,0 +1,375 @@
+/*
+ * This file is autogenerated with bcop: