13.0.0-rc3 Release

This commit is contained in:
Tom Stellard 2021-09-22 22:57:24 +00:00
parent 0ef86a0303
commit ef3e0dd523
5 changed files with 34 additions and 34 deletions

2
.gitignore vendored
View File

@ -83,3 +83,5 @@
/compiler-rt-12.0.1.src.tar.xz.sig
/compiler-rt-13.0.0rc1.src.tar.xz
/compiler-rt-13.0.0rc1.src.tar.xz.sig
/compiler-rt-13.0.0rc3.src.tar.xz
/compiler-rt-13.0.0rc3.src.tar.xz.sig

View File

@ -0,0 +1,25 @@
From 72191190adea8e861e9a383b83799e7472b80e30 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Thu, 23 Sep 2021 18:06:41 -0700
Subject: [PATCH] Fix compiler-rt arch detection for ppc64le
---
compiler-rt/cmake/base-config-ix.cmake | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/compiler-rt/cmake/base-config-ix.cmake b/compiler-rt/cmake/base-config-ix.cmake
index c11342e68813..3ca9dc0f5515 100644
--- a/compiler-rt/cmake/base-config-ix.cmake
+++ b/compiler-rt/cmake/base-config-ix.cmake
@@ -204,7 +204,7 @@ macro(test_targets)
test_target_arch(x86_64 "" "")
endif()
endif()
- elseif("${COMPILER_RT_DEFAULT_TARGET_ARCH}" MATCHES "powerpc64le")
+ elseif("${COMPILER_RT_DEFAULT_TARGET_ARCH}" MATCHES "powerpc64le|ppc64le")
test_target_arch(powerpc64le "" "-m64")
elseif("${COMPILER_RT_DEFAULT_TARGET_ARCH}" MATCHES "powerpc")
if(CMAKE_SYSTEM_NAME MATCHES "AIX")
--
2.27.0

View File

@ -1,30 +0,0 @@
From 1738127904d20d403d8cf8ad67b0f68d728ad6b8 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Mon, 9 Aug 2021 13:57:40 -0700
Subject: [PATCH] Only add no-omit-frame-pointer flags when the compiler
supports them
---
compiler-rt/lib/scudo/standalone/CMakeLists.txt | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/compiler-rt/lib/scudo/standalone/CMakeLists.txt b/compiler-rt/lib/scudo/standalone/CMakeLists.txt
index 8c3708d3a45f..6a1f2f3accff 100644
--- a/compiler-rt/lib/scudo/standalone/CMakeLists.txt
+++ b/compiler-rt/lib/scudo/standalone/CMakeLists.txt
@@ -124,8 +124,10 @@ if (COMPILER_RT_HAS_GWP_ASAN)
RTGwpAsan RTGwpAsanBacktraceLibc RTGwpAsanSegvHandler
RTGwpAsanOptionsParser)
- list(APPEND SCUDO_CFLAGS -DGWP_ASAN_HOOKS -fno-omit-frame-pointer
- -mno-omit-leaf-frame-pointer)
+ append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG -fno-omit-frame-pointer
+ SCUDO_CFLAGS)
+ list(APPEND SCUDO_CFLAGS -DGWP_ASAN_HOOKS)
+
endif()
set(SCUDO_LINK_LIBS)
--
2.27.0

View File

@ -1,4 +1,4 @@
%global rc_ver 1
%global rc_ver 3
%global compiler_rt_version 13.0.0
%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
@ -21,7 +21,7 @@ Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compil
Source2: tstellar-gpg-key.asc
Patch0: 0001-PATCH-compiler-rt-Workaround-libstdc-limitation-wrt..patch
Patch1: 0001-Only-add-no-omit-frame-pointer-flags-when-the-compil.patch
Patch1: 0001-Fix-compiler-rt-arch-detection-for-ppc64le.patch
BuildRequires: gcc
BuildRequires: gcc-c++
@ -111,6 +111,9 @@ popd
%endif
%changelog
* Wed Sep 22 2021 Tom Stellard <tsellar@redhat.com> - 13.0.0~rc3-1
- 13.0.0-rc3 Release
* Mon Aug 09 2021 Tom Stellard <tstellar@redhat.com> = 13.0.0~rc1-1
- 13.0.0-rc1 Release

View File

@ -1,2 +1,2 @@
SHA512 (compiler-rt-13.0.0rc1.src.tar.xz) = 4e03c76aef587cfdbe846e20690ae4143bb432e6bb92135c13d49cb8667d5590f2df492db15b6c1af03cec4e4d51aa044b16a487b04786ee8a002de0d3b2846b
SHA512 (compiler-rt-13.0.0rc1.src.tar.xz.sig) = 3ffa21fa6c8ab3a93c63e05f80d1076aeeb15beedaf444ec60d9a70228f99ec6ad53e3426f045953400383a2dc5f4fb5c3e4be9db21dc6a2f6a3a056c2b40283
SHA512 (compiler-rt-13.0.0rc3.src.tar.xz) = 3aea4f62c639af04f60ef9db268c4c3b635c5f6f6f96825b9676c43a835a63285fc8978a9c9273e4895d5f24931084571be2f6cc25320f80d34a3f954997dd8d
SHA512 (compiler-rt-13.0.0rc3.src.tar.xz.sig) = 643315e79bccd507160adcba856b7f60feefd4aa7e0199e57e6a7fbbbb53c08146f985c14e4c6c515570689b87c555f3fc47443b570fbb66b791fc01464f32f4