Use python3 for build scripts

This should have been done with the previous commit.
This commit is contained in:
Tom Stellard 2018-09-07 00:35:55 +00:00
parent 911d0525fe
commit b19eff0b2f
2 changed files with 35 additions and 1 deletions

View File

@ -0,0 +1,24 @@
From 1353b7e97319f82ceee621e2e321c3f932c391fa Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Thu, 6 Sep 2018 17:32:09 -0700
Subject: [PATCH] cmake: Don't prefer python2.7
---
CMakeLists.txt | 1 -
1 file changed, 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86ca2b3..ef8effa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,7 +71,6 @@ if (COMPILER_RT_STANDALONE_BUILD)
endif()
# Find Python interpreter.
- set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5)
include(FindPythonInterp)
if(NOT PYTHONINTERP_FOUND)
message(FATAL_ERROR "
--
1.8.3.1

View File

@ -9,16 +9,21 @@
Name: compiler-rt
Version: 7.0.0
Release: 0.2.rc%{rc_ver}%{?dist}
Release: 0.3.rc%{rc_ver}%{?dist}
Summary: LLVM "compiler-rt" runtime libraries
License: NCSA or MIT
URL: http://llvm.org
Source0: http://llvm.org/releases/%{version}/%{crt_srcdir}.tar.xz
Patch0: 0001-cmake-Don-t-prefer-python2.7.patch
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: python3
# We need python3-devel for pathfix.py.
BuildRequires: python3-devel
BuildRequires: llvm-devel = %{version}
BuildRequires: llvm-static = %{version}
@ -31,6 +36,8 @@ instrumentation, and Blocks C language extension.
%prep
%autosetup -n %{crt_srcdir} -p1
pathfix.py -i %{__python3} -pn .
%build
mkdir -p _build
cd _build
@ -78,6 +85,9 @@ cd _build
%{_libdir}/clang/%{version}
%changelog
* Fri Sep 07 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.3.rc1
- Use python3 for build scripts
* Thu Sep 06 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.2.rc1
- Drop BuildRequires: python2