e443003589
Also: - Update project URL. - Change License from EPL to EPL-1.0. - Eliminate unnecessary BRs and Rs. - Build with Cbc, MUMPS, nauty, and suitesparse. - Build in bootstrap mode. - Add -bad-cast, -badcolumn, -param, -catch, -sprintf, -overflow, and -signed patches. - Eliminate rpath from the library. - Force libtool to not defeat -Wl,--as-needed. - Be explicit about library versions as required by latest guidelines. - Filter out unnecessary Libs values from pkgconfig files. - Package doxygen tag file to enable cross-linking.
34 lines
1.7 KiB
Diff
34 lines
1.7 KiB
Diff
diff -up Clp-1.17.3/configure.orig Clp-1.17.3/configure
|
|
--- Clp-1.17.3/configure.orig 2019-06-14 15:45:20.000000000 -0600
|
|
+++ Clp-1.17.3/configure 2019-06-21 10:41:48.445343096 -0600
|
|
@@ -32184,7 +32184,7 @@ echo "${ECHO_T}$doxysrcdir (src)" >&6
|
|
fi
|
|
# Not built, fall back to installed tag file
|
|
if test $doxyfound = no ; then
|
|
- eval doxydir="${datadir}/coin/doc/${proj}/doxydoc"
|
|
+ eval doxydir="${datadir}/doc/coin-or-${proj}"
|
|
# AC_MSG_NOTICE([Considering $doxydir (install)])
|
|
# AC_MSG_NOTICE([Subdirs: $coin_subdirs)])
|
|
coin_doxy_tagfiles="$coin_doxy_tagfiles $doxydir/$doxytag=$doxydir/html"
|
|
diff -up Clp-1.17.3/Makefile.in.orig Clp-1.17.3/Makefile.in
|
|
--- Clp-1.17.3/Makefile.in.orig 2016-02-01 21:31:08.000000000 -0700
|
|
+++ Clp-1.17.3/Makefile.in 2019-06-21 10:40:52.417258808 -0600
|
|
@@ -420,7 +420,7 @@ EXTRA_DIST = doc/authors.xml doc/basicmo
|
|
########################################################################
|
|
pkgconfiglibdir = $(libdir)/pkgconfig
|
|
pkgconfiglib_DATA = clp.pc $(am__append_3)
|
|
-addlibsdir = $(DESTDIR)$(datadir)/coin/doc/Clp
|
|
+addlibsdir = $(DESTDIR)$(datadir)/doc/coin-or-$(PACKAGE_NAME)
|
|
|
|
########################################################################
|
|
# Maintainer Stuff #
|
|
@@ -430,7 +430,7 @@ CLEANFILES =
|
|
# Files that are generated and should be cleaned with make distclean
|
|
DISTCLEANFILES = $(am__append_5) $(VPATH_DISTCLEANFILES)
|
|
DocFiles = README AUTHORS LICENSE
|
|
-DocInstallDir = $(datadir)/coin/doc/$(PACKAGE_NAME)
|
|
+DocInstallDir = $(datadir)/doc/coin-or-$(PACKAGE_NAME)
|
|
COIN_HAS_DOXYGEN = @COIN_HAS_DOXYGEN_TRUE@TRUE
|
|
COIN_HAS_LATEX = @COIN_HAS_LATEX_TRUE@TRUE
|
|
all: all-recursive
|