Version 1.17.5. Drop unnecessary libnauty BR.

This commit is contained in:
Jerry James 2020-02-21 12:42:47 -07:00
parent a7ac2b4990
commit c01a286e00
13 changed files with 97 additions and 88 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/Clp-*.tgz
/Clp-*.tar.gz

View File

@ -1,7 +1,7 @@
diff -up Clp-1.17.1/src/ClpSolver.cpp.orig Clp-1.17.1/src/ClpSolver.cpp
--- Clp-1.17.1/src/ClpSolver.cpp.orig 2019-02-07 14:43:52.000000000 -0700
+++ Clp-1.17.1/src/ClpSolver.cpp 2019-03-27 11:53:43.018224450 -0600
@@ -2888,7 +2888,7 @@ clp watson.mps -\nscaling off\nprimalsim
diff -up Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig Clp-releases-1.17.5/Clp/src/ClpSolver.cpp
--- Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpSolver.cpp 2020-02-20 09:48:11.863261899 -0700
@@ -2890,7 +2890,7 @@ clp watson.mps -\nscaling off\nprimalsim
case CLP_PARAM_ACTION_GUESS:
if (goodModels[iModel]) {
delete[] alternativeEnvironment;

View File

@ -1,6 +1,7 @@
--- Clp-1.17.1/src/ClpModel.cpp.orig 2019-03-15 09:56:51.000000000 -0600
+++ Clp-1.17.1/src/ClpModel.cpp 2019-04-01 16:40:33.283793373 -0600
@@ -3701,7 +3701,7 @@ int ClpModel::emptyProblem(int *infeasNu
diff -up Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig Clp-releases-1.17.5/Clp/src/ClpModel.cpp
--- Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpModel.cpp 2020-02-20 09:50:46.973499354 -0700
@@ -3720,7 +3720,7 @@ int ClpModel::emptyProblem(int *infeasNu
numberDualInfeasibilities++;
;
sumDualInfeasibilities += fabs(objValue);

View File

@ -1,6 +1,7 @@
--- Clp-1.17.3/src/ClpModel.cpp.orig 2019-04-01 16:40:33.283793373 -0600
+++ Clp-1.17.3/src/ClpModel.cpp 2019-06-19 09:26:15.694712302 -0600
@@ -2873,7 +2873,7 @@ int ClpModel::readMps(const char *fileNa
diff -up Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig Clp-releases-1.17.5/Clp/src/ClpModel.cpp
--- Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig 2020-02-20 09:50:46.973499354 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpModel.cpp 2020-02-20 09:54:26.138615175 -0700
@@ -2892,7 +2892,7 @@ int ClpModel::readMps(const char *fileNa
int status = 0;
try {
status = m.readMps(fileName, "");
@ -9,8 +10,9 @@
e.print();
status = -1;
}
--- Clp-1.17.3/src/ClpSolver.cpp.orig 2019-06-19 08:55:49.245584625 -0600
+++ Clp-1.17.3/src/ClpSolver.cpp 2019-06-19 09:27:25.963449066 -0600
diff -up Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig Clp-releases-1.17.5/Clp/src/ClpSolver.cpp
--- Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig 2020-02-20 09:53:29.722615016 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpSolver.cpp 2020-02-20 09:54:26.139615157 -0700
@@ -1294,7 +1294,7 @@ int ClpMain1(int argc, const char *argv[
}
}
@ -20,9 +22,10 @@
e.print();
status = -1;
}
--- Clp-1.17.3/src/OsiClp/OsiClpSolverInterface.cpp.orig 2019-04-07 21:34:28.000000000 -0600
+++ Clp-1.17.3/src/OsiClp/OsiClpSolverInterface.cpp 2019-06-19 09:28:24.993388970 -0600
@@ -5792,7 +5792,7 @@ int OsiClpSolverInterface::readLp(const
diff -up Clp-releases-1.17.5/Clp/src/OsiClp/OsiClpSolverInterface.cpp.orig Clp-releases-1.17.5/Clp/src/OsiClp/OsiClpSolverInterface.cpp
--- Clp-releases-1.17.5/Clp/src/OsiClp/OsiClpSolverInterface.cpp.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/src/OsiClp/OsiClpSolverInterface.cpp 2020-02-20 09:54:26.141615122 -0700
@@ -5790,7 +5790,7 @@ int OsiClpSolverInterface::readLp(const
*m.messagesPointer() = modelPtr_->coinMessages();
try {
m.readLp(filename, epsilon);
@ -31,8 +34,9 @@
printf("ERROR: %s::%s, %s\n",
e.className().c_str(), e.methodName().c_str(), e.message().c_str());
return -1;
--- Clp-1.17.3/test/OsiClpSolverInterfaceTest.cpp.orig 2017-08-16 08:40:35.000000000 -0600
+++ Clp-1.17.3/test/OsiClpSolverInterfaceTest.cpp 2019-06-19 09:29:07.273629672 -0600
diff -up Clp-releases-1.17.5/Clp/test/OsiClpSolverInterfaceTest.cpp.orig Clp-releases-1.17.5/Clp/test/OsiClpSolverInterfaceTest.cpp
--- Clp-releases-1.17.5/Clp/test/OsiClpSolverInterfaceTest.cpp.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/test/OsiClpSolverInterfaceTest.cpp 2020-02-20 09:54:26.141615122 -0700
@@ -143,7 +143,7 @@ OsiClpSolverInterfaceUnitTest(const std:
solver.setObjCoeff(0,0.0);
OSIUNITTEST_ADD_OUTCOME("clp", "setObjCoeff on empty model", "should throw exception", OsiUnitTest::TestOutcome::ERROR, false);

View File

@ -1,7 +1,7 @@
diff -up Clp-1.17.3/configure.orig Clp-1.17.3/configure
--- Clp-1.17.3/configure.orig 2019-06-14 15:45:20.000000000 -0600
+++ Clp-1.17.3/configure 2019-06-21 10:41:48.445343096 -0600
@@ -32184,7 +32184,7 @@ echo "${ECHO_T}$doxysrcdir (src)" >&6
diff -up Clp-releases-1.17.5/Clp/configure.orig Clp-releases-1.17.5/Clp/configure
--- Clp-releases-1.17.5/Clp/configure.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/configure 2020-02-20 09:46:50.382716225 -0700
@@ -32230,7 +32230,7 @@ echo "${ECHO_T}$doxysrcdir (src)" >&6
fi
# Not built, fall back to installed tag file
if test $doxyfound = no ; then
@ -10,10 +10,10 @@ diff -up Clp-1.17.3/configure.orig Clp-1.17.3/configure
# AC_MSG_NOTICE([Considering $doxydir (install)])
# AC_MSG_NOTICE([Subdirs: $coin_subdirs)])
coin_doxy_tagfiles="$coin_doxy_tagfiles $doxydir/$doxytag=$doxydir/html"
diff -up Clp-1.17.3/Makefile.in.orig Clp-1.17.3/Makefile.in
--- Clp-1.17.3/Makefile.in.orig 2016-02-01 21:31:08.000000000 -0700
+++ Clp-1.17.3/Makefile.in 2019-06-21 10:40:52.417258808 -0600
@@ -420,7 +420,7 @@ EXTRA_DIST = doc/authors.xml doc/basicmo
diff -up Clp-releases-1.17.5/Clp/Makefile.in.orig Clp-releases-1.17.5/Clp/Makefile.in
--- Clp-releases-1.17.5/Clp/Makefile.in.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/Makefile.in 2020-02-20 09:46:50.398715939 -0700
@@ -421,7 +421,7 @@ EXTRA_DIST = doc/authors.xml doc/basicmo
########################################################################
pkgconfiglibdir = $(libdir)/pkgconfig
pkgconfiglib_DATA = clp.pc $(am__append_3)
@ -22,7 +22,7 @@ diff -up Clp-1.17.3/Makefile.in.orig Clp-1.17.3/Makefile.in
########################################################################
# Maintainer Stuff #
@@ -430,7 +430,7 @@ CLEANFILES =
@@ -431,7 +431,7 @@ CLEANFILES =
# Files that are generated and should be cleaned with make distclean
DISTCLEANFILES = $(am__append_5) $(VPATH_DISTCLEANFILES)
DocFiles = README AUTHORS LICENSE

View File

@ -1,14 +1,6 @@
--- Clp-1.17.3/src/ClpPackedMatrix.cpp.orig 2019-05-02 22:31:14.000000000 -0600
+++ Clp-1.17.3/src/ClpPackedMatrix.cpp 2019-06-27 19:58:07.491096817 -0600
@@ -6751,7 +6751,7 @@ ClpPackedMatrix3::ClpPackedMatrix3()
#include <intrin.h>
#elif defined(__arm__)
#include <arm_neon.h>
-#else
+#elif defined(__x86_64__)
#include <immintrin.h>
//#include <fmaintrin.h>
#endif
diff -up Clp-releases-1.17.5/Clp/src/ClpPackedMatrix.cpp.orig Clp-releases-1.17.5/Clp/src/ClpPackedMatrix.cpp
--- Clp-releases-1.17.5/Clp/src/ClpPackedMatrix.cpp.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpPackedMatrix.cpp 2020-02-20 09:58:51.057918125 -0700
@@ -6778,8 +6778,9 @@ ClpPackedMatrix3::ClpPackedMatrix3(ClpSi
//#undef COIN_AVX2
//#define COIN_AVX2 8
@ -21,24 +13,20 @@
#else
#if COIN_AVX2 == 4
#ifndef NO_AVX_HARDWARE
--- Clp-1.17.3/src/ClpSimplexDual.cpp.orig 2019-05-02 22:31:14.000000000 -0600
+++ Clp-1.17.3/src/ClpSimplexDual.cpp 2019-06-27 20:01:18.523941139 -0600
@@ -3554,11 +3554,12 @@ void moveAndZero(clpTempInfo *info, int
diff -up Clp-releases-1.17.5/Clp/src/ClpSimplexDual.cpp.orig Clp-releases-1.17.5/Clp/src/ClpSimplexDual.cpp
--- Clp-releases-1.17.5/Clp/src/ClpSimplexDual.cpp.orig 2020-02-20 09:58:51.059918089 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpSimplexDual.cpp 2020-02-20 10:00:22.752278429 -0700
@@ -3554,6 +3554,7 @@ void moveAndZero(clpTempInfo *info, int
}
}
#endif
+#undef COIN_AVX2
#ifdef _MSC_VER
#include <intrin.h>
#elif defined(__arm__)
#include <arm_neon.h>
-#else
+#elif defined(__x86_64__)
#include <immintrin.h>
//#include <fmaintrin.h>
#endif
--- Clp-1.17.3/src/CoinAbcHelperFunctions.cpp.orig 2019-01-06 12:43:06.000000000 -0700
+++ Clp-1.17.3/src/CoinAbcHelperFunctions.cpp 2019-06-27 19:59:50.890012555 -0600
#elif defined(__ARM_FEATURE_SIMD32) || defined(__ARM_NEON)
diff -up Clp-releases-1.17.5/Clp/src/CoinAbcHelperFunctions.cpp.orig Clp-releases-1.17.5/Clp/src/CoinAbcHelperFunctions.cpp
--- Clp-releases-1.17.5/Clp/src/CoinAbcHelperFunctions.cpp.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/src/CoinAbcHelperFunctions.cpp 2020-02-20 09:58:51.059918089 -0700
@@ -11,7 +11,8 @@
#include "CoinTypes.hpp"
#include "CoinFinite.hpp"

View File

@ -1,5 +1,6 @@
--- Clp-1.17.3/src/ClpModel.cpp.orig 2019-06-19 09:26:15.694712302 -0600
+++ Clp-1.17.3/src/ClpModel.cpp 2019-06-19 09:49:10.677041278 -0600
diff -up Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig Clp-releases-1.17.5/Clp/src/ClpModel.cpp
--- Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig 2020-02-20 09:54:26.138615175 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpModel.cpp 2020-02-20 09:56:18.361626298 -0700
@@ -1337,7 +1337,7 @@ void ClpModel::resize(int newNumberRows,
if (numberRowNames < newNumberRows) {
rowNames_.resize(newNumberRows);
@ -18,7 +19,7 @@
for (unsigned int iColumn = numberColumnNames;
iColumn < newNumberColumns; iColumn++) {
sprintf(name, "C%7.7d", iColumn);
@@ -3426,7 +3426,7 @@ ClpModel::getRowName(int iRow) const
@@ -3445,7 +3445,7 @@ ClpModel::getRowName(int iRow) const
if (size > iRow) {
return rowNames_[iRow];
} else {
@ -27,7 +28,7 @@
sprintf(name, "R%7.7d", iRow);
std::string rowName(name);
return rowName;
@@ -3462,7 +3462,7 @@ ClpModel::getColumnName(int iColumn) con
@@ -3481,7 +3481,7 @@ ClpModel::getColumnName(int iColumn) con
if (size > iColumn) {
return columnNames_[iColumn];
} else {
@ -36,7 +37,7 @@
sprintf(name, "C%7.7d", iColumn);
std::string columnName(name);
return columnName;
@@ -3544,7 +3544,7 @@ void ClpModel::copyRowNames(const char *
@@ -3563,7 +3563,7 @@ void ClpModel::copyRowNames(const char *
maxLength = CoinMax(maxLength, static_cast< unsigned int >(strlen(rowNames[iRow - first])));
} else {
maxLength = CoinMax(maxLength, static_cast< unsigned int >(8));
@ -45,7 +46,7 @@
sprintf(name, "R%7.7d", iRow);
rowNames_[iRow] = name;
}
@@ -3571,7 +3571,7 @@ void ClpModel::copyColumnNames(const cha
@@ -3590,7 +3590,7 @@ void ClpModel::copyColumnNames(const cha
maxLength = CoinMax(maxLength, static_cast< unsigned int >(strlen(columnNames[iColumn - first])));
} else {
maxLength = CoinMax(maxLength, static_cast< unsigned int >(8));
@ -54,7 +55,7 @@
sprintf(name, "C%7.7d", iColumn);
columnNames_[iColumn] = name;
}
@@ -3817,7 +3817,7 @@ ClpModel::rowNamesAsChar() const
@@ -3836,7 +3836,7 @@ ClpModel::rowNamesAsChar() const
if (rowName(iRow) != "") {
rowNames[iRow] = CoinStrdup(rowName(iRow).c_str());
} else {
@ -63,7 +64,7 @@
sprintf(name, "R%7.7d", iRow);
rowNames[iRow] = CoinStrdup(name);
}
@@ -3833,7 +3833,7 @@ ClpModel::rowNamesAsChar() const
@@ -3852,7 +3852,7 @@ ClpModel::rowNamesAsChar() const
xx[n] = '\0';
#endif
}
@ -72,7 +73,7 @@
for (; iRow < numberRows_; iRow++) {
sprintf(name, "R%7.7d", iRow);
rowNames[iRow] = CoinStrdup(name);
@@ -3856,7 +3856,7 @@ ClpModel::columnNamesAsChar() const
@@ -3875,7 +3875,7 @@ ClpModel::columnNamesAsChar() const
if (columnName(iColumn) != "") {
columnNames[iColumn] = CoinStrdup(columnName(iColumn).c_str());
} else {
@ -81,7 +82,7 @@
sprintf(name, "C%7.7d", iColumn);
columnNames[iColumn] = CoinStrdup(name);
}
@@ -3872,7 +3872,7 @@ ClpModel::columnNamesAsChar() const
@@ -3891,7 +3891,7 @@ ClpModel::columnNamesAsChar() const
xx[n] = '\0';
#endif
}
@ -90,8 +91,9 @@
for (; iColumn < numberColumns_; iColumn++) {
sprintf(name, "C%7.7d", iColumn);
columnNames[iColumn] = CoinStrdup(name);
--- Clp-1.17.3/src/ClpSimplexOther.cpp.orig 2019-06-19 09:35:35.100664914 -0600
+++ Clp-1.17.3/src/ClpSimplexOther.cpp 2019-06-19 09:44:47.465748162 -0600
diff -up Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp.orig Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp
--- Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp.orig 2020-02-20 09:55:43.777239225 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp 2020-02-20 09:56:18.363626263 -0700
@@ -2276,7 +2276,7 @@ int ClpSimplexOther::parametrics(const c
{
int returnCode = -2;

View File

@ -1,5 +1,6 @@
--- Clp-1.17.1/src/ClpSolver.cpp.orig 2019-03-27 11:53:43.018224450 -0600
+++ Clp-1.17.1/src/ClpSolver.cpp 2019-04-02 20:37:12.984912142 -0600
diff -up Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig Clp-releases-1.17.5/Clp/src/ClpSolver.cpp
--- Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig 2020-02-20 09:48:11.863261899 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpSolver.cpp 2020-02-20 09:53:29.722615016 -0700
@@ -293,7 +293,11 @@ int ClpMain1(int argc, const char *argv[
parameters[whichParam(CLP_PARAM_DBL_PRIMALWEIGHT, parameters)].setDoubleValue(models->infeasibilityCost());
parameters[whichParam(CLP_PARAM_ACTION_RESTORE, parameters)].setStringValue(restoreFile);

View File

@ -1,5 +1,6 @@
--- Clp-1.17.3/src/ClpModel.cpp.orig 2019-06-19 09:49:10.677041278 -0600
+++ Clp-1.17.3/src/ClpModel.cpp 2019-06-19 09:53:14.743676733 -0600
diff -up Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig Clp-releases-1.17.5/Clp/src/ClpModel.cpp
--- Clp-releases-1.17.5/Clp/src/ClpModel.cpp.orig 2020-02-20 09:56:18.361626298 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpModel.cpp 2020-02-20 09:56:58.777910020 -0700
@@ -1338,7 +1338,7 @@ void ClpModel::resize(int newNumberRows,
rowNames_.resize(newNumberRows);
lengthNames_ = CoinMax(lengthNames_, 8);
@ -18,7 +19,7 @@
iColumn < newNumberColumns; iColumn++) {
sprintf(name, "C%7.7d", iColumn);
columnNames_[iColumn] = name;
@@ -3537,7 +3537,7 @@ void ClpModel::copyRowNames(const char *
@@ -3556,7 +3556,7 @@ void ClpModel::copyRowNames(const char *
int size = static_cast< int >(rowNames_.size());
if (size != numberRows_)
rowNames_.resize(numberRows_);
@ -27,7 +28,7 @@
for (iRow = first; iRow < last; iRow++) {
if (rowNames && rowNames[iRow - first] && strlen(rowNames[iRow - first])) {
rowNames_[iRow] = rowNames[iRow - first];
@@ -3564,7 +3564,7 @@ void ClpModel::copyColumnNames(const cha
@@ -3583,7 +3583,7 @@ void ClpModel::copyColumnNames(const cha
int size = static_cast< int >(columnNames_.size());
if (size != numberColumns_)
columnNames_.resize(numberColumns_);
@ -36,7 +37,7 @@
for (iColumn = first; iColumn < last; iColumn++) {
if (columnNames && columnNames[iColumn - first] && strlen(columnNames[iColumn - first])) {
columnNames_[iColumn] = columnNames[iColumn - first];
@@ -3812,7 +3812,7 @@ ClpModel::rowNamesAsChar() const
@@ -3831,7 +3831,7 @@ ClpModel::rowNamesAsChar() const
rowNames = new char *[numberRows_ + 1];
int numberNames = static_cast< int >(rowNames_.size());
numberNames = CoinMin(numberRows_, numberNames);
@ -45,7 +46,7 @@
for (iRow = 0; iRow < numberNames; iRow++) {
if (rowName(iRow) != "") {
rowNames[iRow] = CoinStrdup(rowName(iRow).c_str());
@@ -3851,7 +3851,7 @@ ClpModel::columnNamesAsChar() const
@@ -3870,7 +3870,7 @@ ClpModel::columnNamesAsChar() const
columnNames = new char *[numberColumns_];
int numberNames = static_cast< int >(columnNames_.size());
numberNames = CoinMin(numberColumns_, numberNames);
@ -54,9 +55,10 @@
for (iColumn = 0; iColumn < numberNames; iColumn++) {
if (columnName(iColumn) != "") {
columnNames[iColumn] = CoinStrdup(columnName(iColumn).c_str());
--- Clp-1.17.3/src/ClpSolver.cpp.orig 2019-06-19 09:48:01.364280767 -0600
+++ Clp-1.17.3/src/ClpSolver.cpp 2019-06-19 09:55:03.409733509 -0600
@@ -3797,9 +3797,9 @@ static void statistics(ClpSimplex *origi
diff -up Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig Clp-releases-1.17.5/Clp/src/ClpSolver.cpp
--- Clp-releases-1.17.5/Clp/src/ClpSolver.cpp.orig 2020-02-20 09:54:26.139615157 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpSolver.cpp 2020-02-20 09:56:58.777910020 -0700
@@ -3799,9 +3799,9 @@ static void statistics(ClpSimplex *origi
numberWritten = fwrite(stats, sizeof(int), 3, fpBlocks);
assert(numberWritten == 3);
numberWritten = fwrite(blockStart, sizeof(int), numberRows, fpBlocks);

View File

@ -1,5 +1,6 @@
--- Clp-1.17.3/src/ClpSimplexOther.cpp.orig 2019-01-07 12:04:36.000000000 -0700
+++ Clp-1.17.3/src/ClpSimplexOther.cpp 2019-06-19 09:35:35.100664914 -0600
diff -up Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp.orig Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp
--- Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp.orig 2020-02-03 06:32:17.000000000 -0700
+++ Clp-releases-1.17.5/Clp/src/ClpSimplexOther.cpp 2020-02-20 09:55:43.777239225 -0700
@@ -2360,9 +2360,9 @@ int ClpSimplexOther::parametrics(const c
if (intervalTheta >= endTheta)
intervalTheta = 0.0;

8
coin-or-Clp.rpmlintrc Normal file
View File

@ -0,0 +1,8 @@
# THIS FILE IS FOR WHITELISTING RPMLINT ERRORS AND WARNINGS IN TASKOTRON
# https://fedoraproject.org/wiki/Taskotron/Tasks/dist.rpmlint#Whitelisting_errors
# Upstream does not give us a man page
addFilter(r'coin-or-Clp\.[^:]+: W: no-manual-page-for-binary clp')
# The documentation is in the doc subpackage
addFilter(r'coin-or-Clp-devel\.[^:]+: W: no-documentation')

View File

@ -1,26 +1,25 @@
%global module Clp
# Avoid circular dependencies on first build
%bcond_with bootstrap
%bcond_without bootstrap
Name: coin-or-%{module}
Summary: Coin-or linear programming
Version: 1.17.3
Release: 4%{?dist}
Version: 1.17.5
Release: 1%{?dist}
License: EPL-1.0
URL: https://github.com/coin-or/%{module}
Source0: http://www.coin-or.org/download/pkgsource/%{module}/%{module}-%{version}.tgz
Source0: %{url}/archive/releases/%{version}/%{module}-%{version}.tar.gz
BuildRequires: coin-or-Data-Netlib
BuildRequires: coin-or-Osi-devel
BuildRequires: coin-or-Osi-doc
BuildRequires: gcc-c++
BuildRequires: doxygen
BuildRequires: MUMPS-devel
%if %{without bootstrap}
BuildRequires: coin-or-Cbc-devel
BuildRequires: libnauty-devel
BuildRequires: pkgconfig(cbc)
%endif
BuildRequires: readline-devel
BuildRequires: pkgconfig(osi)
BuildRequires: pkgconfig(readline)
BuildRequires: suitesparse-devel
# Install documentation in standard rpm directory
@ -80,7 +79,7 @@ BuildArch: noarch
This package contains the documentation for %{name}.
%prep
%setup -q -n %{module}-%{version}
%setup -q -n %{module}-releases-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
@ -106,10 +105,8 @@ export CPPFLAGS="-DCOIN_HAS_CBC -DCOIN_HAS_NTY -I$PWD/src/OsiClp"
--with-glpk-lib=-lglpk \
--with-mumps-incdir=%{_includedir}/MUMPS \
--with-mumps-lib="-ldmumps -lmpiseq" \
%if %{with bootstrap}
LIBS="-lpthread"
%else
LIBS="-lCbc -lnauty -lpthread"
%if %{without bootstrap}
LIBS="-lCbc"
%endif
# Get rid of undesirable hardcoded rpaths; workaround libtool reordering
@ -162,6 +159,10 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test
%{_docdir}/%{name}/clp_doxy.tag
%changelog
* Fri Feb 21 2020 Jerry James <loganjerry@gmail.com> - 1.17.5-1
- Version 1.17.5
- Drop unnecessary libnauty BR
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.17.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (Clp-1.17.3.tgz) = 0b1fa2a831563255c9d64216c61791cdd33d057ca5cd540dbcfdd8c60cb76fad1f1ad71283d57fd7132ada9e8e444987ba58a2ca8116b0d27c90cd05ee9eae74
SHA512 (Clp-1.17.5.tar.gz) = c451e22ce43b183843fb52c73fe33fcb2fbc7793979c3113c7395f765a70c3e19252bcae0b651299075e3f113e19ff1d2b81ead813a89d0291fe9c4e238937ed