Merge commit 'e4497063d8fc85624ecd7f34ec086ef5b833e0f5' into main-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
be977f03c0
@ -1,116 +0,0 @@
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/Absoft-Fortran.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/Absoft-Fortran.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/Absoft-Fortran.cmake
|
||||
@@ -1,7 +1,7 @@
|
||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " ")
|
||||
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O3")
|
||||
+string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O2")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||
set(CMAKE_Fortran_MODDIR_FLAG "-YMOD_OUT_DIR=")
|
||||
set(CMAKE_Fortran_MODPATH_FLAG "-p")
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/G95-Fortran.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/G95-Fortran.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/G95-Fortran.cmake
|
||||
@@ -1,7 +1,7 @@
|
||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
||||
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O3")
|
||||
+string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O2")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||
set(CMAKE_Fortran_MODDIR_FLAG "-fmod=")
|
||||
set(CMAKE_Fortran_VERBOSE_FLAG "-v")
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/GNU.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/GNU.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/GNU.cmake
|
||||
@@ -55,7 +55,7 @@ macro(__compiler_gnu lang)
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG")
|
||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3 -DNDEBUG")
|
||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2 -DNDEBUG")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
||||
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/GNU-Fortran.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/GNU-Fortran.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/GNU-Fortran.cmake
|
||||
@@ -19,7 +19,7 @@ set(CMAKE_Fortran_POSTPROCESS_FLAG "-fpr
|
||||
|
||||
# No -DNDEBUG for Fortran.
|
||||
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
||||
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O3")
|
||||
+string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O2")
|
||||
|
||||
# No -isystem for Fortran because it will not find .mod files.
|
||||
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/Intel.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/Intel.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/Intel.cmake
|
||||
@@ -22,7 +22,7 @@ else()
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os")
|
||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3")
|
||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||
|
||||
set(CMAKE_${lang}_COMPILER_PREDEFINES_COMMAND "${CMAKE_${lang}_COMPILER}")
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
@@ -51,7 +51,7 @@ if(NOT "x${CMAKE_CUDA_SIMULATE_ID}" STRE
|
||||
set(CMAKE_SHARED_LIBRARY_CUDA_FLAGS -fPIC)
|
||||
string(APPEND CMAKE_CUDA_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_CUDA_FLAGS_DEBUG_INIT " -g")
|
||||
- string(APPEND CMAKE_CUDA_FLAGS_RELEASE_INIT " -O3 -DNDEBUG")
|
||||
+ string(APPEND CMAKE_CUDA_FLAGS_RELEASE_INIT " -O2 -DNDEBUG")
|
||||
string(APPEND CMAKE_CUDA_FLAGS_MINSIZEREL_INIT " -O1 -DNDEBUG")
|
||||
string(APPEND CMAKE_CUDA_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||
endif()
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/PathScale.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/PathScale.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/PathScale.cmake
|
||||
@@ -16,6 +16,6 @@ macro(__compiler_pathscale lang)
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os")
|
||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3")
|
||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g -O2")
|
||||
endmacro()
|
||||
Index: cmake-3.22.0-rc1/Modules/Compiler/PGI.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Compiler/PGI.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Compiler/PGI.cmake
|
||||
@@ -18,7 +18,7 @@ macro(__compiler_pgi lang)
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -O2 -s")
|
||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -fast -O3")
|
||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -fast -O2")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -gopt")
|
||||
|
||||
if(CMAKE_HOST_WIN32)
|
||||
Index: cmake-3.22.0-rc1/Modules/Platform/Windows-Clang.cmake
|
||||
===================================================================
|
||||
--- cmake-3.22.0-rc1.orig/Modules/Platform/Windows-Clang.cmake
|
||||
+++ cmake-3.22.0-rc1/Modules/Platform/Windows-Clang.cmake
|
||||
@@ -92,7 +92,7 @@ macro(__windows_compiler_clang_gnu lang)
|
||||
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -Xclang -gcodeview -O0 ${__ADDED_FLAGS_DEBUG}")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG ${__ADDED_FLAGS}")
|
||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3 -DNDEBUG ${__ADDED_FLAGS}")
|
||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2 -DNDEBUG ${__ADDED_FLAGS}")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG -Xclang -gcodeview ${__ADDED_FLAGS}")
|
||||
endif()
|
||||
set(CMAKE_INCLUDE_SYSTEM_FLAG_${lang} "-isystem ")
|
@ -1,18 +0,0 @@
|
||||
Index: cmake-3.23.0-rc2/Modules/Platform/Windows-GNU.cmake
|
||||
===================================================================
|
||||
--- cmake-3.23.0-rc2.orig/Modules/Platform/Windows-GNU.cmake
|
||||
+++ cmake-3.23.0-rc2/Modules/Platform/Windows-GNU.cmake
|
||||
@@ -24,11 +24,11 @@ set(CMAKE_STATIC_LIBRARY_SUFFIX ".a")
|
||||
set(CMAKE_EXTRA_LINK_EXTENSIONS ".lib") # MinGW can also link to a MS .lib
|
||||
|
||||
set(CMAKE_FIND_LIBRARY_PREFIXES "lib" "")
|
||||
-set(CMAKE_FIND_LIBRARY_SUFFIXES ".dll.a" ".a" ".lib")
|
||||
+set(CMAKE_FIND_LIBRARY_SUFFIXES ".dll" ".dll.a" ".a" ".lib")
|
||||
set(CMAKE_C_STANDARD_LIBRARIES_INIT "-lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -ladvapi32")
|
||||
set(CMAKE_CXX_STANDARD_LIBRARIES_INIT "${CMAKE_C_STANDARD_LIBRARIES_INIT}")
|
||||
|
||||
-set(CMAKE_DL_LIBS "")
|
||||
+set(CMAKE_DL_LIBS "dl")
|
||||
set(CMAKE_LIBRARY_PATH_FLAG "-L")
|
||||
set(CMAKE_LINK_LIBRARY_FLAG "-l")
|
||||
set(CMAKE_LINK_DEF_FILE_FLAG "") # Empty string: passing the file is enough
|
324
cmake.spec
324
cmake.spec
@ -11,22 +11,13 @@
|
||||
%bcond_with bootstrap
|
||||
|
||||
# Build with Emacs support
|
||||
%ifnarch riscv64
|
||||
%bcond_without emacs
|
||||
%else
|
||||
%bcond_with emacs
|
||||
%global _emacs_sitelispdir /usr/share/emacs/site-lisp
|
||||
%endif
|
||||
|
||||
# Run git tests
|
||||
%bcond_without git_test
|
||||
|
||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||
%ifnarch riscv64
|
||||
# Set to bcond_with or use --without gui to disable qt gui build
|
||||
%bcond_without gui
|
||||
%else
|
||||
%bcond_with gui
|
||||
%endif
|
||||
|
||||
# Use ncurses for colorful output
|
||||
%bcond_without ncurses
|
||||
@ -51,6 +42,10 @@
|
||||
%bcond_without bundled_rhash
|
||||
%endif
|
||||
|
||||
# cppdap is currently shipped as a static lib from upstream,
|
||||
# so we do not have it in the repos.
|
||||
%bcond_without bundled_cppdap
|
||||
|
||||
# Run tests
|
||||
%bcond_without test
|
||||
|
||||
@ -58,7 +53,10 @@
|
||||
%bcond_without X11_test
|
||||
|
||||
# Do not build non-lto objects to reduce build time significantly.
|
||||
%global optflags %(echo '%{optflags}' | sed -e 's!-ffat-lto-objects!-fno-fat-lto-objects!g')
|
||||
%global build_cflags %(echo '%{build_cflags}' | sed -e 's!-ffat-lto-objects!-fno-fat-lto-objects!g')
|
||||
%global build_cxxflags %(echo '%{build_cxxflags}' | sed -e 's!-ffat-lto-objects!-fno-fat-lto-objects!g')
|
||||
%global build_fflags %(echo '%{build_fflags}' | sed -e 's!-ffat-lto-objects!-fno-fat-lto-objects!g')
|
||||
%global build_fcflags %(echo '%{build_fflags}' | sed -e 's!-ffat-lto-objects!-fno-fat-lto-objects!g')
|
||||
|
||||
# Place rpm-macros into proper location
|
||||
%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||
@ -70,22 +68,30 @@
|
||||
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 24
|
||||
# Set to RC version if building RC, else %%{nil}
|
||||
#global rcsuf %%{nil}
|
||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||
%{?rcsuf:%global versuf -%{rcsuf}}
|
||||
%global minor_version 27
|
||||
%global patch_version 7
|
||||
|
||||
# For handling bump release by rpmdev-bumpspec and mass rebuild
|
||||
%global baserelease 1
|
||||
|
||||
# Set to RC version if building RC, else comment out.
|
||||
#global rcsuf rc1
|
||||
|
||||
%if 0%{?rcsuf:1}
|
||||
%global pkg_version %{major_version}.%{minor_version}.%{patch_version}~%{rcsuf}
|
||||
%global tar_version %{major_version}.%{minor_version}.%{patch_version}-%{rcsuf}
|
||||
%else
|
||||
%global pkg_version %{major_version}.%{minor_version}.%{patch_version}
|
||||
%global tar_version %{major_version}.%{minor_version}.%{patch_version}
|
||||
%endif
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix %%{major_version}
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.1
|
||||
Release: %{baserelease}%{?relsuf}.3.riscv64%{?dist}
|
||||
Version: %{pkg_version}
|
||||
Release: %{baserelease}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
# most sources are BSD
|
||||
@ -93,11 +99,11 @@ Summary: Cross-platform make system
|
||||
# Source/kwsys/MD5.c is zlib
|
||||
# some GPL-licensed bison-generated files, which all include an
|
||||
# exception granting redistribution under terms of your choice
|
||||
License: BSD and MIT and zlib
|
||||
License: BSD-3-Clause AND MIT-open-group AND Zlib%{?with_bundled_cppdap: AND Apache-2.0}
|
||||
URL: http://www.cmake.org
|
||||
Source0: http://www.cmake.org/files/v%{major_version}.%{minor_version}/%{orig_name}-%{version}%{?versuf}.tar.gz
|
||||
Source0: http://www.cmake.org/files/v%{major_version}.%{minor_version}/%{orig_name}-%{tar_version}.tar.gz
|
||||
Source1: %{name}-init.el
|
||||
Source2: macros.%{name}
|
||||
Source2: macros.%{name}.in
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=1202899
|
||||
Source3: %{name}.attr
|
||||
Source4: %{name}.prov
|
||||
@ -111,17 +117,10 @@ Source5: %{name}.req
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch100: %{name}-findruby.patch
|
||||
# replace release flag -O3 with -O2 for fedora
|
||||
%if 0%{?fedora} && 0%{?fedora} < 34
|
||||
Patch101: %{name}-fedora-flag_release.patch
|
||||
%endif
|
||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||
Patch102: %{name}-mingw-dl.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
Patch1: %{name}-rename.patch
|
||||
Patch1: %{name}-rename.patch
|
||||
%endif
|
||||
|
||||
BuildRequires: coreutils
|
||||
@ -147,6 +146,11 @@ BuildRequires: %{_bindir}/sphinx-build
|
||||
%if %{without bootstrap}
|
||||
BuildRequires: bzip2-devel
|
||||
BuildRequires: curl-devel
|
||||
%if %{with bundled_cppdap}
|
||||
Provides: bundled(cppdap)
|
||||
%else
|
||||
BuildRequires: cppdap-devel
|
||||
%endif
|
||||
BuildRequires: expat-devel
|
||||
%if %{with bundled_jsoncpp}
|
||||
Provides: bundled(jsoncpp)
|
||||
@ -181,7 +185,9 @@ BuildRequires: python2-devel
|
||||
%endif
|
||||
%endif
|
||||
%if %{with gui}
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%if 0%{?fedora} || 0%{?rhel} > 9
|
||||
BuildRequires: pkgconfig(Qt6Widgets)
|
||||
%elif 0%{?rhel} > 7
|
||||
BuildRequires: pkgconfig(Qt5Widgets)
|
||||
%else
|
||||
BuildRequires: pkgconfig(QtGui)
|
||||
@ -199,7 +205,7 @@ BuildRequires: %{name}-rpm-macros
|
||||
BuildRequires: make
|
||||
|
||||
Requires: %{name}-data = %{version}-%{release}
|
||||
Requires: %{name}-rpm-macros = %{version}-%{release}
|
||||
Requires: (%{name}-rpm-macros = %{version}-%{release} if rpm-build)
|
||||
Requires: %{name}-filesystem%{?_isa} = %{version}-%{release}
|
||||
|
||||
# Explicitly require make. (rhbz#1862014)
|
||||
@ -228,7 +234,7 @@ generation, code generation, and template instantiation.
|
||||
Summary: Common data-files for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: %{name}-filesystem = %{version}-%{release}
|
||||
Requires: %{name}-rpm-macros = %{version}-%{release}
|
||||
Requires: (%{name}-rpm-macros = %{version}-%{release} if rpm-build)
|
||||
%if %{with emacs}
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 7
|
||||
Requires: emacs-filesystem%{?_emacs_version: >= %{_emacs_version}}
|
||||
@ -283,7 +289,7 @@ This package contains common RPM macros for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -n %{orig_name}-%{version}%{?versuf} -p 1
|
||||
%autosetup -n %{orig_name}-%{tar_version} -p 1
|
||||
|
||||
%if %{with rpm}
|
||||
%if %{with python3}
|
||||
@ -299,15 +305,7 @@ tail -n +2 %{SOURCE5} >> %{name}.req
|
||||
|
||||
|
||||
%build
|
||||
%if 0%{?set_build_flags:1}
|
||||
%{set_build_flags}
|
||||
%else
|
||||
CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
|
||||
CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
|
||||
FFLAGS="${FFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}" ; export FFLAGS
|
||||
FCFLAGS="${FCFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}" ; export FCFLAGS
|
||||
%{?__global_ldflags:LDFLAGS="${LDFLAGS:-%__global_ldflags}" ; export LDFLAGS ;}
|
||||
%endif
|
||||
SRCDIR="$(/usr/bin/pwd)"
|
||||
mkdir %{_vpath_builddir}
|
||||
pushd %{_vpath_builddir}
|
||||
@ -317,6 +315,9 @@ $SRCDIR/bootstrap --prefix=%{_prefix} \
|
||||
--mandir=/share/man \
|
||||
--%{?with_bootstrap:no-}system-libs \
|
||||
--parallel="$(echo %{?_smp_mflags} | sed -e 's|-j||g')" \
|
||||
%if %{with bundled_cppdap}
|
||||
--no-system-cppdap \
|
||||
%endif
|
||||
%if %{with bundled_rhash}
|
||||
--no-system-librhash \
|
||||
%endif
|
||||
@ -356,7 +357,7 @@ mv %{buildroot}%{_emacs_sitelispdir}/%{name}-mode.el %{buildroot}%{_emacs_siteli
|
||||
%{_emacs_bytecompile} %{buildroot}%{_emacs_sitelispdir}/%{name}/%{name}-mode.el
|
||||
install -p -m 0644 %{SOURCE1} %{buildroot}%{_emacs_sitestartdir}
|
||||
%else
|
||||
rm -rf %{buildroot}%{_emacs_sitelispdir}
|
||||
rm -f %{buildroot}%{_emacs_sitelispdir}
|
||||
%endif
|
||||
# RPM macros
|
||||
install -p -m0644 -D %{SOURCE2} %{buildroot}%{rpm_macros_dir}/macros.%{name}
|
||||
@ -377,6 +378,10 @@ do
|
||||
dname=$(basename $dir)
|
||||
cp -p $f ./${fname}_${dname}
|
||||
done
|
||||
%if %{with bundled_cppdap}
|
||||
cp -p Utilities/cmcppdap/LICENSE LICENSE.cppdap
|
||||
cp -p Utilities/cmcppdap/NOTICE NOTICE.cppdap
|
||||
%endif
|
||||
# Cleanup pre-installed documentation
|
||||
%if %{with sphinx}
|
||||
mv %{buildroot}%{_docdir}/%{name}/html .
|
||||
@ -452,25 +457,24 @@ find %{buildroot}%{_bindir} -type f -or -type l -or -xtype l | \
|
||||
%if %{with test}
|
||||
%check
|
||||
pushd %{_vpath_builddir}
|
||||
%ifarch riscv64
|
||||
TEST_TIMEOUT="--timeout 6000"
|
||||
%endif
|
||||
# CTestTestUpload and BundleUtilities require internet access
|
||||
# CPackComponentsForAll-RPM-IgnoreGroup failing wih rpm 4.15 - https://gitlab.kitware.com/cmake/cmake/issues/19983
|
||||
NO_TEST="CTestTestUpload|BundleUtilities"
|
||||
# Likely failing for GCC 12
|
||||
NO_TEST="$NO_TEST|CustomCommand|CMakeLib.testCTestResourceAllocator"
|
||||
NO_TEST="$NO_TEST|CMakeLib.testCTestResourceSpec|RunCMake.PositionIndependentCode"
|
||||
# kwsys.testProcess-{4,5} are flaky on s390x.
|
||||
%ifarch s390x
|
||||
NO_TEST="$NO_TEST|kwsys.testProcess-4|kwsys.testProcess-5"
|
||||
%endif
|
||||
# CTestTestUpload requires internet access.
|
||||
NO_TEST="CTestTestUpload"
|
||||
# Likely failing for hardening flags from system.
|
||||
NO_TEST="$NO_TEST|CustomCommand|RunCMake.PositionIndependentCode"
|
||||
# Failing for rpm 4.19
|
||||
NO_TEST="$NO_TEST|CPackComponentsForAll-RPM-default"
|
||||
NO_TEST="$NO_TEST|CPackComponentsForAll-RPM-OnePackPerGroup"
|
||||
NO_TEST="$NO_TEST|CPackComponentsForAll-RPM-AllInOne"
|
||||
# curl test may fail during bootstrap
|
||||
%if %{with bootstrap}
|
||||
NO_TEST="$NO_TEST|curl"
|
||||
%endif
|
||||
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -E "$NO_TEST" $TEST_TIMEOUT --output-on-failure
|
||||
## do this only periodically, not for every build -- rdieter 20210429
|
||||
%ifarch riscv64
|
||||
# These three tests timeout on riscv64, skip them.
|
||||
NO_TEST="$NO_TEST|Qt5Autogen.ManySources|Qt5Autogen.MocInclude|Qt5Autogen.MocIncludeSymlink"
|
||||
%endif
|
||||
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -E "$NO_TEST" --output-on-failure
|
||||
## do this only periodically, not for every build -- besser82 20221102
|
||||
# Keep an eye on failing tests
|
||||
#bin/ctest%{?name_suffix} %{?_smp_mflags} -V -R "$NO_TEST" --output-on-failure || :
|
||||
popd
|
||||
@ -481,6 +485,10 @@ popd
|
||||
%doc %dir %{_pkgdocdir}
|
||||
%license Copyright.txt*
|
||||
%license COPYING*
|
||||
%if %{with bundled_cppdap}
|
||||
%license LICENSE.cppdap
|
||||
%license NOTICE.cppdap
|
||||
%endif
|
||||
%if %{with sphinx}
|
||||
%{_mandir}/man1/c%{name}.1.*
|
||||
%{_mandir}/man1/%{name}.1.*
|
||||
@ -541,17 +549,203 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 27 2022 David Abdurachmanov <davidlt@rivosinc.com> - 3.24.1-1.3.riscv64
|
||||
- Rebuild for a new libjsoncpp
|
||||
* Sat Oct 07 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.7-1
|
||||
- cmake-3.27.7
|
||||
Fixes rhbz#2242491
|
||||
|
||||
* Thu Sep 01 2022 David Abdurachmanov <davidlt@rivosinc.com> - 3.24.1-1.2.riscv64
|
||||
- Set %%_emacs_sitelispdir until emacs is rebuilt
|
||||
* Tue Oct 03 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.6-2
|
||||
- Include new upstream patches
|
||||
|
||||
* Thu Sep 01 2022 David Abdurachmanov <davidlt@rivosinc.com> - 3.24.1-1.1.riscv64
|
||||
- Disable GUI and emacs on riscv64
|
||||
* Wed Sep 27 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.6-1
|
||||
- cmake-3.27.6
|
||||
Fixes rhbz#2239015, rhbz#2240311
|
||||
- Include new upstream patch
|
||||
|
||||
* Thu Aug 25 2022 David Abdurachmanov <davidlt@rivosinc.com> - 3.24.1-1.0.riscv64
|
||||
- Increase timeout for tests to 6000 seconds on riscv64
|
||||
* Fri Sep 15 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.5-1
|
||||
- cmake-3.27.5
|
||||
Fixes rhbz#2239015
|
||||
|
||||
* Fri Sep 15 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.4-9
|
||||
- Fix CI failure finally
|
||||
|
||||
* Thu Sep 14 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.4-8
|
||||
- Fix CI failure
|
||||
|
||||
* Thu Sep 14 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.4-7
|
||||
- Add upstream patches from milestone to cmake-3.27.5
|
||||
|
||||
* Wed Sep 06 2023 Panu Matilainen <pmatilai@redhat.com> - 3.27.4-6
|
||||
- Only require cmake-rpm-macros when rpm-build is installed part II
|
||||
|
||||
* Sat Sep 02 2023 Tom Stellard <tstellar@redhat.com> - 3.27.4-5
|
||||
- Convert license to SPDX
|
||||
|
||||
* Fri Sep 01 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.4-4
|
||||
- Fix outdated CI configuration
|
||||
|
||||
* Thu Aug 31 2023 Panu Matilainen <pmatilai@redhat.com> - 3.27.4-3
|
||||
- Only require cmake-rpm-macros when rpm-build is installed
|
||||
|
||||
* Mon Aug 28 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.4-2
|
||||
- Add upstream patch to fix linking non-builtin libatomic on some arches
|
||||
|
||||
* Thu Aug 24 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.4-1
|
||||
- cmake-3.27.4
|
||||
Fixes rhbz#2233852
|
||||
|
||||
* Thu Aug 17 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.3-1
|
||||
- cmake-3.27.3
|
||||
Fixes rhbz#2232421
|
||||
|
||||
* Thu Aug 10 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.2-1
|
||||
- cmake-3.27.2
|
||||
Fixes rhbz#2231131
|
||||
|
||||
* Tue Jul 25 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.1-1
|
||||
- cmake-3.27.1
|
||||
Fixes rhbz#2226276
|
||||
|
||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.27.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Tue Jul 18 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0-1
|
||||
- cmake-3.27.0
|
||||
Fixes rhbz#2223754
|
||||
|
||||
* Fri Jul 14 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0~rc5-1
|
||||
- cmake-3.27.0-rc5
|
||||
Fixes rhbz#2222977
|
||||
|
||||
* Thu Jul 06 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0~rc4-2
|
||||
- Fix FTBFS for redhat-rpm-config v260 and later
|
||||
- Re-include tests that were failing with rc1
|
||||
|
||||
* Fri Jun 30 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0~rc4-1
|
||||
- cmake-3.27.0-rc4
|
||||
Fixes rhbz#2218941
|
||||
|
||||
* Tue Jun 20 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0~rc3-1
|
||||
- cmake-3.27.0-rc3
|
||||
Fixes rhbz#2214407
|
||||
|
||||
* Mon Jun 19 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0~rc2-2
|
||||
- Backport some upstream patches which will be included in rc3
|
||||
|
||||
* Mon Jun 12 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0~rc2-1
|
||||
- cmake-3.27.0-rc2
|
||||
|
||||
* Thu Jun 08 2023 Björn Esser <besser82@fedoraproject.org> - 3.27.0~rc1-1
|
||||
- cmake-3.27.0-rc1
|
||||
- Use CMake-provided cppdap
|
||||
- Add licensing information for cppdap to packaged files if needed
|
||||
- Exclude tests that started failing
|
||||
|
||||
* Thu Jun 01 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.4-4
|
||||
- Backport several bugfixes and support for Boost v1.82 from upstream
|
||||
|
||||
* Sat May 27 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.4-3
|
||||
- Rename macros.cmake -> macros.cmake.in
|
||||
- macros: Fix formatting and indentation
|
||||
- macros: Directly use %%set_build_flags, as it is supported since EPEL 7
|
||||
- Exclude tests that are failing for rpm 4.19
|
||||
|
||||
* Fri May 19 2023 Neal Gompa <ngompa@fedoraproject.org> - 3.26.4-2
|
||||
- macros: Use the language build flag macros for compiler flags
|
||||
|
||||
* Fri May 19 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.4-1
|
||||
- cmake-3.26.4
|
||||
Fixes rhbz#2208383
|
||||
|
||||
* Mon May 08 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.3-3
|
||||
- Build cmake-gui with Qt6
|
||||
|
||||
* Fri May 05 2023 Nianqing Yao <imbearchild@outlook.com> - 3.26.3-2
|
||||
- Fix build on riscv64
|
||||
|
||||
* Wed Apr 05 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.3-1
|
||||
- cmake-3.26.3
|
||||
Fixes rhbz#2184478
|
||||
|
||||
* Thu Mar 30 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.2-1
|
||||
- cmake-3.26.2
|
||||
Fixes rhbz#2182863
|
||||
|
||||
* Thu Mar 23 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.1-1
|
||||
- cmake-3.26.1
|
||||
Fixes rhbz#2181278
|
||||
|
||||
* Tue Mar 14 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.0-1
|
||||
- cmake-3.26.0
|
||||
Fixes rhbz#2178221
|
||||
|
||||
* Thu Mar 09 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.0~rc6-1
|
||||
- cmake-3.26.0-rc6
|
||||
Fixes rhbz#2176581
|
||||
|
||||
* Wed Mar 01 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.0~rc5-1
|
||||
- cmake-3.26.0-rc5
|
||||
|
||||
* Wed Feb 22 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.0~rc4-1
|
||||
- cmake-3.26.0-rc4
|
||||
Fixes rhbz#2172604
|
||||
|
||||
* Wed Feb 15 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.0~rc3-1
|
||||
- cmake-3.26.0-rc3
|
||||
Fixes rhbz#2170100
|
||||
|
||||
* Thu Feb 09 2023 Björn Esser <besser82@fedoraproject.org> - 3.26.0~rc2-1
|
||||
- cmake-3.26.0-rc2
|
||||
Fixes rhbz#2167064
|
||||
|
||||
* Thu Jan 19 2023 Björn Esser <besser82@fedoraproject.org> - 3.25.2-1
|
||||
- cmake-3.25.2
|
||||
Fixes rhbz#2162459
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sun Jan 15 2023 Björn Esser <besser82@fedoraproject.org> - 3.25.1-3
|
||||
- Backport upstream patch for Boost v1.81 support
|
||||
|
||||
* Fri Jan 13 2023 Neal Gompa <ngompa@fedoraproject.org> - 3.25.1-2
|
||||
- Adjust ctest macro to use native out-of-tree support
|
||||
|
||||
* Mon Dec 05 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.1-1
|
||||
- cmake-3.25.1
|
||||
Fixes rhbz#2149681
|
||||
|
||||
* Wed Nov 16 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.0-1
|
||||
- cmake-3.25.0
|
||||
Fixes rhbz#2143345
|
||||
|
||||
* Wed Nov 09 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.0-0.6.rc4
|
||||
- cmake-3.25.0-rc4
|
||||
Fixes rhbz#2141122
|
||||
|
||||
* Wed Nov 02 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.0-0.5.rc3
|
||||
- Re-enable BundleUtilities, CMakeLib.testCTestResourceAllocator,
|
||||
CMakeLib.testCTestResourceSpec, CTest.UpdateGIT, ExternalProject
|
||||
during testsuite run
|
||||
- Re-enable kwsys.testProcess-{4,5} on s390x
|
||||
|
||||
* Wed Nov 02 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.0-0.4.rc3
|
||||
- cmake-3.25.0-rc3
|
||||
Fixes rhbz#2062783
|
||||
|
||||
* Sun Oct 30 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.0-0.3.rc2
|
||||
- Allow valid short arguments for %%ctest macro
|
||||
Fixes rhbz#2127650
|
||||
|
||||
* Sun Oct 30 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.0-0.2.rc2
|
||||
- Drop non-upstream CMAKE_DL_LIBS windows patch
|
||||
Fixes rhbz#2127529
|
||||
|
||||
* Sat Oct 29 2022 Björn Esser <besser82@fedoraproject.org> - 3.25.0-0.1.rc2
|
||||
- cmake-3.25.0-rc2
|
||||
Fixes rhbz#2062783
|
||||
|
||||
* Sat Oct 29 2022 Björn Esser <besser82@fedoraproject.org> - 3.24.2-1
|
||||
- cmake-3.24.2
|
||||
|
||||
* Thu Aug 18 2022 Björn Esser <besser82@fedoraproject.org> - 3.24.1-1
|
||||
- cmake-3.24.1
|
||||
|
@ -9,23 +9,16 @@
|
||||
%__ctest /usr/bin/ctest
|
||||
%__cmake_builddir %{!?__cmake_in_source_build:%{_vpath_builddir}}%{?__cmake_in_source_build:.}
|
||||
|
||||
|
||||
# - Set default compile flags
|
||||
# - CMAKE_*_FLAGS_RELEASE are added *after* the *FLAGS environment variables
|
||||
# and default to -O3 -DNDEBUG. Strip the -O3 so we can override with *FLAGS
|
||||
# and default to -O3 -DNDEBUG. Strip the -O3 so we can override with *FLAGS
|
||||
# - Turn on verbose makefiles so we can see and verify compile flags
|
||||
# - Turn off stripping by default so RPM can do it separately
|
||||
# - Set default install prefixes and library install directories
|
||||
# - Turn on shared libraries by default
|
||||
%cmake \
|
||||
%if 0%{?set_build_flags:1} \
|
||||
%set_build_flags \
|
||||
%else \
|
||||
CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
|
||||
CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
|
||||
FFLAGS="${FFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}" ; export FFLAGS ; \
|
||||
FCFLAGS="${FCFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}" ; export FCFLAGS ; \
|
||||
%{?__global_ldflags:LDFLAGS="${LDFLAGS:-%__global_ldflags}" ; export LDFLAGS ;} \
|
||||
%endif \
|
||||
%{set_build_flags} \
|
||||
%__cmake \\\
|
||||
%{!?__cmake_in_source_build:-S "%{_vpath_srcdir}"} \\\
|
||||
%{!?__cmake_in_source_build:-B "%{__cmake_builddir}"} \\\
|
||||
@ -50,13 +43,12 @@
|
||||
%cmake_install \
|
||||
DESTDIR="%{buildroot}" %__cmake --install "%{__cmake_builddir}"
|
||||
|
||||
%ctest(:-:) \
|
||||
cd "%{__cmake_builddir}" \
|
||||
%__ctest --output-on-failure --force-new-ctest-process %{?_smp_mflags} %{**} \
|
||||
cd -
|
||||
%ctest(:-:h:j:u:v:A:C:D:E:F:H:I:L:M:N:O:Q:R:S:T:U:V:) \
|
||||
%__ctest --test-dir "%{__cmake_builddir}" --output-on-failure --force-new-ctest-process %{?_smp_mflags} %{**}
|
||||
|
||||
|
||||
%cmake@@CMAKE_MAJOR_VERSION@@ %cmake
|
||||
%cmake@@CMAKE_MAJOR_VERSION@@_build %cmake_build
|
||||
%cmake@@CMAKE_MAJOR_VERSION@@_install %cmake_install
|
||||
%ctest@@CMAKE_MAJOR_VERSION@@(:-:) %ctest %{**}
|
||||
%ctest@@CMAKE_MAJOR_VERSION@@(:-:h:j:u:v:A:C:D:E:F:H:I:L:M:N:O:Q:R:S:T:U:V:) \
|
||||
%ctest %{**}
|
@ -3,4 +3,4 @@ discover:
|
||||
how: fmf
|
||||
directory: tests
|
||||
execute:
|
||||
how: beakerlib
|
||||
how: tmt
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.24.1.tar.gz) = 67bfafcf9ceba617d7ebbb0ac88b689a2d90ab51fea4a83bd073ee082fb55de8962ce7fb283f3db5f455d286f2199843ffa595a1de207d4fa3e4472d951eb289
|
||||
SHA512 (cmake-3.27.7.tar.gz) = 2e9b83dee8f8c012be4219ab74ebaa8b8438ea55d5204237a1c9feba94c732afe7baceddb9c681672903112b1e40f7b1a86b284cfceed15f46ce8f90143dbb86
|
||||
|
@ -37,6 +37,7 @@ if rlIsFedora; then
|
||||
else
|
||||
REQUIRES="$REQUIRES yum-utils"
|
||||
fi
|
||||
export CLICOLOR=0
|
||||
|
||||
rlJournalStart
|
||||
rlPhaseStartSetup
|
||||
@ -56,10 +57,12 @@ rlJournalStart
|
||||
rlRun "dnf builddep -y $TmpDir/SPECS/*.spec"
|
||||
rlRun "su -c 'rpmbuild -D \"_topdir $TmpDir\" -bp $TmpDir/SPECS/*.spec &>$TmpDir/rpmbuild.log' $BUILD_USER"
|
||||
rlRun "rlFileSubmit $TmpDir/rpmbuild.log"
|
||||
rlRun "cd $TmpDir/BUILD/cmake*"
|
||||
rlRun "CMakeDir=`ls $TmpDir/BUILD | grep -E '^cmake-[0-9]+(\.[0-9]+)+(-rc[0-9]+)?$' | tail -n 1`"
|
||||
rlRun "cd $TmpDir/BUILD/$CMakeDir"
|
||||
rlRun "su -c './bootstrap &>$TmpDir/bootstrap.log' $BUILD_USER"
|
||||
rlRun "rlFileSubmit $TmpDir/bootstrap.log"
|
||||
rlRun "ln -s /usr/bin/cmake bin/cmake"
|
||||
rlRun "ln -fs /usr/bin/cmake bin/cmake"
|
||||
rlRun "make exit_code"
|
||||
rlPhaseEnd
|
||||
|
||||
rlPhaseStartTest "run testsuite"
|
||||
|
Loading…
x
Reference in New Issue
Block a user