cmake-3.31.0
Fixes rhbz#2324190
This commit is contained in:
parent
a02c626742
commit
ae4cdafd95
@ -1,7 +1,7 @@
|
||||
Index: cmake-3.30.5/Modules/FindRuby.cmake
|
||||
Index: cmake-3.31.0/Modules/FindRuby.cmake
|
||||
===================================================================
|
||||
--- cmake-3.30.5.orig/Modules/FindRuby.cmake
|
||||
+++ cmake-3.30.5/Modules/FindRuby.cmake
|
||||
--- cmake-3.31.0.orig/Modules/FindRuby.cmake
|
||||
+++ cmake-3.31.0/Modules/FindRuby.cmake
|
||||
@@ -312,14 +312,9 @@ if(Ruby_EXECUTABLE AND NOT Ruby_VERSION_
|
||||
_RUBY_CONFIG_VAR("sitearchdir" Ruby_SITEARCH_DIR)
|
||||
_RUBY_CONFIG_VAR("sitelibdir" Ruby_SITELIB_DIR)
|
||||
|
@ -1,53 +0,0 @@
|
||||
From be958c8f3529248c0c234596dab230a034424662 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Thu, 17 Oct 2024 21:27:32 +0200
|
||||
Subject: [PATCH] FindPython: Add support for Python 3.14
|
||||
|
||||
---
|
||||
Modules/FindPython/Support.cmake | 2 +-
|
||||
Modules/FindPythonInterp.cmake | 2 +-
|
||||
Modules/FindPythonLibs.cmake | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindPython/Support.cmake b/Modules/FindPython/Support.cmake
|
||||
index faca5ae98a6..e0bdbc54060 100644
|
||||
--- a/Modules/FindPython/Support.cmake
|
||||
+++ b/Modules/FindPython/Support.cmake
|
||||
@@ -30,7 +30,7 @@ if (NOT DEFINED _${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR)
|
||||
message (FATAL_ERROR "FindPython: INTERNAL ERROR")
|
||||
endif()
|
||||
if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL "3")
|
||||
- set(_${_PYTHON_PREFIX}_VERSIONS 3.13 3.12 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+ set(_${_PYTHON_PREFIX}_VERSIONS 3.14 3.13 3.12 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL "2")
|
||||
set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
||||
else()
|
||||
diff --git a/Modules/FindPythonInterp.cmake b/Modules/FindPythonInterp.cmake
|
||||
index 443c6ebf612..e5bcb5f5d1a 100644
|
||||
--- a/Modules/FindPythonInterp.cmake
|
||||
+++ b/Modules/FindPythonInterp.cmake
|
||||
@@ -67,7 +67,7 @@ unset(_Python_NAMES)
|
||||
|
||||
set(_PYTHON1_VERSIONS 1.6 1.5)
|
||||
set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
||||
-set(_PYTHON3_VERSIONS 3.13 3.12 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+set(_PYTHON3_VERSIONS 3.14 3.13 3.12 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
|
||||
if(PythonInterp_FIND_VERSION)
|
||||
if(PythonInterp_FIND_VERSION_COUNT GREATER 1)
|
||||
diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
|
||||
index 112adaeba07..467e8c2759e 100644
|
||||
--- a/Modules/FindPythonLibs.cmake
|
||||
+++ b/Modules/FindPythonLibs.cmake
|
||||
@@ -96,7 +96,7 @@ set(CMAKE_FIND_FRAMEWORK LAST)
|
||||
|
||||
set(_PYTHON1_VERSIONS 1.6 1.5)
|
||||
set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
||||
-set(_PYTHON3_VERSIONS 3.13 3.12 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+set(_PYTHON3_VERSIONS 3.14 3.13 3.12 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
|
||||
if(PythonLibs_FIND_VERSION)
|
||||
if(PythonLibs_FIND_VERSION_COUNT GREATER 1)
|
||||
--
|
||||
GitLab
|
||||
|
11
cmake.spec
11
cmake.spec
@ -68,8 +68,8 @@
|
||||
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 30
|
||||
%global patch_version 5
|
||||
%global minor_version 31
|
||||
%global patch_version 0
|
||||
|
||||
# For handling bump release by rpmdev-bumpspec and mass rebuild
|
||||
%global baserelease 1
|
||||
@ -117,9 +117,6 @@ Source5: %{name}.req
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch100: %{name}-findruby.patch
|
||||
#
|
||||
# FindPython: Add Python 3.14 to the list of hardcoded Python versions
|
||||
Patch101: https://gitlab.kitware.com/cmake/cmake/-/merge_requests/9915.patch#/%{name}-python3.14.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -587,6 +584,10 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 08 2024 Björn Esser <besser82@fedoraproject.org> - 3.31.0-1
|
||||
- cmake-3.31.0
|
||||
Fixes rhbz#2324190
|
||||
|
||||
* Sun Nov 03 2024 Björn Esser <besser82@fedoraproject.org> - 3.30.5-1
|
||||
- cmake-3.30.5
|
||||
Fixes rhbz#2262837
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.30.5.tar.gz) = 968ad4769e869378049b1d82ace98db25a6cb234b6362a51737f0d2978b8914ad42967ba112741850b23631e73b8a8876cd4f99dd0285b9da1c2bb5ea4c4ee4e
|
||||
SHA512 (cmake-3.31.0.tar.gz) = feea7e7e86cfbc228d83c96b84502146516d003a753a2daeeaabb4d2dedefae881c44de7e1e9b424680b0047568c12632472a0030c5ce8413033f94f9b361700
|
||||
|
Loading…
x
Reference in New Issue
Block a user