Update to 2.8.6 RC 2

Drop aclocal patch
This commit is contained in:
Orion Poplawski 2011-09-06 16:34:44 -06:00
parent 2c740a1e9c
commit 5fa4687978
4 changed files with 8 additions and 35 deletions

1
.gitignore vendored
View File

@ -11,3 +11,4 @@ cmake-2.8.2.tar.gz
/cmake-2.8.5-rc3.tar.gz
/cmake-2.8.5.tar.gz
/cmake-2.8.6-rc1.tar.gz
/cmake-2.8.6-rc2.tar.gz

View File

@ -1,29 +0,0 @@
From a2a0a8e0d5f8ad5e464363b952220f716c8fba14 Mon Sep 17 00:00:00 2001
From: David Cole <david.cole@kitware.com>
Date: Fri, 26 Aug 2011 13:51:32 -0400
Subject: [PATCH] cmake.m4: Use modern signature of install(FILES ...)
The older install_files command uses a leading slash in front
of the destination directory, whereas the modern signature does
not. Use the modern signature since that's what the CMake devs
are now used to.
---
Utilities/CMakeLists.txt | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/Utilities/CMakeLists.txt b/Utilities/CMakeLists.txt
index 85db367..798c163 100644
--- a/Utilities/CMakeLists.txt
+++ b/Utilities/CMakeLists.txt
@@ -126,7 +126,7 @@ ADD_CUSTOM_COMMAND(
INSTALL_FILES(${CMAKE_MAN_DIR}/man1 FILES ${MAN_FILES})
INSTALL_FILES(${CMAKE_DOC_DIR} FILES ${HTML_FILES} ${TEXT_FILES})
-INSTALL_FILES(share/aclocal FILES cmake.m4)
+INSTALL(FILES cmake.m4 DESTINATION share/aclocal)
# Drive documentation generation.
ADD_CUSTOM_TARGET(documentation ALL DEPENDS ${DOC_FILES} ${CMake_BINARY_DIR}/Docs/cmake.txt )
--
1.7.0

View File

@ -4,11 +4,11 @@
# Set to bcond_with or use --without gui to disable qt4 gui build
%bcond_without gui
# Set to RC version if building RC, else %{nil}
%define rcver -rc1
%define rcver -rc2
Name: cmake
Version: 2.8.6
Release: 0.1.rc1%{?dist}
Release: 0.2.rc2%{?dist}
Summary: Cross-platform make system
Group: Development/Tools
@ -18,8 +18,6 @@ Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
Source2: macros.cmake
# Patch to find DCMTK in Fedora (bug #720140)
Patch0: cmake-dcmtk.patch
# Upstream patch to fix aclocal install location
Patch1: cmake-aclocal.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -61,7 +59,6 @@ The %{name}-gui package contains the Qt based GUI for CMake.
%prep
%setup -q -n %{name}-%{version}%{?rcver}
%patch0 -p1 -b .dcmtk
%patch1 -p1 -b .aclocal
%build
@ -163,6 +160,10 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%changelog
* Tue Sep 6 2011 Orion Poplawski <orion@cora.nwra.com> - 2.8.6-0.2.rc2
- Update to 2.8.6 RC 2
- Drop aclocal patch
* Mon Aug 29 2011 Orion Poplawski <orion@cora.nwra.com> - 2.8.6-0.1.rc1
- Update to 2.8.6 RC 1
- Update dcmtk patch

View File

@ -1 +1 @@
82d546a0b8a7d75dc42776bd583622ed cmake-2.8.6-rc1.tar.gz
f127d07974a56c6dbfb9b597563cc2d3 cmake-2.8.6-rc2.tar.gz