Update to 2.8.9 RC 1

Drop pkgconfig patch
This commit is contained in:
Orion Poplawski 2012-07-10 15:46:09 -06:00
parent 6afad27c1a
commit 3763a9c898
4 changed files with 9 additions and 62 deletions

1
.gitignore vendored
View File

@ -21,3 +21,4 @@ cmake-2.8.2.tar.gz
/cmake-2.8.8-rc1.tar.gz
/cmake-2.8.8-rc2.tar.gz
/cmake-2.8.8.tar.gz
/cmake-2.8.9-rc1.tar.gz

View File

@ -1,55 +0,0 @@
commit 8bd38d7070b1cec6ed27b71d0359f1b2ccd1e1c8
Author: Rolf Eike Beer <eike@sf-mail.de>
Date: Fri Apr 13 08:50:49 2012 +0200
FindPkgConfig.cmake: fix documented output variable no longer set (#13125)
The real fix is from Yury G. Kudryashov while I added the surrounding cleanups.
diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
index 5d93ab1..30aab45 100644
--- a/Modules/FindPkgConfig.cmake
+++ b/Modules/FindPkgConfig.cmake
@@ -13,11 +13,10 @@
# When the 'QUIET' argument is set, no status messages will be printed.
#
# It sets the following variables:
-# PKG_CONFIG_FOUND ... true if pkg-config works on the system
+# PKG_CONFIG_FOUND ... if pkg-config executable was found
# PKG_CONFIG_EXECUTABLE ... pathname of the pkg-config program
# PKG_CONFIG_VERSION_STRING ... the version of the pkg-config program found
# (since CMake 2.8.8)
-# PKG_CONFIG_FOUND ... if pkg-config executable was found
#
# For the following variables two sets of values exist; first one is the
# common one and has the given PREFIX. The second set contains flags
@@ -104,6 +103,11 @@ find_package_handle_standard_args(PkgConfig
REQUIRED_VARS PKG_CONFIG_EXECUTABLE
VERSION_VAR PKG_CONFIG_VERSION_STRING)
+# This is needed because the module name is "PkgConfig" but the name of
+# this variable has always been PKG_CONFIG_FOUND so this isn't automatically
+# handled by FPHSA.
+set(PKG_CONFIG_FOUND "${PKGCONFIG_FOUND}")
+
# Unsets the given variables
macro(_pkgconfig_unset var)
set(${var} "" CACHE INTERNAL "")
diff --git a/Tests/CMakeOnly/AllFindModules/CMakeLists.txt b/Tests/CMakeOnly/AllFindModules/CMakeLists.txt
index 6604208..fc65e58 100644
--- a/Tests/CMakeOnly/AllFindModules/CMakeLists.txt
+++ b/Tests/CMakeOnly/AllFindModules/CMakeLists.txt
@@ -71,7 +71,7 @@ endmacro(check_version_string)
# reported.
foreach(VTEST ALSA ARMADILLO BZIP2 CUPS CURL EXPAT FREETYPE GETTEXT GIT HSPELL
- JASPER LIBXML2 LIBXSLT PERL PostgreSQL TIFF ZLIB)
+ JASPER LIBXML2 LIBXSLT PERL PKG_CONFIG PostgreSQL TIFF ZLIB)
check_version_string(${VTEST} ${VTEST}_VERSION_STRING)
endforeach(VTEST)
@@ -82,4 +82,3 @@ endforeach(VTEST)
check_version_string(PYTHONINTERP PYTHON_VERSION_STRING)
check_version_string(SUBVERSION Subversion_VERSION_SVN)
-check_version_string(PKGCONFIG PKG_CONFIG_VERSION_STRING)

View File

@ -4,11 +4,11 @@
# Set to bcond_with or use --without gui to disable qt4 gui build
%bcond_without gui
# Set to RC version if building RC, else %{nil}
%define rcver %{nil}
%define rcver -rc1
Name: cmake
Version: 2.8.8
Release: 5%{?dist}
Version: 2.8.9
Release: 0.1.rc1%{?dist}
Summary: Cross-platform make system
Group: Development/Tools
@ -22,8 +22,6 @@ Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
Source2: macros.cmake
# Patch to find DCMTK in Fedora (bug #720140)
Patch0: cmake-dcmtk.patch
# (modified) Upstream patch to fix setting PKG_CONFIG_FOUND (bug #812188)
Patch1: cmake-pkgconfig.patch
# Patch to fix RindRuby vendor settings
# http://public.kitware.com/Bug/view.php?id=12965
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
@ -81,7 +79,6 @@ The %{name}-gui package contains the Qt based GUI for CMake.
%prep
%setup -q -n %{name}-%{version}%{?rcver}
%patch0 -p1 -b .dcmtk
%patch1 -p1 -b .pkgconfig
%patch2 -p1 -b .findruby
%patch3 -p1 -b .findpostgresql
@ -180,6 +177,10 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%changelog
* Tue Jul 10 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.9-0.1.rc1
- Update to 2.8.9 RC 1
- Drop pkgconfig patch
* Thu Jul 5 2012 Orion Poplawski <orion@cora.nwra.com> 2.8.8-5
- Add patch to fix FindPostgreSQL (bug 828467)

View File

@ -1 +1 @@
ba74b22c788a0c8547976b880cd02b17 cmake-2.8.8.tar.gz
ee9facc9a2647d9fa1c35be5f9bb5bef cmake-2.8.9-rc1.tar.gz