Add upstream patch to fix aclocal install location

This commit is contained in:
Orion Poplawski 2011-08-30 09:14:47 -06:00
parent d6faab91a7
commit 2c740a1e9c
2 changed files with 34 additions and 0 deletions

29
cmake-aclocal.patch Normal file
View File

@ -0,0 +1,29 @@
From a2a0a8e0d5f8ad5e464363b952220f716c8fba14 Mon Sep 17 00:00:00 2001
From: David Cole <david.cole@kitware.com>
Date: Fri, 26 Aug 2011 13:51:32 -0400
Subject: [PATCH] cmake.m4: Use modern signature of install(FILES ...)
The older install_files command uses a leading slash in front
of the destination directory, whereas the modern signature does
not. Use the modern signature since that's what the CMake devs
are now used to.
---
Utilities/CMakeLists.txt | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/Utilities/CMakeLists.txt b/Utilities/CMakeLists.txt
index 85db367..798c163 100644
--- a/Utilities/CMakeLists.txt
+++ b/Utilities/CMakeLists.txt
@@ -126,7 +126,7 @@ ADD_CUSTOM_COMMAND(
INSTALL_FILES(${CMAKE_MAN_DIR}/man1 FILES ${MAN_FILES})
INSTALL_FILES(${CMAKE_DOC_DIR} FILES ${HTML_FILES} ${TEXT_FILES})
-INSTALL_FILES(share/aclocal FILES cmake.m4)
+INSTALL(FILES cmake.m4 DESTINATION share/aclocal)
# Drive documentation generation.
ADD_CUSTOM_TARGET(documentation ALL DEPENDS ${DOC_FILES} ${CMake_BINARY_DIR}/Docs/cmake.txt )
--
1.7.0

View File

@ -18,6 +18,8 @@ Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
Source2: macros.cmake
# Patch to find DCMTK in Fedora (bug #720140)
Patch0: cmake-dcmtk.patch
# Upstream patch to fix aclocal install location
Patch1: cmake-aclocal.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -59,6 +61,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
%prep
%setup -q -n %{name}-%{version}%{?rcver}
%patch0 -p1 -b .dcmtk
%patch1 -p1 -b .aclocal
%build
@ -132,6 +135,7 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%{_bindir}/cmake
%{_bindir}/cpack
%{_bindir}/ctest
%{_datadir}/aclocal/cmake.m4
%{_datadir}/%{name}/
%{_mandir}/man1/ccmake.1.gz
%{_mandir}/man1/cmake.1.gz
@ -162,6 +166,7 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
* Mon Aug 29 2011 Orion Poplawski <orion@cora.nwra.com> - 2.8.6-0.1.rc1
- Update to 2.8.6 RC 1
- Update dcmtk patch
- Add upstream patch to fix aclocal install location
* Thu Jul 28 2011 Orion Poplawski <orion@cora.nwra.com> - 2.8.5-3
- Updated patch to find dcmtk in Fedora (Bug #720140)