Merge remote-tracking branch 'origin/master' into f17

Conflicts:
	cmake.spec
This commit is contained in:
Lukas Tinkl 2012-04-20 20:21:27 +02:00
commit 2b4f452d76
5 changed files with 91 additions and 11 deletions

3
.gitignore vendored
View File

@ -18,3 +18,6 @@ cmake-2.8.2.tar.gz
/cmake-2.8.7-rc1.tar.gz
/cmake-2.8.7-rc2.tar.gz
/cmake-2.8.7.tar.gz
/cmake-2.8.8-rc1.tar.gz
/cmake-2.8.8-rc2.tar.gz
/cmake-2.8.8.tar.gz

55
cmake-pkgconfig.patch Normal file
View File

@ -0,0 +1,55 @@
commit 8bd38d7070b1cec6ed27b71d0359f1b2ccd1e1c8
Author: Rolf Eike Beer <eike@sf-mail.de>
Date: Fri Apr 13 08:50:49 2012 +0200
FindPkgConfig.cmake: fix documented output variable no longer set (#13125)
The real fix is from Yury G. Kudryashov while I added the surrounding cleanups.
diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
index 5d93ab1..30aab45 100644
--- a/Modules/FindPkgConfig.cmake
+++ b/Modules/FindPkgConfig.cmake
@@ -13,11 +13,10 @@
# When the 'QUIET' argument is set, no status messages will be printed.
#
# It sets the following variables:
-# PKG_CONFIG_FOUND ... true if pkg-config works on the system
+# PKG_CONFIG_FOUND ... if pkg-config executable was found
# PKG_CONFIG_EXECUTABLE ... pathname of the pkg-config program
# PKG_CONFIG_VERSION_STRING ... the version of the pkg-config program found
# (since CMake 2.8.8)
-# PKG_CONFIG_FOUND ... if pkg-config executable was found
#
# For the following variables two sets of values exist; first one is the
# common one and has the given PREFIX. The second set contains flags
@@ -104,6 +103,11 @@ find_package_handle_standard_args(PkgConfig
REQUIRED_VARS PKG_CONFIG_EXECUTABLE
VERSION_VAR PKG_CONFIG_VERSION_STRING)
+# This is needed because the module name is "PkgConfig" but the name of
+# this variable has always been PKG_CONFIG_FOUND so this isn't automatically
+# handled by FPHSA.
+set(PKG_CONFIG_FOUND "${PKGCONFIG_FOUND}")
+
# Unsets the given variables
macro(_pkgconfig_unset var)
set(${var} "" CACHE INTERNAL "")
diff --git a/Tests/CMakeOnly/AllFindModules/CMakeLists.txt b/Tests/CMakeOnly/AllFindModules/CMakeLists.txt
index 6604208..fc65e58 100644
--- a/Tests/CMakeOnly/AllFindModules/CMakeLists.txt
+++ b/Tests/CMakeOnly/AllFindModules/CMakeLists.txt
@@ -71,7 +71,7 @@ endmacro(check_version_string)
# reported.
foreach(VTEST ALSA ARMADILLO BZIP2 CUPS CURL EXPAT FREETYPE GETTEXT GIT HSPELL
- JASPER LIBXML2 LIBXSLT PERL PostgreSQL TIFF ZLIB)
+ JASPER LIBXML2 LIBXSLT PERL PKG_CONFIG PostgreSQL TIFF ZLIB)
check_version_string(${VTEST} ${VTEST}_VERSION_STRING)
endforeach(VTEST)
@@ -82,4 +82,3 @@ endforeach(VTEST)
check_version_string(PYTHONINTERP PYTHON_VERSION_STRING)
check_version_string(SUBVERSION Subversion_VERSION_SVN)
-check_version_string(PKGCONFIG PKG_CONFIG_VERSION_STRING)

View File

@ -7,8 +7,8 @@
%define rcver %{nil}
Name: cmake
Version: 2.8.7
Release: 5%{?dist}
Version: 2.8.8
Release: 1%{?dist}
Summary: Cross-platform make system
Group: Development/Tools
@ -18,6 +18,9 @@ Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
Source2: macros.cmake
# Patch to find DCMTK in Fedora (bug #720140)
Patch0: cmake-dcmtk.patch
# (modified) Upstream patch to fix setting PKG_CONFIG_FOUND (bug #812188)
Patch1: cmake-pkgconfig.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -43,7 +46,7 @@ CMake is used to control the software compilation process using simple
platform and compiler independent configuration files. CMake generates
native makefiles and workspaces that can be used in the compiler
environment of your choice. CMake is quite sophisticated: it is possible
to support complex environments requiring system configuration, pre-processor
to support complex environments requiring system configuration, preprocessor
generation, code generation, and template instantiation.
@ -59,6 +62,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
%prep
%setup -q -n %{name}-%{version}%{?rcver}
%patch0 -p1 -b .dcmtk
%patch1 -p1 -b .pkgconfig
%build
@ -80,7 +84,7 @@ pushd build
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
popd
cp -a Example $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}/
cp -a Example $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
install -m 0644 Docs/cmake-mode.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/
# RPM macros
@ -104,6 +108,7 @@ pushd build
#CMake.HTML currently requires internet access
#CTestTestUpload requires internet access
bin/ctest -V -E ModuleNotices -E CMake.HTML -E CTestTestUpload %{?_smp_mflags}
popd
%clean
@ -124,9 +129,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%files
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
%{_datadir}/doc/%{name}-%{version}/
%{_docdir}/%{name}-%{version}/
%if %{with gui}
%exclude %{_datadir}/doc/%{name}-%{version}/cmake-gui.*
%exclude %{_docdir}/%{name}-%{version}/cmake-gui.*
%endif
%{_bindir}/ccmake
%{_bindir}/cmake
@ -150,7 +155,7 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%if %{with gui}
%files gui
%defattr(-,root,root,-)
%{_datadir}/doc/%{name}-%{version}/cmake-gui.*
%{_docdir}/%{name}-%{version}/cmake-gui.*
%{_bindir}/cmake-gui
%{_datadir}/applications/CMake.desktop
%{_datadir}/mime/packages/cmakecache.xml
@ -160,8 +165,26 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%changelog
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.7-5
- Rebuilt for c++ ABI breakage
* Thu Apr 20 2012 Lukas Tinkl <ltinkl@redhat.com> - 2.8.8-1
- Update to 2.8.8 final
* Sat Apr 14 2012 Rex Dieter <rdieter@fedoraproject.org> 2.8.8-0.4.rc2
- adjust pkgconfig patch (#812188)
* Fri Apr 13 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.8-0.3.rc2
- Add upstream patch to set PKG_CONFIG_FOUND (bug #812188)
* Mon Apr 9 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.8-0.2.rc2
- Update to 2.8.8 RC 2
* Fri Mar 23 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.8-0.1.rc1
- Update to 2.8.8 RC 1
* Tue Feb 21 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.7-6
- Just strip CMAKE_INSTALL_LIBDIR from %%cmake macro
* Tue Feb 21 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.7-5
- Strip CMAKE_INSTALL_LIBDIR and others from %%cmake macro (bug 795542)
* Thu Jan 26 2012 Tomas Bzatek <tbzatek@redhat.com> - 2.8.7-4
- Rebuilt for new libarchive

View File

@ -14,7 +14,6 @@
%__cmake \\\
-DCMAKE_VERBOSE_MAKEFILE=ON \\\
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \\\
-DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \\\
-DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \\\
-DLIB_INSTALL_DIR:PATH=%{_libdir} \\\
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \\\

View File

@ -1 +1 @@
e1b237aeaed880f65dec9c20602452f6 cmake-2.8.7.tar.gz
ba74b22c788a0c8547976b880cd02b17 cmake-2.8.8.tar.gz