Merge remote-tracking branch 'up/master' into master-riscv64
Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
commit
2174d01a53
@ -1,7 +1,7 @@
|
|||||||
Index: cmake-3.14.0/Modules/Compiler/Absoft-Fortran.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/Absoft-Fortran.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/Absoft-Fortran.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/Absoft-Fortran.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/Absoft-Fortran.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/Absoft-Fortran.cmake
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -11,10 +11,10 @@ Index: cmake-3.14.0/Modules/Compiler/Absoft-Fortran.cmake
|
|||||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
set(CMAKE_Fortran_MODDIR_FLAG "-YMOD_OUT_DIR=")
|
set(CMAKE_Fortran_MODDIR_FLAG "-YMOD_OUT_DIR=")
|
||||||
set(CMAKE_Fortran_MODPATH_FLAG "-p")
|
set(CMAKE_Fortran_MODPATH_FLAG "-p")
|
||||||
Index: cmake-3.14.0/Modules/Compiler/G95-Fortran.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/G95-Fortran.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/G95-Fortran.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/G95-Fortran.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/G95-Fortran.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/G95-Fortran.cmake
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -24,11 +24,11 @@ Index: cmake-3.14.0/Modules/Compiler/G95-Fortran.cmake
|
|||||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
set(CMAKE_Fortran_MODDIR_FLAG "-fmod=")
|
set(CMAKE_Fortran_MODDIR_FLAG "-fmod=")
|
||||||
set(CMAKE_Fortran_VERBOSE_FLAG "-v")
|
set(CMAKE_Fortran_VERBOSE_FLAG "-v")
|
||||||
Index: cmake-3.14.0/Modules/Compiler/GNU.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/GNU.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/GNU.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/GNU.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/GNU.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/GNU.cmake
|
||||||
@@ -50,7 +50,7 @@ macro(__compiler_gnu lang)
|
@@ -55,7 +55,7 @@ macro(__compiler_gnu lang)
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG")
|
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG")
|
||||||
@ -37,10 +37,10 @@ Index: cmake-3.14.0/Modules/Compiler/GNU.cmake
|
|||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||||
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
||||||
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
||||||
Index: cmake-3.14.0/Modules/Compiler/GNU-Fortran.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/GNU-Fortran.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/GNU-Fortran.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/GNU-Fortran.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/GNU-Fortran.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/GNU-Fortran.cmake
|
||||||
@@ -14,7 +14,7 @@ set(CMAKE_Fortran_POSTPROCESS_FLAG "-fpr
|
@@ -14,7 +14,7 @@ set(CMAKE_Fortran_POSTPROCESS_FLAG "-fpr
|
||||||
|
|
||||||
# No -DNDEBUG for Fortran.
|
# No -DNDEBUG for Fortran.
|
||||||
@ -50,10 +50,10 @@ Index: cmake-3.14.0/Modules/Compiler/GNU-Fortran.cmake
|
|||||||
|
|
||||||
# No -isystem for Fortran because it will not find .mod files.
|
# No -isystem for Fortran because it will not find .mod files.
|
||||||
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
||||||
Index: cmake-3.14.0/Modules/Compiler/Intel.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/Intel.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/Intel.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/Intel.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/Intel.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/Intel.cmake
|
||||||
@@ -22,7 +22,7 @@ else()
|
@@ -22,7 +22,7 @@ else()
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -63,11 +63,11 @@ Index: cmake-3.14.0/Modules/Compiler/Intel.cmake
|
|||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
|
|
||||||
set(CMAKE_${lang}_COMPILER_PREDEFINES_COMMAND "${CMAKE_${lang}_COMPILER}")
|
set(CMAKE_${lang}_COMPILER_PREDEFINES_COMMAND "${CMAKE_${lang}_COMPILER}")
|
||||||
Index: cmake-3.14.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/NVIDIA-CUDA.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||||
@@ -10,7 +10,7 @@ if(NOT "x${CMAKE_CUDA_SIMULATE_ID}" STRE
|
@@ -36,7 +36,7 @@ if(NOT "x${CMAKE_CUDA_SIMULATE_ID}" STRE
|
||||||
set(CMAKE_SHARED_LIBRARY_CUDA_FLAGS -fPIC)
|
set(CMAKE_SHARED_LIBRARY_CUDA_FLAGS -fPIC)
|
||||||
string(APPEND CMAKE_CUDA_FLAGS_INIT " ")
|
string(APPEND CMAKE_CUDA_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_CUDA_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_CUDA_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -76,10 +76,10 @@ Index: cmake-3.14.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
|||||||
string(APPEND CMAKE_CUDA_FLAGS_MINSIZEREL_INIT " -O1 -DNDEBUG")
|
string(APPEND CMAKE_CUDA_FLAGS_MINSIZEREL_INIT " -O1 -DNDEBUG")
|
||||||
string(APPEND CMAKE_CUDA_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
string(APPEND CMAKE_CUDA_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||||
endif()
|
endif()
|
||||||
Index: cmake-3.14.0/Modules/Compiler/PathScale.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/PathScale.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/PathScale.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/PathScale.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/PathScale.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/PathScale.cmake
|
||||||
@@ -16,6 +16,6 @@ macro(__compiler_pathscale lang)
|
@@ -16,6 +16,6 @@ macro(__compiler_pathscale lang)
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||||
@ -88,10 +88,10 @@ Index: cmake-3.14.0/Modules/Compiler/PathScale.cmake
|
|||||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2")
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g -O2")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g -O2")
|
||||||
endmacro()
|
endmacro()
|
||||||
Index: cmake-3.14.0/Modules/Compiler/PGI.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/PGI.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/PGI.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/PGI.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/PGI.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/PGI.cmake
|
||||||
@@ -18,7 +18,7 @@ macro(__compiler_pgi lang)
|
@@ -18,7 +18,7 @@ macro(__compiler_pgi lang)
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||||
@ -101,10 +101,10 @@ Index: cmake-3.14.0/Modules/Compiler/PGI.cmake
|
|||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -gopt")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -gopt")
|
||||||
|
|
||||||
if(CMAKE_HOST_WIN32)
|
if(CMAKE_HOST_WIN32)
|
||||||
Index: cmake-3.14.0/Modules/Compiler/SunPro-ASM.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-ASM.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/SunPro-ASM.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-ASM.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/SunPro-ASM.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-ASM.cmake
|
||||||
@@ -11,7 +11,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_ASM_FLAG
|
@@ -11,7 +11,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_ASM_FLAG
|
||||||
string(APPEND CMAKE_ASM_FLAGS_INIT " ")
|
string(APPEND CMAKE_ASM_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_ASM_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_ASM_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -114,10 +114,10 @@ Index: cmake-3.14.0/Modules/Compiler/SunPro-ASM.cmake
|
|||||||
string(APPEND CMAKE_ASM_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
string(APPEND CMAKE_ASM_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
|
|
||||||
# Initialize ASM link type selection flags. These flags are used when
|
# Initialize ASM link type selection flags. These flags are used when
|
||||||
Index: cmake-3.14.0/Modules/Compiler/SunPro-C.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-C.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/SunPro-C.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-C.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/SunPro-C.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-C.cmake
|
||||||
@@ -19,7 +19,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG "
|
@@ -19,7 +19,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG "
|
||||||
string(APPEND CMAKE_C_FLAGS_INIT " ")
|
string(APPEND CMAKE_C_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_C_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_C_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -127,10 +127,10 @@ Index: cmake-3.14.0/Modules/Compiler/SunPro-C.cmake
|
|||||||
string(APPEND CMAKE_C_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
string(APPEND CMAKE_C_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
|
|
||||||
set(CMAKE_DEPFILE_FLAGS_C "-xMD -xMF <DEPFILE>")
|
set(CMAKE_DEPFILE_FLAGS_C "-xMD -xMF <DEPFILE>")
|
||||||
Index: cmake-3.14.0/Modules/Compiler/SunPro-CXX.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-CXX.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/SunPro-CXX.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-CXX.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/SunPro-CXX.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-CXX.cmake
|
||||||
@@ -19,7 +19,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_CXX_FLAG
|
@@ -19,7 +19,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_CXX_FLAG
|
||||||
string(APPEND CMAKE_CXX_FLAGS_INIT " ")
|
string(APPEND CMAKE_CXX_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_CXX_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_CXX_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -140,10 +140,10 @@ Index: cmake-3.14.0/Modules/Compiler/SunPro-CXX.cmake
|
|||||||
string(APPEND CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
string(APPEND CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
|
|
||||||
set(CMAKE_DEPFILE_FLAGS_CXX "-xMD -xMF <DEPFILE>")
|
set(CMAKE_DEPFILE_FLAGS_CXX "-xMD -xMF <DEPFILE>")
|
||||||
Index: cmake-3.14.0/Modules/Compiler/SunPro-Fortran.cmake
|
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-Fortran.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Compiler/SunPro-Fortran.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-Fortran.cmake
|
||||||
+++ cmake-3.14.0/Modules/Compiler/SunPro-Fortran.cmake
|
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-Fortran.cmake
|
||||||
@@ -17,7 +17,7 @@ set(CMAKE_EXECUTABLE_RUNTIME_Fortran_FLA
|
@@ -17,7 +17,7 @@ set(CMAKE_EXECUTABLE_RUNTIME_Fortran_FLA
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -153,3 +153,16 @@ Index: cmake-3.14.0/Modules/Compiler/SunPro-Fortran.cmake
|
|||||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
set(CMAKE_Fortran_MODDIR_FLAG "-moddir=")
|
set(CMAKE_Fortran_MODDIR_FLAG "-moddir=")
|
||||||
set(CMAKE_Fortran_MODPATH_FLAG "-M")
|
set(CMAKE_Fortran_MODPATH_FLAG "-M")
|
||||||
|
Index: cmake-3.17.0-rc1/Modules/Platform/Windows-Clang.cmake
|
||||||
|
===================================================================
|
||||||
|
--- cmake-3.17.0-rc1.orig/Modules/Platform/Windows-Clang.cmake
|
||||||
|
+++ cmake-3.17.0-rc1/Modules/Platform/Windows-Clang.cmake
|
||||||
|
@@ -79,7 +79,7 @@ macro(__windows_compiler_clang_gnu lang)
|
||||||
|
|
||||||
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -Xclang -gcodeview -O0 ${__ADDED_FLAGS_DEBUG}")
|
||||||
|
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG ${__ADDED_FLAGS}")
|
||||||
|
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3 -DNDEBUG ${__ADDED_FLAGS}")
|
||||||
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2 -DNDEBUG ${__ADDED_FLAGS}")
|
||||||
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG -Xclang -gcodeview ${__ADDED_FLAGS}")
|
||||||
|
endif()
|
||||||
|
set(CMAKE_INCLUDE_SYSTEM_FLAG_${lang} "-isystem ")
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
diff -up cmake-3.15.3/Modules/FindRuby.cmake.orig cmake-3.15.3/Modules/FindRuby.cmake
|
Index: cmake-3.17.0-rc1/Modules/FindRuby.cmake
|
||||||
--- cmake-3.15.3/Modules/FindRuby.cmake.orig 2019-09-30 22:18:24.213679271 -0600
|
===================================================================
|
||||||
+++ cmake-3.15.3/Modules/FindRuby.cmake 2019-09-30 22:19:24.177961574 -0600
|
--- cmake-3.17.0-rc1.orig/Modules/FindRuby.cmake
|
||||||
|
+++ cmake-3.17.0-rc1/Modules/FindRuby.cmake
|
||||||
@@ -110,14 +110,8 @@ if(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
@@ -110,14 +110,8 @@ if(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
||||||
_RUBY_CONFIG_VAR("sitearchdir" RUBY_SITEARCH_DIR)
|
_RUBY_CONFIG_VAR("sitearchdir" RUBY_SITEARCH_DIR)
|
||||||
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
||||||
|
@ -1,9 +1,13 @@
|
|||||||
Index: cmake-3.14.0/Modules/Platform/Windows-GNU.cmake
|
Index: cmake-3.17.0-rc1/Modules/Platform/Windows-GNU.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.14.0.orig/Modules/Platform/Windows-GNU.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Platform/Windows-GNU.cmake
|
||||||
+++ cmake-3.14.0/Modules/Platform/Windows-GNU.cmake
|
+++ cmake-3.17.0-rc1/Modules/Platform/Windows-GNU.cmake
|
||||||
@@ -28,9 +28,11 @@ if(MINGW)
|
@@ -25,12 +25,14 @@ endif()
|
||||||
set(CMAKE_FIND_LIBRARY_SUFFIXES ".dll" ".dll.a" ".a" ".lib")
|
|
||||||
|
if(MINGW)
|
||||||
|
set(CMAKE_FIND_LIBRARY_PREFIXES "lib" "")
|
||||||
|
- set(CMAKE_FIND_LIBRARY_SUFFIXES ".dll.a" ".a" ".lib")
|
||||||
|
+ set(CMAKE_FIND_LIBRARY_SUFFIXES ".dll" ".dll.a" ".a" ".lib")
|
||||||
set(CMAKE_C_STANDARD_LIBRARIES_INIT "-lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -ladvapi32")
|
set(CMAKE_C_STANDARD_LIBRARIES_INIT "-lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -ladvapi32")
|
||||||
set(CMAKE_CXX_STANDARD_LIBRARIES_INIT "${CMAKE_C_STANDARD_LIBRARIES_INIT}")
|
set(CMAKE_CXX_STANDARD_LIBRARIES_INIT "${CMAKE_C_STANDARD_LIBRARIES_INIT}")
|
||||||
+ set(CMAKE_DL_LIBS "dl")
|
+ set(CMAKE_DL_LIBS "dl")
|
||||||
|
@ -1,57 +0,0 @@
|
|||||||
From 3bad618ecea6a0552490515f18934ffd05c69983 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
|
||||||
Date: Tue, 14 Jan 2020 19:41:29 +0100
|
|
||||||
Subject: [PATCH] FindPython: Add support for version 3.9
|
|
||||||
|
|
||||||
Development versions of Python 3.9.0 are already out there.
|
|
||||||
|
|
||||||
See PEP 596 -- Python 3.9 Release Schedule:
|
|
||||||
https://www.python.org/dev/peps/pep-0596/
|
|
||||||
---
|
|
||||||
Modules/FindPython/Support.cmake | 2 +-
|
|
||||||
Modules/FindPythonInterp.cmake | 2 +-
|
|
||||||
Modules/FindPythonLibs.cmake | 2 +-
|
|
||||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Modules/FindPython/Support.cmake b/Modules/FindPython/Support.cmake
|
|
||||||
index 7c20512080..7483d72ad8 100644
|
|
||||||
--- a/Modules/FindPython/Support.cmake
|
|
||||||
+++ b/Modules/FindPython/Support.cmake
|
|
||||||
@@ -23,7 +23,7 @@ if (NOT DEFINED _${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR)
|
|
||||||
message (FATAL_ERROR "FindPython: INTERNAL ERROR")
|
|
||||||
endif()
|
|
||||||
if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 3)
|
|
||||||
- set(_${_PYTHON_PREFIX}_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
|
||||||
+ set(_${_PYTHON_PREFIX}_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
|
||||||
elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 2)
|
|
||||||
set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
|
||||||
else()
|
|
||||||
diff --git a/Modules/FindPythonInterp.cmake b/Modules/FindPythonInterp.cmake
|
|
||||||
index ccc7d5b585..1e01a99cbe 100644
|
|
||||||
--- a/Modules/FindPythonInterp.cmake
|
|
||||||
+++ b/Modules/FindPythonInterp.cmake
|
|
||||||
@@ -54,7 +54,7 @@ unset(_Python_NAMES)
|
|
||||||
|
|
||||||
set(_PYTHON1_VERSIONS 1.6 1.5)
|
|
||||||
set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
|
||||||
-set(_PYTHON3_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
|
||||||
+set(_PYTHON3_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
|
||||||
|
|
||||||
if(PythonInterp_FIND_VERSION)
|
|
||||||
if(PythonInterp_FIND_VERSION_COUNT GREATER 1)
|
|
||||||
diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
|
|
||||||
index 1d62ac43ea..d3ec7beec6 100644
|
|
||||||
--- a/Modules/FindPythonLibs.cmake
|
|
||||||
+++ b/Modules/FindPythonLibs.cmake
|
|
||||||
@@ -79,7 +79,7 @@ set(CMAKE_FIND_FRAMEWORK LAST)
|
|
||||||
|
|
||||||
set(_PYTHON1_VERSIONS 1.6 1.5)
|
|
||||||
set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
|
||||||
-set(_PYTHON3_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
|
||||||
+set(_PYTHON3_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
|
||||||
|
|
||||||
if(PythonLibs_FIND_VERSION)
|
|
||||||
if(PythonLibs_FIND_VERSION_COUNT GREATER 1)
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
13
cmake.prov
13
cmake.prov
@ -1,4 +1,4 @@
|
|||||||
#!/usr/bin/python
|
#!/usr/bin/python3
|
||||||
# -*- coding:utf-8 -*-
|
# -*- coding:utf-8 -*-
|
||||||
#
|
#
|
||||||
# Copyright (C) 2015 Daniel Vrátil <dvratil@redhat.com>
|
# Copyright (C) 2015 Daniel Vrátil <dvratil@redhat.com>
|
||||||
@ -37,9 +37,16 @@ class CMakeParser:
|
|||||||
version = self.resolveCMakeModuleVersion(modulePath, cmakeModule, lowercase)
|
version = self.resolveCMakeModuleVersion(modulePath, cmakeModule, lowercase)
|
||||||
|
|
||||||
if version:
|
if version:
|
||||||
print("cmake(%s) = %s" % (cmakeModule, version))
|
string = "cmake(" + cmakeModule + ") = " + version
|
||||||
else:
|
else:
|
||||||
print("cmake(%s)" % cmakeModule)
|
string = "cmake(" + cmakeModule + ")"
|
||||||
|
if string == string.lower():
|
||||||
|
print(string)
|
||||||
|
else:
|
||||||
|
# Temporarily print both variants to satisfy requires
|
||||||
|
# by the old version of this generator which made mistakes
|
||||||
|
print(string)
|
||||||
|
print(string.lower())
|
||||||
|
|
||||||
|
|
||||||
def parseCmakeModuleConfig(self, configFile):
|
def parseCmakeModuleConfig(self, configFile):
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
#!/usr/bin/python
|
#!/usr/bin/python3
|
||||||
# -*- coding:utf-8 -*-
|
# -*- coding:utf-8 -*-
|
||||||
#
|
#
|
||||||
# Copyright (C) 2017 Björn Esser <besser82@fedoraproject.org>
|
# Copyright (C) 2017 Björn Esser <besser82@fedoraproject.org>
|
||||||
|
58
cmake.spec
58
cmake.spec
@ -59,9 +59,9 @@
|
|||||||
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
||||||
|
|
||||||
%global major_version 3
|
%global major_version 3
|
||||||
%global minor_version 16
|
%global minor_version 17
|
||||||
# Set to RC version if building RC, else %%{nil}
|
# Set to RC version if building RC, else %%{nil}
|
||||||
#global rcsuf %%{nil}
|
#global rcsuf rc3
|
||||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||||
%{?rcsuf:%global versuf -%{rcsuf}}
|
%{?rcsuf:%global versuf -%{rcsuf}}
|
||||||
|
|
||||||
@ -70,8 +70,8 @@
|
|||||||
%global orig_name cmake
|
%global orig_name cmake
|
||||||
|
|
||||||
Name: %{orig_name}%{?name_suffix}
|
Name: %{orig_name}%{?name_suffix}
|
||||||
Version: %{major_version}.%{minor_version}.2
|
Version: %{major_version}.%{minor_version}.3
|
||||||
Release: 1%{?relsuf}.0.riscv64%{?dist}
|
Release: 2%{?relsuf}.0.riscv64%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
# most sources are BSD
|
# most sources are BSD
|
||||||
@ -102,9 +102,6 @@ Patch101: %{name}-fedora-flag_release.patch
|
|||||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||||
Patch102: %{name}-mingw-dl.patch
|
Patch102: %{name}-mingw-dl.patch
|
||||||
# FindPython: Add support for version 3.9
|
|
||||||
# https://gitlab.kitware.com/cmake/cmake/merge_requests/4225
|
|
||||||
Patch103: %{name}-python39.patch
|
|
||||||
|
|
||||||
|
|
||||||
# Patch for renaming on EPEL
|
# Patch for renaming on EPEL
|
||||||
@ -424,6 +421,14 @@ pushd %{_vpath_builddir}
|
|||||||
# CTestTestUpload require internet access
|
# CTestTestUpload require internet access
|
||||||
# CPackComponentsForAll-RPM-IgnoreGroup failing wih rpm 4.15 - https://gitlab.kitware.com/cmake/cmake/issues/19983
|
# CPackComponentsForAll-RPM-IgnoreGroup failing wih rpm 4.15 - https://gitlab.kitware.com/cmake/cmake/issues/19983
|
||||||
NO_TEST="CTestTestUpload|CPackComponentsForAll-RPM-IgnoreGroup"
|
NO_TEST="CTestTestUpload|CPackComponentsForAll-RPM-IgnoreGroup"
|
||||||
|
# kwsys.testProcess-{4,5} are flaky on s390x.
|
||||||
|
%ifarch s390x
|
||||||
|
NO_TEST="$NO_TEST|kwsys.testProcess-4|kwsys.testProcess-5"
|
||||||
|
%endif
|
||||||
|
# curl test may fail during bootstrap
|
||||||
|
%if %{with bootstrap}
|
||||||
|
NO_TEST="$NO_TEST|curl"
|
||||||
|
%endif
|
||||||
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -E "$NO_TEST" --output-on-failure
|
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -E "$NO_TEST" --output-on-failure
|
||||||
# Keep an eye on failing tests
|
# Keep an eye on failing tests
|
||||||
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -R "$NO_TEST" --output-on-failure || :
|
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -R "$NO_TEST" --output-on-failure || :
|
||||||
@ -496,9 +501,46 @@ mv -f Modules/FindLibArchive.disabled Modules/FindLibArchive.cmake
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Jan 16 2020 David Abdurachmanov <david.abdurachmanov@sifive.com> - 3.16.2-1.0.riscv64
|
* Sat Jun 06 2020 David Abdurachmanov <david.abdurachmanov@sifive.com> - 3.17.3-2.0.riscv64
|
||||||
- Disable Qt GUI
|
- Disable Qt GUI
|
||||||
|
|
||||||
|
* Sat May 30 2020 Björn Esser <besser82@fedoraproject.org> - 3.17.3-2
|
||||||
|
- Rebuild (jsoncpp)
|
||||||
|
|
||||||
|
* Fri May 29 2020 Björn Esser <besser82@fedoraproject.org> - 3.17.3-1
|
||||||
|
- Update to cmake-3.17.3
|
||||||
|
|
||||||
|
* Tue Apr 28 2020 Björn Esser <besser82@fedoraproject.org> - 3.17.2-1
|
||||||
|
- Update to cmake-3.17.2
|
||||||
|
|
||||||
|
* Thu Apr 09 2020 Björn Esser <besser82@fedoraproject.org> - 3.17.1-1
|
||||||
|
- Update to cmake-3.17.1
|
||||||
|
|
||||||
|
* Tue Mar 24 2020 Rex Dieter <rdieter@fedoraproject.org> - 3.17.0-1
|
||||||
|
- Update to cmake-3.17.0
|
||||||
|
|
||||||
|
* Fri Mar 13 2020 Björn Esser <besser82@fedoraproject.org> - 3.17.0-0.4.rc3
|
||||||
|
- Update to 3.17.0-rc3
|
||||||
|
|
||||||
|
* Tue Mar 03 2020 Björn Esser <besser82@fedoraproject.org> - 3.17.0-0.3.rc2
|
||||||
|
- Update to 3.17.0-rc2
|
||||||
|
|
||||||
|
* Thu Feb 27 2020 Orion Poplawski <orion@nwra.com> - 3.17.0-0.2.rc1
|
||||||
|
- Use python3 for rpm generators
|
||||||
|
- Use lowercase names for cmake provides in generator (in addition to old names)
|
||||||
|
|
||||||
|
* Mon Feb 17 2020 Björn Esser <besser82@fedoraproject.org> - 3.17.0-0.1.rc1
|
||||||
|
- Update to 3.17.0-rc1
|
||||||
|
|
||||||
|
* Wed Feb 05 2020 Björn Esser <besser82@fedoraproject.org> - 3.16.4-1
|
||||||
|
- Update to 3.16.4
|
||||||
|
|
||||||
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.16.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 22 2020 Björn Esser <besser82@fedoraproject.org> - 3.16.3-1
|
||||||
|
- Update to 3.16.3
|
||||||
|
|
||||||
* Wed Jan 15 2020 Björn Esser <besser82@fedoraproject.org> - 3.16.2-1
|
* Wed Jan 15 2020 Björn Esser <besser82@fedoraproject.org> - 3.16.2-1
|
||||||
- Update to 3.16.2
|
- Update to 3.16.2
|
||||||
- Use %%_vpath_builddir for out-of-tree build
|
- Use %%_vpath_builddir for out-of-tree build
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cmake-3.16.2.tar.gz) = b5e68083713462400b38424bf1dbfe73d37a5fbe211fadac30c576246024a1d40f95fab7044804b7201a1bc2e7fd5b7093257e9534cd35538c8b274dc00f4b76
|
SHA512 (cmake-3.17.3.tar.gz) = 13479bd48ef8a8c95277a62b4f42e63152a5979292a98b5456022ca42ad3963cad75e917cc8b92a8485dbf5a2b59cde3fdc90fd9abdb806bc97c8570d03c1c69
|
||||||
|
Loading…
Reference in New Issue
Block a user