Drop various patches/workarounds

- Drop C++11 ABI workaround, fixed in gcc
- Drop strict_aliasing patch fixed upstream long ago
- Drop FindLua52, FindLua should work now for 5.1-5.3
This commit is contained in:
Orion Poplawski 2015-02-26 17:28:03 -07:00
parent cfe5d737b4
commit 1261626b3a
3 changed files with 4 additions and 102 deletions

View File

@ -1,77 +0,0 @@
diff -up cmake-2.8.11-rc4/Modules/FindLua52.cmake.lua-52 cmake-2.8.11-rc4/Modules/FindLua52.cmake
--- cmake-2.8.11-rc4/Modules/FindLua52.cmake.lua-52 2013-05-13 09:41:15.221278404 -0400
+++ cmake-2.8.11-rc4/Modules/FindLua52.cmake 2013-05-13 09:03:43.422233385 -0400
@@ -0,0 +1,73 @@
+# Locate Lua library
+# This module defines
+# LUA52_FOUND, if false, do not try to link to Lua
+# LUA_LIBRARIES
+# LUA_INCLUDE_DIR, where to find lua.h
+# LUA_VERSION_STRING, the version of Lua found (since CMake 2.8.8)
+#
+# Note that the expected include convention is
+# #include "lua.h"
+# and not
+# #include <lua/lua.h>
+# This is because, the lua location is not standardized and may exist
+# in locations other than lua/
+
+#=============================================================================
+# Copyright 2007-2009 Kitware, Inc.
+#
+# Distributed under the OSI-approved BSD License (the "License");
+# see accompanying file Copyright.txt for details.
+#
+# This software is distributed WITHOUT ANY WARRANTY; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+# See the License for more information.
+#=============================================================================
+# (To distribute this file outside of CMake, substitute the full
+# License text for the above reference.)
+
+find_path(LUA_INCLUDE_DIR lua.h
+ HINTS
+ ENV LUA_DIR
+ PATH_SUFFIXES include/lua52 include/lua5.2 include/lua-5.2 include/lua include
+ PATHS
+ ~/Library/Frameworks
+ /Library/Frameworks
+ /sw # Fink
+ /opt/local # DarwinPorts
+ /opt/csw # Blastwave
+ /opt
+)
+
+find_library(LUA_LIBRARY
+ NAMES lua52 lua5.2 lua-5.2 lua
+ HINTS
+ ENV LUA_DIR
+ PATH_SUFFIXES lib
+ PATHS
+ ~/Library/Frameworks
+ /Library/Frameworks
+ /sw
+ /opt/local
+ /opt/csw
+ /opt
+)
+
+if(LUA_LIBRARY)
+ # include the math library for Unix
+ if(UNIX AND NOT APPLE AND NOT BEOS)
+ find_library(LUA_MATH_LIBRARY m)
+ set( LUA_LIBRARIES "${LUA_LIBRARY};${LUA_MATH_LIBRARY}" CACHE STRING "Lua Libraries")
+ # For Windows and Mac, don't need to explicitly include the math library
+ else()
+ set( LUA_LIBRARIES "${LUA_LIBRARY}" CACHE STRING "Lua Libraries")
+ endif()
+endif()
+
+include(${CMAKE_CURRENT_LIST_DIR}/FindPackageHandleStandardArgs.cmake)
+# handle the QUIETLY and REQUIRED arguments and set LUA_FOUND to TRUE if
+# all listed variables are TRUE
+FIND_PACKAGE_HANDLE_STANDARD_ARGS(Lua52
+ REQUIRED_VARS LUA_LIBRARIES LUA_INCLUDE_DIR)
+
+mark_as_advanced(LUA_INCLUDE_DIR LUA_LIBRARIES LUA_LIBRARY LUA_MATH_LIBRARY)
+

View File

@ -1,17 +0,0 @@
diff -up cmake-3.1.0/Source/CMakeLists.txt.strict_aliasing cmake-3.1.0/Source/CMakeLists.txt
--- cmake-3.1.0/Source/CMakeLists.txt.strict_aliasing 2014-12-15 13:07:43.000000000 -0700
+++ cmake-3.1.0/Source/CMakeLists.txt 2014-12-17 18:44:38.547555582 -0700
@@ -388,6 +388,13 @@ if(APPLE)
cmLocalXCodeGenerator.h)
endif()
+# GCC shows strict aliasing warnings with cm_sha2.c. Turn off the
+# corresponding optimizations.
+if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC)
+ set_source_files_properties(cm_sha2.c PROPERTIES
+ COMPILE_FLAGS "-fno-strict-aliasing")
+endif()
+
if (WIN32)
set(SRCS ${SRCS}

View File

@ -32,11 +32,6 @@ Patch0: cmake-dcmtk.patch
# http://public.kitware.com/Bug/view.php?id=12965
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
Patch2: cmake-findruby.patch
# Add FindLua52.cmake
Patch5: cmake-2.8.11-rc4-lua-5.2.patch
# Add -fno-strict-aliasing when compiling cm_sha2.c
# http://www.cmake.org/Bug/view.php?id=14314
Patch6: cmake-strict_aliasing.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -101,8 +96,6 @@ The %{name}-gui package contains the Qt based GUI for CMake.
# We cannot use backups with patches to Modules as they end up being installed
%patch0 -p1
%patch2 -p1
%patch5 -p1
%patch6 -p1 -b .strict_aliasing
%build
@ -115,7 +108,7 @@ pushd build
--%{?with_bootstrap:no-}system-libs \
--parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
--sphinx-man \
%{?qt_gui} -- -DCMAKE_C_STANDARD=90 -DCMAKE_CXX_STANDARD=98
%{?qt_gui}
make VERBOSE=1 %{?_smp_mflags}
@ -230,6 +223,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%changelog
* Thu Feb 26 2015 Orion Poplawski <orion@cora.nwra.com> - 3.2.0-0.2.rc2
- Update to 3.2.0-rc2
- Drop C++11 ABI workaround, fixed in gcc
- Drop strict_aliasing patch fixed upstream long ago
- Drop FindLua52, FindLua should work now for 5.1-5.3
* Sun Feb 15 2015 Orion Poplawski <orion@cora.nwra.com> - 3.2.0-0.1.rc1
- Update to 3.2.0-rc1