23bb636548
clearsilver-0.10.2-2.src.rpm
119 lines
4.4 KiB
Diff
119 lines
4.4 KiB
Diff
diff -Nur clearsilver-0.10.2.orig/cgi/cgi.c clearsilver-0.10.2/cgi/cgi.c
|
|
--- clearsilver-0.10.2.orig/cgi/cgi.c 2005-12-02 10:34:04.000000000 +0100
|
|
+++ clearsilver-0.10.2/cgi/cgi.c 2005-12-15 20:45:13.000000000 +0100
|
|
@@ -641,7 +641,7 @@
|
|
|
|
if ((debugger = hdf_get_value (cgi->hdf, "Config.Debugger", NULL)) == NULL)
|
|
{
|
|
- debugger = "/usr/local/bin/sudo /usr/local/bin/ddd -display %s %s %d";
|
|
+ debugger = "/usr/bin/sudo /usr/local/bin/ddd -display %s %s %d";
|
|
}
|
|
|
|
if (!pid)
|
|
diff -Nur clearsilver-0.10.2.orig/configure clearsilver-0.10.2/configure
|
|
--- clearsilver-0.10.2.orig/configure 2005-12-15 01:26:08.000000000 +0100
|
|
+++ clearsilver-0.10.2/configure 2005-12-15 20:56:46.000000000 +0100
|
|
@@ -6002,7 +6002,7 @@
|
|
echo "$as_me:$LINENO: checking for python includes" >&5
|
|
echo $ECHO_N "checking for python includes... $ECHO_C" >&6
|
|
python_inc=no
|
|
- python_search_path="/neo/opt /usr/local /usr /c"
|
|
+ python_search_path="/usr"
|
|
python_versions="2.4 2.3 2.2 2.1 2.0 1.5 24 23 22 21 20 15"
|
|
if test $cs_cv_python_path != "no" -a -x $cs_cv_python_path; then
|
|
python_bin=$cs_cv_python_path
|
|
@@ -6023,7 +6023,7 @@
|
|
python_site=$path/lib/python$vers/site-packages
|
|
break 2
|
|
fi
|
|
- if test -f $path/python$vers/include/Python.h; then
|
|
+ if test -f $path/python$vers/include/Python.h; then
|
|
python_inc=$path/python$vers/include
|
|
python_lib="-L$path/python$vers/libs -lpython$vers"
|
|
python_site=$path/python$vers/Lib/site-packages
|
|
@@ -6034,14 +6034,14 @@
|
|
fi
|
|
if test "x$python_inc" = "xno"; then
|
|
echo "$as_me:$LINENO: result: not found" >&5
|
|
-echo "${ECHO_T}not found" >&6
|
|
+ echo "${ECHO_T}not found" >&6
|
|
PYTHON=
|
|
PYTHON_INC=
|
|
PYTHON_LIB=
|
|
PYTHON_SITE=
|
|
else
|
|
echo "$as_me:$LINENO: result: found $python_inc" >&5
|
|
-echo "${ECHO_T}found $python_inc" >&6
|
|
+ echo "${ECHO_T}found $python_inc" >&6
|
|
PYTHON=$python_bin
|
|
PYTHON_INC="-I$python_inc"
|
|
PYTHON_LIB=$python_lib
|
|
@@ -6050,6 +6050,7 @@
|
|
fi
|
|
BUILD_WRAPPERS="$BUILD_WRAPPERS python"
|
|
fi
|
|
+ PYTHON_SITE=`$python_bin -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)"`
|
|
fi
|
|
|
|
cs_cv_perl=yes
|
|
@@ -6278,7 +6279,8 @@
|
|
done
|
|
_ACJNI_FOLLOWED="$_cur"
|
|
|
|
-_JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[^/]*$::'`
|
|
+#_JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[^/]*$::'`
|
|
+_JTOPDIR="$java_path"
|
|
case "$host_os" in
|
|
darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[^/]*$::'`
|
|
_JINC="$_JTOPDIR/Headers";;
|
|
diff -Nur clearsilver-0.10.2.orig/imd/imdm.py clearsilver-0.10.2/imd/imdm.py
|
|
--- clearsilver-0.10.2.orig/imd/imdm.py 2005-06-30 20:51:54.000000000 +0200
|
|
+++ clearsilver-0.10.2/imd/imdm.py 2005-12-15 20:45:14.000000000 +0100
|
|
@@ -1,4 +1,4 @@
|
|
-#!/usr/local/bin/python
|
|
+#!/usr/bin/python
|
|
#
|
|
# imdm
|
|
#
|
|
diff -Nur clearsilver-0.10.2.orig/java-jni/Makefile clearsilver-0.10.2/java-jni/Makefile
|
|
--- clearsilver-0.10.2.orig/java-jni/Makefile 2005-12-02 11:35:28.000000000 +0100
|
|
+++ clearsilver-0.10.2/java-jni/Makefile 2005-12-15 20:45:13.000000000 +0100
|
|
@@ -37,14 +37,14 @@
|
|
org_clearsilver_CS.h: $(NEO_UTIL_JAVA_JAR)
|
|
$(JAVAH) -classpath $(NEO_UTIL_JAVA_JAR) -jni org.clearsilver.CS
|
|
|
|
-CSTest.class: CSTest.java
|
|
+CSTest.class: CSTest.java $(NEO_UTIL_JAVA_JAR)
|
|
$(JAVAC) -classpath $(NEO_UTIL_JAVA_JAR) CSTest.java
|
|
|
|
gold: CSTest.class
|
|
@/bin/sh -c "LD_LIBRARY_PATH=$(NEOTONIC_ROOT)/java-jni; export LD_LIBRARY_PATH; CLASSPATH=$(NEO_UTIL_JAVA_JAR):.; export CLASSPATH; $(JAVA_PATH)/bin/java CSTest" > javatest.gold
|
|
@echo "Generated gold files"
|
|
|
|
-test: CSTest.class
|
|
+test: CSTest.class $(NEO_UTIL_SO)
|
|
@echo "Running java test"
|
|
@failed=0; \
|
|
rm -f javatest.out; \
|
|
diff -Nur clearsilver-0.10.2.orig/ruby/Makefile clearsilver-0.10.2/ruby/Makefile
|
|
--- clearsilver-0.10.2.orig/ruby/Makefile 2005-12-02 11:35:52.000000000 +0100
|
|
+++ clearsilver-0.10.2/ruby/Makefile 2005-12-15 20:45:14.000000000 +0100
|
|
@@ -41,7 +41,7 @@
|
|
|
|
|
|
install: all
|
|
- $(RUBY) install.rb install
|
|
+ $(RUBY) install.rb install --prefix=$(DESTDIR)
|
|
|
|
clean:
|
|
$(RM) ext/hdf/*.o ext/hdf/*.so
|
|
diff -Nur clearsilver-0.10.2.orig/scripts/document.py clearsilver-0.10.2/scripts/document.py
|
|
--- clearsilver-0.10.2.orig/scripts/document.py 2005-07-28 02:53:10.000000000 +0200
|
|
+++ clearsilver-0.10.2/scripts/document.py 2005-12-15 20:45:14.000000000 +0100
|
|
@@ -1,4 +1,4 @@
|
|
-#!/bin/env python
|
|
+#!/usr/bin/env python
|
|
"""
|
|
document.py -- Simple script to generate manpages from C header
|
|
files. Looks for the following formatted C comments in the C header files:
|