Florian Weimer 2022-12-12 20:57:05 +01:00
parent b296d963fb
commit d836fdc9e5
2 changed files with 48 additions and 1 deletions

View File

@ -0,0 +1,42 @@
Avoid implicit function declarations in the configure script. This
helps to ensure compatibility with future compilers, which are likely
to reject them by default.
In the unlikely event of another upstream release, current autoconf no
longer produces these script fragments, so the issue should go away on
its own.
diff --git a/configure b/configure
index e49342eb47e20ca1..9a331621d4059d1c 100755
--- a/configure
+++ b/configure
@@ -2124,7 +2124,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; }; then
for ac_declaration in \
- '' \
+ '#include <stdlib.h>' \
'extern "C" void std::exit (int) throw (); using std::exit;' \
'extern "C" void std::exit (int); using std::exit;' \
'extern "C" void exit (int) throw ();' \
@@ -3221,8 +3221,8 @@ main ()
for (i = 0; i < 256; i++)
if (XOR (islower (i), ISLOWER (i))
|| toupper (i) != TOUPPER (i))
- exit(2);
- exit (0);
+ return 2;
+ return 0;
}
_ACEOF
rm -f conftest$ac_exeext
@@ -4697,6 +4697,9 @@ cat >>conftest.$ac_ext <<_ACEOF
#include <sys/time.h>
#include <sys/resource.h>
#include <stdio.h>
+#include <unistd.h>
+#include <sys/wait.h>
+#include <stdlib.h>
/* HP-UX has wait3 but does not fill in rusage at all. */
int
main ()

View File

@ -2,7 +2,7 @@
Name: clearsilver
Version: 0.10.5
Release: 69%{?dist}
Release: 70%{?dist}
Summary: Fast and powerful HTML templating system
# Technically, the license is "Neotonic ClearSilver", but it is a copy of
# ASL 1.1 with the trademarks as the only difference.
@ -16,6 +16,7 @@ Patch3: clearsilver-ruby-1.9.patch
Patch4: clearsilver-ruby-2.2.patch
# GCC 5 compatibility, bug #1190760
Patch5: clearsilver-0.10.5-gcc5.patch
Patch6: clearsilver-configure-c99.patch
BuildRequires: gcc
BuildRequires: zlib-devel
BuildRequires: httpd-devel
@ -84,6 +85,7 @@ Provides: %{name}-java = %{version}-%{release}
%patch3 -p1
%patch4 -p1
%patch5 -p2
%patch6 -p1
touch configure
sed -i -r 's|(\$\(RUBY\) install.rb config) (--.*)|\1 --rb-dir="$(DESTDIR)%{ruby_vendorlibdir}" --so-dir="$(DESTDIR)%{ruby_vendorarchdir}" \2|' ruby/Makefile
@ -157,6 +159,9 @@ ln -s clearsilver-%{version}.jar $RPM_BUILD_ROOT%{_libdir}/java/clearsilver.jar
%changelog
* Mon Dec 12 2022 Florian Weimer <fweimer@redhat.com> - 0.10.5-70
- Port configure script to C99
* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.5-69
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild