- Add patch from Kevin Kofler to fix build failures.

This commit is contained in:
Jeffrey C. Ollie 2008-04-14 17:15:21 +00:00
parent 9b8d0855ce
commit d78c597339
2 changed files with 18 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -ur clearsilver-0.10.5/cs/csparse.c clearsilver-0.10.5-option3/cs/csparse.c
--- clearsilver-0.10.5/cs/csparse.c 2007-07-12 04:37:34.000000000 +0200
+++ clearsilver-0.10.5-option3/cs/csparse.c 2008-04-14 18:55:58.000000000 +0200
@@ -3717,7 +3717,7 @@
if (val.op_type & (CS_TYPE_VAR | CS_TYPE_STRING))
{
char *s = arg_eval(parse, &val);
- if (s) result->n = ne_crc((unsigned char *)s, strlen(s));
+ if (s) result->n = (int) ne_crc((unsigned char *)s, strlen(s));
}
if (val.alloc) free(val.s);
return STATUS_OK;

View File

@ -2,7 +2,7 @@
Name: clearsilver
Version: 0.10.5
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Fast and powerful HTML templating system
Group: Development/Libraries
# Technically, the license is "Neotonic ClearSilver", but it is a copy of
@ -11,6 +11,7 @@ License: ASL 1.1
URL: http://www.clearsilver.net/
Source0: http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
Patch0: clearsilver-0.10.5-fedora.patch
Patch1: clearsilver-0.10.5-regression.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
BuildRequires: httpd-devel
@ -82,6 +83,7 @@ Provides: %{name}-java = %{version}-%{release}
%prep
%setup -q
%patch0 -p1
%patch1 -p1
touch configure
sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
@ -171,6 +173,9 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Mon Apr 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.5-4
- Add patch from Kevin Kofler to fix build failures.
* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.10.5-3
Rebuild for new perl