This commit is contained in:
Vít Ondruch 2015-01-16 16:51:05 +01:00
parent febc5ebfcf
commit 51bedcf166
2 changed files with 26 additions and 1 deletions

View File

@ -0,0 +1,20 @@
--- a/ruby/install.rb
+++ b/ruby/install.rb
@@ -45,7 +45,7 @@
class ConfigTable
- c = ::Config::CONFIG
+ c = ::RbConfig::CONFIG
rubypath = c['bindir'] + '/' + c['ruby_install_name']
@@ -695,7 +695,7 @@
"no extention exists: Have you done 'ruby #{$0} setup' ?"
end
- DLEXT = /\.#{ ::Config::CONFIG['DLEXT'] }\z/
+ DLEXT = /\.#{ ::RbConfig::CONFIG['DLEXT'] }\z/
def _allext( dir )
Dir.open( dir ) {|d|

View File

@ -3,7 +3,7 @@
Name: clearsilver
Version: 0.10.5
Release: 28%{?dist}
Release: 29%{?dist}
Summary: Fast and powerful HTML templating system
Group: Development/Libraries
# Technically, the license is "Neotonic ClearSilver", but it is a copy of
@ -15,6 +15,7 @@ Patch0: clearsilver-0.10.5-fedora.patch
Patch1: clearsilver-0.10.5-regression.patch
Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
Patch3: clearsilver-ruby-1.9.patch
Patch4: clearsilver-ruby-2.2.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
BuildRequires: httpd-devel
@ -86,6 +87,7 @@ Provides: %{name}-java = %{version}-%{release}
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
touch configure
sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
@ -176,6 +178,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Fri Jan 16 2015 Vít Ondruch <vondruch@redhat.com> - 0.10.5-29
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.2
* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.10.5-28
- Perl 5.20 rebuild