auto-import clearsilver-0.10.2-2 on branch devel from

clearsilver-0.10.2-2.src.rpm
This commit is contained in:
Joost Soeterbroek 2006-01-08 17:15:17 +00:00
parent aca2597f33
commit 23bb636548
4 changed files with 309 additions and 0 deletions

View File

@ -0,0 +1 @@
clearsilver-0.10.2.tar.gz

View File

@ -0,0 +1,118 @@
diff -Nur clearsilver-0.10.2.orig/cgi/cgi.c clearsilver-0.10.2/cgi/cgi.c
--- clearsilver-0.10.2.orig/cgi/cgi.c 2005-12-02 10:34:04.000000000 +0100
+++ clearsilver-0.10.2/cgi/cgi.c 2005-12-15 20:45:13.000000000 +0100
@@ -641,7 +641,7 @@
if ((debugger = hdf_get_value (cgi->hdf, "Config.Debugger", NULL)) == NULL)
{
- debugger = "/usr/local/bin/sudo /usr/local/bin/ddd -display %s %s %d";
+ debugger = "/usr/bin/sudo /usr/local/bin/ddd -display %s %s %d";
}
if (!pid)
diff -Nur clearsilver-0.10.2.orig/configure clearsilver-0.10.2/configure
--- clearsilver-0.10.2.orig/configure 2005-12-15 01:26:08.000000000 +0100
+++ clearsilver-0.10.2/configure 2005-12-15 20:56:46.000000000 +0100
@@ -6002,7 +6002,7 @@
echo "$as_me:$LINENO: checking for python includes" >&5
echo $ECHO_N "checking for python includes... $ECHO_C" >&6
python_inc=no
- python_search_path="/neo/opt /usr/local /usr /c"
+ python_search_path="/usr"
python_versions="2.4 2.3 2.2 2.1 2.0 1.5 24 23 22 21 20 15"
if test $cs_cv_python_path != "no" -a -x $cs_cv_python_path; then
python_bin=$cs_cv_python_path
@@ -6023,7 +6023,7 @@
python_site=$path/lib/python$vers/site-packages
break 2
fi
- if test -f $path/python$vers/include/Python.h; then
+ if test -f $path/python$vers/include/Python.h; then
python_inc=$path/python$vers/include
python_lib="-L$path/python$vers/libs -lpython$vers"
python_site=$path/python$vers/Lib/site-packages
@@ -6034,14 +6034,14 @@
fi
if test "x$python_inc" = "xno"; then
echo "$as_me:$LINENO: result: not found" >&5
-echo "${ECHO_T}not found" >&6
+ echo "${ECHO_T}not found" >&6
PYTHON=
PYTHON_INC=
PYTHON_LIB=
PYTHON_SITE=
else
echo "$as_me:$LINENO: result: found $python_inc" >&5
-echo "${ECHO_T}found $python_inc" >&6
+ echo "${ECHO_T}found $python_inc" >&6
PYTHON=$python_bin
PYTHON_INC="-I$python_inc"
PYTHON_LIB=$python_lib
@@ -6050,6 +6050,7 @@
fi
BUILD_WRAPPERS="$BUILD_WRAPPERS python"
fi
+ PYTHON_SITE=`$python_bin -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)"`
fi
cs_cv_perl=yes
@@ -6278,7 +6279,8 @@
done
_ACJNI_FOLLOWED="$_cur"
-_JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[^/]*$::'`
+#_JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[^/]*$::'`
+_JTOPDIR="$java_path"
case "$host_os" in
darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[^/]*$::'`
_JINC="$_JTOPDIR/Headers";;
diff -Nur clearsilver-0.10.2.orig/imd/imdm.py clearsilver-0.10.2/imd/imdm.py
--- clearsilver-0.10.2.orig/imd/imdm.py 2005-06-30 20:51:54.000000000 +0200
+++ clearsilver-0.10.2/imd/imdm.py 2005-12-15 20:45:14.000000000 +0100
@@ -1,4 +1,4 @@
-#!/usr/local/bin/python
+#!/usr/bin/python
#
# imdm
#
diff -Nur clearsilver-0.10.2.orig/java-jni/Makefile clearsilver-0.10.2/java-jni/Makefile
--- clearsilver-0.10.2.orig/java-jni/Makefile 2005-12-02 11:35:28.000000000 +0100
+++ clearsilver-0.10.2/java-jni/Makefile 2005-12-15 20:45:13.000000000 +0100
@@ -37,14 +37,14 @@
org_clearsilver_CS.h: $(NEO_UTIL_JAVA_JAR)
$(JAVAH) -classpath $(NEO_UTIL_JAVA_JAR) -jni org.clearsilver.CS
-CSTest.class: CSTest.java
+CSTest.class: CSTest.java $(NEO_UTIL_JAVA_JAR)
$(JAVAC) -classpath $(NEO_UTIL_JAVA_JAR) CSTest.java
gold: CSTest.class
@/bin/sh -c "LD_LIBRARY_PATH=$(NEOTONIC_ROOT)/java-jni; export LD_LIBRARY_PATH; CLASSPATH=$(NEO_UTIL_JAVA_JAR):.; export CLASSPATH; $(JAVA_PATH)/bin/java CSTest" > javatest.gold
@echo "Generated gold files"
-test: CSTest.class
+test: CSTest.class $(NEO_UTIL_SO)
@echo "Running java test"
@failed=0; \
rm -f javatest.out; \
diff -Nur clearsilver-0.10.2.orig/ruby/Makefile clearsilver-0.10.2/ruby/Makefile
--- clearsilver-0.10.2.orig/ruby/Makefile 2005-12-02 11:35:52.000000000 +0100
+++ clearsilver-0.10.2/ruby/Makefile 2005-12-15 20:45:14.000000000 +0100
@@ -41,7 +41,7 @@
install: all
- $(RUBY) install.rb install
+ $(RUBY) install.rb install --prefix=$(DESTDIR)
clean:
$(RM) ext/hdf/*.o ext/hdf/*.so
diff -Nur clearsilver-0.10.2.orig/scripts/document.py clearsilver-0.10.2/scripts/document.py
--- clearsilver-0.10.2.orig/scripts/document.py 2005-07-28 02:53:10.000000000 +0200
+++ clearsilver-0.10.2/scripts/document.py 2005-12-15 20:45:14.000000000 +0100
@@ -1,4 +1,4 @@
-#!/bin/env python
+#!/usr/bin/env python
"""
document.py -- Simple script to generate manpages from C header
files. Looks for the following formatted C comments in the C header files:

189
clearsilver.spec Normal file
View File

@ -0,0 +1,189 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: clearsilver
Version: 0.10.2
Release: 2%{?dist}
Summary: Fast and powerful HTML templating system
Group: Development/Libraries
License: Neotonic ClearSilver Software License
URL: http://www.clearsilver.net/
Source0: http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
Patch0: %{name}-0.10.2-fedora.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
Provides: %{name}-devel = %{version}-%{release}
%description
ClearSilver is a fast, powerful, and language-neutral HTML template
system. In both static content sites and dynamic HTML applications,
it provides a separation between presentation code and application
logic which makes working with your project easier. The design of
ClearSilver began in 1999, and evolved during its use at onelist.com,
egroups.com, and Yahoo! Groups. Today many other projects and
websites are using it.
%package devel
Summary: ClearSilver development package
Group: Development/Libraries
%description devel
This package provides needed files to develop extensions
to ClearSilver.
%package -n python-%{name}
Summary: Python interface to the ClearSilver HTML templating system
Group: Development/Libraries
BuildRequires: python-devel >= 2.1
Provides: %{name}-python = %{version}-%{release}
%description -n python-%{name}
%{summary}.
%package -n perl-%{name}
Summary: Perl interface to the ClearSilver HTML templating system
Group: Development/Libraries
BuildRequires: perl
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Provides: %{name}-perl = %{version}-%{release}
%description -n perl-%{name}
%{summary}.
%ifarch %{ix86} ppc
%package -n ruby-%{name}
Summary: Ruby interface to the ClearSilver HTML templating system
Group: Development/Libraries
BuildRequires: ruby
BuildRequires: ruby-devel
Provides: %{name}-ruby = %{version}-%{release}
%endif
%ifarch %{ix86} ppc
%description -n ruby-%{name}
%{summary}.
%endif
%ifarch %{ix86} ppc
%package -n java-%{name}
Summary: Java interface to the ClearSilver HTML templating system
Group: Development/Libraries
BuildRequires: java-devel
Provides: %{name}-java = %{version}-%{release}
%endif
%ifarch %{ix86} ppc
%description -n java-%{name}
%{summary}.
%endif
%prep
%setup -q
%patch0 -p1
touch configure
sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
find python/examples -type f | xargs chmod -x
%build
# java and ruby does not build on x86_64
%ifarch %{ix86} ppc
%configure \
--with-java=%{_libdir}/jvm/java \
--with-python=%{__python} \
--disable-csharp
%else
%configure \
--with-python=%{__python} \
--disable-java \
--disable-ruby \
--disable-csharp
%endif
cd perl && %{__perl} Makefile.PL INSTALLDIRS=vendor && cd ..
make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
chmod -R u+w $RPM_BUILD_ROOT/*
%ifarch %{ix86} ppc
install -dm 755 $RPM_BUILD_ROOT%{_libdir}/java
mv $RPM_BUILD_ROOT%{_libdir}{,/java}/libclearsilver-jni.so
mv $RPM_BUILD_ROOT%{_libdir}/clearsilver.jar \
$RPM_BUILD_ROOT%{_libdir}/java/clearsilver-%{version}.jar
chmod 644 $RPM_BUILD_ROOT%{_libdir}/java/clearsilver-%{version}.jar
ln -s clearsilver-%{version}.jar $RPM_BUILD_ROOT%{_libdir}/java/clearsilver.jar
%endif
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc CS_LICENSE INSTALL LICENSE README
%{_bindir}/cstest
%{_bindir}/static.cgi
%{_mandir}/man3/*
%files devel
%defattr(-, root, root, 0755)
%doc CS_LICENSE LICENSE
%{_includedir}/ClearSilver/
%{_libdir}/libneo_*.a
%files -n python-clearsilver
%doc CS_LICENSE LICENSE
%defattr(-,root,root,-)
%doc README.python python/examples/
%{python_sitearch}/neo_cgi.so
%files -n perl-clearsilver
%doc CS_LICENSE LICENSE
%defattr(-,root,root,-)
%{perl_vendorarch}/auto/ClearSilver/
%{perl_vendorarch}/ClearSilver.pm
%ifarch %{ix86} ppc
%files -n ruby-clearsilver
%doc CS_LICENSE LICENSE
%defattr(-,root,root,-)
%{_libdir}/site_ruby/*/*/hdf.so
%{_libdir}/site_ruby/*/neo.rb
%endif
%ifarch %{ix86} ppc
%files -n java-clearsilver
%doc CS_LICENSE LICENSE
%defattr(-,root,root,-)
%{_libdir}/java/*clearsilver*
%endif
%changelog
* Fri Jan 6 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.2-2
- Rebuild with disable-ruby, disable-java for any arch other than i386
- hardcoded version in Patch0
- extra line in prep-section
- license files in all subpackages
* Thu Dec 15 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.2-1
- Rebuild for 0.10.2
* Tue Nov 29 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.1-1
- Rebuild for Fedora Extras
* Sun Jul 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.10.1-0.1
- 0.10.1, PIC issues fixed upstream.
* Sun May 29 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.9.14-0.3
- Rebuild for FC4.
- Rename subpackages to $foo-clearsilver.
* Mon Apr 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.9.14-0.2
- Build as PIC, fixes Ruby and Java builds on FC4.
- More parallel make fixing.
* Fri Apr 8 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.9.14-0.1
- First build.

View File

@ -0,0 +1 @@
10e19526e87b712068e9073469b10d94 clearsilver-0.10.2.tar.gz