CVE-2011-4357.

This commit is contained in:
Jon Ciesla 2011-12-12 08:04:28 -06:00
parent 7d9205c3bb
commit 10cc46eec2
2 changed files with 19 additions and 1 deletions

View File

@ -0,0 +1,13 @@
Description: Fix FTBFS with -Werror=format-security
--- a/python/neo_cgi.c
+++ b/python/neo_cgi.c
@@ -178,7 +178,7 @@
if (!PyArg_ParseTuple(args, "s:error(str)", &s))
return NULL;
- cgi_error (cgi, s);
+ cgi_error (cgi, "%s", s);
rv = Py_None;
Py_INCREF(rv);
return rv;

View File

@ -2,7 +2,7 @@
Name: clearsilver
Version: 0.10.5
Release: 14%{?dist}
Release: 15%{?dist}
Summary: Fast and powerful HTML templating system
Group: Development/Libraries
# Technically, the license is "Neotonic ClearSilver", but it is a copy of
@ -12,6 +12,7 @@ URL: http://www.clearsilver.net/
Source0: http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
Patch0: clearsilver-0.10.5-fedora.patch
Patch1: clearsilver-0.10.5-regression.patch
Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
BuildRequires: httpd-devel
@ -83,6 +84,7 @@ Provides: %{name}-java = %{version}-%{release}
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
touch configure
sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
@ -172,6 +174,9 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Mon Dec 12 2011 Jon Ciesla <limburgher@gmail.com> - 0.10.5-15
- Patch for CVE-2011-4357, BZ 757543.
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.10.5-14
- Perl mass rebuild