5.0.0 Release

This commit is contained in:
Tom Stellard 2017-09-12 02:10:03 +00:00
parent c9eea4fec4
commit b81322cfd7
4 changed files with 16 additions and 109 deletions

View File

@ -1,29 +0,0 @@
From 9d17579a4fa653627bfafa77621c3a89867da97d Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 9 May 2017 01:42:33 +0000
Subject: [PATCH] docs: Fix Sphinx detection with out-of-tree builds
Adapt to changes made in r302499.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@302500 91177308-0d34-0410-b5e6-96231b3b80d8
---
docs/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index 13b79fdf..d2956c1 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -91,8 +91,8 @@ endif()
endif()
if (LLVM_ENABLE_SPHINX)
+ include(AddSphinxTarget)
if (SPHINX_FOUND)
- include(AddSphinxTarget)
if (${SPHINX_OUTPUT_HTML})
add_sphinx_target(html clang)
add_custom_command(TARGET docs-clang-html POST_BUILD
--
1.8.3.1

View File

@ -1,43 +0,0 @@
From 3306314bccdb3429a58fca198bec8d1a01cdf170 Mon Sep 17 00:00:00 2001
From: Matthias Braun <matze@braunis.de>
Date: Fri, 13 Jan 2017 18:36:20 +0000
Subject: [PATCH] litsupport: Add compatibility cludge so it still works with
the pypy version of lit
git-svn-id: https://llvm.org/svn/llvm-project/test-suite/trunk@291933 91177308-0d34-0410-b5e6-96231b3b80d8
---
litsupport/testfile.py | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
diff --git a/litsupport/testfile.py b/litsupport/testfile.py
index d1d234a..7223938 100644
--- a/litsupport/testfile.py
+++ b/litsupport/testfile.py
@@ -27,16 +27,19 @@ def parse(context, filename):
runscript = []
verifyscript = []
metricscripts = {}
- keywords = ['PREPARE:', 'RUN:', 'VERIFY:', 'METRIC:']
+ # Note that we keep both "RUN" and "RUN:" in the list to stay compatible
+ # with older lit versions.
+ keywords = ['PREPARE:', 'PREPARE', 'RUN:', 'RUN', 'VERIFY:', 'VERIFY',
+ 'METRIC:', 'METRIC']
for line_number, command_type, ln in \
parseIntegratedTestScriptCommands(filename, keywords):
- if command_type == 'PREPARE:':
+ if command_type.startswith('PREPARE'):
_parseShellCommand(preparescript, ln)
- elif command_type == 'RUN:':
+ elif command_type.startswith('RUN'):
_parseShellCommand(runscript, ln)
- elif command_type == 'VERIFY:':
+ elif command_type.startswith('VERIFY'):
_parseShellCommand(verifyscript, ln)
- elif command_type == 'METRIC:':
+ elif command_type.startswith('METRIC'):
metric, ln = ln.split(':', 1)
metricscript = metricscripts.setdefault(metric.strip(), list())
_parseShellCommand(metricscript, ln)
--
2.9.3

View File

@ -1,27 +0,0 @@
From 0d272ed9be35fcd1992b08a9026a74d18cf1d7ec Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Thu, 15 Jun 2017 16:33:25 -0400
Subject: [PATCH] test: Remove FileCheck, not, count dependencies
clang already adds these as dependencies for lit.
---
test/CMakeLists.txt | 3 ---
1 file changed, 3 deletions(-)
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a9d7b7c..1a8930a 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -31,9 +31,6 @@ if(CLANG_TOOLS_TEST_USE_VG)
endif()
set(CLANG_TOOLS_TEST_DEPS
- # Base line deps.
- FileCheck count not
-
# clang-tidy tests require it.
clang-headers
--
1.8.3.1

View File

@ -1,4 +1,9 @@
%global maj_ver 5
%global min_ver 0
%global patch_ver 0
%global clang_tools_binaries \
%{_bindir}/clangd \
%{_bindir}/clang-apply-replacements \
%{_bindir}/clang-change-namespace \
%{_bindir}/clang-include-fixer \
@ -10,7 +15,7 @@
%global clang_binaries \
%{_bindir}/clang \
%{_bindir}/clang++ \
%{_bindir}/clang-4.0 \
%{_bindir}/clang-%{maj_ver}.%{min_ver} \
%{_bindir}/clang-check \
%{_bindir}/clang-cl \
%{_bindir}/clang-cpp \
@ -25,8 +30,8 @@
%endif
Name: clang
Version: 4.0.1
Release: 6%{?dist}
Version: %{maj_ver}.%{min_ver}.%{patch_ver}
Release: 1%{?dist}
Summary: A C language family front-end for LLVM
License: NCSA
@ -37,10 +42,6 @@ Source2: http://llvm.org/releases/%{version}/test-suite-%{version}.src.tar.xz
Source100: clang-config.h
# This patch is required when the test suite is using python-lit 0.5.0.
Patch1: 0001-litsupport-Add-compatibility-cludge-so-it-still-work.patch
Patch2: 0001-docs-Fix-Sphinx-detection-with-out-of-tree-builds.patch
Patch3: 0001-test-Remove-FileCheck-not-count-dependencies.patch
Patch4: 0001-lit.cfg-Remove-substitutions-for-clang-llvm-tools.patch
BuildRequires: cmake
@ -95,6 +96,8 @@ Runtime library for clang.
%package devel
Summary: Development header files for clang.
Requires: %{name}%{?_isa} = %{version}-%{release}
# The clang CMake files reference tools from clang-tools-extra.
Requires: %{name}-tools-extra%{?_isa} = %{version}-%{release}
%description devel
Development header files for clang.
@ -144,13 +147,10 @@ Requires: python2
%prep
%setup -T -q -b 1 -n clang-tools-extra-%{version}.src
%patch3 -p1 -b .lit-dep-fix
%setup -T -q -b 2 -n test-suite-%{version}.src
%patch1 -p1 -b .lit-fix
%setup -q -n cfe-%{version}.src
%patch2 -p1 -b .docs-fix
%patch4 -p1 -b .lit-tools-fix
mv ../clang-tools-extra-%{version}.src tools/extra
@ -217,6 +217,9 @@ rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
# TODO: Package html docs
rm -Rvf %{buildroot}%{_pkgdocdir}
# TODO: What are the Fedora guidelines for packaging bash autocomplete files?
rm -vf %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
%check
# requires lit.py from LLVM utilities
cd _build
@ -270,6 +273,9 @@ make %{?_smp_mflags} check || :
%{python2_sitelib}/clang/
%changelog
* Mon Oct 16 2017 Tom Stellard <tstellar@redhat.com> - 5.0.0-1
- 5.0.0 Release
* Wed Oct 04 2017 Rex Dieter <rdieter@fedoraproject.org> - 4.0.1-6
- python2-clang subpkg (#1490997)
- tools-extras: tighten (internal) -libs dep