Remove patch applied upstream

This commit is contained in:
sergesanspaille 2021-02-24 18:16:29 +01:00
parent 8dfbf069f3
commit 1ca8ec6bba
2 changed files with 0 additions and 38 deletions

View File

@ -1,36 +0,0 @@
diff -Naur clang-tools-extra-12.0.0rc1.src.orig/unittests/clang-tidy/CMakeLists.txt clang-tools-extra-12.0.0rc1.src/unittests/clang-tidy/CMakeLists.txt
--- clang-tools-extra-12.0.0rc1.src.orig/unittests/clang-tidy/CMakeLists.txt 2021-02-15 11:12:22.000000000 +0100
+++ clang-tools-extra-12.0.0rc1.src/unittests/clang-tidy/CMakeLists.txt 2021-02-15 17:02:32.000000000 +0100
@@ -1,9 +1,17 @@
set(LLVM_LINK_COMPONENTS
FrontendOpenMP
Support
- TestingSupport
)
+if(CLANG_BUILT_STANDALONE)
+ # LLVMTestingSupport library is needed for clang-tidy tests.
+ if (EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Testing/Support
+ AND NOT TARGET LLVMTestingSupport)
+ add_subdirectory(${LLVM_MAIN_SRC_DIR}/lib/Testing/Support
+ lib/Testing/Support)
+ endif()
+endif()
+
get_filename_component(CLANG_LINT_SOURCE_DIR
${CMAKE_CURRENT_SOURCE_DIR}/../../clang-tidy REALPATH)
include_directories(${CLANG_LINT_SOURCE_DIR})
@@ -37,6 +45,7 @@
clangToolingCore
clangTransformer
)
+
target_link_libraries(ClangTidyTests
PRIVATE
clangTidy
@@ -46,4 +55,5 @@
clangTidyObjCModule
clangTidyReadabilityModule
clangTidyUtils
+ LLVMTestingSupport
)

View File

@ -88,7 +88,6 @@ Source4: tstellar-gpg-key.asc
%if !0%{?compat_build}
Patch21: completion-model-cmake.patch
Patch22: clang-tidy.patch
%endif
# Not Upstream
@ -266,7 +265,6 @@ Requires: python3
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE2}' --data='%{SOURCE1}'
%setup -T -q -b 1 -n %{clang_tools_srcdir}
%patch21 -p1 -b .comp-model
%patch22 -p1 -b .clang-tidy
# failing test case
rm test/clang-tidy/checkers/altera-struct-pack-align.cpp