Update to 0.103.0
This commit is contained in:
parent
2f1ce735e0
commit
ba61c84605
12
clamav-check.patch
Normal file
12
clamav-check.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up clamav-0.103.0/unit_tests/check_jsnorm.c.check clamav-0.103.0/unit_tests/check_jsnorm.c
|
||||
--- clamav-0.103.0/unit_tests/check_jsnorm.c.check 2020-09-12 18:27:10.000000000 -0600
|
||||
+++ clamav-0.103.0/unit_tests/check_jsnorm.c 2020-09-17 22:15:26.199957518 -0600
|
||||
@@ -247,7 +247,7 @@ static void tokenizer_test(const char *i
|
||||
fd = open(filename, O_RDONLY);
|
||||
if (fd < 0) {
|
||||
jstest_teardown();
|
||||
- ck_assert_msg("failed to open output file: %s", filename);
|
||||
+ ck_assert_msg(0, "failed to open output file: %s", filename);
|
||||
}
|
||||
|
||||
diff_file_mem(fd, expected, len);
|
@ -1,4 +1,4 @@
|
||||
VERSION=0.102.4
|
||||
VERSION=0.103.0
|
||||
NAME=clamav
|
||||
TARBALL_CLEAN=${NAME}-${VERSION}-norar.tar.xz
|
||||
TARBALL=${NAME}-${VERSION}.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up clamav-0.102.0/clamconf/clamconf.c.default_confs clamav-0.102.0/clamconf/clamconf.c
|
||||
--- clamav-0.102.0/clamconf/clamconf.c.default_confs 2019-10-11 20:46:32.216962895 -0600
|
||||
+++ clamav-0.102.0/clamconf/clamconf.c 2019-10-11 20:47:16.201174669 -0600
|
||||
@@ -60,9 +60,9 @@ static struct _cfgfile {
|
||||
diff -up clamav-0.103.0/clamconf/clamconf.c.default_confs clamav-0.103.0/clamconf/clamconf.c
|
||||
--- clamav-0.103.0/clamconf/clamconf.c.default_confs 2020-09-12 18:27:09.000000000 -0600
|
||||
+++ clamav-0.103.0/clamconf/clamconf.c 2020-09-17 22:00:20.792879792 -0600
|
||||
@@ -63,9 +63,9 @@ static struct _cfgfile {
|
||||
const char *name;
|
||||
int tool;
|
||||
} cfgfile[] = {
|
||||
@ -13,9 +13,9 @@ diff -up clamav-0.102.0/clamconf/clamconf.c.default_confs clamav-0.102.0/clamcon
|
||||
{NULL, 0}};
|
||||
|
||||
static void printopts(struct optstruct *opts, int nondef)
|
||||
diff -up clamav-0.102.0/docs/man/clamav-milter.8.in.default_confs clamav-0.102.0/docs/man/clamav-milter.8.in
|
||||
--- clamav-0.102.0/docs/man/clamav-milter.8.in.default_confs 2019-10-01 11:24:08.000000000 -0600
|
||||
+++ clamav-0.102.0/docs/man/clamav-milter.8.in 2019-10-11 20:46:32.218962904 -0600
|
||||
diff -up clamav-0.103.0/docs/man/clamav-milter.8.in.default_confs clamav-0.103.0/docs/man/clamav-milter.8.in
|
||||
--- clamav-0.103.0/docs/man/clamav-milter.8.in.default_confs 2020-09-12 18:27:09.000000000 -0600
|
||||
+++ clamav-0.103.0/docs/man/clamav-milter.8.in 2020-09-17 22:00:20.793879800 -0600
|
||||
@@ -27,7 +27,7 @@ Print the version number and exit.
|
||||
Read configuration from FILE.
|
||||
.SH "FILES"
|
||||
@ -25,9 +25,9 @@ diff -up clamav-0.102.0/docs/man/clamav-milter.8.in.default_confs clamav-0.102.0
|
||||
.SH "AUTHOR"
|
||||
.LP
|
||||
aCaB <acab@clamav.net>
|
||||
diff -up clamav-0.102.0/docs/man/clamav-milter.conf.5.in.default_confs clamav-0.102.0/docs/man/clamav-milter.conf.5.in
|
||||
--- clamav-0.102.0/docs/man/clamav-milter.conf.5.in.default_confs 2019-10-01 11:24:08.000000000 -0600
|
||||
+++ clamav-0.102.0/docs/man/clamav-milter.conf.5.in 2019-10-11 20:46:32.218962904 -0600
|
||||
diff -up clamav-0.103.0/docs/man/clamav-milter.conf.5.in.default_confs clamav-0.103.0/docs/man/clamav-milter.conf.5.in
|
||||
--- clamav-0.103.0/docs/man/clamav-milter.conf.5.in.default_confs 2020-09-12 18:27:09.000000000 -0600
|
||||
+++ clamav-0.103.0/docs/man/clamav-milter.conf.5.in 2020-09-17 22:00:20.794879808 -0600
|
||||
@@ -239,7 +239,7 @@ Default: no
|
||||
All options expressing a size are limited to max 4GB. Values in excess will be reset to the maximum.
|
||||
.SH "FILES"
|
||||
@ -37,9 +37,9 @@ diff -up clamav-0.102.0/docs/man/clamav-milter.conf.5.in.default_confs clamav-0.
|
||||
.SH "AUTHOR"
|
||||
.LP
|
||||
aCaB <acab@clamav.net>
|
||||
diff -up clamav-0.102.0/docs/man/clamd.8.in.default_confs clamav-0.102.0/docs/man/clamd.8.in
|
||||
--- clamav-0.102.0/docs/man/clamd.8.in.default_confs 2019-10-01 11:24:08.000000000 -0600
|
||||
+++ clamav-0.102.0/docs/man/clamd.8.in 2019-10-11 20:46:32.220962914 -0600
|
||||
diff -up clamav-0.103.0/docs/man/clamd.8.in.default_confs clamav-0.103.0/docs/man/clamd.8.in
|
||||
--- clamav-0.103.0/docs/man/clamd.8.in.default_confs 2020-09-12 18:27:09.000000000 -0600
|
||||
+++ clamav-0.103.0/docs/man/clamd.8.in 2020-09-17 22:00:20.794879808 -0600
|
||||
@@ -7,7 +7,7 @@ clamd \- an anti\-virus daemon
|
||||
clamd [options]
|
||||
.SH "DESCRIPTION"
|
||||
@ -58,30 +58,30 @@ diff -up clamav-0.102.0/docs/man/clamd.8.in.default_confs clamav-0.102.0/docs/ma
|
||||
.SH "CREDITS"
|
||||
Please check the full documentation for credits.
|
||||
.SH "AUTHOR"
|
||||
diff -up clamav-0.102.0/docs/man/clamd.conf.5.in.default_confs clamav-0.102.0/docs/man/clamd.conf.5.in
|
||||
--- clamav-0.102.0/docs/man/clamd.conf.5.in.default_confs 2019-10-01 11:24:08.000000000 -0600
|
||||
+++ clamav-0.102.0/docs/man/clamd.conf.5.in 2019-10-11 20:46:32.219962909 -0600
|
||||
@@ -742,7 +742,7 @@ Default: no
|
||||
diff -up clamav-0.103.0/docs/man/clamd.conf.5.in.default_confs clamav-0.103.0/docs/man/clamd.conf.5.in
|
||||
--- clamav-0.103.0/docs/man/clamd.conf.5.in.default_confs 2020-09-17 22:00:20.795879816 -0600
|
||||
+++ clamav-0.103.0/docs/man/clamd.conf.5.in 2020-09-17 22:01:21.414353121 -0600
|
||||
@@ -759,7 +759,7 @@ Default: no
|
||||
All options expressing a size are limited to max 4GB. Values in excess will be reset to the maximum.
|
||||
.SH "FILES"
|
||||
.LP
|
||||
.LP
|
||||
-@CFGDIR@/clamd.conf
|
||||
+@CFGDIR@/clamd.d/scan.conf
|
||||
.SH "AUTHORS"
|
||||
.LP
|
||||
.LP
|
||||
Tomasz Kojm <tkojm@clamav.net>, Kevin Lin <klin@sourcefire.com>
|
||||
diff -up clamav-0.102.0/platform.h.in.default_confs clamav-0.102.0/platform.h.in
|
||||
--- clamav-0.102.0/platform.h.in.default_confs 2019-10-01 11:24:09.000000000 -0600
|
||||
+++ clamav-0.102.0/platform.h.in 2019-10-11 20:46:32.217962899 -0600
|
||||
@@ -34,9 +34,9 @@ typedef unsigned int in_addr_t;
|
||||
#define PATHSEP "/"
|
||||
diff -up clamav-0.103.0/platform.h.in.default_confs clamav-0.103.0/platform.h.in
|
||||
--- clamav-0.103.0/platform.h.in.default_confs 2020-09-17 22:00:20.796879824 -0600
|
||||
+++ clamav-0.103.0/platform.h.in 2020-09-17 22:01:56.842629739 -0600
|
||||
@@ -112,9 +112,9 @@ typedef unsigned int in_addr_t;
|
||||
#endif
|
||||
|
||||
#ifndef _WIN32
|
||||
-#define CONFDIR_CLAMD CONFDIR PATHSEP "clamd.conf"
|
||||
+#define CONFDIR_CLAMD CONFDIR PATHSEP "clamd.d/scan.conf"
|
||||
#define CONFDIR_FRESHCLAM CONFDIR PATHSEP "freshclam.conf"
|
||||
-#define CONFDIR_MILTER CONFDIR PATHSEP "clamav-milter.conf"
|
||||
+#define CONFDIR_MILTER CONFDIR PATHSEP "mail/clamav-milter.conf"
|
||||
#endif
|
||||
|
||||
#define cli_to_utf8_maybe_alloc(x) (x)
|
||||
#define cli_strdup_to_utf8(x) strdup(x)
|
||||
#ifndef WORDS_BIGENDIAN
|
||||
|
11
clamav.spec
11
clamav.spec
@ -40,8 +40,8 @@
|
||||
|
||||
Summary: End-user tools for the Clam Antivirus scanner
|
||||
Name: clamav
|
||||
Version: 0.102.4
|
||||
Release: 2%{?dist}
|
||||
Version: 0.103.0
|
||||
Release: 1%{?dist}
|
||||
License: %{?with_unrar:proprietary}%{!?with_unrar:GPLv2}
|
||||
URL: https://www.clamav.net/
|
||||
%if %{with unrar}
|
||||
@ -91,6 +91,9 @@ Patch1: clamav-default_confs.patch
|
||||
Patch2: clamav-0.99-private.patch
|
||||
# Patch to use EL7 libcurl
|
||||
Patch3: clamav-curl.patch
|
||||
# Fix ck_assert_msg() call
|
||||
# https://github.com/Cisco-Talos/clamav-devel/pull/138
|
||||
Patch4: clamav-check.patch
|
||||
|
||||
BuildRequires: autoconf automake gettext-devel libtool libtool-ltdl-devel
|
||||
BuildRequires: gcc-c++
|
||||
@ -253,6 +256,7 @@ This package contains files which are needed to run the clamav-milter.
|
||||
%patch2 -p1 -b .private
|
||||
# Patch to use older libcurl
|
||||
%{?el7:%patch3 -p1 -b .curl}
|
||||
%patch4 -p1 -b .check
|
||||
|
||||
install -p -m0644 %SOURCE300 clamav-milter/
|
||||
|
||||
@ -617,6 +621,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Sep 17 2020 Orion Poplawski <orion@nwra.com> - 0.103.0-1
|
||||
- Update to 0.103.0
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.102.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
5
sources
5
sources
@ -1,4 +1 @@
|
||||
SHA512 (clamav-0.102.4-norar.tar.xz) = 202bf77edac1c6880b51981ef2508b90b935f9da62d235620ca457eaaa613ef3f1ac48ea3908f53bbc1a10cf204d9973cbe447cb2d96c1724b68eb3ef8cf4b80
|
||||
SHA512 (bytecode-331.cvd) = 41957106337cb28fd0eb6459bd70ab23b4ce218b3691d592e0f1bc14841696b36b1fbbc4feaef64f7b572b6cbe400f5d44fc4efedd07afe37921a9044a1a8f53
|
||||
SHA512 (daily-25876.cvd) = dd3ae3b1a95976014adeacf63574b7662212668676b0fc6a6d6f52bbb3c576e0c6e1188d6e8431ddd8da787e71de6d2e5ac25cfce9e824f41d7c271f16bcba9d
|
||||
SHA512 (main-59.cvd) = c01792bdb9e07889af04ead91ba49f440cd4510b81b1c83bdfb10c65f099cf29416699f5485cc13b07c4d24195c81abc0b1c4439f5ba6d5d391b7406ba9fe26c
|
||||
SHA512 (clamav-0.103.0-norar.tar.xz) = e1eaa9efc4e5156dd9ebec72f1ddfd55d230596157ca91bf2ea93ee198ebaf24da601a7478c11b67147a9e7c0eb469cc3acd6ef6be339f114554f994af87bb0a
|
||||
|
Loading…
Reference in New Issue
Block a user