Upgrade to 0.99 and updated daily.cvd (#1287327)
This commit is contained in:
parent
daca419a0a
commit
9815683656
@ -1,33 +0,0 @@
|
||||
Index: clamav-0.97.2/libclamav.pc.in
|
||||
===================================================================
|
||||
--- clamav-0.97.2.orig/libclamav.pc.in
|
||||
+++ clamav-0.97.2/libclamav.pc.in
|
||||
@@ -6,6 +6,7 @@ includedir=@includedir@
|
||||
Name: libclamav
|
||||
Description: A GPL virus scanner
|
||||
Version: @PACKAGE_VERSION@
|
||||
-Libs: -L${libdir} -lclamav @LIBCLAMAV_LIBS@
|
||||
-Cflags: -I${includedir} @CFLAGS@
|
||||
+Libs: -L${libdir} -lclamav
|
||||
+Libs.private: -L${libdir} -lclamav @LIBCLAMAV_LIBS@
|
||||
+Cflags: -I${includedir}
|
||||
|
||||
Index: clamav-0.97.2/clamav-config.in
|
||||
===================================================================
|
||||
--- clamav-0.97.2.orig/clamav-config.in
|
||||
+++ clamav-0.97.2/clamav-config.in
|
||||
@@ -54,12 +54,8 @@ while test $# -gt 0; do
|
||||
usage 0
|
||||
;;
|
||||
|
||||
- --cflags)
|
||||
- echo -I@includedir@ @CFLAGS@
|
||||
- ;;
|
||||
-
|
||||
- --libs)
|
||||
- echo -L@libdir@ @LIBCLAMAV_LIBS@
|
||||
+ (--cflags|--libs)
|
||||
+ ${PKG_CONFIG:-pkg-config} "$1" libclamav
|
||||
;;
|
||||
|
||||
*)
|
@ -1,6 +1,6 @@
|
||||
--- clamav-0.98.6/etc/clamd.conf.sample 2014-05-06 20:39:56.000000000 +0200
|
||||
+++ clamav-0.98.6/etc/clamd.conf.sample.jitoff 2014-05-10 22:20:49.000000000 +0200
|
||||
@@ -564,6 +564,16 @@
|
||||
--- clamav-0.99/etc/clamd.conf.sample 2015-11-24 00:13:46.000000000 +0100
|
||||
+++ clamav-0.99/etc/clamd.conf.sample.jitoff 2015-12-02 01:36:11.766462183 +0100
|
||||
@@ -614,6 +614,16 @@
|
||||
# Default: yes
|
||||
#Bytecode yes
|
||||
|
||||
@ -17,9 +17,9 @@
|
||||
# Set bytecode security level.
|
||||
# Possible values:
|
||||
# None - no security at all, meant for debugging. DO NOT USE THIS ON PRODUCTION SYSTEMS
|
||||
--- clamav-0.98.6/shared/optparser.c 2015-01-29 21:28:10.024678857 +0100
|
||||
+++ clamav-0.98.6/shared/optparser.c.jitoff 2015-01-29 21:29:11.676195061 +0100
|
||||
@@ -294,7 +294,7 @@
|
||||
--- clamav-0.99/shared/optparser.c 2015-12-02 01:35:26.632828082 +0100
|
||||
+++ clamav-0.99/shared/optparser.c.jitoff 2015-12-02 01:36:54.249117737 +0100
|
||||
@@ -298,7 +298,7 @@
|
||||
{ "BytecodeUnsigned", "bytecode-unsigned", 0, CLOPT_TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMD | OPT_CLAMSCAN,
|
||||
"Allow loading bytecode from outside digitally signed .c[lv]d files.","no"},
|
||||
|
||||
@ -27,4 +27,4 @@
|
||||
+ { "BytecodeMode", "bytecode-mode", 0, CLOPT_TYPE_STRING, "^(Auto|ForceJIT|ForceInterpreter|Test)$", -1, "ForceInterpreter", FLAG_REQUIRED, OPT_CLAMD | OPT_CLAMSCAN,
|
||||
"Set bytecode execution mode.\nPossible values:\n\tAuto - automatically choose JIT if possible, fallback to interpreter\nForceJIT - always choose JIT, fail if not possible\nForceInterpreter - always choose interpreter\nTest - run with both JIT and interpreter and compare results. Make all failures fatal.","Auto"},
|
||||
|
||||
{ "BytecodeStatistics", "bytecode-statistics", 0, CLOPT_TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMSCAN | OPT_CLAMBC, "Collect and print bytecode execution statistics.", "no" },
|
||||
{ "Statistics", "statistics", 0, CLOPT_TYPE_STRING, "^(none|None|bytecode|Bytecode|pcre|PCRE)$", -1, NULL, FLAG_MULTIPLE, OPT_CLAMSCAN | OPT_CLAMBC, "Collect and print execution statistics.\nPossible values:\n\tBytecode - reports bytecode statistics\nPCRE - reports PCRE execution statistics\nNone - reports no statistics", "None" },
|
27
clamav-0.99-private.patch
Normal file
27
clamav-0.99-private.patch
Normal file
@ -0,0 +1,27 @@
|
||||
--- clamav-0.99/libclamav.pc.in 2015-09-18 22:48:25.000000000 +0200
|
||||
+++ clamav-0.99/libclamav.pc.in.private 2015-12-02 01:30:30.055231319 +0100
|
||||
@@ -7,6 +7,6 @@
|
||||
Description: A GPL virus scanner
|
||||
Version: @PACKAGE_VERSION@
|
||||
Libs: -L${libdir} -lclamav
|
||||
-Libs.private: @LIBCLAMAV_LIBS@
|
||||
+Libs.private: -L${libdir} -lclamav @LIBCLAMAV_LIBS@
|
||||
Cflags: -I${includedir}
|
||||
|
||||
--- clamav-0.99/clamav-config.in 2015-05-28 23:56:25.000000000 +0200
|
||||
+++ clamav-0.99/clamav-config.in.private 2015-12-02 01:31:34.933705763 +0100
|
||||
@@ -54,12 +54,8 @@
|
||||
usage 0
|
||||
;;
|
||||
|
||||
- --cflags)
|
||||
- echo -I@includedir@ @CFLAGS@
|
||||
- ;;
|
||||
-
|
||||
- --libs)
|
||||
- echo -L@libdir@ @LIBCLAMAV_LIBS@
|
||||
+ (--cflags|--libs)
|
||||
+ ${PKG_CONFIG:-pkg-config} "$1" libclamav
|
||||
;;
|
||||
|
||||
*)
|
13
clamav.spec
13
clamav.spec
@ -57,8 +57,8 @@ Requires(postun): /bin/systemctl\
|
||||
|
||||
Summary: End-user tools for the Clam Antivirus scanner
|
||||
Name: clamav
|
||||
Version: 0.98.7
|
||||
Release: 3%{?dist}
|
||||
Version: 0.99
|
||||
Release: 1%{?dist}
|
||||
License: %{?with_unrar:proprietary}%{!?with_unrar:GPLv2}
|
||||
Group: Applications/File
|
||||
URL: http://www.clamav.net
|
||||
@ -75,13 +75,13 @@ Source0: %name-%version%{?prerelease}-norar.tar.xz
|
||||
# To download the *.cvd, go to http://www.clamav.net and use the links
|
||||
# there (I renamed the files to add the -version suffix for verifying).
|
||||
Source10: http://db.local.clamav.net/main-55.cvd
|
||||
Source11: http://db.local.clamav.net/daily-20394.cvd
|
||||
Source11: http://db.local.clamav.net/daily-21123.cvd
|
||||
|
||||
Patch24: clamav-0.92-private.patch
|
||||
Patch24: clamav-0.99-private.patch
|
||||
Patch26: clamav-0.98.5-cliopts.patch
|
||||
Patch27: clamav-0.98-umask.patch
|
||||
# https://bugzilla.redhat.com/attachment.cgi?id=403775&action=diff&context=patch&collapsed=&headers=1&format=raw
|
||||
Patch29: clamav-0.98.6-jitoff.patch
|
||||
Patch29: clamav-0.99-jitoff.patch
|
||||
# https://llvm.org/viewvc/llvm-project/llvm/trunk/lib/ExecutionEngine/JIT/Intercept.cpp?r1=128086&r2=137567
|
||||
Patch30: llvm-glibc.patch
|
||||
BuildRoot: %_tmppath/%name-%version-%release-root
|
||||
@ -891,6 +891,9 @@ test "$1" != "0" || /sbin/initctl -q stop clamav-milter || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 02 2015 Robert Scheck <robert@fedoraproject.org> - 0.99-1
|
||||
- Upgrade to 0.99 and updated daily.cvd (#1287327)
|
||||
|
||||
* Tue Jun 30 2015 Robert Scheck <robert@fedoraproject.org> - 0.98.7-3
|
||||
- Move /etc/tmpfiles.d/ to /usr/lib/tmpfiles.d/ (#1126595)
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user