Update to 0.103.1
This commit is contained in:
parent
fc271e6c07
commit
873e1f3af7
@ -1,38 +0,0 @@
|
||||
From 2b46876dcccd95eeb329477ba6f413eb485703a8 Mon Sep 17 00:00:00 2001
|
||||
From: Emilio Pozuelo Monfort <pochu27@gmail.com>
|
||||
Date: Tue, 8 Dec 2020 22:49:11 -0800
|
||||
Subject: [PATCH] clamonacc: Fix stack buffer overflow with old curl
|
||||
|
||||
curl_easy_getinfo expects a long for CURLINFO_ACTIVESOCKET, but
|
||||
curl_socket_t is an int, which was causing a stack buffer overflow
|
||||
and crash.
|
||||
---
|
||||
clamonacc/client/communication.c | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/clamonacc/client/communication.c b/clamonacc/client/communication.c
|
||||
index 2af46aa15a..1d2e53c03e 100644
|
||||
--- a/clamonacc/client/communication.c
|
||||
+++ b/clamonacc/client/communication.c
|
||||
@@ -87,7 +87,9 @@ int onas_sendln(CURL *curl, const void *line, size_t len, int64_t timeout)
|
||||
curlcode = curl_easy_getinfo(curl, CURLINFO_ACTIVESOCKET, &sockfd);
|
||||
#else
|
||||
/* Use deprecated CURLINFO_LASTSOCKET option */
|
||||
- curlcode = curl_easy_getinfo(curl, CURLINFO_LASTSOCKET, &sockfd);
|
||||
+ long long_sockfd;
|
||||
+ curlcode = curl_easy_getinfo(curl, CURLINFO_LASTSOCKET, &long_sockfd);
|
||||
+ sockfd = (curl_socket_t) long_sockfd;
|
||||
#endif
|
||||
|
||||
if (CURLE_OK != curlcode) {
|
||||
@@ -152,7 +154,9 @@ int onas_recvln(struct onas_rcvln *rcv_data, char **ret_bol, char **ret_eol, int
|
||||
rcv_data->curlcode = curl_easy_getinfo(rcv_data->curl, CURLINFO_ACTIVESOCKET, &sockfd);
|
||||
#else
|
||||
/* Use deprecated CURLINFO_LASTSOCKET option */
|
||||
- rcv_data->curlcode = curl_easy_getinfo(rcv_data->curl, CURLINFO_LASTSOCKET, &sockfd);
|
||||
+ long long_sockfd;
|
||||
+ rcv_data->curlcode = curl_easy_getinfo(rcv_data->curl, CURLINFO_LASTSOCKET, &long_sockfd);
|
||||
+ sockfd = (curl_socket_t) long_sockfd;
|
||||
#endif
|
||||
|
||||
if (CURLE_OK != rcv_data->curlcode) {
|
@ -1,4 +1,4 @@
|
||||
VERSION=0.103.0
|
||||
VERSION=0.103.1
|
||||
NAME=clamav
|
||||
TARBALL_CLEAN=${NAME}-${VERSION}-norar.tar.xz
|
||||
TARBALL=${NAME}-${VERSION}.tar.gz
|
||||
|
11
clamav.spec
11
clamav.spec
@ -41,8 +41,8 @@
|
||||
|
||||
Summary: End-user tools for the Clam Antivirus scanner
|
||||
Name: clamav
|
||||
Version: 0.103.0
|
||||
Release: 3%{?dist}
|
||||
Version: 0.103.1
|
||||
Release: 1%{?dist}
|
||||
License: %{?with_unrar:proprietary}%{!?with_unrar:GPLv2}
|
||||
URL: https://www.clamav.net/
|
||||
%if %{with unrar}
|
||||
@ -65,7 +65,7 @@ Source5: clamd-README
|
||||
#http://database.clamav.net/main.cvd
|
||||
Source10: main-59.cvd
|
||||
#http://database.clamav.net/daily.cvd
|
||||
Source11: daily-25931.cvd
|
||||
Source11: daily-26082.cvd
|
||||
#http://database.clamav.net/bytecode.cvd
|
||||
Source12: bytecode-331.cvd
|
||||
#for update
|
||||
@ -93,7 +93,6 @@ Patch2: clamav-0.99-private.patch
|
||||
Patch4: clamav-check.patch
|
||||
# Modify clamav-clamonacc.service for Fedora compatibility
|
||||
Patch5: clamav-clamonacc-service.patch
|
||||
Patch6: https://github.com/Cisco-Talos/clamav-devel/commit/2b46876dcccd95eeb329477ba6f413eb485703a8.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -261,7 +260,6 @@ This package contains files which are needed to run the clamav-milter.
|
||||
%patch2 -p1 -b .private
|
||||
%patch4 -p1 -b .check
|
||||
%patch5 -p1 -b .clamonacc-service
|
||||
%patch6 -p1 -b .clamonacc-el7
|
||||
|
||||
install -p -m0644 %SOURCE300 clamav-milter/
|
||||
|
||||
@ -631,6 +629,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 17 2021 Sérgio Basto <sergio@serjux.com> - 0.103.1-1
|
||||
- Update to 0.103.1
|
||||
|
||||
* Wed Jan 27 2021 Sérgio Basto <sergio@serjux.com> - 0.103.0-3
|
||||
- Add upstream patch clamonacc: Fix stack buffer overflow with old curl
|
||||
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (clamav-0.103.0-norar.tar.xz) = e1eaa9efc4e5156dd9ebec72f1ddfd55d230596157ca91bf2ea93ee198ebaf24da601a7478c11b67147a9e7c0eb469cc3acd6ef6be339f114554f994af87bb0a
|
||||
SHA512 (clamav-0.103.1-norar.tar.xz) = a6732d40a706572cfea8484924af5b9211db13accddedf73738dc0ca0e6259d0612916302d30890b7c27c8fabe936f35c4a27c87bce027fd1f28b548df6b762f
|
||||
SHA512 (bytecode-331.cvd) = 41957106337cb28fd0eb6459bd70ab23b4ce218b3691d592e0f1bc14841696b36b1fbbc4feaef64f7b572b6cbe400f5d44fc4efedd07afe37921a9044a1a8f53
|
||||
SHA512 (daily-25931.cvd) = c63571e2e8e71346c0ed5573e91644e331cbfcfe955d543f6081ae2cb6a99f5ef2b4ddd10844c5d67facbd841566e87881ef27f515c329008b90e86b6a620fba
|
||||
SHA512 (daily-26082.cvd) = 1824397d5063e026e15f8a1e048234b75c819a99cd87050ba13256f638ca51a840ea81909decef07f1b9286c79ce310755305279fd57bfc6dbb8f9199172582c
|
||||
SHA512 (main-59.cvd) = c01792bdb9e07889af04ead91ba49f440cd4510b81b1c83bdfb10c65f099cf29416699f5485cc13b07c4d24195c81abc0b1c4439f5ba6d5d391b7406ba9fe26c
|
||||
|
Loading…
x
Reference in New Issue
Block a user