Upgrade to 0.100.0 (#1565381)
This commit is contained in:
parent
76a1c6b58e
commit
7b491c4ecf
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,5 +1,4 @@
|
||||
/clamav-*-norar.tar.xz
|
||||
/main*.cvd
|
||||
/daily*.cvd
|
||||
/bytecode-278.cvd
|
||||
/bytecode-319.cvd
|
||||
/bytecode*.cvd
|
||||
|
18
clamav-0.100.0-stats-deprecation.patch
Normal file
18
clamav-0.100.0-stats-deprecation.patch
Normal file
@ -0,0 +1,18 @@
|
||||
https://bugzilla.clamav.net/show_bug.cgi?id=12097
|
||||
|
||||
--- shared/optparser.c
|
||||
+++ shared/optparser.c
|
||||
@@ -505,6 +505,13 @@ const struct clam_option __clam_options[
|
||||
{ "ClamukoExcludeUID", NULL, 0, CLOPT_TYPE_NUMBER, MATCH_NUMBER, -1, NULL, FLAG_MULTIPLE, OPT_CLAMD | OPT_DEPRECATED, "", "" },
|
||||
{ "ClamukoMaxFileSize", NULL, 0, CLOPT_TYPE_SIZE, MATCH_SIZE, 5242880, NULL, 0, OPT_CLAMD | OPT_DEPRECATED, "", "" },
|
||||
{ "AllowSupplementaryGroups", NULL, 0, CLOPT_TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMD | OPT_FRESHCLAM | OPT_MILTER | OPT_DEPRECATED, "Initialize a supplementary group access (the process must be started by root).", "no" },
|
||||
+ { "StatsHostID", "stats-host-id", 0, CLOPT_TYPE_STRING, NULL, -1, NULL, 0, OPT_FRESHCLAM | OPT_CLAMD | OPT_CLAMSCAN | OPT_DEPRECATED, "", "" },
|
||||
+ { "StatsEnabled", "enable-stats", 0, CLOPT_TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMD | OPT_FRESHCLAM | OPT_CLAMSCAN | OPT_DEPRECATED, "", "" },
|
||||
+ { "StatsPEDisabled", "disable-pe-stats", 0, CLOPT_TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMD | OPT_CLAMSCAN | OPT_DEPRECATED, "", "" },
|
||||
+ { "StatsTimeout", "stats-timeout", 0, CLOPT_TYPE_NUMBER, MATCH_NUMBER, -1, NULL, 0, OPT_CLAMD | OPT_CLAMSCAN | OPT_FRESHCLAM | OPT_DEPRECATED, "", "" },
|
||||
+ { "SubmitDetectionStats", NULL, 0, CLOPT_TYPE_STRING, NULL, -1, NULL, 0, OPT_FRESHCLAM | OPT_DEPRECATED, "", "" },
|
||||
+ { "DetectionStatsCountry", NULL, 0, CLOPT_TYPE_STRING, NULL, -1, NULL, 0, OPT_FRESHCLAM | OPT_DEPRECATED, "", "" },
|
||||
+ { "DetectionStatsHostID", NULL, 0, CLOPT_TYPE_STRING, NULL, -1, NULL, 0, OPT_FRESHCLAM | OPT_DEPRECATED, "", "" },
|
||||
|
||||
/* Milter specific options */
|
||||
|
33
clamav-0.100.0-umask.patch
Normal file
33
clamav-0.100.0-umask.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- clamav-0.100.0/clamav-milter/clamav-milter.c 2018-04-04 02:13:58.000000000 +0200
|
||||
+++ clamav-0.100.0/clamav-milter/clamav-milter.c.umask 2018-05-28 23:25:12.374047156 +0200
|
||||
@@ -432,7 +432,7 @@
|
||||
|
||||
if((opt = optget(opts, "PidFile"))->enabled) {
|
||||
FILE *fd;
|
||||
- mode_t old_umask = umask(0002);
|
||||
+ mode_t old_umask = umask(0022);
|
||||
|
||||
if((fd = fopen(opt->strarg, "w")) == NULL) {
|
||||
logg("!Can't save PID in file %s\n", opt->strarg);
|
||||
--- clamav-0.100.0/shared/output.c 2018-04-04 02:13:58.000000000 +0200
|
||||
+++ clamav-0.100.0/shared/output.c.umask 2018-05-28 23:24:41.968851516 +0200
|
||||
@@ -379,7 +379,7 @@
|
||||
|
||||
if (!logg_fp && logg_file)
|
||||
{
|
||||
- old_umask = umask(0037);
|
||||
+ old_umask = umask(0077);
|
||||
if ((logg_fp = fopen(logg_file, "at")) == NULL)
|
||||
{
|
||||
umask(old_umask);
|
||||
--- clamav-0.100.0/freshclam/freshclam.c 2018-04-04 02:13:58.000000000 +0200
|
||||
+++ clamav-0.100.0/freshclam/freshclam.c.umask 2018-05-28 23:25:30.675164850 +0200
|
||||
@@ -127,7 +127,7 @@
|
||||
{
|
||||
FILE *fd;
|
||||
int old_umask;
|
||||
- old_umask = umask (0006);
|
||||
+ old_umask = umask (0022);
|
||||
if ((fd = fopen (pidfile, "w")) == NULL)
|
||||
{
|
||||
logg ("!Can't save PID to file %s: %s\n", pidfile, strerror (errno));
|
@ -1,33 +0,0 @@
|
||||
--- clamav-0.98/clamav-milter/clamav-milter.c 2013-09-16 21:28:14.000000000 +0200
|
||||
+++ clamav-0.98/clamav-milter/clamav-milter.c.umask 2013-10-06 20:39:08.000000000 +0200
|
||||
@@ -374,7 +374,7 @@
|
||||
|
||||
if((opt = optget(opts, "PidFile"))->enabled) {
|
||||
FILE *fd;
|
||||
- mode_t old_umask = umask(0002);
|
||||
+ mode_t old_umask = umask(0022);
|
||||
|
||||
if((fd = fopen(opt->strarg, "w")) == NULL) {
|
||||
logg("!Can't save PID in file %s\n", opt->strarg);
|
||||
--- clamav-0.98/shared/output.c 2013-09-16 21:28:14.000000000 +0200
|
||||
+++ clamav-0.98/shared/output.c.umask 2013-10-06 20:39:28.000000000 +0200
|
||||
@@ -348,7 +348,7 @@
|
||||
logg_open();
|
||||
|
||||
if(!logg_fp && logg_file) {
|
||||
- old_umask = umask(0037);
|
||||
+ old_umask = umask(0077);
|
||||
if((logg_fp = fopen(logg_file, "at")) == NULL) {
|
||||
umask(old_umask);
|
||||
#ifdef CL_THREAD_SAFE
|
||||
--- clamav-0.98/freshclam/freshclam.c 2013-09-16 21:28:14.000000000 +0200
|
||||
+++ clamav-0.98/freshclam/freshclam.c.umask 2013-10-06 20:39:47.000000000 +0200
|
||||
@@ -123,7 +123,7 @@
|
||||
{
|
||||
FILE *fd;
|
||||
int old_umask;
|
||||
- old_umask = umask (0006);
|
||||
+ old_umask = umask (0022);
|
||||
if ((fd = fopen (pidfile, "w")) == NULL)
|
||||
{
|
||||
logg ("!Can't save PID to file %s: %s\n", pidfile, strerror (errno));
|
25
clamav.spec
25
clamav.spec
@ -61,14 +61,14 @@
|
||||
|
||||
Summary: End-user tools for the Clam Antivirus scanner
|
||||
Name: clamav
|
||||
Version: 0.99.4
|
||||
Release: 3%{?dist}
|
||||
Version: 0.100.0
|
||||
Release: 1%{?dist}
|
||||
License: %{?with_unrar:proprietary}%{!?with_unrar:GPLv2}
|
||||
Group: Applications/File
|
||||
URL: http://www.clamav.net
|
||||
URL: https://www.clamav.net/
|
||||
%if %{with unrar}
|
||||
Source0: http://www.clamav.net/downloads/production/%name-%version%{?prerelease}.tar.gz
|
||||
Source999: http://www.clamav.net/downloads/production/%name-%version%{?prerelease}.tar.gz.sig
|
||||
Source0: https://www.clamav.net/downloads/production/%name-%version%{?prerelease}.tar.gz
|
||||
Source999: https://www.clamav.net/downloads/production/%name-%version%{?prerelease}.tar.gz.sig
|
||||
%else
|
||||
# Unfortunately, clamav includes support for RAR v3, derived from GPL
|
||||
# incompatible unrar from RARlabs. We have to pull this code out.
|
||||
@ -81,12 +81,12 @@ Source2: clamd.sysconfig
|
||||
Source3: clamd.logrotate
|
||||
Source5: clamd-README
|
||||
Source7: clamd.SERVICE.init
|
||||
# To download the *.cvd, go to http://www.clamav.net and use the links
|
||||
# To download the *.cvd, go to https://www.clamav.net and use the links
|
||||
# there (I renamed the files to add the -version suffix for verifying).
|
||||
# Check the first line of the file for version, file is not working
|
||||
# see https://bugzilla.redhat.com/show_bug.cgi?id=1539107
|
||||
Source10: http://db.local.clamav.net/main-58.cvd
|
||||
Source11: http://db.local.clamav.net/daily-24356.cvd
|
||||
Source11: http://db.local.clamav.net/daily-24611.cvd
|
||||
Source12: http://db.local.clamav.net/bytecode-319.cvd
|
||||
#for devel
|
||||
Source100: clamd-gen
|
||||
@ -112,15 +112,16 @@ Source520: clamd-wrapper
|
||||
#for server-systemd
|
||||
Source530: clamd@.service
|
||||
|
||||
Patch0: clamav-0.100.0-stats-deprecation.patch
|
||||
Patch24: clamav-0.99-private.patch
|
||||
Patch27: clamav-0.98-umask.patch
|
||||
Patch27: clamav-0.100.0-umask.patch
|
||||
# https://llvm.org/viewvc/llvm-project/llvm/trunk/lib/ExecutionEngine/JIT/Intercept.cpp?r1=128086&r2=137567
|
||||
Patch30: llvm-glibc.patch
|
||||
Patch31: clamav-0.99.1-setsebool.patch
|
||||
|
||||
|
||||
BuildRequires: autoconf automake gettext-devel libtool libtool-ltdl-devel
|
||||
BuildRequires: zlib-devel bzip2-devel gmp-devel curl-devel
|
||||
BuildRequires: zlib-devel bzip2-devel gmp-devel curl-devel json-c-devel
|
||||
BuildRequires: ncurses-devel openssl-devel libxml2-devel
|
||||
BuildRequires: pcre2-devel
|
||||
#BuildRequires: %_includedir/tcpd.h
|
||||
@ -170,6 +171,7 @@ user-creation scripts required by clamav.
|
||||
Summary: Dynamic libraries for the Clam Antivirus scanner
|
||||
Group: System Environment/Libraries
|
||||
Requires: data(clamav)
|
||||
Provides: bundled(libmspack) = 0.5-0.1.alpha.modified_by_clamav
|
||||
|
||||
%description lib
|
||||
This package contains dynamic libraries shared between applications
|
||||
@ -358,6 +360,7 @@ This package contains files which are needed to run the clamav-milter.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?prerelease}
|
||||
|
||||
%apply -n0 -p0 -b .stats-deprecation
|
||||
%apply -n24 -p1 -b .private
|
||||
%apply -n27 -p1 -b .umask
|
||||
%apply -n30 -p1
|
||||
@ -690,7 +693,6 @@ test "$1" = 0 || %_initrddir/clamav-milter condrestart >/dev/null || :
|
||||
|
||||
|
||||
%files
|
||||
%doc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README UPGRADE
|
||||
%doc docs/*.pdf
|
||||
%_bindir/*
|
||||
%_mandir/man[15]/*
|
||||
@ -814,6 +816,9 @@ test "$1" = 0 || %_initrddir/clamav-milter condrestart >/dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon May 28 2018 Robert Scheck <robert@fedoraproject.org> - 0.100.0-1
|
||||
- Upgrade to 0.100.0 (#1565381)
|
||||
|
||||
* Wed Mar 21 2018 Sérgio Basto <sergio@serjux.com> - 0.99.4-3
|
||||
- Fix data-empty sub-package (ghost the correct files)
|
||||
- Add Obsoletes systemd sub-packages
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (clamav-0.99.4-norar.tar.xz) = c947d4626b210fe92bf6b287b038c4af26346f5e392d4a5b6c5e535fa805c0f72b38875fe87960539d4b859bf9fd478ce798fc6b33f44b94ee23ee7c430932a9
|
||||
SHA512 (clamav-0.100.0-norar.tar.xz) = ecb6602f746f570481cf8df396fe60853be73b0b01adff17a6ef50a1db285f1f26947a9d63981631b6f809188e4752632fba148ef77c46be6a7d4480b12a2649
|
||||
SHA512 (bytecode-319.cvd) = 1b2785fde078e0dae5a4b8a5161a0da55b26b010deda9fd9dc5edb7113d46d6eb45f644c16b4cb3882e7192d0b389d7b1826fbb718377aa40e1bac3485829acc
|
||||
SHA512 (daily-24356.cvd) = 0550e4d136189dfd6fd78e027fb81713530abeaee47d48a678ed4a521114cae87fc0500a0f8eaa7e4ba1f8ed8ecd5159f96cd0b62eac92491acfcc01f9277973
|
||||
SHA512 (daily-24611.cvd) = 109bca93329b5be740f4e3916dcf5c2f01b99593711a55ed9502e764d3b7aefab8735d05864749ae5a133b32f2f9112f56dfdea4fbadc6cfd945c7f3fd2bd2da
|
||||
SHA512 (main-58.cvd) = 71309a7ea26f0fbfe329252c728173c895b107b7ea2e0bd613b12475db1d0270a496d707c4d80c842bf8b6f21680e86edfa7fa3b8aea075e93d67c91d696603a
|
||||
|
Loading…
Reference in New Issue
Block a user