- Upgrade to 0.98.3 and updated daily.cvd (#1095614)

- Avoid automatic path detection breakage regarding curl
- Added build requirement to openssl-devel for hasing code
- Added clamsubmit to main package
This commit is contained in:
Robert Scheck 2014-05-10 23:17:17 +02:00
parent 1f72798844
commit 07c7f28670
4 changed files with 21 additions and 113 deletions

View File

@ -1,95 +0,0 @@
From 4cd8ed07d0313bca37b01064208eafa842f1a169 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 9 Oct 2013 12:17:30 +0200
Subject: [PATCH] switch to glibc functions for fanotify
Switch to glibc functions for fanotify instead of using the incomplete
hand-crafted support. It makes possible to build clamav on non-x86
Linux architectures.
---
clamd/fan-syscalllib.h | 28 ----------------------------
clamd/fan.c | 3 +--
configure | 4 ++--
configure.ac | 2 +-
4 files changed, 4 insertions(+), 33 deletions(-)
delete mode 100644 clamd/fan-syscalllib.h
diff --git a/clamd/fan-syscalllib.h b/clamd/fan-syscalllib.h
deleted file mode 100644
index 288cd99..0000000
--- a/clamd/fan-syscalllib.h
+++ /dev/null
@@ -1,28 +0,0 @@
-#ifndef __FANOTIFY_SYSCALL_LIB
-#define __FANOTIFY_SYSCALL_LIB
-
-#include <unistd.h>
-#include <linux/types.h>
-
-#if defined(__x86_64__)
-# define __NR_fanotify_init 300
-# define __NR_fanotify_mark 301
-#elif defined(__i386__)
-# define __NR_fanotify_init 338
-# define __NR_fanotify_mark 339
-#else
-# error "System call numbers not defined for this architecture"
-#endif
-
-static inline int fanotify_init(unsigned int flags, unsigned int event_f_flags)
-{
- return syscall(__NR_fanotify_init, flags, event_f_flags);
-}
-
-static inline int fanotify_mark(int fanotify_fd, unsigned int flags, __u64 mask,
- int dfd, const char *pathname)
-{
- return syscall(__NR_fanotify_mark, fanotify_fd, flags, mask,
- dfd, pathname);
-}
-#endif
diff --git a/clamd/fan.c b/clamd/fan.c
index 303f52e..66d2932 100644
--- a/clamd/fan.c
+++ b/clamd/fan.c
@@ -34,8 +34,7 @@
#include <string.h>
#include <errno.h>
-#include <linux/fanotify.h>
-#include "fan-syscalllib.h"
+#include <sys/fanotify.h>
#include "fan.h"
#include "libclamav/clamav.h"
diff --git a/configure b/configure
index a570707..b75e740 100755
--- a/configure
+++ b/configure
@@ -17840,8 +17840,8 @@ $as_echo "#define C_LINUX 1" >>confdefs.h
THREAD_LIBS="-lpthread"
TH_SAFE="-thread-safe"
if test "$want_fanotify" = "yes"; then
- ac_fn_c_check_header_mongrel "$LINENO" "linux/fanotify.h" "ac_cv_header_linux_fanotify_h" "$ac_includes_default"
-if test "x$ac_cv_header_linux_fanotify_h" = xyes; then :
+ ac_fn_c_check_header_mongrel "$LINENO" "sys/fanotify.h" "ac_cv_header_sys_fanotify_h" "$ac_includes_default"
+if test "x$ac_cv_header_sys_fanotify_h" = xyes; then :
$as_echo "#define FANOTIFY 1" >>confdefs.h
diff --git a/configure.ac b/configure.ac
index 8ea9dac..4dba8f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1001,7 +1001,7 @@ linux*)
THREAD_LIBS="-lpthread"
TH_SAFE="-thread-safe"
if test "$want_fanotify" = "yes"; then
- AC_CHECK_HEADER([linux/fanotify.h],AC_DEFINE([FANOTIFY],1,[use fanotify]),)
+ AC_CHECK_HEADER([sys/fanotify.h],AC_DEFINE([FANOTIFY],1,[use fanotify]),)
fi
fi
;;
--
1.8.1.4

View File

@ -1,6 +1,6 @@
--- clamav-0.98/etc/clamd.conf.sample 2013-09-16 21:28:14.000000000 +0200
+++ clamav-0.98/etc/clamd.conf.sample.jitoff 2013-10-06 20:46:59.000000000 +0200
@@ -543,6 +543,16 @@
--- clamav-0.98.3/etc/clamd.conf.sample 2014-05-06 20:39:56.000000000 +0200
+++ clamav-0.98.3/etc/clamd.conf.sample.jitoff 2014-05-10 22:20:49.000000000 +0200
@@ -564,6 +564,16 @@
# Default: yes
#Bytecode yes
@ -17,9 +17,9 @@
# Set bytecode security level.
# Possible values:
# None - no security at all, meant for debugging. DO NOT USE THIS ON PRODUCTION SYSTEMS
--- clamav-0.98/shared/optparser.c 2013-09-16 21:28:14.000000000 +0200
+++ clamav-0.98/shared/optparser.c.jitoff 2013-10-06 20:46:12.000000000 +0200
@@ -277,7 +277,7 @@
--- clamav-0.98.3/shared/optparser.c 2014-05-06 20:42:41.000000000 +0200
+++ clamav-0.98.3/shared/optparser.c.jitoff 2014-05-10 22:21:27.000000000 +0200
@@ -295,7 +295,7 @@
{ "BytecodeUnsigned", "bytecode-unsigned", 0, TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMD | OPT_CLAMSCAN,
"Allow loading bytecode from outside digitally signed .c[lv]d files.","no"},
@ -27,4 +27,4 @@
+ { "BytecodeMode", "bytecode-mode", 0, TYPE_STRING, "^(Auto|ForceJIT|ForceInterpreter|Test)$", -1, "ForceInterpreter", FLAG_REQUIRED, OPT_CLAMD | OPT_CLAMSCAN,
"Set bytecode execution mode.\nPossible values:\n\tAuto - automatically choose JIT if possible, fallback to interpreter\nForceJIT - always choose JIT, fail if not possible\nForceIntepreter - always choose interpreter\nTest - run with both JIT and interpreter and compare results. Make all failures fatal.","Auto"},
{ "BytecodeStatistics", "bytecode-statistics", 0, TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMSCAN, "Collect and print bytecode execution statistics.", "no" },
{ "BytecodeStatistics", "bytecode-statistics", 0, TYPE_BOOL, MATCH_BOOL, 0, NULL, 0, OPT_CLAMSCAN | OPT_CLAMBC, "Collect and print bytecode execution statistics.", "no" },

View File

@ -52,7 +52,7 @@ Requires(postun): /bin/systemctl\
Summary: End-user tools for the Clam Antivirus scanner
Name: clamav
Version: 0.98.1
Version: 0.98.3
Release: 1%{?dist}
License: %{?with_unrar:proprietary}%{!?with_unrar:GPLv2}
Group: Applications/File
@ -64,29 +64,26 @@ Source999: http://download.sourceforge.net/sourceforge/clamav/%name-%version%{?p
# Unfortunately, clamav includes support for RAR v3, derived from GPL
# incompatible unrar from RARlabs. We have to pull this code out.
# tarball was created by
# make clean-sources [TARBALL=<original-tarball>] [VERSION=<version>]
# make clean-sources NAME=clamav VERSION=<version> TARBALL=clamav-<version>.tar.gz TARBALL_CLEAN=clamav-<version>-norar.tar.xz
Source0: %name-%version%{?prerelease}-norar.tar.xz
%endif
# To download the *.cvd, go to http://www.clamav.net and use the links
# there (I renamed the files to add the -version suffix for verifying).
Source10: http://db.local.clamav.net/main-55.cvd
Source11: http://db.local.clamav.net/daily-18353.cvd
Source11: http://db.local.clamav.net/daily-18354.cvd
Patch24: clamav-0.92-private.patch
Patch26: clamav-0.98-cliopts.patch
Patch27: clamav-0.98-umask.patch
# https://bugzilla.redhat.com/attachment.cgi?id=403775&action=diff&context=patch&collapsed=&headers=1&format=raw
Patch29: clamav-0.98-jitoff.patch
Patch29: clamav-0.98.3-jitoff.patch
# https://llvm.org/viewvc/llvm-project/llvm/trunk/lib/ExecutionEngine/JIT/Intercept.cpp?r1=128086&r2=137567
Patch30: llvm-glibc.patch
# use glibc fanotify instead of limited hand-crafted support
# https://bugzilla.clamav.net/show_bug.cgi?id=9156
Patch31: clamav-0.98-glibc-fanotify.patch
BuildRoot: %_tmppath/%name-%version-%release-root
Requires: clamav-lib = %version-%release
Requires: data(clamav)
BuildRequires: zlib-devel bzip2-devel gmp-devel curl-devel
BuildRequires: ncurses-devel
BuildRequires: ncurses-devel openssl-devel
BuildRequires: %_includedir/tcpd.h
%{?with_bytecode:BuildRequires: bc tcl groff graphviz}
%if %{have_ocaml}
@ -395,7 +392,6 @@ The systemd initscripts for clamav-scanner.
%apply -n27 -p1 -b .umask
%apply -n29 -p1 -b .jitoff
%apply -n30 -p1
%apply -n31 -p1 -b .glibc-fanotify
%{?apply_end}
install -p -m0644 %SOURCE300 clamav-milter/
@ -434,6 +430,7 @@ export have_cv_ipv6=yes
--disable-clamav \
--with-user=%username \
--with-group=%username \
--with-libcurl=%{_prefix} \
--with-dbdir=/var/lib/clamav \
--enable-milter \
--enable-clamdtop \
@ -858,6 +855,12 @@ test "$1" != "0" || /sbin/initctl -q stop clamav-milter || :
%changelog
* Sat May 10 2014 Robert Scheck <robert@fedoraproject.org> - 0.98.3-1
- Upgrade to 0.98.3 and updated daily.cvd (#1095614)
- Avoid automatic path detection breakage regarding curl
- Added build requirement to openssl-devel for hasing code
- Added clamsubmit to main package
* Wed Jan 15 2014 Robert Scheck <robert@fedoraproject.org> - 0.98.1-1
- Upgrade to 0.98.1 and updated daily.cvd (#1053400)

View File

@ -1,3 +1,3 @@
8944174b2dca6f38d96a2a2a7146d36e clamav-0.98.1-norar.tar.xz
e9210784829725bf716fda7ca536bbb0 clamav-0.98.3-norar.tar.xz
06f660f474d1a6863de4a00eb02521e3 main-55.cvd
52ce049e8df4693766c5c42697890d35 daily-18353.cvd
5a7d62d7d8ee4b237d6e08f5bc02037c daily-18354.cvd