Update to 0.99.2
- Enable llvm - Drop cliopts patch fixed upstream, use upstream's "--forground" option name - Fix main.cvd (fedora #1325482, epel #1325717) - Own bytecode.cld (#1176252) and mirrors.dat, ship bytecode.cvd - Update daily.cvd - Fixup Requires(pre) usage (#1319151) Conflicts: clamav-milter.systemd clamav-milter.sysv clamav-milter.upstart clamav.spec clamd.scan.upstart clamd@.service sources
This commit is contained in:
parent
ea28252658
commit
0577117bb2
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/clamav-*-norar.tar.xz
|
||||
/main*.cvd
|
||||
/daily*.cvd
|
||||
/bytecode-278.cvd
|
||||
|
15
clamav-0.99.1-setsebool.patch
Normal file
15
clamav-0.99.1-setsebool.patch
Normal file
@ -0,0 +1,15 @@
|
||||
Patch by Robert Scheck <robert@fedoraproject.org> for clamav >= 0.99.1 which changes the SELinux
|
||||
boolean name from the obsolete (and former alias) clamd_use_jit to the current antivirus_use_jit.
|
||||
See also: https://bugzilla.redhat.com/show_bug.cgi?id=1295473
|
||||
|
||||
--- clamav-0.99.1/libclamav/builtin_bytecodes.h 2015-12-11 17:26:02.000000000 +0100
|
||||
+++ clamav-0.99.1/libclamav/builtin_bytecodes.h.setsebool 2016-03-29 23:32:03.000000000 +0200
|
||||
@@ -139,7 +139,7 @@
|
||||
if (env.os_features & (1 << feature_selinux))
|
||||
/* all SELinux versions deny RWX mapping when policy says so */
|
||||
disable_jit_if("^SELinux is preventing 'execmem' access.\n"
|
||||
- "Run 'setsebool -P clamd_use_jit on'.", 0, 1);
|
||||
+ "Run 'setsebool -P antivirus_use_jit on'.", 0, 1);
|
||||
else if (env.os_features & (1 << feature_pax))
|
||||
/* recent versions of PaX deny RWX mapping */
|
||||
disable_jit_if("^PaX is preventing 'mprotect' access.\n"
|
28
clamav.spec
28
clamav.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Summary: Anti-virus software
|
||||
Name: clamav
|
||||
Version: 0.99.1
|
||||
Version: 0.99.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: Applications/System
|
||||
@ -28,12 +28,16 @@ Source10: clamav-milter.sysconfig
|
||||
# To download the *.cvd, go to http://www.clamav.net and use the links
|
||||
# there (I renamed the files to add the -version suffix for verifying).
|
||||
Source11: http://db.local.clamav.net/main-57.cvd
|
||||
Source12: http://db.local.clamav.net/daily-21478.cvd
|
||||
Source12: http://db.local.clamav.net/daily-21723.cvd
|
||||
Source13: http://db.local.clamav.net/bytecode-278.cvd
|
||||
|
||||
Patch31: clamav-0.99.1-setsebool.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: bzip2-devel, zlib-devel, gmp-devel, curl-devel, xz, ncurses-devel, openssl-devel, libxml2-devel, pcre-devel
|
||||
%{!?_without_milter:BuildRequires: sendmail-devel >= 8.12}
|
||||
|
||||
Requires: clamav-db = %{version}-%{release}
|
||||
Requires(pre): shadow-utils
|
||||
|
||||
@ -126,6 +130,7 @@ you will need to install %{name}-devel.
|
||||
# Handle that rpmbuild in RHEL < 6 doesn't handle xz archives automatically.
|
||||
%setup -q -T -c
|
||||
xz -dc %{SOURCE0} | (cd .. ; tar xvvf -)
|
||||
%patch31 -p1 -b .setsebool
|
||||
|
||||
%{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g;' configure
|
||||
|
||||
@ -199,7 +204,7 @@ xz -dc %{SOURCE0} | (cd .. ; tar xvvf -)
|
||||
--with-group="clam" \
|
||||
--with-libcurl=%{_prefix} \
|
||||
--with-user="clam" \
|
||||
--disable-llvm
|
||||
# --disable-llvm
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -242,6 +247,11 @@ install -d -m0755 %{buildroot}%{_sysconfdir}/clamd.d/
|
||||
|
||||
install -Dp -m0644 %{SOURCE11} %{buildroot}%{_localstatedir}/lib/clamav/main.cvd
|
||||
install -Dp -m0644 %{SOURCE12} %{buildroot}%{_localstatedir}/lib/clamav/daily.cvd
|
||||
install -Dp -m0644 %{SOURCE13} %{buildroot}%{_localstatedir}/lib/clamav/bytecode.cvd
|
||||
touch $RPM_BUILD_ROOT%{_localstatedir}/lib/clamav/bytecode.cld
|
||||
touch $RPM_BUILD_ROOT%{_localstatedir}/lib/clamav/{daily,main}.cld
|
||||
touch $RPM_BUILD_ROOT%{_localstatedir}/lib/clamav/mirrors.dat
|
||||
|
||||
|
||||
# Clean up for later usage in documentation
|
||||
for conf in etc/*.sample; do mv ${conf} ${conf%%.sample}; done
|
||||
@ -387,6 +397,9 @@ rm -rf %{buildroot}
|
||||
%dir %{_localstatedir}/log/clamav/
|
||||
%ghost %{_localstatedir}/log/clamav/freshclam.log
|
||||
|
||||
%ghost %attr(0664,%username,%username) %{_localstatedir}/lib/clamav/*.cld
|
||||
%ghost %attr(0664,%username,%username) %{_localstatedir}/lib/clamav/mirrors.dat
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, 0755)
|
||||
%{_bindir}/clamav-config
|
||||
@ -397,6 +410,15 @@ rm -rf %{buildroot}
|
||||
%exclude %{_libdir}/libclamav.la
|
||||
|
||||
%changelog
|
||||
* Mon Jun 13 2016 Orion Poplawski <orion@cora.nwra.com> - 0.99.2-1
|
||||
- Update to 0.99.2
|
||||
- Enable llvm
|
||||
- Drop cliopts patch fixed upstream, use upstream's "--forground" option name
|
||||
- Fix main.cvd (fedora #1325482, epel #1325717)
|
||||
- Own bytecode.cld (#1176252) and mirrors.dat, ship bytecode.cvd
|
||||
- Update daily.cvd
|
||||
- Fixup Requires(pre) usage (#1319151)
|
||||
|
||||
* Tue Mar 29 2016 Robert Scheck <robert@fedoraproject.org> - 0.99.1-1
|
||||
- Upgrade to 0.99.1 and updated main.cvd and daily.cvd (#1314115)
|
||||
|
||||
|
7
sources
7
sources
@ -1,4 +1,5 @@
|
||||
6bf23527691890664c66e62e7bee44ff clamav-0.99.1-norar.tar.xz
|
||||
85b8dd2229ba4a0ddd8bf048fe2b2078 main-57.cvd
|
||||
b82f2fc713069d378d79b8e4e3db0b74 daily-21478.cvd
|
||||
a4517adbd9c72a3fec3fbb1384dd3234 clamav-0.99.2-norar.tar.xz
|
||||
d71fbb44799945970f2c2b75e40ec105 daily-21723.cvd
|
||||
f13ead862171f50019c15c946d25e91f main-57.cvd
|
||||
c545b6a9775ccb72a293d259335589be bytecode-278.cvd
|
||||
e809f74ed139df2e4af3fafbca32f678 clamd-wrapper.tar.bz2
|
||||
|
Loading…
x
Reference in New Issue
Block a user