- updated to final 0.90

- removed -visibility patch since fixed upstream
This commit is contained in:
ensc 2007-02-18 21:19:28 +00:00
parent 8aa983a992
commit 017299770b
3 changed files with 11 additions and 41 deletions

View File

@ -1,29 +0,0 @@
--- clamav-0.88.4/libclamav/md5.c.visibility 2005-06-23 22:03:12.000000000 +0200
+++ clamav-0.88.4/libclamav/md5.c 2006-08-11 08:19:02.000000000 +0200
@@ -176,7 +176,7 @@ static void *body(MD5_CTX *ctx, void *da
return ptr;
}
-void MD5_Init(MD5_CTX *ctx)
+void __attribute__ ((__visibility__("hidden"))) MD5_Init(MD5_CTX *ctx)
{
ctx->a = 0x67452301;
ctx->b = 0xefcdab89;
@@ -187,7 +187,7 @@ void MD5_Init(MD5_CTX *ctx)
ctx->hi = 0;
}
-void MD5_Update(MD5_CTX *ctx, void *data, unsigned long size)
+void __attribute__ ((__visibility__("hidden"))) MD5_Update(MD5_CTX *ctx, void *data, unsigned long size)
{
MD5_u32plus saved_lo;
unsigned long used, free;
@@ -221,7 +221,7 @@ void MD5_Update(MD5_CTX *ctx, void *data
memcpy(ctx->buffer, data, size);
}
-void MD5_Final(unsigned char *result, MD5_CTX *ctx)
+void __attribute__ ((__visibility__("hidden"))) MD5_Final(unsigned char *result, MD5_CTX *ctx)
{
unsigned long used, free;

View File

@ -1,12 +1,9 @@
## $Id: clamav.spec,v 1.46 2007/02/03 15:16:08 ensc Exp $
## $Id: clamav.spec,v 1.47 2007/02/04 11:57:35 ensc Exp $
## Fedora Extras specific customization below...
%bcond_without fedora
##
%global rcver rc3
%global username clamav
%global homedir %_var/lib/clamav
%global freshclamlog %_var/log/freshclam.log
@ -21,13 +18,13 @@
Summary: End-user tools for the Clam Antivirus scanner
Name: clamav
Version: 0.90
Release: %release_func 0.3.rc3
Release: %release_func 0.4
License: GPL
Group: Applications/File
URL: http://www.clamav.net
Source0: http://download.sourceforge.net/sourceforge/clamav/%name-%version%{?rcver}.tar.gz
Source999: http://download.sourceforge.net/sourceforge/clamav/%name-%version%{?rcver}.tar.gz.sig
Source0: http://download.sourceforge.net/sourceforge/clamav/%name-%version.tar.gz
Source999: http://download.sourceforge.net/sourceforge/clamav/%name-%version.tar.gz.sig
Source1: clamd-wrapper
Source2: clamd.sysconfig
Source3: clamd.logrotate
@ -37,7 +34,6 @@ Source7: clamd.SERVICE.init
Source8: clamav-notify-servers
Patch21: clamav-0.70-path.patch
Patch22: clamav-0.80-initoff.patch
Patch23: clamav-0.88.4-visibility.patch
Patch24: clamav-0.90rc3-private.patch
BuildRoot: %_tmppath/%name-%version-%release-root
Requires: clamav-lib = %version-%release
@ -224,11 +220,10 @@ The SysV initscripts for clamav-milter.
## ------------------------------------------------------------
%prep
%setup -q -n %name-%version%{?rcver}
%setup -q
%patch21 -p1 -b .path
%patch22 -p1 -b .initoff
%patch23 -p1 -b .visibility
%patch24 -p1 -b .private
perl -pi -e 's!^(#?LogFile ).*!\1/var/log/clamd.<SERVICE>!g;
@ -509,6 +504,10 @@ test "$1" = 0 || %_initrddir/clamav-milter condrestart >/dev/null || :
%changelog
* Sun Feb 18 2007 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.90-1
- updated to final 0.90
- removed -visibility patch since fixed upstream
* Sun Feb 4 2007 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.90-0.3.rc3
- build with -Wl,-as-needed and cleaned up pkgconfig file
- removed old hack which forced installation of freshclam.conf; related

View File

@ -1,2 +1,2 @@
5af2bdbbb255829dd590609d900c1854 clamav-0.90rc3.tar.gz
978715ae312d5dda63a0591b0a4eae14 clamav-0.90rc3.tar.gz.sig
9d5d53eed766976c2cfc9b14d56b2bba clamav-0.90.tar.gz.sig
f04372e49c3c5ff3bd94bbe1fef2eaca clamav-0.90.tar.gz