Upstream release 20.1 and add cjdns.service to local SOURCES
This commit is contained in:
parent
26ceedf6b1
commit
1afaf13c91
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/*.src.rpm
|
||||
/cjdns-v19.1.tar.gz
|
||||
/cjdns-v20.tar.gz
|
||||
/cjdns-v20.1.tar.gz
|
||||
|
@ -109,34 +109,6 @@ diff -up ./contrib/systemd/cjdns-online.sh.sbin ./contrib/systemd/cjdns-online.s
|
||||
+ cjdns_dev
|
||||
+ fi
|
||||
+fi
|
||||
diff -up ./contrib/systemd/cjdns.service.sbin ./contrib/systemd/cjdns.service
|
||||
--- ./contrib/systemd/cjdns.service.sbin 2016-10-11 17:39:44.000000000 -0400
|
||||
+++ ./contrib/systemd/cjdns.service 2017-01-13 22:07:35.128118775 -0500
|
||||
@@ -1,18 +1,21 @@
|
||||
[Unit]
|
||||
Description=cjdns: routing engine designed for security, scalability, speed and ease of use
|
||||
Wants=network.target
|
||||
-After=network.target
|
||||
+After=network.target cjdns-loadmodules.service
|
||||
+Requires=cjdns-loadmodules.service
|
||||
|
||||
[Service]
|
||||
ProtectHome=true
|
||||
ProtectSystem=true
|
||||
SyslogIdentifier=cjdroute
|
||||
+CapabilityBoundingSet=CAP_NET_ADMIN CAP_NET_RAW CAP_SETUID CAP_SETGID CAP_SYS_CHROOT CAP_AUDIT_CONTROL
|
||||
ExecStartPre=/bin/sh -ec "if ! test -s /etc/cjdroute.conf; \
|
||||
then umask 077; \
|
||||
- /usr/bin/cjdroute --genconf > /etc/cjdroute.conf; \
|
||||
+ /usr/sbin/cjdroute --genconf | cat > /etc/cjdroute.conf; \
|
||||
echo 'WARNING: A new /etc/cjdroute.conf file has been generated.'; \
|
||||
fi"
|
||||
-ExecStart=/bin/sh -c "exec cjdroute --nobg < /etc/cjdroute.conf"
|
||||
+ExecStart=/bin/sh -c "exec /usr/sbin/cjdroute --nobg < /etc/cjdroute.conf"
|
||||
+ExecStartPost=/bin/sh /usr/libexec/cjdns/cjdns-up
|
||||
Restart=always
|
||||
|
||||
[Install]
|
||||
diff -up ./contrib/systemd/cjdns-wait-online.service.sbin ./contrib/systemd/cjdns-wait-online.service
|
||||
--- ./contrib/systemd/cjdns-wait-online.service.sbin 2017-01-13 21:43:05.414731254 -0500
|
||||
+++ ./contrib/systemd/cjdns-wait-online.service 2017-01-13 21:43:05.414731254 -0500
|
||||
|
23
cjdns.service
Normal file
23
cjdns.service
Normal file
@ -0,0 +1,23 @@
|
||||
[Unit]
|
||||
Description=cjdns: routing engine designed for security, scalability, speed and ease of use
|
||||
Wants=network.target
|
||||
After=network.target cjdns-loadmodules.service
|
||||
Requires=cjdns-loadmodules.service
|
||||
|
||||
[Service]
|
||||
ProtectHome=true
|
||||
ProtectSystem=true
|
||||
SyslogIdentifier=cjdroute
|
||||
CapabilityBoundingSet=CAP_NET_ADMIN CAP_NET_RAW CAP_SETUID CAP_SETGID CAP_SYS_CHROOT CAP_AUDIT_CONTROL
|
||||
ExecStartPre=/bin/sh -ec "if ! test -s /etc/cjdroute.conf; \
|
||||
then umask 077; \
|
||||
/usr/sbin/cjdroute --genconf | cat > /etc/cjdroute.conf; \
|
||||
echo 'WARNING: A new /etc/cjdroute.conf file has been generated.'; \
|
||||
fi"
|
||||
ExecStart=/bin/sh -c "exec /usr/sbin/cjdroute --nobg < /etc/cjdroute.conf"
|
||||
ExecStartPost=/bin/sh /usr/libexec/cjdns/cjdns-up
|
||||
Restart=always
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
Also=cjdns-resume.service
|
14
cjdns.spec
14
cjdns.spec
@ -2,7 +2,7 @@
|
||||
# Fedora review: http://bugzilla.redhat.com/1268716
|
||||
|
||||
# Option to enable SUBNODE mode (WIP)
|
||||
%bcond_with subnode
|
||||
%bcond_without subnode
|
||||
# Use the optimized libnacl embedded with cjdns
|
||||
%if %{with subnode}
|
||||
%global use_embedded 1
|
||||
@ -16,7 +16,7 @@
|
||||
|
||||
%if 0%{use_libsodium}
|
||||
%global nacl_name libsodium
|
||||
%global nacl_version 1.0.5
|
||||
%global nacl_version 1.0.14
|
||||
%global nacl_lib %{_libdir}/libsodium.so
|
||||
%else
|
||||
%global nacl_name nacl
|
||||
@ -46,8 +46,8 @@
|
||||
|
||||
Name: cjdns
|
||||
# major version is cjdns protocol version:
|
||||
Version: 19.1
|
||||
Release: 10%{?dist}
|
||||
Version: 20.1
|
||||
Release: 1%{?dist}
|
||||
Summary: The privacy-friendly network without borders
|
||||
Group: System Environment/Base
|
||||
# cjdns is all GPLv3 except libuv which is MIT and BSD and ISC
|
||||
@ -56,6 +56,7 @@ License: GPLv3 and MIT and BSD and ISC
|
||||
URL: http://hyperboria.net/
|
||||
Source0: https://github.com/cjdelisle/cjdns/archive/%{name}-v%{version}.tar.gz
|
||||
Source1: cjdns.README_Fedora.md
|
||||
Source2: cjdns.service
|
||||
# Add targeted selinux policy
|
||||
Patch0: cjdns.selinux.patch
|
||||
# Allow python2.6 for build. Python is not used during the build
|
||||
@ -192,6 +193,8 @@ Python graphing tools for cjdns.
|
||||
%patch4 -b .genconf
|
||||
%patch5 -b .sbin
|
||||
|
||||
cp %{SOURCE2} contrib/systemd
|
||||
|
||||
%if !%{use_embedded}
|
||||
# use system nacl library if provided.
|
||||
if test -x %{nacl_lib}; then
|
||||
@ -528,6 +531,9 @@ fi
|
||||
%{_bindir}/graphStats
|
||||
|
||||
%changelog
|
||||
* Wed Feb 21 2018 Stuart Gathman <stuart@gathman.org> - 20.1-1
|
||||
- New upstream release
|
||||
|
||||
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 19.1-10
|
||||
- Escape macros in %%changelog
|
||||
|
||||
|
4
sources
4
sources
@ -1,3 +1 @@
|
||||
SHA512 (cjdns-v18.tar.gz) = 3b7ed50c81ed51f8deea3999aa0b820f78de53da3d3937c13f572e35bb7c2a6f963d3779c2f0b7b4afc64e6a45ae98c4a6958a0c31d43d4309a47ae3ccbb709b
|
||||
SHA512 (cjdns-v19.1.tar.gz) = 9c29bf1d136237bd60e125718bdd2c6d7f5a651d51af50aea3173eed1626a402dac5a2a72f9fb129fc9af24c3b67472a1dfe7b2b6a09bb28d01a120fc667b206
|
||||
SHA512 (cjdns-v20.tar.gz) = 7da6537ed417d33ebd9ffa27a9e08758c48ea99930a85497853f0ee43cc87501434ab76bee0e69dc935b3338959d86bcb4bef527f1b93887b0a3662b4ab55879
|
||||
SHA512 (cjdns-v20.1.tar.gz) = 519835f489359fb677d35040862dece20b75d84716281096f2c32c8531e8d784d852d8e2709d8c67e8098ad819f62c2a2ef1647fbad3e28e3e20f502d23cd3e7
|
||||
|
Loading…
Reference in New Issue
Block a user