Merge branch 'master' into f27

This commit is contained in:
Tom Callaway 2018-05-05 10:11:38 -04:00
commit a94664f791
2 changed files with 17 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up chromium-66.0.3359.139/skia/ext/convolver_neon.cc.arm-init-fix chromium-66.0.3359.139/skia/ext/convolver_neon.cc
--- chromium-66.0.3359.139/skia/ext/convolver_neon.cc.arm-init-fix 2018-05-05 10:07:03.624424987 -0400
+++ chromium-66.0.3359.139/skia/ext/convolver_neon.cc 2018-05-05 10:07:45.417503001 -0400
@@ -23,7 +23,7 @@ AccumRemainder(const unsigned char* pixe
remainder[2] += coeff * pixels_left[i * 4 + 2];
remainder[3] += coeff * pixels_left[i * 4 + 3];
}
- return {remainder[0], remainder[1], remainder[2], remainder[3]};
+ return vld1q_s32(remainder);
}
// Convolves horizontally along a single row. The row data is given in

View File

@ -242,6 +242,9 @@ Patch94: chromium-66.0.3359.117-GCC-fully-declare-ConfigurationPolicyProvider.pa
Patch95: chromium-65.0.3325.146-GCC-IDB-methods-String-renamed-to-GetString.patch
# https://github.com/archlinuxarm/PKGBUILDs/blob/master/extra/chromium/0006-GCC-do-not-use-initializer-list-for-NoDestructor-of-.patch
Patch96: chromium-66.0.3359.117-GCC-do-not-use-initializer-list-for-NoDestructor-of-.patch
# https://chromium.googlesource.com/chromium/src/+/b84682f31dc99b9c90f5a04947075815697c68d9%5E%21/#F0
Patch97: chromium-66.0.3359.139-arm-init-fix.patch
# Use chromium-latest.py to generate clean tarball from released build tarballs, found here:
# http://build.chromium.org/buildbot/official/
@ -698,7 +701,7 @@ udev.
%patch45 -p1 -b .nozmangle
%if 0%{?rhel} == 7
%patch46 -p1 -b .kmaxskip
%patch47 -p1 -b .c99
# %%patch47 -p1 -b .c99
%endif
%patch50 -p1 -b .pathfix
%patch53 -p1 -b .nogccoptmath
@ -723,6 +726,7 @@ udev.
%patch94 -p1 -b .gcc-cpolicyprovider
%patch95 -p1 -b .gcc-getstring
%patch96 -p1 -b .flatsetfix
%patch97 -p1 -b .arm-init-fix
# Change shebang in all relevant files in this directory and all subdirectories
# See `man find` for how the `-exec command {} +` syntax works