88.0.4324.96
This commit is contained in:
parent
3e97351d73
commit
8cc5f083e1
27
chromium-88-AXTreeFormatter-include.patch
Normal file
27
chromium-88-AXTreeFormatter-include.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 6e402d97c2dec5726f37e95f97b7f7e12b1d3b1d Mon Sep 17 00:00:00 2001
|
||||
From: Jose Dapena Paz <jdapena@igalia.com>
|
||||
Date: Wed, 11 Nov 2020 11:02:13 +0100
|
||||
Subject: [PATCH] IWYU: include headers for std::vector and std::unique_ptr in AXTreeFormatter
|
||||
|
||||
Fix these build errors with libstdc++:
|
||||
../../ui/accessibility/platform/inspect/tree_formatter.h:35:12: error: ‘std::vector’ has not been declared
|
||||
../../ui/accessibility/platform/inspect/tree_formatter.h:61:16: error: ‘unique_ptr’ in namespace ‘std’ does not name a template type
|
||||
|
||||
Bug: 957519
|
||||
Change-Id: I402ac0644255b3cd4932ff2fe72d999b125a7895
|
||||
---
|
||||
|
||||
diff --git a/ui/accessibility/platform/inspect/tree_formatter.h b/ui/accessibility/platform/inspect/tree_formatter.h
|
||||
index 4a70a4d..bb23768 100644
|
||||
--- a/ui/accessibility/platform/inspect/tree_formatter.h
|
||||
+++ b/ui/accessibility/platform/inspect/tree_formatter.h
|
||||
@@ -5,6 +5,9 @@
|
||||
#ifndef UI_ACCESSIBILITY_PLATFORM_INSPECT_TREE_FORMATTER_H_
|
||||
#define UI_ACCESSIBILITY_PLATFORM_INSPECT_TREE_FORMATTER_H_
|
||||
|
||||
+#include <memory>
|
||||
+#include <vector>
|
||||
+
|
||||
#include "ui/accessibility/platform/inspect/inspect.h"
|
||||
|
||||
#include "ui/gfx/native_widget_types.h"
|
21
chromium-88-BookmarkModelObserver-include.patch
Normal file
21
chromium-88-BookmarkModelObserver-include.patch
Normal file
@ -0,0 +1,21 @@
|
||||
From 127ec3b1bf26ab37f2ae8333f284008868756274 Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Hartmann <stha09@googlemail.com>
|
||||
Date: Sat, 21 Nov 2020 15:59:23 +0000
|
||||
Subject: [PATCH] IWYU: size_t is defined stddef.h
|
||||
|
||||
Change-Id: I4400ac7c6004b49ec6e72c44f2754e2166642f88
|
||||
---
|
||||
|
||||
diff --git a/components/bookmarks/browser/bookmark_model_observer.h b/components/bookmarks/browser/bookmark_model_observer.h
|
||||
index 69c40e7..0e5eb96 100644
|
||||
--- a/components/bookmarks/browser/bookmark_model_observer.h
|
||||
+++ b/components/bookmarks/browser/bookmark_model_observer.h
|
||||
@@ -7,6 +7,8 @@
|
||||
|
||||
#include <set>
|
||||
|
||||
+#include <stddef.h>
|
||||
+
|
||||
class GURL;
|
||||
|
||||
namespace bookmarks {
|
36
chromium-88-CompositorFrameReporter-dcheck.patch
Normal file
36
chromium-88-CompositorFrameReporter-dcheck.patch
Normal file
@ -0,0 +1,36 @@
|
||||
From 56c654a91600e3bf254aa9f66c1151b0850b6ee4 Mon Sep 17 00:00:00 2001
|
||||
From: Jose Dapena Paz <jdapena@igalia.com>
|
||||
Date: Wed, 11 Nov 2020 10:24:47 +0100
|
||||
Subject: [PATCH] GCC: do not pass unique_ptr to DCHECK_NE, but the actual pointer, in CompositorFrameReporter
|
||||
|
||||
DCHECK_NE comparison requires CheckOpValueStr to be defined for the
|
||||
type, or providing an output stream operator. A unique_ptr does not
|
||||
provide any.
|
||||
|
||||
Compilation in GCC is failing in CompositorFrameReporter because of
|
||||
this:
|
||||
../../cc/metrics/compositor_frame_reporter.cc: In member function ‘void cc::CompositorFrameReporter::ReportEventLatencyHistograms() const’:
|
||||
../../base/check_op.h:224:59: error: no matching function for call to ‘CheckOpValueStr(const std::unique_ptr<cc::EventMetrics>&)’
|
||||
|
||||
Fixed comparing the result of get() method for unique_ptr instead of
|
||||
the unique_ptr.
|
||||
|
||||
Bug: 819294
|
||||
Change-Id: I11103d1867c7196c1de92e72f9f12dcfd31c29f1
|
||||
|
||||
(updated to use DCHECK as suggested in comments)
|
||||
---
|
||||
|
||||
diff --git a/cc/metrics/compositor_frame_reporter.cc b/cc/metrics/compositor_frame_reporter.cc
|
||||
index 725beb0..fafd0f3 100644
|
||||
--- a/cc/metrics/compositor_frame_reporter.cc
|
||||
+++ b/cc/metrics/compositor_frame_reporter.cc
|
||||
@@ -686,7 +686,7 @@
|
||||
|
||||
void CompositorFrameReporter::ReportEventLatencyHistograms() const {
|
||||
for (const auto& event_metrics : events_metrics_) {
|
||||
- DCHECK_NE(event_metrics, nullptr);
|
||||
+ DCHECK(event_metrics);
|
||||
const std::string histogram_base_name =
|
||||
GetEventLatencyHistogramBaseName(*event_metrics);
|
||||
const int event_type_index = static_cast<int>(event_metrics->type());
|
20
chromium-88-StringPool-include.patch
Normal file
20
chromium-88-StringPool-include.patch
Normal file
@ -0,0 +1,20 @@
|
||||
From 372366b4180533f27d3250a50810828370d697b0 Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Hartmann <stha09@googlemail.com>
|
||||
Date: Sat, 21 Nov 2020 16:12:18 +0000
|
||||
Subject: [PATCH] IWYU: include limits for std::numeric_limits
|
||||
|
||||
Change-Id: Ia5226e1432a622f4f4abc8f1b18bcab8638a73c6
|
||||
---
|
||||
|
||||
diff --git a/src/trace_processor/containers/string_pool.h b/src/trace_processor/containers/string_pool.h
|
||||
index 11ae91c..58c6db2 100644
|
||||
--- a/third_party/perfetto/src/trace_processor/containers/string_pool.h
|
||||
+++ b/third_party/perfetto/src/trace_processor/containers/string_pool.h
|
||||
@@ -22,6 +22,7 @@
|
||||
|
||||
#include <unordered_map>
|
||||
#include <vector>
|
||||
+#include <limits>
|
||||
|
||||
#include "perfetto/ext/base/optional.h"
|
||||
#include "perfetto/ext/base/paged_memory.h"
|
59
chromium-88-dawn-static.patch
Normal file
59
chromium-88-dawn-static.patch
Normal file
@ -0,0 +1,59 @@
|
||||
From 75a1f5234e4b544b4d16eddb995d39685da21361 Mon Sep 17 00:00:00 2001
|
||||
From: Ivan Murashov <ivan.murashov@lge.com>
|
||||
Date: Fri, 20 Nov 2020 09:38:56 +0000
|
||||
Subject: [PATCH] Remove storage class specifier for the explicit template specialization
|
||||
|
||||
According to the http://www.eel.is/c++draft/temp.expl.spec:
|
||||
An explicit specialization shall not use a storage-class-specifier
|
||||
other than thread_local.
|
||||
Clang doesn't claims about it, but GCC does.
|
||||
An error example for GCC 8.4.0:
|
||||
gen/third_party/dawn/src/dawn_wire/client/ApiObjects_autogen.h:25:5:
|
||||
error: explicit template specialization cannot have a storage class
|
||||
|
||||
Bug: dawn:384
|
||||
Change-Id: Iaf86722a943d19c9796a7f112885666ac88f20ca
|
||||
Reviewed-on: https://dawn-review.googlesource.com/c/dawn/+/33480
|
||||
Commit-Queue: Corentin Wallez <cwallez@chromium.org>
|
||||
Reviewed-by: Corentin Wallez <cwallez@chromium.org>
|
||||
---
|
||||
|
||||
diff --git a/third_party/dawn/generator/templates/dawn_wire/client/ApiObjects.h b/third_party/dawn/generator/templates/dawn_wire/client/ApiObjects.h
|
||||
index 0d8421b..bbf9817 100644
|
||||
--- a/third_party/dawn/generator/templates/dawn_wire/client/ApiObjects.h
|
||||
+++ b/third_party/dawn/generator/templates/dawn_wire/client/ApiObjects.h
|
||||
@@ -21,7 +21,9 @@
|
||||
namespace dawn_wire { namespace client {
|
||||
|
||||
template <typename T>
|
||||
- static constexpr ObjectType ObjectTypeToTypeEnum = static_cast<ObjectType>(-1);
|
||||
+ struct ObjectTypeToTypeEnum {
|
||||
+ static constexpr ObjectType value = static_cast<ObjectType>(-1);
|
||||
+ };
|
||||
|
||||
{% for type in by_category["object"] %}
|
||||
{% set Type = type.name.CamelCase() %}
|
||||
@@ -41,7 +43,9 @@
|
||||
}
|
||||
|
||||
template <>
|
||||
- static constexpr ObjectType ObjectTypeToTypeEnum<{{type.name.CamelCase()}}> = ObjectType::{{type.name.CamelCase()}};
|
||||
+ struct ObjectTypeToTypeEnum<{{Type}}> {
|
||||
+ static constexpr ObjectType value = ObjectType::{{Type}};
|
||||
+ };
|
||||
|
||||
{% endfor %}
|
||||
}} // namespace dawn_wire::client
|
||||
diff --git a/third_party/dawn/src/dawn_wire/client/Device.h b/third_party/dawn/src/dawn_wire/client/Device.h
|
||||
index eef03a5..a0036a4 100644
|
||||
--- a/third_party/dawn/src/dawn_wire/client/Device.h
|
||||
+++ b/third_party/dawn/src/dawn_wire/client/Device.h
|
||||
@@ -65,7 +65,7 @@
|
||||
|
||||
template <typename T>
|
||||
void TrackObject(T* object) {
|
||||
- mObjects[ObjectTypeToTypeEnum<T>].Append(object);
|
||||
+ mObjects[ObjectTypeToTypeEnum<T>::value].Append(object);
|
||||
}
|
||||
|
||||
void CancelCallbacksForDisconnect() override;
|
21
chromium-88-federated_learning-include.patch
Normal file
21
chromium-88-federated_learning-include.patch
Normal file
@ -0,0 +1,21 @@
|
||||
From bcb20babee602b55fe4bd026e13a41d10b89632f Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Hartmann <stha09@googlemail.com>
|
||||
Date: Sat, 21 Nov 2020 15:55:02 +0000
|
||||
Subject: [PATCH] IWYU: include limits for std::numeric_limits
|
||||
|
||||
Change-Id: I1b6b07ebb397a29c84d3ed51ae41523e3ecab497
|
||||
---
|
||||
|
||||
diff --git a/components/federated_learning/floc_constants.cc b/components/federated_learning/floc_constants.cc
|
||||
index df66e5d..2eb50f1 100644
|
||||
--- a/components/federated_learning/floc_constants.cc
|
||||
+++ b/components/federated_learning/floc_constants.cc
|
||||
@@ -4,6 +4,8 @@
|
||||
|
||||
#include "components/federated_learning/floc_constants.h"
|
||||
|
||||
+#include <limits>
|
||||
+
|
||||
namespace federated_learning {
|
||||
|
||||
// This is only for experimentation and won't be served to websites.
|
25
chromium-88-ityp-include.patch
Normal file
25
chromium-88-ityp-include.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From bc383a5dd7fa8f2b535f28815fd6932fbc0d2a45 Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Hartmann <stha09@googlemail.com>
|
||||
Date: Wed, 28 Oct 2020 16:00:35 +0000
|
||||
Subject: [PATCH] IWYU: include stddef.h for size_t
|
||||
|
||||
---
|
||||
third_party/dawn/src/common/ityp_array.h | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/third_party/dawn/src/common/ityp_array.h b/third_party/dawn/src/common/ityp_array.h
|
||||
index 48e080f..c784198 100644
|
||||
--- a/third_party/dawn/src/common/ityp_array.h
|
||||
+++ b/third_party/dawn/src/common/ityp_array.h
|
||||
@@ -21,6 +21,8 @@
|
||||
#include <array>
|
||||
#include <type_traits>
|
||||
|
||||
+#include <stddef.h>
|
||||
+
|
||||
namespace ityp {
|
||||
|
||||
// ityp::array is a helper class that wraps std::array with the restriction that
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,72 @@
|
||||
diff -up chromium-88.0.4324.11/chrome/browser/about_flags.cc.accel-mjpeg chromium-88.0.4324.11/chrome/browser/about_flags.cc
|
||||
--- chromium-88.0.4324.11/chrome/browser/about_flags.cc.accel-mjpeg 2020-11-19 20:51:19.000000000 -0500
|
||||
+++ chromium-88.0.4324.11/chrome/browser/about_flags.cc 2020-11-30 16:14:32.393366384 -0500
|
||||
@@ -3309,12 +3309,12 @@ const FeatureEntry kFeatureEntries[] = {
|
||||
flag_descriptions::kWebXrForceRuntimeDescription, kOsDesktop,
|
||||
MULTI_VALUE_TYPE(kWebXrForceRuntimeChoices)},
|
||||
#endif // ENABLE_VR
|
||||
-#if defined(OS_CHROMEOS)
|
||||
+#if defined(OS_CHROMEOS) || defined(OS_LINUX)
|
||||
{"disable-accelerated-mjpeg-decode",
|
||||
flag_descriptions::kAcceleratedMjpegDecodeName,
|
||||
- flag_descriptions::kAcceleratedMjpegDecodeDescription, kOsCrOS,
|
||||
+ flag_descriptions::kAcceleratedMjpegDecodeDescription, kOsCrOS | kOsLinux,
|
||||
SINGLE_DISABLE_VALUE_TYPE(switches::kDisableAcceleratedMjpegDecode)},
|
||||
-#endif // OS_CHROMEOS
|
||||
+#endif // OS_CHROMEOS || OS_LINUX
|
||||
{"system-keyboard-lock", flag_descriptions::kSystemKeyboardLockName,
|
||||
flag_descriptions::kSystemKeyboardLockDescription, kOsDesktop,
|
||||
FEATURE_VALUE_TYPE(features::kSystemKeyboardLock)},
|
||||
diff -up chromium-88.0.4324.11/chrome/browser/flag_descriptions.cc.accel-mjpeg chromium-88.0.4324.11/chrome/browser/flag_descriptions.cc
|
||||
--- chromium-88.0.4324.11/chrome/browser/flag_descriptions.cc.accel-mjpeg 2020-11-30 16:14:32.393366384 -0500
|
||||
+++ chromium-88.0.4324.11/chrome/browser/flag_descriptions.cc 2020-11-30 16:20:50.174195910 -0500
|
||||
@@ -3572,9 +3572,9 @@ const char kVideoToolboxVp9DecodingDescr
|
||||
|
||||
#endif
|
||||
|
||||
-// Chrome OS -------------------------------------------------------------------
|
||||
+// Chrome OS and Linux ---------------------------------------------------------
|
||||
|
||||
-#if defined(OS_CHROMEOS)
|
||||
+#if defined(OS_CHROMEOS) || (defined(OS_LINUX) && !defined(OS_ANDROID))
|
||||
|
||||
const char kAcceleratedMjpegDecodeName[] =
|
||||
"Hardware-accelerated mjpeg decode for captured frame";
|
||||
@@ -3582,6 +3582,12 @@ const char kAcceleratedMjpegDecodeDescri
|
||||
"Enable hardware-accelerated mjpeg decode for captured frame where "
|
||||
"available.";
|
||||
|
||||
+#endif
|
||||
+
|
||||
+// Chrome OS -------------------------------------------------------------------
|
||||
+
|
||||
+#if defined(OS_CHROMEOS)
|
||||
+
|
||||
const char kAllowDisableMouseAccelerationName[] =
|
||||
"Allow disabling mouse acceleration";
|
||||
const char kAllowDisableMouseAccelerationDescription[] =
|
||||
diff -up chromium-88.0.4324.11/chrome/browser/flag_descriptions.h.accel-mjpeg chromium-88.0.4324.11/chrome/browser/flag_descriptions.h
|
||||
--- chromium-88.0.4324.11/chrome/browser/flag_descriptions.h.accel-mjpeg 2020-11-30 16:14:32.394366389 -0500
|
||||
+++ chromium-88.0.4324.11/chrome/browser/flag_descriptions.h 2020-11-30 16:22:13.831601058 -0500
|
||||
@@ -2068,13 +2068,19 @@ extern const char kVideoToolboxVp9Decodi
|
||||
|
||||
#endif // defined(OS_MAC)
|
||||
|
||||
-// Chrome OS ------------------------------------------------------------------
|
||||
+// Chrome OS and Linux --------------------------------------------------------
|
||||
|
||||
-#if defined(OS_CHROMEOS)
|
||||
+#if defined(OS_CHROMEOS) || (defined(OS_LINUX) && !defined(OS_ANDROID))
|
||||
|
||||
extern const char kAcceleratedMjpegDecodeName[];
|
||||
extern const char kAcceleratedMjpegDecodeDescription[];
|
||||
|
||||
+#endif
|
||||
+
|
||||
+// Chrome OS ------------------------------------------------------------------
|
||||
+
|
||||
+#if defined(OS_CHROMEOS)
|
||||
+
|
||||
extern const char kAllowDisableMouseAccelerationName[];
|
||||
extern const char kAllowDisableMouseAccelerationDescription[];
|
||||
|
90
chromium-88.0.4324.11-norar.patch
Normal file
90
chromium-88.0.4324.11-norar.patch
Normal file
@ -0,0 +1,90 @@
|
||||
diff -up chromium-88.0.4324.11/chrome/common/safe_browsing/BUILD.gn.nounrar chromium-88.0.4324.11/chrome/common/safe_browsing/BUILD.gn
|
||||
--- chromium-88.0.4324.11/chrome/common/safe_browsing/BUILD.gn.nounrar 2020-11-19 20:51:23.000000000 -0500
|
||||
+++ chromium-88.0.4324.11/chrome/common/safe_browsing/BUILD.gn 2020-11-30 16:09:01.104762930 -0500
|
||||
@@ -43,39 +43,6 @@ if (safe_browsing_mode == 1) {
|
||||
public_deps = [ "//components/safe_browsing/core:csd_proto" ]
|
||||
}
|
||||
|
||||
- source_set("rar_analyzer") {
|
||||
- sources = [
|
||||
- "rar_analyzer.cc",
|
||||
- "rar_analyzer.h",
|
||||
- ]
|
||||
-
|
||||
- deps = [
|
||||
- ":archive_analyzer_results",
|
||||
- ":download_type_util",
|
||||
- "//base",
|
||||
- "//base:i18n",
|
||||
- "//components/safe_browsing/core:features",
|
||||
- "//components/safe_browsing/core:file_type_policies",
|
||||
- "//third_party/unrar:unrar",
|
||||
- ]
|
||||
-
|
||||
- defines = [
|
||||
- "_FILE_OFFSET_BITS=64",
|
||||
- "LARGEFILE_SOURCE",
|
||||
- "RAR_SMP",
|
||||
- "SILENT",
|
||||
-
|
||||
- # The following is set to disable certain macro definitions in the unrar
|
||||
- # source code.
|
||||
- "CHROMIUM_UNRAR",
|
||||
-
|
||||
- # Disables exceptions in unrar, replaces them with process termination.
|
||||
- "UNRAR_NO_EXCEPTIONS",
|
||||
- ]
|
||||
-
|
||||
- public_deps = [ "//components/safe_browsing/core:csd_proto" ]
|
||||
- }
|
||||
-
|
||||
if (is_mac) {
|
||||
source_set("disk_image_type_sniffer_mac") {
|
||||
sources = [
|
||||
@@ -145,7 +112,6 @@ source_set("safe_browsing") {
|
||||
":archive_analyzer_results",
|
||||
":binary_feature_extractor",
|
||||
":download_type_util",
|
||||
- ":rar_analyzer",
|
||||
"//components/safe_browsing/core:features",
|
||||
]
|
||||
|
||||
diff -up chromium-88.0.4324.11/chrome/common/safe_browsing/DEPS.nounrar chromium-88.0.4324.11/chrome/common/safe_browsing/DEPS
|
||||
--- chromium-88.0.4324.11/chrome/common/safe_browsing/DEPS.nounrar 2020-11-19 20:51:23.000000000 -0500
|
||||
+++ chromium-88.0.4324.11/chrome/common/safe_browsing/DEPS 2020-11-30 16:04:30.599454130 -0500
|
||||
@@ -1,6 +1,5 @@
|
||||
include_rules = [
|
||||
"+components/safe_browsing",
|
||||
"+third_party/protobuf",
|
||||
- "+third_party/unrar",
|
||||
"+third_party/zlib",
|
||||
]
|
||||
diff -up chromium-88.0.4324.11/chrome/services/file_util/BUILD.gn.nounrar chromium-88.0.4324.11/chrome/services/file_util/BUILD.gn
|
||||
--- chromium-88.0.4324.11/chrome/services/file_util/BUILD.gn.nounrar 2020-11-19 20:51:24.000000000 -0500
|
||||
+++ chromium-88.0.4324.11/chrome/services/file_util/BUILD.gn 2020-11-30 16:04:30.599454130 -0500
|
||||
@@ -15,7 +15,6 @@ source_set("file_util") {
|
||||
"//base",
|
||||
"//chrome/common/safe_browsing",
|
||||
"//chrome/common/safe_browsing:archive_analyzer_results",
|
||||
- "//chrome/common/safe_browsing:rar_analyzer",
|
||||
"//components/safe_browsing:buildflags",
|
||||
"//mojo/public/cpp/bindings",
|
||||
]
|
||||
diff -up chromium-88.0.4324.11/chrome/services/file_util/safe_archive_analyzer.cc.nounrar chromium-88.0.4324.11/chrome/services/file_util/safe_archive_analyzer.cc
|
||||
--- chromium-88.0.4324.11/chrome/services/file_util/safe_archive_analyzer.cc.nounrar 2020-11-19 20:51:24.000000000 -0500
|
||||
+++ chromium-88.0.4324.11/chrome/services/file_util/safe_archive_analyzer.cc 2020-11-30 16:04:30.599454130 -0500
|
||||
@@ -45,10 +45,14 @@ void SafeArchiveAnalyzer::AnalyzeDmgFile
|
||||
void SafeArchiveAnalyzer::AnalyzeRarFile(base::File rar_file,
|
||||
base::File temporary_file,
|
||||
AnalyzeRarFileCallback callback) {
|
||||
+#if 0
|
||||
DCHECK(rar_file.IsValid());
|
||||
|
||||
safe_browsing::ArchiveAnalyzerResults results;
|
||||
safe_browsing::rar_analyzer::AnalyzeRarFile(
|
||||
std::move(rar_file), std::move(temporary_file), &results);
|
||||
std::move(callback).Run(results);
|
||||
+#else
|
||||
+ NOTREACHED();
|
||||
+#endif
|
||||
}
|
128
chromium.spec
128
chromium.spec
@ -51,9 +51,8 @@
|
||||
%global nsuffix %{nil}
|
||||
%endif
|
||||
|
||||
# Some people wish not to use the Fedora Google API keys. Mmkay.
|
||||
# Expect stuff to break in weird ways if you disable.
|
||||
%global useapikeys 1
|
||||
# Disabled because of Google, starting with Chromium 88.
|
||||
%global useapikeys 0
|
||||
|
||||
# Leave this alone, please.
|
||||
%global builddir out/Release
|
||||
@ -161,6 +160,19 @@ BuildRequires: libicu-devel >= 5.4
|
||||
%global bundleharfbuzz 0
|
||||
%endif
|
||||
|
||||
### From 2013 until early 2021, Google permitted distribution builds of
|
||||
### Chromium to access Google APIs that added significant features to
|
||||
### Chromium including, but not limited to, Sync and geolocation.
|
||||
### As of March 15, 2021, any Chromium builds which pass API keys
|
||||
### during build will prevent end-users from signing into their
|
||||
### Google account.
|
||||
|
||||
### With Chromium 88, I have removed the calls to "google_default_client_id"
|
||||
### and "google_default_client_secret" to comply with their changes.
|
||||
|
||||
### Honestly, at this point, you might be better off looking for a different
|
||||
### FOSS browser.
|
||||
|
||||
### Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
### Note: These are for Fedora use ONLY.
|
||||
### For your own distribution, please get your own set of keys.
|
||||
@ -177,14 +189,14 @@ BuildRequires: libicu-devel >= 5.4
|
||||
%global chromoting_client_id %nil
|
||||
%endif
|
||||
|
||||
%global majorversion 87
|
||||
%global majorversion 88
|
||||
|
||||
%if %{freeworld}
|
||||
Name: chromium%{chromium_channel}%{nsuffix}
|
||||
%else
|
||||
Name: chromium%{chromium_channel}
|
||||
%endif
|
||||
Version: %{majorversion}.0.4280.141
|
||||
Version: %{majorversion}.0.4324.96
|
||||
Release: 1%{?dist}
|
||||
%if %{?freeworld}
|
||||
%if %{?shared}
|
||||
@ -213,7 +225,7 @@ Patch4: chromium-60.0.3112.78-jpeg-nomangle.patch
|
||||
# Do not mangle zlib
|
||||
Patch5: chromium-77.0.3865.75-no-zlib-mangle.patch
|
||||
# Do not use unrar code, it is non-free
|
||||
Patch6: chromium-86.0.4240.75-norar.patch
|
||||
Patch6: chromium-88.0.4324.11-norar.patch
|
||||
# Use Gentoo's Widevine hack
|
||||
# https://gitweb.gentoo.org/repo/gentoo.git/tree/www-client/chromium/files/chromium-widevine-r3.patch
|
||||
Patch7: chromium-71.0.3578.98-widevine-r3.patch
|
||||
@ -241,38 +253,44 @@ Patch54: chromium-79-gcc-protobuf-alignas.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-78-protobuf-RepeatedPtrField-export.patch
|
||||
Patch55: chromium-78-protobuf-RepeatedPtrField-export.patch
|
||||
# ../../third_party/perfetto/include/perfetto/base/task_runner.h:48:55: error: 'uint32_t' has not been declared
|
||||
Patch57: chromium-80.0.3987.87-missing-cstdint-header.patch
|
||||
Patch56: chromium-80.0.3987.87-missing-cstdint-header.patch
|
||||
# Missing <cstring> (thanks c++17)
|
||||
Patch58: chromium-80.0.3987.106-missing-cstring-header.patch
|
||||
Patch57: chromium-80.0.3987.106-missing-cstring-header.patch
|
||||
# prepare for using system ffmpeg (clean)
|
||||
# http://svnweb.mageia.org/packages/cauldron/chromium-browser-stable/current/SOURCES/chromium-53-ffmpeg-no-deprecation-errors.patch?view=markup
|
||||
Patch59: chromium-53-ffmpeg-no-deprecation-errors.patch
|
||||
Patch58: chromium-53-ffmpeg-no-deprecation-errors.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-84-blink-disable-clang-format.patch
|
||||
Patch61: chromium-84-blink-disable-clang-format.patch
|
||||
Patch59: chromium-84-blink-disable-clang-format.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-fix-char_traits.patch
|
||||
Patch62: chromium-fix-char_traits.patch
|
||||
Patch60: chromium-fix-char_traits.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-87-CursorFactory-include.patch
|
||||
Patch63: chromium-87-CursorFactory-include.patch
|
||||
Patch61: chromium-87-CursorFactory-include.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-87-openscreen-include.patch
|
||||
Patch64: chromium-87-openscreen-include.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-87-ServiceWorkerContainerHost-crash.patch
|
||||
Patch65: chromium-87-ServiceWorkerContainerHost-crash.patch
|
||||
Patch62: chromium-87-openscreen-include.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-AXTreeFormatter-include.patch
|
||||
Patch63: chromium-88-AXTreeFormatter-include.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-vaapi-attribute.patch
|
||||
Patch66: chromium-88-vaapi-attribute.patch
|
||||
|
||||
Patch64: chromium-88-vaapi-attribute.patch
|
||||
# Silence GCC warnings during gn compile
|
||||
Patch68: chromium-84.0.4147.105-gn-gcc-cleanup.patch
|
||||
Patch65: chromium-84.0.4147.105-gn-gcc-cleanup.patch
|
||||
# Fix missing cstring in remoting code
|
||||
Patch69: chromium-84.0.4147.125-remoting-cstring.patch
|
||||
Patch66: chromium-84.0.4147.125-remoting-cstring.patch
|
||||
# Apply fix_textrels hack for i686 (even without lld)
|
||||
Patch70: chromium-84.0.4147.125-i686-fix_textrels.patch
|
||||
Patch67: chromium-84.0.4147.125-i686-fix_textrels.patch
|
||||
# Work around binutils bug in aarch64 (F33+)
|
||||
Patch71: chromium-84.0.4147.125-aarch64-clearkeycdm-binutils-workaround.patch
|
||||
# error: 'size_t' does not name a type
|
||||
# note: 'size_t' is defined in header '<cstddef>'; did you forget to '#include <cstddef>'?
|
||||
Patch72: chromium-87.0.4280.88-dns_server_iterator-missing-cstddef.patch
|
||||
# ../../components/federated_learning/floc_constants.cc:13:28: error: 'numeric_limits' is not a member of 'std'
|
||||
Patch73: chromium-87.0.4280.88-floc_constants-missing-limits.patch
|
||||
Patch68: chromium-84.0.4147.125-aarch64-clearkeycdm-binutils-workaround.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-BookmarkModelObserver-include.patch
|
||||
Patch69: chromium-88-BookmarkModelObserver-include.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-CompositorFrameReporter-dcheck.patch
|
||||
Patch70: chromium-88-CompositorFrameReporter-dcheck.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-dawn-static.patch
|
||||
Patch71: chromium-88-dawn-static.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-federated_learning-include.patch
|
||||
Patch72: chromium-88-federated_learning-include.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-ityp-include.patch
|
||||
Patch73: chromium-88-ityp-include.patch
|
||||
# https://github.com/stha09/chromium-patches/blob/master/chromium-88-StringPool-include.patch
|
||||
Patch74: chromium-88-StringPool-include.patch
|
||||
|
||||
# Use lstdc++ on EPEL7 only
|
||||
Patch101: chromium-75.0.3770.100-epel7-stdc++.patch
|
||||
@ -297,7 +315,7 @@ Patch109: chromium-87.0.4280.66-el7-no-sys-random.patch
|
||||
|
||||
# VAAPI
|
||||
# Upstream turned VAAPI on in Linux in 86
|
||||
Patch202: chromium-86.0.4240.75-enable-hardware-accelerated-mjpeg.patch
|
||||
Patch202: chromium-88.0.4324.11-enable-hardware-accelerated-mjpeg.patch
|
||||
Patch203: chromium-86.0.4240.75-vaapi-i686-fpermissive.patch
|
||||
Patch205: chromium-86.0.4240.75-fix-vaapi-on-intel.patch
|
||||
|
||||
@ -878,21 +896,25 @@ udev.
|
||||
%patch53 -p1 -b .gcc-include-memory
|
||||
%patch54 -p1 -b .base-gcc-no-alignas
|
||||
%patch55 -p1 -b .protobuf-export
|
||||
%patch57 -p1 -b .missing-cstdint
|
||||
%patch58 -p1 -b .missing-cstring
|
||||
%patch59 -p1 -b .ffmpeg-deprecations
|
||||
%patch61 -p1 -b .blink-disable-clang-format
|
||||
%patch62 -p1 -b .fix-char_traits
|
||||
%patch63 -p1 -b .CursorFactory-include
|
||||
%patch64 -p1 -b .openscreen-include
|
||||
%patch65 -p1 -b .ServiceWorkerContainerHost-crash
|
||||
%patch66 -p1 -b .vaapi-attribute
|
||||
%patch68 -p1 -b .gn-gcc-cleanup
|
||||
%patch69 -p1 -b .remoting-cstring
|
||||
%patch70 -p1 -b .i686-textrels
|
||||
%patch71 -p1 -b .aarch64-clearkeycdm-binutils-workaround
|
||||
%patch72 -p1 -b .missing-cstddef
|
||||
%patch73 -p1 -b .missing-limits
|
||||
%patch56 -p1 -b .missing-cstdint
|
||||
%patch57 -p1 -b .missing-cstring
|
||||
%patch58 -p1 -b .ffmpeg-deprecations
|
||||
%patch59 -p1 -b .blink-disable-clang-format
|
||||
%patch60 -p1 -b .fix-char_traits
|
||||
%patch61 -p1 -b .CursorFactory-include
|
||||
%patch62 -p1 -b .openscreen-include
|
||||
%patch63 -p1 -b .AXTreeFormatter-include
|
||||
%patch64 -p1 -b .vaapi-attribute
|
||||
%patch65 -p1 -b .gn-gcc-cleanup
|
||||
%patch66 -p1 -b .remoting-cstring
|
||||
%patch67 -p1 -b .i686-textrels
|
||||
%patch68 -p1 -b .aarch64-clearkeycdm-binutils-workaround
|
||||
%patch69 -p1 -b .BookmarkModelObserver-include
|
||||
%patch70 -p1 -b .CompositorFrameReporter-dcheck
|
||||
%patch71 -p1 -b .dawn-static
|
||||
%patch72 -p1 -b .federated_learning-include
|
||||
%patch73 -p1 -b .ityp-include
|
||||
%patch74 -p1 -b .StringPool-include
|
||||
|
||||
# Fedora branded user agent
|
||||
%if 0%{?fedora}
|
||||
@ -1019,7 +1041,9 @@ CHROMIUM_CORE_GN_DEFINES+=' is_debug=false'
|
||||
%ifarch x86_64 aarch64
|
||||
CHROMIUM_CORE_GN_DEFINES+=' system_libdir="lib64"'
|
||||
%endif
|
||||
%if %{useapikeys}
|
||||
CHROMIUM_CORE_GN_DEFINES+=' google_api_key="%{api_key}" google_default_client_id="%{default_client_id}" google_default_client_secret="%{default_client_secret}"'
|
||||
%endif
|
||||
CHROMIUM_CORE_GN_DEFINES+=' is_clang=false use_sysroot=false fieldtrial_testing_like_official_build=true use_lld=false rtc_enable_symbol_export=true'
|
||||
%if %{use_gold}
|
||||
CHROMIUM_CORE_GN_DEFINES+=' use_gold=true'
|
||||
@ -1184,6 +1208,7 @@ build/linux/unbundle/remove_bundled_libraries.py \
|
||||
'third_party/flatbuffers' \
|
||||
'third_party/fontconfig' \
|
||||
'third_party/freetype' \
|
||||
'third_party/fusejs' \
|
||||
'third_party/glslang' \
|
||||
'third_party/google_input_tools' \
|
||||
'third_party/google_input_tools/third_party/closure_library' \
|
||||
@ -1223,6 +1248,8 @@ build/linux/unbundle/remove_bundled_libraries.py \
|
||||
'third_party/libvpx/source/libvpx/third_party/x86inc' \
|
||||
'third_party/libwebm' \
|
||||
'third_party/libwebp' \
|
||||
'third_party/libx11' \
|
||||
'third_party/libxcb-keysyms' \
|
||||
'third_party/libxml' \
|
||||
'third_party/libxml/chromium' \
|
||||
'third_party/libxslt' \
|
||||
@ -1321,6 +1348,7 @@ build/linux/unbundle/remove_bundled_libraries.py \
|
||||
'third_party/widevine' \
|
||||
'third_party/woff2' \
|
||||
'third_party/wuffs' \
|
||||
'third_party/x11proto' \
|
||||
'third_party/xcbproto' \
|
||||
'third_party/xdg-utils' \
|
||||
'third_party/zxcvbn-cpp' \
|
||||
@ -1930,15 +1958,23 @@ getent group chrome-remote-desktop >/dev/null || groupadd -r chrome-remote-deskt
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 13 2021 Tom Callaway <spot@fedoraproject.org> - 87.0.4280.141-1
|
||||
* Wed Jan 20 2021 Tom Callaway <spot@fedoraproject.org> - 88.0.4324.96-1
|
||||
- 88 goes from beta to stable
|
||||
- disable use of api keys (Google shut off API access)
|
||||
|
||||
* Wed Jan 13 2021 Tom Callaway <spot@fedoraproject.org>
|
||||
- update to 87.0.4280.141
|
||||
|
||||
* Wed Dec 30 2020 Tom Callaway <spot@fedoraproject.org> - 87.0.4280.88-2
|
||||
- rebuild against new gcc (rawhide)
|
||||
* Wed Dec 30 2020 Tom Callaway <spot@fedoraproject.org> - 88.0.4324.50-1
|
||||
- update to 88.0.4324.50
|
||||
- drop patches 74 & 75 (applied upstream)
|
||||
|
||||
* Thu Dec 17 2020 Tom Callaway <spot@fedoraproject.org> - 87.0.4280.88-1.1
|
||||
* Thu Dec 17 2020 Tom Callaway <spot@fedoraproject.org>
|
||||
- add two patches for missing headers to build with gcc 11
|
||||
|
||||
* Thu Dec 3 2020 Tom Callaway <spot@fedoraproject.org> - 88.0.4324.27-1
|
||||
- dev release to prepare for next stable
|
||||
|
||||
* Thu Dec 3 2020 Tom Callaway <spot@fedoraproject.org> - 87.0.4280.88-1
|
||||
- update to 87.0.4280.88
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user