ceph/0002-src-common-CMakeLists.txt.patch
Kaleb S. KEITHLEY 13fa69ddf9 ceph 14.1.0 w/ static libcrc32
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
2019-03-06 13:39:40 -05:00

14 lines
457 B
Diff

diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 65ba10b0f1..eeedc29c37 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -165,7 +165,7 @@ elseif(HAVE_ARMV8_CRC)
crc32c_aarch64.c)
endif(HAVE_INTEL)
-add_library(crc32 ${crc32_srcs})
+add_library(crc32 STATIC ${crc32_srcs})
if(HAVE_ARMV8_CRC)
set_target_properties(crc32 PROPERTIES
COMPILE_FLAGS "${CMAKE_C_FLAGS} ${ARMV8_CRC_COMPILE_FLAGS}")