4f4defa7e2
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
20 lines
696 B
Diff
20 lines
696 B
Diff
--- ceph-18.0.0-3078-gc4847bf8/src/rgw/driver/dbstore/CMakeLists.txt.orig 2023-05-10 08:23:50.000000000 -0400
|
|
+++ ceph-18.0.0-3078-gc4847bf8/src/rgw/driver/dbstore/CMakeLists.txt 2023-05-11 08:21:13.794152904 -0400
|
|
@@ -24,7 +24,7 @@
|
|
dbstore_mgr.cc
|
|
)
|
|
|
|
-add_library(dbstore_lib ${dbstore_srcs})
|
|
+add_library(dbstore_lib STATIC ${dbstore_srcs})
|
|
target_include_directories(dbstore_lib
|
|
PUBLIC "${CMAKE_SOURCE_DIR}/src/rgw"
|
|
PUBLIC "${CMAKE_SOURCE_DIR}/src/rgw/store/rados"
|
|
@@ -49,6 +49,7 @@
|
|
|
|
# add pthread library
|
|
set (CMAKE_LINK_LIBRARIES ${CMAKE_LINK_LIBRARIES} pthread)
|
|
+set (CMAKE_LINK_LIBRARIES ${CMAKE_LINK_LIBRARIES} global)
|
|
|
|
find_package(gtest QUIET)
|
|
if(WITH_TESTS)
|