ceph-17.2.6, log create of global_legacy_options.h

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2023-05-10 10:56:37 -04:00
parent 0e8a2ef902
commit c817d5a04e
3 changed files with 55 additions and 2 deletions

View File

@ -100,3 +100,43 @@
struct CompactionIterationStats {
// Compaction statistics
--- ceph-17.2.6/src/rocksdb/table/block_based/data_block_hash_index.h.orig 2023-04-21 17:46:42.186339184 -0400
+++ ceph-17.2.6/src/rocksdb/table/block_based/data_block_hash_index.h 2023-04-21 17:47:01.392005151 -0400
@@ -7,6 +7,7 @@
#include <string>
#include <vector>
+#include <cstdint>
#include "rocksdb/slice.h"
--- ceph-17.2.6/src/rocksdb/util/string_util.h.orig 2023-04-21 18:13:51.060496792 -0400
+++ ceph-17.2.6/src/rocksdb/util/string_util.h 2023-04-21 18:14:06.496223220 -0400
@@ -10,6 +10,7 @@
#include <string>
#include <unordered_map>
#include <vector>
+#include <cstdint>
#include "rocksdb/rocksdb_namespace.h"
--- ceph-17.2.6/src/rocksdb/include/rocksdb/utilities/checkpoint.h.orig 2023-04-22 05:54:32.260798114 -0400
+++ ceph-17.2.6/src/rocksdb/include/rocksdb/utilities/checkpoint.h 2023-04-22 05:55:42.997522143 -0400
@@ -10,6 +10,7 @@
#include <string>
#include <vector>
+#include <cstdint>
#include "rocksdb/status.h"
namespace ROCKSDB_NAMESPACE {
--- ceph-17.2.6/src/rocksdb/third-party/folly/folly/synchronization/detail/ProxyLockable-inl.h.orig 2023-04-22 06:14:55.624679075 -0400
+++ ceph-17.2.6/src/rocksdb/third-party/folly/folly/synchronization/detail/ProxyLockable-inl.h 2023-04-22 09:18:39.424624618 -0400
@@ -13,6 +13,7 @@
#include <memory>
#include <mutex>
#include <stdexcept>
+#include <system_error>
#include <utility>
namespace folly {

View File

@ -0,0 +1,10 @@
--- ceph-17.2.6/src/CMakeLists.txt.orig 2023-05-10 10:00:58.457793274 -0400
+++ ceph-17.2.6/src/CMakeLists.txt 2023-05-10 10:01:31.553198698 -0400
@@ -809,6 +809,7 @@
if(WITH_KRBD)
add_library(krbd STATIC krbd.cc
$<TARGET_OBJECTS:parse_secret_objs>)
+ add_dependencies(krbd legacy-option-headers)
target_link_libraries(krbd keyutils::keyutils)
endif()
add_subdirectory(librbd)

View File

@ -160,7 +160,7 @@
#################################################################################
Name: ceph
Version: 17.2.6
Release: 5%{?dist}
Release: 6%{?dist}
%if 0%{?fedora} || 0%{?rhel}
Epoch: 2
%endif
@ -193,9 +193,9 @@ Patch0023: 0023-src-s3select-include-s3select_parquet_intrf.h.patch
Patch0024: 0024-gcc-13.patch
Patch0025: 0025-selinux-prepare-for-anon-inode-controls-enablement.patch
Patch0026: 0026-src-boost-libs-python-src-object.patch
Patch0027: 0027-src-rocksdb-table-block_based-data_block_hash_index.h.patch
Patch0028: 0028-cmake-modules-BuildBoost.cmake.patch
Patch0029: 0029-boost-asm.patch
Patch0030: 0030-src-CMakeLists.txt.patch
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
ExcludeArch: i686 armv7hl
%if 0%{?suse_version}
@ -2620,6 +2620,9 @@ exit 0
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
%changelog
* Tue May 9 2023 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.2.6-5
- ceph-17.2.6, log create of global_legacy_options.h
* Mon May 1 2023 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.2.6-5
- ceph-17.2.6, rebuild with libarrow-12.0.0